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The following changes have been made to DAT/EM products between Release 7.1 and Release 7.2. Please review these 
revisions made to the software and update your software to implement changes. 
 
As always, DAT/EM welcomes comments and suggestions from you, our clients, so please don’t hesitate to contact our 
support department at support@datem.com or call us with your requests. 
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Operating Systems and Microsoft Updates 
Release 7.2 is supported on the following operating systems: 

 Windows 7 Ultimate and Professional 

 Windows 8 and 8.1 Professional and Enterprise 

 

DO NOT USE Windows 10. 

DAT/EM software works with Windows 10; however nVidia video drivers are not working well for OepnGL stereo 
and Windows 10 has some behaviors that interfere with video drivers. If you install Windows 10, DAT/EM will not 
guarantee that you will be able to find a video driver that works. Problems include, but are not limited to: 

o The nVidia driver may not offer the right stereo modes; 

o The nVidia driver may not display stereo at all. 

o The nVidia driver may display in stereo only while the Summit cursor is moving and display in mono when 
the cursor is at rest. 

o The nVidia driver may disable any secondary video card (usually present if you have three or more 
monitors). 

o Windows 10 automatically installs a different nVidia video driver without installing the matching the emitter 
driver. Windows 10 ignores its own setting that tells it not to update the video driver (as of Oct. 1, 2015). 

It is possible that Windows 10 and nVidia drivers will improve during the v.7.2 release term; contact DAT/EM if 
you would like the latest news on Windows 10. 

 

Install all critical Microsoft Windows Updates before DAT/EM software installation.  

Microsoft Office 2007 users must install all available Microsoft Office updates before installing DAT/EM version 7.2. 
 

Hint: If you have Windows 8 and you miss the Windows 7 Start menu, you may be interested in the third-party 
“Classic Shell” application. We use it on our DAT/EM computers and tablets and we really like it. Classic Shell™: 
http://www.classicshell.net/   
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Hardware Locks/Dongles 
Please install Microsoft Updates and OS Service Packs before applying lock reset programs. Network licensing should 
have the same Sentinel driver version on both the server and the local computers running the software. 
 

1. DAT/EM changed its hardware lock configuration with the release of version 7.1. If you have a hardware lock that 
was “written” by DAT/EM 13 August 2014 or earlier and you did not install version 7.1, you will need to apply a 
WriteLock.exe to update the lock for v.7.2. This prepares the lock to work for version 7.1 or 7.2 created 14 August 
2014 or later. The newly written lock is not backwards compatible with version 7.0 or earlier. If for any reason you 
want to return to v.7.0 or earlier, please ask DAT/EM for a v.7.0 WriteLock. 
 

Q: I have been using DAT/EM version 6.8 or 7.0. Do I need to apply a WriteLock? 
A: Yes! You need both a new WriteLock (from 7.1 or 7.2) and a 7.2 installation keycode. 
 
Q: I have a network lock that is currently running v.7.0 or earlier. Do I need to apply a WriteLock before I 
install version 7.2? 
A: Yes! You need both a new WriteLock (from 7.1 or 7.2) and a 7.2 installation keycode. 
 
Q: I am currently running the release version of 7.1. Do I need to apply a WriteLock for 7.2? 
A: No. A lock that works for 7.1 will still work for 7.2. 
 
Q: I have a softlock demo. Do I need to apply a WriteLock? 
A: No. The WriteLock does not apply to softlocks. You may upgrade to version 7.2 using a 7.2 installation 
keycode only. If you change to a hardware lock later, DAT/EM will pre-write your new hardware lock to 
work with version 7.2 or the older version of your choice. 

  
2. WriteLock(license number).exe files now run a version of Release Information when finished. This allows the user 

to verify that the correct products are activated on the lock. Additional .dll files are supplied with the WriteLock 
files; the .dlls must be kept in the same folder with the WriteLock. Do not run the Release Information file directly 
from the folder that contains the WriteLock program; it should only be run automatically by the WriteLock. 
 

3. The Safenet Sentinel driver version 7.6.8 is provided with DAT/EM version 7.2. If version 7.2 (release or beta) 
dated after August 3, 2015 was not previously installed, then the first run of the DAT/EM self-extracting 
executable will install or update the Sentinel driver. Please reboot when asked. 
 
If you have a network lock on a network server and it is not already running Sentinel v.7.6.8, install it on the server 
before you install DAT/EM v.7.2 on your DAT/EM workstations. The Sentinel driver version must match on the 
network lock server and all workstations that will access the lock. There are three choices for installing the driver 
on the network server (choose A, B, or C): 
 

 Choice A) Run the DAT/EM “Setup…exe” file one or two times on the network server. The first time it 
runs, it may install C redistribution files and may require a reboot; if so, run DAT/EM “Setup…exe” again. 
It will then install the Sentinel driver. Answer “Yes” to the firewall question. Reboot if asked. 
 

 
It is very important to answer “Yes” to this question 
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 Choice B) Download and install version 7.6.8 from the Sentinel website: http://www.safenet-

inc.com/support_and_downloads/Download_Drivers/Sentinel_Drivers/ (note that the driver posted there 
could be updated beyond 7.6.8 at any time. If you want to use a newer driver, you must install it on all 
your DAT/EM workstations and on your network lock server.) During installation, answer “Yes” to the 
firewall question as shown above. 
 

 Choice C) Download version 7.6.8 from the DAT/EM website 
http://www.datemsystems.com/down/drivers/Sentinel%20Protection%20Installer%207.6.8.exe. During 
installation, answer “Yes” to the firewall question as shown above. 
 
 

4. The micro USB hardware lock is a new option for single-license hardware locks. There will be a charge to trade a 
larger lock for the micro USB. If your current supported hardware lock breaks and you need a replacement, it will 
be replaced for free by a lock of similar size. You will have the option to pay the extra fee for a micro USB 
replacement lock. 

 
Left to right: Old light purple lock (manufacture date stamps before May 2005 need to be replaced), 

black lock (shipping until we run out of current stock), 
new dark purple lock (will ship soon, same as the black locks in functionality, fewer network lock choices), 

and new green micro USB lock (single-seat licenses only, available for an additional cost) 
 

Stereo Viewing Devices 
The following changes or additions have been made to the list of compatible stereo viewing devices and drivers: 

1. The Oculus Rift® is now supported. DAT/EM VR Desktop™ (VR Desktop) and DAT/EM VR Point Viewer™ are 
new applications that make it possible DAT/EM stereo applications to use the Oculus Rift as a virtual reality 
stereo viewing device. 

Note that the Oculus Rift is still in development by the manufacturer as of October 2015. It will have a more 
restrictive video card compatibility than nVidia 3D Vision; check with the manufacturer. The release version is 
expected to have a higher resolution view than the development version. 

See more information in the “DAT/EM Virtual Reality” section below. 
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2. New compatible stereo viewing screen types have been posted to the hardware configuration list on our website: 

a. VRLOGIC SONIC4 – Wide Screen 27″ Passive Stereo3D Display, http://www.datem.com/vrlogic-sonic4/  

 

VRLOGIC SONIC4 

b. HP Zvr 23.6-inch VR Display, http://www.datem.com/hp-zvr-vr-display/  

 

HP Zvr 

 

Video Drivers 
Please note our video driver installation/update recommendations: 

 DO NOT install the driver on media packaged with a video card. It will be too old. 

 1st: Get the latest driver for your video card and operating system from www.nVidia.com. During installation, turn 
on “Custom (Advanced)” and “Perform a clean installation”. 
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 2nd: If the driver on www.nvidia.com does not work, contact support@datem.com for advice. We may ask you to 
download an older driver from either www.nvidia.com or www.datem.com, depending on your hardware and 
operating system. 

 If you need to change (update or back out) a video driver, please follow the instructions at www.datem.com 
Support > Downloads > Manuals > Installation Instructions>“StereoLCDInstallationInstructions.pdf”. This 
shows how to replace drivers and verify that the new drivers have been installed properly. It is very important to 
check on the “Custom” and “Clean” installation choices shown above. 

 On existing workstations, check your video driver periodically. The easiest schedule is to check it before installing 
each DAT/EM software update. If you use a single-panel LCD display and the video driver is older than the one 
currently offered at www.nvidia.com, please update it using the “Custom” and “Clean” installation options. 

More notes: 

 When checking your installed video driver version, remember that the actual version consists of the last five digits 
with the decimal point moved two spaces to the right. For example, 6.14.12.7642 is really version 276.42. In the 
past, nVidia sometimes omitted a zero (0) from the version; for example, version 6.14.13.732 was really 307.32. 

 For video settings, see www.datem.com Support > Downloads > Manuals > Installation Instructions. Most 
users will want either “PlanarInstallationInstructions.pdf” for Planar dual-LCD monitors or 
“StereoLCDInstallationInstructions.pdf” for single LCD stereo monitors. 

 
 

Software Installation, File Locations, and Installed Utilities 
The following has changed for DAT/EM software installation or the location where DAT/EM applications store data: 

Note: Blue Marble's Geographic Calculator ArcGIS plugin directly conflicts with DAT/EM's CaptureArcInfo.2010.dll. 
When DAT/EM software is installed, "Registration Failed" is reported near the end of installation. Run "C:\Program 
Files (x86)\Blue Marble Geo\Geographic Calculator\UnRegisterEsriPlugin.bat" before installing DAT/EM software. 
Contact DAT/EM for more information if you have Geographic Calculator and would like to use it in ArcGIS. 

1. This change was implemented in version 6.8, but if 6.8 or higher was not installed, please take note. There is a 
new DAT/EM-PCI Runtime ProPack installation to install after installing version 6.8, 7.0, 7.1, or 7.2. It allows you 
to use Geomatica 2010-to-2013 projects. Download the file at www.datem.com and install it. It will launch the PCI 
License Utility, which contains a fingerprint and a link to a web request form. Copy the fingerprint and use the link 
to send the fingerprint to PCI. 

 

PCI will send a license file. Rename the file to “lservrc.txt” and copy it to the 32-bit location: 

 \Program Files (x86)\Datem Software\ProPack\exe 

Run the following file in the 32-bit locations.  

 \Program Files (x86)\Datem Software\ProPack\exe\LaunchLicenseUtil.bat 

Select the “Import” button, and browse for the “lservrc.txt” file in that same folder. Information will appear in the 
license file list below the “Import” button. Close. 

 

Select “Import” and browse for lservrc.txt 
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PIX images should now open in Summit when Summit is launched from Windows Start > All Programs > Datem 
Software > PCI ProPack > Summit 64 with Propack (64-bit) or Summit 32 with Propack (32 bit), which launch 
Summit from the LaunchSummitWithPropack.bat files in the corresponding 64- or 32- bit applications folders. If 
they continue to give license errors, please contact DAT/EM Support. 

 
2. DAT/EM software now checks the registry item “HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Oculus 

VR, LLC\Oculus Runtime\Location” to detect the Oculus Rift. If it finds it, then it will ask the user whether to install 
the DAT/EM VR (virtual reality) Desktop: 
 

 
 
If “Yes” is selected, then it installs the additional DAT/EM VR software. The following reminder appears: 

 
 

It will also add shortcuts to the Windows Start menu Datem Software area. Run “VR_Desktop”, then launch 
“Landscape VR” or “Summit VR”, which have the “-vr” switch added to the Landscape and Summit shortcuts. 
More information is in the DAT/EM Virtual Reality section below. 

 
 

3. DAT/EM version 7.2 is the first version to install a beta version extension for ArcGIS Pro v.1.1. If you have 
Capture for ArcGIS enabled on your DAT/EM hardware lock and ArcGIS Pro 1.1 is found on the computer, it will 
install the DAT/EM extension. More information is in the Capture for ArcGIS Pro section below. 
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DAT/EM Virtual Reality 
DAT/EM Virtual Reality options have been added to work with the Oculus Rift: 

 

New Datem Software VR_Oculus start group 

 

1. DAT/EM VR Desktop™ (VR Desktop) is a new software application (app) that makes it possible for Summit 
Evolution and Landscape to use the Oculus Rift® as a virtual reality stereo viewing device. The DAT/EM 
installation process installs the VR Desktop if the Oculus Rift is detected and the user agrees to install it. See the 
installation section below for additional installation information. 

Note that the Oculus Rift is still in development by the manufacturer as of October 2015. It will have a more 
restrictive video card compatibility than nVidia 3D Vision; check with the manufacturer. The release version is 
expected to have a higher resolution view than the development version. 

The VR Desktop has the ability to display OpenGL stereo desktop applications in stereo. Just copying the 
Windows desktop into virtual reality is not enough, since you would only get one image in Summit or Landscape 
(it is just like taking a screen shot). DAT/EM’s special DLL allows stereo apps to communicate and share their 
graphic surfaces with VR Desktop. There is little to no drop in Summit or Landscape performance, since all the 
required actions happen in the video card, not the CPU. 

Both Summit and Landscape have been modified to use this DLL, so that they can be viewed in stereo in virtual 
reality. In summary: 

o VR Desktop shows the Windows desktop in the Oculus Rift. 

o OpenGL Stereo apps communicate and share their graphics surfaces via DAT/EM’s new GLInterop SDK. 

Requirements and notes: 

o Window 7 or newer. Note: Windows 8 or newer will update much faster, since it uses the new Microsoft 
Desktop Duplication API. This API allows the desktop to be copied directly in the video card. This is not 
available on Windows 7, therefore Windows 7 uses an older and slower method to copy the desktop. 
(Note that as of the time of this publication, DAT/EM does not recommend Windows 10.) 

o Direct X 11. This should already be on Windows 7 or newer. 

o An Oculus Rift. Note: Never use the Oculus on a USB hub. 
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o Does not require a stereo-enabled video card for the Oculus Rift developer kit version. Video card 
restrictions may apply to the eventual Oculus Rift release version. 

o It may not work on every video card. Some cards may not support OpenGL interop functions and this 
would be the main reason it would not work. 

The DAT/EM VR Desktop app has several settings: 

  

All options are automatically saved in real time. 

When using the Oculus Rift to view Summit or Landscape: 

 First: Start the VR Desktop 

 Second: Start the application with the provided Start > All Programs > Datem Software > VR_Oculus > 
Summit VR or Landscape VR shortcut or a shortcut that uses the -vr flag. Examples of shortcut targets: 

"C:\Program Files\Datem Software\StereoPlotter_64.exe" -vr 

"C:\Program Files\Datem Software\Landscape_64.exe" -vr 

Do not run more than one stereo application at a time with the Oculus. For example, do not run DAT/EM VR Point 
Viewer and Summit at the same time. 

 

2. DAT/EM VR Point Viewer™ is a new application that is installed with the VR Desktop for Oculus Rift described 
above. It may be launched from Start > All Programs > Datem Software > VR_Oculus > VR Point Viewer. This 
allows you to add one or more supported-format point files and view them in the Oculus. At this time, the points 
are view only; the VR Point Viewer is not an editor. 

Do not use VR Point Viewer at the same time as Summit, Summit VR, Landscape, or Landscape VR. 

 

DAT/EM Keypad 
The following changes have been made to the DAT/EM Keypad products: 

1. If a key had a previous Call Keys setting, it could not be deleted in the Edit Key dialog. The call key number 
would still be effective and would reappear the next time the Edit Key dialog opened the key setting. This is fixed. 
(June 16, 2015) 

2. DAT/EM Keypad Advantage Version 1.5 is available on the Google Play Store. It includes a fix to find and display 
the keypad images on newer Android versions. (June 23, 2015) 

3. The DAT/EM Keypad may now be used with Capture for Global Mapper. See more information below. 
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Elevation Database 
The following changes have been made to the DAT/EM-Blue Marble elevation database. To activate these new 
selections, there is a new “SetupElevationModels blt mm dd yyyy.exe” file that must be installed. 

1. On 12 March 2015, DAT/EM added updated Blue Marble files to DAT/EM Setup and compiled a new Elevation 
Database installation file. The files may be added manually to versions 6.8, 7.0, 7.1, and 7.2 betas dated earlier 
than 12 March 2015 (ask DAT/EM Support for the files). Any 7.2 betas after this date will have all the updated 
files included, but you must also install the newest Elevation Database that is posted on www.datem.com. These 
files install an updated North America Geoid 12A that includes a new tile for Puerto Rico and the Virgin Islands. 

 

Summit Evolution 
The following changes have been made to Summit Evolution and the applications that are provided with it.  

 
General Summit Evolution Subjects 

 

1. The Xbox controller is now allowed as an input device for Summit Professional and Feature Collection. The 
drivers are sometimes difficult to get working. If you have trouble, contact DAT/EM support. 

To set Summit to the correct input device, start Summit>Tools>Options>Input Devices tab and check “Xbox 360 
Controller”. To assign button functions, use the Summit>Tools>Button Manager>Xbox Controller tab. 

    

Xbox 360 Controller input device setting and Button Manager tab 

2. With the system mouse set as the 3D input device, sometimes deactivating Summit cursor control would make 
the mouse cursor get stuck in the upper left corner of the window. This is fixed. 

3. The Tie Points Overview window could make Summit crash. This is fixed. 

4. Terrain Visualization now accepts AutoCAD LINEs as input. Previously, it required them to be converted to 
POLYLINEs in order to affect contour calculations. 

5. The Move To Ground tool has a fix to the Report function. Previously, if you selected all measured points on the 
Report tab and used “Delete” to remove them, it would not record any subsequently digitized points. The dialog 
would have to be closed and reopened to make it work again. Now you may delete all points and resume 
digitizing in the same Move To Ground session. 
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6. The stereo print option in Summit>File>Print has enhancements: 

 It can now output JPG format. 

 It can now make multiple output files if there are multiple polygon boundaries in the “Use Boundary” 
options’ CAD file. 

 There is a new “Right and Left separate images” option. Output files have _R and _L appended to the file 
names. 

7. A memory allocation error in the 64-bit TIN generating code was fixed. This affected 64-bit versions of DAT/EM 
applications only. It could have caused crashing in any application that generates a TIN, such as Summit Terrain 
Visualization, Realtime Contour Visualization, Contour Creator, Lidar image creator, and stereo mate creator. 

8. If you ever use legacy .smtprj files, take note! If the flag to use a corner pixel origin was set in a project that was 
previously open in the Summit session, then File>New would make a project that also had the origin set to corner 
pixel. The corner pixel origin is a legacy setting and should only be used for compatibility with very old Summit 
projects. Now all new projects will be set properly to us a center pixel origin. Additionally, when opening a legacy 
.smtprj file, it will now ask the user whether the project was made by Trimble Inpho software, so that the proper 
value can be set. 

9. The Drive Summit Evolution tool called by all the Capture products was not working in v.7.1. It is fixed for 7.2. 

10. Terrain Following now accepts larger files as input. 

 
Aerial Projects 

11. Aerial projects have the following changes: 

 Summit has multiple methods to export exterior orientation values: File>Export>Export Exteriors, 
Help>Orientation Snapshot, and Tools>Reports. These would not always work for one image that had an 
EO value or for exteriors that needed absolute orientation to be calculated. Now it exports exterior values 
for these types of projects. 

 All methods of importing exterior values, including EO file imports and importing third-party projects such 
as Z/I projects, could make the Z wheel direction move backwards if the angles exceeded certain ranges. 
Now Summit will automatically convert the angles to the desired range and the Z wheel will move 
correctly. 

 Summit’s Camera Editor for aerial projects has a fix for the Radial and Decentering “Decentering P4” 
distortion value. Every time the dialog appeared, the P3 value would be shown in the P4 field. If you 
replaced the value and saved the file one time, the correct value would be written to the .smtxml project 
file. However, if you opened and saved the camera file again without editing the value, P3 would be 
written to both P3 and P4. Now P4 is retained correctly. 

 Summit Feature Collection had “Import Matrix Exterior” on the Orientation toolbar, but it was missing from 
the pull-down menu. It has been added to the menu.  

 There is a slight change to better read Aerosys8 files. Only one file was used as an example. If you have 
a file that can’t be read, please send it to DAT/EM Support for further development. 

 The Close Range toolbar has been renamed to Plane Following so that it may be shared with aerial 
models. Select Summit>Tools>Reset Toolbars to Default (this closes Summit) to activate the changed 
toolbar. 

In a nadir aerial, oblique aerial, or close-range model, define planes so that the usual xy cursor movement 
moves along the plane instead. For example, define a wall or sloped roof of a building so that the cursor 
movement is locked along the wall or roof. The plane definitions are saved in the .smtxml project per 
model. 

The Plane Following toolbar is now enabled for aerial projects, but currently only works for oblique 
models. Note: If you would like this plane following feature to be added to nadir aerial models, please 
contact support@datem.com to request it. 
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 There is a new “Maximum overlap” setting in the aerial project automatic Generate Models dialog. 
Together with the existing “Minimum Overlap” setting, it allows you to restrict models to a range of overlap 
values. For example, with imagery that has 80% overlap, if you only want models that have about 60% 
overlap, set Minimum Overlap to 55% and Maximum Overlap to 65%.  

 

New Maximum Overlap setting for automatic model generation 

 

 The Terrain Height field located in the Interior Corrections dialog was not being saved or applied while 
using the dialog. This meant that when “Per image heights”>”Fill Flight Height” was used, it would not fill 
in the value that had been entered, and the value reverted to 0.00 between dialog sessions. This is fixed. 
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Aerial Projects, Continued. 

 Summit can now import an Agisoft PhotoScan camera file to use in aerial projects. Please note that the 
user must understand the PhotoScan camera file and use only those camera parameters that have an 
equivalent in a Summit camera file. After using a compatible camera type in PhotoScan, export the 
camera file from Agisoft: 

 

Agisoft PhotoScan’s Camera export button 

Then select Summit > File > Import > Convert PhotoScan Camera. Enter the pixel size in micrometers 
and browse for the file names. Select the Convert button. You can add the resulting camera to a Summit 
aerial project. 

 

New dialog to import an Agisoft PhotoScan camera 

As with any imported camera, open the camera file in Summit’s Camera File Editor and check that the 
camera parameters and distortion values match the source camera. If correct, the camera may now be 
used in a Summit aerial project setup for images that were previously aerotriangulated by Agisoft 
PhotoScan. 

 
Close Range Projects 

12. Close Range (Terrestrial) projects: The Close Range toolbar has been renamed to Plane Following so that it 
may be shared with non-close-range oblique models. Select Summit>Tools>Reset Toolbars to Default (this 
closes Summit) to activate the changed toolbar. 
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UAV Generated Stereo Projects (New!) 

13. UAV Generated Stereo projects (new!): UAV is a new project type. It allows you to make a generated stereo 
project from third-party UAV softwares’ mosaic and DTM file results. Some users prefer to use generated stereo 
from larger-footprint mosaics than individual stereo models that each have a very small footprint. The UAV project 
type is active in all Summit editions. 

 Prepare the project. In the third-party UAV processing software, create one or more imagery mosaics and 
a DTM (ground points) file. If the mosaics do not have an image zoom pyramid, process each mosaic with 
the DAT/EM Image Creator to add the pyramid. For more information, see the Image Creator tutorial at 
http://www.datemsystems.com/downloads/Training/DATEM_ImageCreator.ppsx and 
http://www.datemsystems.com/downloads/Training/DATEM_Extension_Chart.pdf  (or see the Training 
link on our new website if you find these links are no longer valid). 

 Select Summit > File > New > UAV. 

  
 

 Drag and drop or browse for one or more mosaic files (they must have image pyramids) and one or more 
DTM files into the Project Edit [UAV] dialog. Note that these files should have been made earlier by the 
third-party UAV processing software. Select the Generate Stereo Mate button. 
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 The Stereo Mate Creator dialog will appear with the file names already loaded: 

 

 If you know there are large holes in the DTM (that is, areas where there are no points), you may need to 
set the Default Elevation value to what you consider the best height for the missing areas. Select a Pixel 
shift per elevation unit. DAT/EM recommends a value between 2.0 and 2.5. This value range typically 
gives good stereo. 

 Select the Generate button. Depending on the image and DTM size, it should take approximately 5 to 10 
minutes per image to generate the stereo mate. The stereo mates will automatically be added to the 
project in Summit. 

 Once the stereo mate processing is finished, open the model(s) to see how they look. 

 
Imported Projects 

14. Imported Projects: 

 Z/I project import has a better conversion for exterior angles that exceed plus or minus 180 degrees. This 
change can prevent the Z wheel from traveling in the wrong direction in the imported model. If the omega, 
phi, and kappa angles were given as, for example, 359.443541, 359.946896, 206.012472, Summit now 
converts them to -0.55645, -0.053104, -153.987528. While technically the same angle, the rotation 
direction happens differently on screen. 

 In the past, Summit has always imported the Z/I exterior values from the Z/I file called “Photo”. Recently 
we have received Z/I projects where the exterior values in the “Model” file were better than the ones in the 
“Photo” file. Now Summit’s ZI Import dialog offers a choice. If you are not sure which to use, DAT/EM 
recommends that you import the project both ways and use Summit>Tools>Move to Ground to visit 
control points throughout the project. Use the project that has the better match between Move to 
Ground’s “Show measured” and “Show calculated” marks. 
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New Z/I Import option allows the user to choose the source file for the exteriors 

Note: There exterior orientation values are not always present in the “Model” file. If you select “Model” 
and the values are not found there, it will use the values from the “Photo” file instead. 

 

 There is a new Pix4D project import. Select File > Import > Pix4D project. Browse for the image folder, 
camera file, exterior file, and ground control points (GCP) file. Choose a folder for the Summit project. 

 

New Pix4D project import dialog 

 The LPS BLK import for aerial projects has been fixed to correctly set the angular distortion in the Summit 
camera file. It previously set the distance distortion type by mistake. 

 In LPS BLK imports for aerial projects, if the camera file description contained characters that were not 
allowed in Windows file names, the camera file would not be written. Now the software discards or 
replaces the characters to make a Windows-compatible file name so that the file may be written. 

 Agisoft PhotoScan Camera XML is a new camera file format import found on the File>Import pull-down 
menu. It is described above in i. on page 13. 
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Button Manager 

15. Button Manager has the following changes: 

 The System mouse tab has an updated button diagram to help the user understand how two system mice 
work together. Generic-looking mice have been used in the diagram, but the second mouse is often a 
trackball mouse. Note that more trackball settings can be found in Tools>Options>Input Devices>Options 
button to the right of “System Mouse”. 

 

 

 The Stealth S4-Z picture can now be set from the “Show” menu on the “Stealth Z” tab. Previously, the 
mouse worked, but the buttons had to be set using the picture from a different Z mouse model. 

 
Lidar Image Generator 

16. Generate LIDAR Image (GenLidarImageUI[_64].exe) has the following changes: 

a. Multiple instances of the application are now allowed. The purpose of running multiple instances is to 
increase the number of files that can be processed per hour. Note that the user is responsible for running 
the proper number and not exceeding the capabilities of the CPU. 

Try three or four instances to check the performance. DAT/EM recommends running no more than five 
instances at one time. If you try too many for the particular CPU, eventually the speed of processing will 
become slower, because all the CPU and disk access will be overloaded. When this happens, all the 
threads will run slower, resulting in all instances taking longer. 

The user must make sure that each instance does not process the same data. If multiple instances 
attempt to process the same file, it could crash. 

b. A memory allocation error in the 64-bit TIN generating code was fixed. This affected 64-bit versions of 
DAT/EM applications only. It could have caused crashing in any application that generates a TIN, such as 
Summit Terrain Visualization and Realtime Contour Visualization, Contour Creator, Lidar image creator, 
and stereo mate creator. 
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c. A customer sent a  .laz files that contained invalid Z values that led the surface generation to produce 
“NAN” (not a number). NAN happens, for example, when 0 is divided by 0 or when attempting to take the 
square root of -1. The application could crash. Now it skips invalid elevations. 

d. Color from input formats that support color is now being passed properly to the resulting orthophoto when 
the “Color RGB image” setting is on. Previously, the image could be created with all black pixels. 

e. Optimization overviews were removed, since they are not needed for this application. This should 
improve performance a small amount. 

Note that input/output (I/O) speed of the available hardware can still be the slowest part of the Stereo 
Mate generation process. However, we have one customer who has greatly improved the processing time 
using a new SSD (solid state drive) RAID array, a  7.2 beta including the above fixes, and running 
multiple instances of the Lidar Image Creator at one time. Here is his report: 

I used the potential I/O issue to justify the purchase of 2 high-end SSD's and put them in a RAID-0 locally 
(they are backed up daily). The 1% CPU issue is now gone. I was able to create the entire project, running 
concurrently in 5 instances, in about 1 hour (250 million first returns) @ 0.5' images. Each instance was 
pegging a single CPU almost the entire time.  

There were only 6 files, but they were huge: About 250 million first return points. Larger is better for stereo 
viewing. I make it a policy to create overlapping tiles just for the purpose of Lidar stereo. That way I have 
overlapping stereo pairs. Edges can be problematic otherwise. Here's roughly my process: 

1) Load all first return data in Blue Marble Global Mapper 

2) Export into roughly 5000’x5000' tiles, overlapping each other by 20% (making them about 
6000'x6000') (units are in feet here) 

3) Use those output tiles in multiple instances of Lidar Image Creator, which creates overlapping 
stereo pairs 

The 0.5' pixel intensity stereo pairs I created yesterday were really nice for breakline collection. Theoretically 
I could have done twice as many in the same amount of time, assuming I didn't run into more IO issues with 
the larger dataset. 

 

Stereo Mate Generator 

17. Stereo Mate Generator has the following changes: 

 The Stereo Mate Generator is now multi threaded, which means image generation speed is much faster. 

 The following problem was introduced in v.7.1, was patched in 7.1, and is now fixed permanently in 7.2: 
When either the 32-bit or 64-bit version ran the first time or on the first file in a list of multiple files, it would 
make a very fast all-black file. 

 The previous version would crash if you renamed an input file that was currently in the Stereo Mate 
Creator list, then tried to remove the file from the Stereo Mate Creator list by clicking on the old file name 
listed there. This is fixed. 

 A memory allocation error in the 64-bit TIN generating code was fixed. This affected 64-bit versions of 
DAT/EM applications only. It could have caused crashing in any application that generates a TIN, such as 
Summit Terrain Visualization, Realtime Contour Visualization, Contour Creator, Lidar image creator, and 
stereo mate creator. 

 The Stereo Mate Generator could make an image with black lines or areas if “Pixel shift per elevation 
unit” was set somewhat high. It could still happen now, but only if the pixel shift distance is set very high. 
If you see black lines in the output, try a smaller pixel shift. 
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Contour Creator 

18. Contour Creator has the following changes: 

 A memory allocation error in the 64-bit TIN generating code was fixed. This affected 64-bit versions of 
DAT/EM applications only. It could have caused crashing in any application that generates a TIN, such as 
Summit Terrain Visualization, Realtime Contour Visualization, Contour Creator, Lidar image creator, and 
stereo mate creator. 

 When Depression>“Maximum Area” was checked on, there could be missing contours. This problem is 
now fixed, and the setting will now correctly limit finding depression contours that are larger than this 
area. Note: The workaround for previous versions is to uncheck this setting. 

 

Point Translator 

19. Point Translator has been fixed so that it does not add a trailing comma to x,y,z output. Previously, it would output 
“x, y, z,” and now it outputs “x, y, z” format. 

 

Project Viewer / Ortho+Mosaic 

20. Project Viewer / Ortho+Mosaic has the following changes: 

 BigTiff is now a format choice for the orthophoto stage output. Tiled satellite images that will generate at 
larger than the 4GB TIF file standard limit should be output as BigTiff. If the deliverable images must be a 
TIF, use the mosaic process to output a grid of smaller TIF files or to reduce the resolution enough that 
every output mosaic file is under 4GB. 

 Note: The order of the stages is 1. Summit project, 2. Orthophoto stage, 3. Mosaic stage. 

 Note: BigTiff was already available in the mosaic stage output. 

 Note: Jpeg2000 is not offered for the orthophoto stage output. We don’t want Jpeg2000 image 
compression in the orthophoto stage, since it’s important to store background color in the image 
for later use in the mosaic stage. However, it is acceptable to output the mosaic as a Jpeg2000. 

 Ortho+Mosaic will now refuse to apply image balancing if the images do not contain zoom levels. 

 A crash in OpenGL drawing code was fixed for the “Show borders around images” option. If this option 
was on, Project Viewer/Ortho+Mosaic would crash on loading some projects. 

 

Landscape 
The following changes were made to Landscape: 

1. There are new toolbar icons. The first time you run Landscape after installing v.7.2, please select Landscape > 
Tools >  Reset toolbars to default. 

2. A problem was fixed for the rubber band that should extend from the most recent vertex during digitizing with 
DAT/EM Drawing Objects or with DAT/EM Capture. 

3. Landscape has added support for read-only mode, which also supports pyramids. The options are available on 
the Landscape > Viewing Tools menu: 
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Landscape Viewing Tools menu and toolbar 
 
If it is in Read-Only mode, then you can build and use pyramids, which can dramatically improve loading speed 
for points (only use it for points that you don’t want to edit). In one of our demonstration cases, the load time went 
from 12 minutes to 30 seconds. 
 
Set the location where the pyramids will be created in Landscape > Tools > Options: 
 

 
New Pyramids options page 

 
The “Default pyramid folder settings” control where the pyramids are created whenever you select the “Build 
Pyramids” button after saving the project. Note that you must save the project first before it will create the 
pyramids, since it uses the names of the project in the pyramid name. The “Current Project” settings let you view 
and modify the pyramid location for the current project. If the pyramids are not found, then the dialog will show a 

warning and the button on the toolbar will turn into a red . 
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Red text appears if the pyramids are not found 

4. Named Views are new in Landscape. Named views may be used to save and load views. Select either Show 
named views from the Windows toolbar or Named Views from the Windows menu. The named views are stored 
in the project file. The view point, rotation, scale (view offset), colorBy, intensity (on/off), and point bounds settings 
are stored for the view. 

 

 

New Landscape Named Views dialog 

  adds an entry for the current Landscape view. The new entry is named 
Current View, but this can be changed by double clicking on the entry. 
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  deletes the selected entries for the list. 

  replaces the first currently selected view with the current view. 

  drives Landscape to the currently selected view. 

 

5. Landscape has updated the interface for better system mouse control. New system mouse control hints appear in 
the upper right of the view: 

 

New Landscape mouse control hints 

6. Save Points is a new interactive point edit tool. It lets the user select points and write them to a file. The options 
change based on the output format selected. 

  

   

New Landscape Save Points tool and its output format choices 
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DAT/EM Capture for ArcGIS ArcMap 
This version is compatible with ArcGIS 9.1, 9.2, 9.3 (service pack 1), 9.3.1(service pack 2), 10.0 (service pack 4), 10.1 (service pack 
1), 10.2, 10.2.1, 10.2.2, and 10.3 (plus any available service pack as they are released). 
 
BE ADVISED: In response to user requests, DAT/EM has decided to support ArcGIS 9.x with DAT/EM version 7.2. During the next 
release cycle, we will again review plans to drop support for ArcGIS 9.x. Please continue to make plans to upgrade any remaining 
ArcGIS 9.x version to 10.x. Contact DAT/EM if you have concerns about upgrading. 

Note: Blue Marble's Geographic Calculator ArcGIS plugin directly conflicts with DAT/EM's CaptureArcInfo.2010.dll. 
When DAT/EM software is installed, "Registration Failed" is reported near the end of installation. Run "C:\Program Files 
(x86)\Blue Marble Geo\Geographic Calculator\UnRegisterEsriPlugin.bat" before installing DAT/EM software. Contact 
DAT/EM for more information if you have Geographic Calculator and would like to use it in ArcGIS. 

The following changes were made to DAT/EM Capture for ArcGIS: 

1. DAT/EM received a customer’s feature class that would not work correctly with the DAT/EM line clip tool. The end 
of the line would clip correctly, but it could not clip a section out of the middle of the line. We found that we had to 
reapply the coordinate system to both the current object and the new one to get it to work. The same function that 
was failing in clip segments was working fine in the modify line tool, so although we found a way around the 
problem, the reason why we had to do it remains a mystery. 

2. The field value method of holding elevation did not work in v.7.1. It has been fixed. As long as the field name field 
is added and checked on in the ArcMap-side DAT/EM Options “Elevation Fields” page, the first elevation of the 
object will be stored in the field. If a Z vertex is also present, both methods will be used, so that the first vertex of 
the object will match the elevation field value. 

3. DAT/EM Auto Complete has the following fixes: 

a. DAT/EM Auto Complete has a fix for drawing with the correct subtype value set in the new polygon. 
Previously, no matter which subtype was picked as the target layer in the Create Features pane, the 
default subtype would be set. (Applies only for ArcGIS licensed to read and write subtypes.) 

b. Undo during DAT/EM Auto Complete could undo the last whole created object instead of the previous 
vertex. This is fixed. 

 

4. The ArcMap-side DAT/EM Options SI (superimposition) tab has a new setting to activate or deactivate line dash 
patterns in SI. 

 

New ArcMap-Superimposition “Show line patterns” setting 
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5. The Quick Snap option has increased performance that will work better on large data sets. Find the Quick Snap 
option in the ArcMap-side DAT/EM Options “SI” setting page. 

 

Quick Snap=Yes will work better for large data sets 

 

6. The “Zoom with Summit” and “Zoom Summit” settings that were previously located on the DAT/EM Capture 
Coordinates dialog have been moved. They are now located on a new “Summit Zoom” tab on the ArcMap-side 
DAT/EM Systems Options dialog. 

a. “Zoom with Summit” has been renamed to “Summit makes ArcMap zoom.” When on and Summit Zooms, 
ArcMap will zoom automatically to match according to the relative zoom scale set on the slider below. 

b. “Zoom Summit” has been renamed to “ArcMap makes Summit zoom.” When on and ArcMap zooms, 
Summit will zoom automatically to match according to the relative zoom scale set on the slider below. 

c. If the previous version had both settings checked on, the update will set only “Summit makes ArcMap 
zoom” on. Only one setting can be on at a time. If both are on as was allowed previously, ArcMap jumps 
unexpectedly to the center of its view again soon after Summit forces it to pan. 

 

   

Old “Zoom with Summit” and “Zoom Summit” setting location 
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New location and layout for the zoom matching settings 

 

7. The Trace Single drawing tool no longer adds an extra vertex at the cursor location where a snap point was 
picked. Previously, both the snap point and the cursor location were added to the sketch, resulting in an unwanted 
segment beyond the traced object. 

8. The Arc drawing tool would move at the wrong time in the following case: A) The ArcMap-side DAT/EM Options 
“Snap” page “Drive stereoplotter following pick” setting was on, and B) The first point of an arc was snapped to 
another object. The stereoplotter would move to the first point’s snap location when the end of the arc was 
digitized. This is fixed so that the stereoplotter moves to the first point pick as soon as it is picked. 

9. The Drive Summit Evolution tool was not working in v.7.1. It is fixed for 7.2. (This was actually a Summit fix, but 
Capture for ArcGIS users noticed it the most.) 

 

Drive Summit Evolution is fixed 

 

10. Airfield3D has the following changes: 

a. It now correctly writes Part 77 surfaces to the ObstructionID layer during export. 

b. It now correctly writes reports for Part 77 surfaces. 

c. It can now handle different Part 77 approaches at either end of the runway. 
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DAT/EM Capture for ArcGIS Pro (Beta) 
This beta version is compatible with ArcGIS Pro 1.1. 

The following changes were made to DAT/EM Capture for ArcGIS Pro: 

1. DAT/EM version 7.2 is the first version to install a beta version extension for ArcGIS Pro v.1.1. If you have 
Capture for ArcGIS enabled on your DAT/EM hardware lock and ArcGIS Pro 1.1 is found on the computer, it will 
install the DAT/EM extension. 

 

DAT/EM CAPTURE for ArcGIS Pro ribbon menu 

Basics: 

 It is currently limited to supporting only ArcGIS Maps (other types include layout views, etc.) 

 It currently only supports basic geometry types (Point, Polygon, Polyline, and Multipoint) in 
superimposition 

 It relies on ArcGIS Pro's geographic translation functionality. The accuracy of editing Features that are not 
in the same Spatial Reference as the current Map is limited by the functionality of ArcGIS Pro. 

Feature Creation: 

 Feature Creation is performed through ArcGIS Pro's creation tools. Basic types (digitizing a simple 
polygon/polyline) are the most supported. The ArcGIS Map View is always panned with Summit, as 
digitizing should always happen within the current view. 

 Certain functionality such as Plotter Snapping may not work if geometry is being created outside of the 
Map View. 

Feature Modification:  

 Basic modification tools are provided under the DAT/EM Capture Tab. These tools do not function 
through the ArcGIS Interface, and as such, do not also accept input from clicking within the mapview. The 
modification tools display their input step in SI, and are canceled upon activation of another tool. 

DAT/EM Capture Tab Overview: 

 SI Update performs a complete refresh of SI and resets the DAT/EM Cursor. This will cause either all 
geometry currently visible in the Map or all geometry currently visible within the current Summit model (if 
clip SI is on) to be redrawn. Since this operation can take a lot of time on large maps, normally SI only 
receives notification of changes. 

 Capture Settings opens the settings dialog, where various settings related to Capture's behavior can be 
changed (detailed below) 

 Snap Type Buttons allow selection of Vertex, Nearest, and Intersection snap. Intersection snap may 
cause a noticeable delay when panning. 

 Snap Mode Selection allows selection between 2D/3D snapping or to disable snapping. When in 2D 
snapping mode, snapping will only snap to the X and Y of the target location and keep the stereoplotter’s 
elevation. This selection can also be used to disable snap completely. 

 Drive Plotter to Snap, if set on, moves the plotter to the snapped location upon pick. 
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 Modify Tools: 

 Add Vertex adds a vertex to a polygon/polyline/multipoint. To add a vertex to a point layer, use the 
appropriate creation tool. 

 Move Vertex moves a polygon/polyline/multipoint/point vertex. 

 Delete Vertex removes a vertex from a polygon/polyline/multipoint. 

 Move Feature moves a feature in 3D using the stereoplotter. 

 Delete Feature deletes a feature using the stereoplotter. 

Keypad/Button Commands: 

 Capture for ArcGIS Pro supports several commands that can be input using the Button Manager with 
“User CAD” buttons or from the DAT/EM Keypad Controller using “Capture” keys. 

 All commands are case insensitive. 

o settings - launches the Capture Settings dialog. 

o setting <setting by name> - sets a given setting by name (as displayed in the Capture Settings 
dialog). Settings with spaces must be contained within quotes. 

Accepted values for a boolean setting are "true" or "false". 

Example: Setting "Clip SI" true 

Additionally, this command supports modifiers of "+" and "-" for settings for numeric values 

Example: Setting "Snap Tolerance" +1 

This example increases the snap tolerance by 1 ground unit. 

o siup - performs an SI Update 

o drivetosnap - sets the "Drive Plotter to Snap" setting as seen in the Snapping category of the 
DAT/EM Capture Tab. Example: drivetosnap true 

o datem_addvertex - launches the "Add Vertex" modify tool 

o datem_movefeature - launches the "Move Feature" modify tool 

o datem_movevertex - launches the "Move Vertex" modify tool 

o datem_deletevertex - launches the "Delete Vertex" modify tool 

o datem_deletefeature - launches the "Delete Feature" modify tool 

o snapmode - Sets the current snap mode, valid inputs are 3d, 2d, and off. Example: snapmode 3d 

o snaptypes - Sets the current snap types. Valid types are vertex, nearest, and intersection. 
Putting a "!" before the type turns it off. Snap types are seperated by a space, and multiple types 
can be specified. 

Example: snaptypes !vertex nearest !intersection 

This example turns off vertex snap, turns on nearest snap, and turns off intersection snap. 
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 Settings: 

    

 General 

o 2D Snap Search - if set, snaps are found by first searching in only the xy direction. If multiple 
possibilities are found, then they are prioritized by xyz distance. If this setting is not set, 
snaps are found by searching in 3D. 

o Snap Tolerance - This sets the radius around the cursor (in ground units) that will be 
searched for potential snap locations. 

o Summit Zoom Scale - This setting is a scaling factor between Summit's zoom and ArcGIS's 
zoom. Larger values will cause the mapview to be zoomed to a wider area compared to 
Summit. 

 SI 

o Clip SI - Limits SI Updates to the current Summit model area. If no model is loaded in 
Summit, SI updates will not occur until one has been loaded. 

o SI Text - Incomplete support for annotation layers. May cause poor performance on SI 
Update. If text shows at Z=0, may require one of the draping settings below. 

o Show Snap Ring - Shows a ring around the summit cursor with radius equal to the snap 
tolerance. 

o Drape Z-less objects over SI Vectors - If set, geometry that does not have a Z value will be 
moved in SI a Z value taken from surrounding 3D geometry, provided the geometry is 
currently visible. 

o Drape Z-less objects over Draping DTM Files - If set, geometry that does not have a Z 
value will be moved in SI to a Z value gathered from the selected DTM files in the "Draping 
DTM Files" setting. 

o Draping DTM Files - See above 

o Draping Z Offset - Applies a vertical offset (in ground units) to 2D objects currently being 
draped in SI. 

o SI Line Width Scale - Multiplies the ArcGIS line symbol size to get a line width for use in SI. 
Larger values will naturally cause lines in SI to be thicker. 

 Stroking - These are the arc stroke settings. All arcs are simulated by multiple straight segments. 

 Streaming – These are the streamed line settings that regulate the density of vertices added 
automatically to the feature. 

o  

o  
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FAQ for Capture for ArcGIS Pro: 

Q: The Z Location of input vertices is getting rounded off to whole numbers in ArcGIS Pro. Why? 

A: As of ArcGIS Pro 1.1, certain spatial references, for instance NAD83 State Plane Tennesee FIPS 4100 
(Meters), seem to cause rounding off of Z. This can be duplicated without DAT/EM Capture loaded, and 
seems to be ESRI's issue. Settings to Z resolution on Feature Class creation are not obeyed. This may only 
happen when features are in the same spatial reference as the current map. A temporary workaround would 
be to set the map spatial reference to unknown, but naturally, this limits editing to Features that are in the 
same spatial reference as the Summit project. 

Q: After changing Map Properties, especially the spatial reference, the Creation tool stops working. How do I 
prevent this? 

A: Relaunch the creation tool by selecting another tool in the "Create Features" panel and then reselecting the 
original. 

   

DAT/EM Capture and MapEditor for AutoCAD 
Changes apply to: 

32-bit AutoCAD 2004-2016 versions with the latest service packs. 

64-bit AutoCAD 2009-2016 versions with the latest service packs. Exception: 64-bit AutoCAD 2008 is not supported. 

BE ADVISED: DAT/EM Capture no longer supports AutoCAD 2000-2002 versions. If you use these old AutoCAD versions, please 
upgrade to AutoCAD 2004 or higher before installing DAT/EM version 7.2. 

DAT/EM software will install for multiple AutoCAD products of different year numbers on the same computer; however, it will not 
install for multiple same-year versions together. For example, it will install for AutoCAD 2011 and AutoCAD Map3D 2012 together, 
but it will not install for both AutoCAD 2012 and AutoCAD Map3D 2012. Please note that files may be copied manually to activate 
more same-year versions (contact DAT/EM Support for instructions). 

Autodesk Infrastructure Design Suite installs three same-year AutoCAD versions (AutoCAD, Map3D, and Civil3D). You must run 
each version and register/”accept” each one before installing DAT/EM software whether or not you intend to run every version with 
DAT/EM Capture active. DAT/EM software will install completely for only one of them. After that, the user can manually copy the 
AutoCAD \datem folder and the wintab driver file into the other two versions of AutoCAD. Contact DAT/EM Support for instructions. 

Reminder: Install all available AutoCAD service packs and updates before installing DAT/EM software. 

Reminder: After every new AutoCAD installation, you must run AutoCAD at least one time to activate its license before installing 
DAT/EM software. This applies to every version of AutoCAD on the computer whether or not you intend to use every version with 
DAT/EM Capture. 

The following changes were made to DAT/EM Capture and MapEditor for AutoCAD: 
 

DAT/EM Capture for AutoCAD 

1. Version 7.2 is the first version that will install for AutoCAD 2016 products. 

2. AUTOARC3D’s Stroke setting was not retained by writing the value to the registry upon AutoCAD exit. It could 
only be initialized from the SETUP dialog. Now either method of setting the stroke distance may be used. 

3. AutoCAD’s LINE command was missing the rubber band in Summit’s superimposition. 

4. SPOTX with a non-zero text rotation will now properly rotate the x and y offset values with the text. 
 

MapEditor for AutoCAD 

5. MapEditor failed to update layer filters on specific object type selections. This is fixed. 

6. MapEditor loads its dialog faster now. Previously, there was a delay while all tools loaded. Now it only loads a tool 
when it is selected for the first time. 
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7. Add Z Text or Block is a new MapEditor command to add elevation labels and/or blocks to existing objects. If the 
input objects are not already at ground elevation, a DSM file may be used to supply an elevation surface. 

 

New AutoCAD MapEditor “Add Z Text or Block” 

 Add Z Text or Block can input spot elevations that are currently AutoCAD POINTs or BLOCKs and add 
elevation labels and/or spot elevation blocks at the point locations.  

     

Before and after ““Add Z Text or Block” adds blocks and elevation labels to existing points 

     

Before and after ““Add Z Text or Block” adds elevation labels to existing blocks 
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 Add Z Text or Block can label the elevation and/or place a block at the center of a closed polyline. 

.      

Before and after ““Add Z Text or Block” adds blocks and elevation labels to closed polylines 
 

8. Densify Polyline is a new MapEditor command to add vertices along existing polyline segments. Use this 
command to densify breaklines in order to make better TIN input or any time long segments are not desired. 

 

New Densify Polyline tool 
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DAT/EM Capture and MapEditor for MicroStation 
Changes apply to Capture for MicroStation. DAT/EM software installs for the following MicroStation versions on 32-bit and 64-
bit operating systems: 

 MicroStation V8 and V8 2004 Edition: Version should be 08.05.00.34 or higher. 

 MicroStation XM: Version should be 08.09.04.88 or higher. 

 MicroStation V8i, V8i-based Bentley Map and Map Enterprise Select Series 1 (1 not recommended), 2, and 3; 
MicroStation PowerView Select Series 3; Power GeoPak* Select Series 3 

If you upgrade from Select Series 1 to 2 or 3, you must reinstall DAT/EM software after installing the Series upgrade.  

DAT/EM will install for all versions of MicroStation that are present on the computer at the time of the DAT/EM installation. 
 
*Note about Power GeoPak Select Series 3: DAT/EM Software installs for Power GeoPak SS3, but has initial loading 
conflicts that affect the GeoPak and DAT/EM menus. Bentley has offered a workaround for this issue. If you have the Bentley 
Power GeoPak SS3 product, please contact DAT/EM for further installation instructions. 
*Note about Power GeoPak Select Series 4 (which runs with  MicroStation Select Series 3): This product seems to be 
more successful running together with DAT/EM applications. There still could be issues. Please contact DAT/EM Support if 
using this version. 
 
Note for MicroStation CONNECT Edition (64-bit MicroStation): MicroStation CONNECT Edition software was released by 
Bentley 1 Sept. 2015. DAT/EM version 7.2 does not contain an interface to it. We plan a limited beta interface available during 
the v.7.3 development cycle. Please contact DAT/EM Support if you are interested. 

The following changes were made to DAT/EM Capture and MapEditor for MicroStation: 

 
General Subjects in Capture for MicroStation 

1. Tentative point object highlighting has been added to Summit’s superimposition (SI). The object that is highlighted 
by a tentative point snap on the MicroStation side will also highlight in SI. Note that this function could degrade 
performance; if we find that it is too slow, we may remove this capability in a future beta. 

2. Selection Set Export (to create an .sset file) would not work if the directory specified by default was a read-only 
folder. The Bentley function called by Selection Set Export initializes to C:\, which is read-only on many systems. 
It did not return an error, so the dialog to browse to a different folder would not appear and the registry setting 
“HKEY_CURRENT_USER\Software\DAT/EM Systems International\MapEditorV8\gSetExportFilename” would not 
be made. DAT/EM has implemented a workaround to set the field to the current working directory. If this function 
is found to be called in other commands, it will be similarly replaced. 

3. Selection Set “Add from Fence” now checks that the level is displayed in the active view before adding it to the 
set. (Sept. 8, 2015) 

4. MicroStation-to-Summit superimposition has the following fixes: 

a. There is a fix for transforming the coordinates for some reference files. Previously, these reference files 
would not appear in Summit’s superimposition. 

b. The by-level color calculation was fixed for reference files that had different by-level colors on same-
named levels in the master file. 

c. A problem was fixed in the reference file element selection. 

 



DAT/EM Systems International RELEASE 7.2 Release Notes 
 

 33 

New Commands in Capture for MicroStation 

5. RCENTERLINE is a new interactive command to draw a center line between two other strings. For example, it 
could draw a line string down the middle of a river after picking the left and right river bank elements. 

  

Before and after running RCENTERLINE 

First, prepare the input. Manual breaks will be used to terminate the center line (to account for anomalies like 
islands, tributaries, the left and right bank not ending in the same area, etc.). If the centerline will be placed along 
a subset of the total vertices, break the input lines where the center line should start and end. 

Next, set the level, color, weight, and line code for the new centerline. It will be placed on the active level and 
attributes; the level and attributes of the selected sides are ignored. 

Keyin: RCENTERLINE 

Follow the prompts to pick the left and right side elements (such as banks of a river). The utility accepts the 
following element types: Type 12 complex string, type 3 line, type 4 line string, type 16 arc, type 27 bspline curve, 
and type 11 curve. 

It places a center line between them by interpolating (x,y,z) values. If the two selected elements contain arcs or 
curves, the centerline will be stroked into a non-complex line string. 

The underlying algorithm interpolates a surface between the two selected elements and extracts the iso (0.5) 
curve between them. This performs very well with most test cases. It does not perform as well with cases where 
the two banks have very different curvatures with asymmetric, sharp edges.  

 

6. SUMMIT ZLOCK and SUMMIT ZUNLOCK are new keyins to lock and unlock the Summit Z coordinate. They 
have the same effect as toggling “Lock Z” on Summit’s Locking toolbar. 

 
SUMMIT ZLOCK locks Summit’s Z axis 

(Summit’s Locking toolbar shown) 

 
Changes to existing commands in Capture for MicroStation 

7. All commands that simulate arcs by stroking them into straight segments have a new option to stroke the arcs by 
an error tolerance method. This error tolerance is a maximum deflection from the original arc. Compared to the 
old segments-along-a-projected-circle method, it will add fewer points along a tighter arc and more segments 
along a long, gradual arc. You can think of it working similarly to the MapEditor Filter command, where both the 
distance and the angle of deflection help determine how many points to retain. The affected commands include 
Stroke Element (MESTROKEELEMENT), 3DOFFSET, ROAD (ROAD SETTINGS) with Autoarc” and “Stroke 
elements” on, and AUTOARC with the “Stroke arcs” option on. 

The old segments-along-a-projected-circle method is still available when the stroke deflection tolerance is set to 0 
(zero). 

A default setting may be set in DATEM SETTINGS. “Fetch Default” buttons appear on affected dialogs. This way, 
each command may have its own setting or it can access the default setting at any time. The default stroke 
tolerance does not directly affect any other commands; they must use their own “Fetch Default” option in order to 
access the default setting. 
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Default Stroke Tolerance in DATEM SETTINGS 

  

Examples of new arc stroke method settings in 3DOFFSET and ROAD SETTINGS 

8. There are some changes to multiple commands that insert and scale cells. The scaling should react better to user 
input. 

9. 3DOFFSET has the following changes: 

a. If complex element contained vertices that were very close together, 3DOFFSET either failed to create an 
offset element or it created only a partial element. This is fixed. 

b. Fixed a problem where 3DOFFSET and ROAD were interpolating incorrect elevation values on parallel 
elements. (April 3, 2015) 

c. Fixed a problem where multi-vertex segments that defined a nearly straight line would offset with a “jog” 
appearance in some areas, where the xy offset distance would increase or decrease somewhat. 

d. 3DOFFSET has additional keyins. It is now possible to make any of the 3DOFFSET dialog settings from a 
keyin. The complete keyin list is as follows: 
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 3DOFFSET                       

 3DOFFSET MEASURE                     

 3DOFFSET MARKON                   

 3DOFFSET MARKOFF                    

 3DOFFSET PCOMPLEXON               

 3DOFFSET PCOMPLEXOFF               

 3DOFFSET FIXEDOFFSET            

 3DOFFSET ZOFFSET <offset>                  

 3DOFFSET XYOFFSET <offset>                

 3DOFFSET ELEMENTSYMB      

 3DOFFSET ACTIVESYMB 

 3DOFFSET STROKETOL <tolerance> 

 

10. AUTOARC, BREAK ELEMENT, CROSSCHECK, and LABELIT have a fix in their underlying “break multiple” code 
to prevent creation of element fragments caused by duplicate break points (e.g. caused by double clicking at the 
same location. 

11. Change Attributes Interior has a new setting, “Include Open Elements as Boundaries”, that allows it to assume a 
boundary element is closed. That is, if it is a line string, Change Attributes Interior will assume there is a segment 
from the last vertex to the first vertex. 

 

 

New option in Change Attributes Interior 

Note that this change allows Change Attributes Interior to be used in some cases instead of ROADCLIP to 
change the attributes of sidewalks where they cross driveways. To do this, draw the driveway as a single element 
that goes into and back out of one or more buildings and returns to the street; Change Attributes Interior on the 
sidewalks; clip the driveway from the building last.  

12. Check Attributes would jump to the beginning of the list after the user edited an object. Now it the edited object is 
removed from the list and the list selection is set to the previous file position. 
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13. Close Linestring from a parameter file has the following changes: 

a. Close Set was not being displayed in Command Description Section. 

b. When editing an existing Par file entry, the currently configured Selection Set was not being carried over 
to the edit dialog. 

14. “Change to 2D” MECHANGETO2D can now operate on any element type that the Selection Set Editor can 
handle. Previously, it would not work on cells or text. Error handling has also been improved. 

15. CPLINE: In the Parameter File Editor, sometimes CPLINE (MECPLINE) would activate its settings dialog, but the 
“OK” button would close the dialog without adding the line to the parameter file. This is fixed. 

Note that MEVOLUME and ZLABEL were not reported, but could have had the same problem and were also 
fixed. 

16. CROSSCHECK has the following changes: 

a. CrossCheck selected in the Parameter File Editor could crash. 

b. CrossCheck checkbox settings could be presented incorrectly in the “Edit” dialog in the Parameter File 
Editor. Crashing could occur when a CrossCheck line was edited with the “Edit” option. 

c. In v.7.1, if the endpoint of a linestring was touching a segment of a shape, it wasn’t seen as an 
intersection. Now endpoint-to-shape-segment intersections are found correctly. 

d. CROSSCHECK, AUTOARC, BREAK ELEMENT, and LABELIT have a fix in their underlying “break 
multiple” code to prevent creation of element fragments caused by duplicate break points (e.g. caused by 
double clicking at the same location). 

17. DATDRAW has the following updates: 

a. Improved error checking to prevent crashes. 

b. DATDRAW STREAM could malfunction in MicroStation version V8i SS3, but it worked in other versions. 
The angle threshold calculation was found to be the cause and was fixed. 

18. DATEM SETTINGS has the following changes: 

a. DATEM SETTINGS no longer gives the message, “Lib not found: dat_emV8.cel” when the settings dialog 
launches. 

b. DATEM SETTINGS offers a new “Default Stroke Tolerance” setting for a global default arc stroking 
tolerance. See more information above.  

 

19. DEPRESSION could crash if the previously used cell library was not attached. 

20. GRIDIT run from a MapEditor batch file has the following changes: 

a. The dialog that appears in the Parameter File Editor is renamed to “DAT/EM Gridit Batch” to match the 
dialog that appears for the GRIDIT BATCH command. 

b. The redundant “Ticks” option has been removed. All it did was use a cell called GRID, which could just as 
easily be set by the Cells option. 

c. Previously GRIDIT would only place marks that were fully inside the boundary element, not on the 
boundary element. Now there are two settings: “On and inside” and “Inside only”. “On and inside” can 
place text and grid marks directly on the boundary line as well as inside the boundary. 

d. The grid marks are now optional. Placing text was already optional. Now the user can place both text and 
marks, marks only, or text only. 

e. Corners-only labeling is now possible when the “Outside” labels are on. 

f. Several error handling problems were corrected. 
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21. FACESHIFT has the following changes: 

a. FACESHIFT EXISTING, which edits points to move them onto an existing surface or bspline surface, now 
also accepts shape and ellipse elements as input to define the surface. It also has some additional 
functionality fixes. 

b. Enhanced functionality and error checking fixes. 

22. JOINIT has the following changes: 

a. The parameter file version of JOINIT now has a log file option. The interactive version already had this 
option. 

b. The interactive version of JOINIT previously automatically appended new log file data to the end of an 
existing log file of the same name. Now if it finds an existing file of the same name, it will prompt to 
replace, append, or rename the file: 

 

New interactive Joinit existing log file prompt 

23. LABELIT, AUTOARC, BREAK ELEMENT, and CROSSCHECK and have a fix in their underlying “break multiple” 
code to prevent creation of element fragments caused by duplicate break points (e.g. caused by double clicking at 
the same location. 

24. PSQR SELECT has a change to the rubber band to help the user see that a 2-point rectangular building is 
possible. Although the 2-point building was previously possible, it was difficult to see, because the previous 
rubber band only showed as 0 or 90 degrees. Now it will show 0, 90, 180, and 270 degree rubber bands 
depending on the cursor position. 

25. Replace Objects, MEREPLACEOBJECTS, has some error handling changes to help prevent it from crashing 
when replacing cells with points. 

26. ROAD has the following changes: 

a. ROAD and 3DOFFSET were interpolating incorrect elevation values on parallel elements. This is fixed. 

b. There are new keyins to make settings without launching the ROAD SETTINGS dialog: 

 ROAD LINE - sets road to Line Mode and starts road digitizing 

 ROAD CURVE - sets road to curve Mode and starts road digitizing 

 ROAD AUTOARC - sets road to AutoArc Mode and starts road digitizing 

 ROAD AUTOARCTOL <stroke tolerance in Master Units> - sets the Autoarc mode arc 
tolerance to the specified value 

 ROAD AUTOARCPRES 0 - Turns off "Preserve Complex" in Autoarc mode 

 ROAD AUTOARCPRES 1 - Turns on "Preserve Complex" in Autoarc mode 

Note: The remaining settings should be made and saved to road configuration files. Use the existing 
ROAD LOADFILE <filename> keyin to reactivate an offset configuration. 
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c. “Stroke Elements” is a new setting that allows all resulting elements to either contain arcs (off) or to stroke 
arcs into a series of line segments that simulate the appearance of an arc. 

d. If “Autoarc” and “Stroke Elements” are on, there is a choice of how to stroke the arcs. 

 If “Stroke Tolerance”=0, the old algorithm is used, which strokes the arc by placing 128 segments 
in a projected circle that contains the arc is used. Segment length will vary depending on the 
curvature of the arc. 

 If “Stroke Tolerance” is not equal to zero, the value is used as a maximum offset distance 
between the new segment and the original arc. This can be thought of as an error tolerance. 
Segments will still vary in length depending on the curvature of the arc, but the density of the 
vertices will better suit each arc than the older segments-per-projected-circle method. 

 

New Stroke Elements applies to the Autoarc method 

When Stroke Elements is off, all elements may contain arcs: 

 

Example of ROAD Autoarc Stroke Elements off 
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When Stroke Elements is off, all elements will have segment-stroked arcs: 

 

Example of ROAD Autoarc Stroke Elements on 

 

27. ROADCLIP has the following changes: 

a. Enhanced error handling to prevent crashing. 

b. Fixed so that it would not delete the original element whether or not the clipping operated on it. 

c. Fixed so that it would not crash when the element to be clipped was an arc. 

Note: Depending on the direction of the line being clipped, ROADCLIP might treat interior segments as 
exterior.  Reversing the element with REVERSELINE before running ROADCLIP will give the desired 
results. 

28. RR (Railroad) now saves its settings between MicroStation sessions and has new keyins to make settings without 
launching the dialog box: 

a. RR SPACING <distance in master units (mu)> - lateral distance between cross ties 

b. RR WIDTH <width in mu> - distance between right and left rails 

c. RR TIELEN <length in mu> - total length of cross ties, which can exceed distance between the rails 

 

New railroad command keyins 
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29. SHEETCUTTER has the following changes: 

a. For MicroStation V8i Select Series, the dialog layout was corrected. The buttons are larger than in 
previous versions, which had caused them to shift their location. 

b. The “Browse” button now browses for an output folder. Previously it could ask for a file instead. 

c. If the “Inside Fence” setting is on when the “Cancel” button is used, it will cancel immediately. Previously, 
it would give a message before exiting if no fence existed. 

30. The “SPOTINTERP CELLNAME <cell name>” key-in did not work. It always set the cell name to CROSS, no 
matter what cell name was keyed in. This is fixed to activate the user-selected cell name. 

31. Stroke Element has the following changes: 

a. Stroke Element in the Parameter File Editor had a problem with selection set names that were more than 
20 characters long. This is fixed. 

b. A new algorithm option has been added. Previously, it stroked arcs using a segments-per-projected-circle 
algorithm, which could place segments that were either too short or too long, and placed different length 
segments on every different arc. Now it can use a maximum deflection tolerance algorithm. A master 
stroke tolerance can be set in DATEM SETTINGS > “Default Stroke Tolerance. See DATEM SETTINGS 
above. 

The first time the command is used, it will show the value from DATEM SETTINGS. Once the user 
overrides it by entering a different value in the individual command settings, it will retain the individual 
value. The individual commands also offer a “Fetch Global Default” button that fetches the value found in 
DATEM SETTINGS. For example, for Stroke Element: 

 

New Stroke Tolerance setting and Fetch Global Default button 

 

32. TOUCH was touching elements to cell components, that is, elements within a cell. Now it ignores cells, even if 
they are in the “to” selection set. Note: As a workaround in previous versions, make sure cells are not included in 
the “to” selection set. 

33. VISIT has new key-ins that work with both VISIT ELEMENT and VISIT FILE: 

a. VISIT NEXT – scrolls to the next point in a set (same as “Next” button on the dialog) 

b. VISIT PREVIOUS – scrolls to the previous point in a set (same as “Previous” button in the dialog) 
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34. Volume calculations in MEVOLUME have the following changes: 

a. The “inside fence” option could be too large when surface elements traversed the fence boundaries. This 
is fixed. 

b. The new parameter “Max distance between Ends (in Master Units)” allows unclosed elements to be 
treated as boundary elements so long as the start and endpoints are within the distance specified. The 
software will treat the elements as if they were closed boundaries without physically closing them or 
modifying them. 

  

New maximum distance settings in MEVOLUME dialogs 

 

35. XYZOUT’s “Standard Visit FMT (format)” button now correctly sets the delimiter setting to comma. Previously, it 
set the output fields correctly, but did not set the delimiter. 
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DAT/EM Capture for Blue Marble Global Mapper 
Changes apply to Capture for Global Mapper . Global Mapper 16.x dated after March 2, 2015 recommended. Global Mapper 
17 is not supported at this time. 

The following changes were made to DAT/EM Capture for Blue Marble Global Mapper: 

1. Note: On March 2, 2015, Blue Marble fixed a stack corruption error that affected the import of SHP files that 
contained islands/holes. DAT/EM recommends when possible to install a version of Global Mapper 16 dated after 
March 2, 2015. However, if that is not possible, DAT/EM v.7.2 has added code to avoid the error in older versions 
of Global Mapper. 

2. There is now a DAT/EM cursor on the Global Mapper side. It indicates the current position of the Summit cursor. 

3. There is a new “Snap Ends” option for linear digitizing commands. It creates end-snapped features without 
making them an Area. The monotonicity settings are disabled when “Snap Ends” is checked on. 

4. Global Mapper scripts may now be run from the DAT/EM Keypad Controller within the current Global Mapper 
session. An example script called “classBuildings.gms” is posted for download on www.datem.com.  

 Create a Global Mapper script (.gms) file (reference link: 
http://www.globalmapper.com/helpv13/ScriptReference.html). 

 Program a DAT/EM Keypad Controller key. If you are referencing a script file, you must provide the full 
path. 

 

Call a script file using the full path 
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Alternately, for simple scripts, the text of the script can be used to program the key. 

 

Simple scripts can be entered directly in the “Text” field 

 

 In Global Mapper, open the data file in which you wish to run the script. 

 The referenced script file will be executed when the DAT/EM Keypad key is pressed. 

The example script, “classBuildings.gms”, classifies MicroStation shapes from Level 33 (Unclassified Areas) 
into Global Mapper Buildings (Area Class  “Building – Ground”) using a DAT/EM example project. 
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Before running the script, the MicroStation DGN level is an unknown area type in Global Mapper 
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After pressing the key to run the script, all DGN Level 33 shapes are classified as Global Mapper Buildings. 

 

DAT/EM will be looking at the Keypad conventions to see how to expand the current GM scripting interface with 
our own custom interface. Please let us know if you have any specific requests or recommendations. 
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5. The installation process will now install an example of a Keypad .dkf file for Global Mapper. To use it, select 
DAT/EM Keypad Controller>File>Open and browse for "C:\ProgramData\Datem 
Systems\keypad\GlobalMapper.dkf". 

 

Example DAT/EM Keypad Controller .dkf file 

 

-End- 


