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The following changes have been made to DAT/EM products between Release 7.4 and Release 7.5. Please review these 
revisions made to the software and update your software to implement changes. 
 
As always, DAT/EM welcomes comments and suggestions from you, our clients, so please don’t hesitate to contact our 
support department at support@datem.com or call us with your requests. 
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Operating Systems and Microsoft Updates 
DAT/EM software no longer supports 32-bit operating systems. If you attempt to install the software on a 32-bit operating 
system (OS), some parts may work, but DAT/EM will not guarantee that everything will work. DAT/EM will not fix any 32-
bit OS-related problems. DAT/EM will not support any 32-bit OS at any time in the future. 

Any reference to an OS in the remainder of this document refers to the 64-bit version of that OS only. 

DAT/EM Release 7.5 is supported on the following operating systems: 

 64-bit Windows 7 Ultimate and Professional with all Windows Updates applied. 

o DAT/EM will stop supporting Windows 7 when Microsoft ends extended support on January 14, 2020. 

 64-bit Windows 8.1 Professional and Enterprise with all Windows Updates applied. 

o Microsoft and DAT/EM no longer support Windows 8.0. Microsoft recommends Windows 8.1 as a service 
pack for 8.0. 

o DAT/EM will stop supporting Windows 8.1 when Microsoft ends extended support on January 10, 2023. 

o If you need to choose between Windows 8.1 and 10, DAT/EM recommends Windows 10. 

 64-bit Windows 10 Professional and Enterprise with all Windows Updates applied. Windows 10 notes: 

o It is the client’s responsibility to be sure that the video card is new enough to work in Windows 10. 

o In general, stereo does not work in Windows 10 with nVidia Fermi generation and older cards. Exception: 
One client reported a Quadro 6000 works with current Windows Updates installed (as of November 
2017); however, many other clients and DAT/EM testers report the more common Fermi-generation 
cards, the Quadro 4000 and 5000, do not work with Windows 10. Either the drivers won’t install or they 
install, but stereo settings do not work. 

Hardware Locks/Dongles 
Install Microsoft Updates before applying lock reset programs. Network licensing should have the same Sentinel driver 
version on both the server and the local computers running the software. 
 

1. DAT/EM changed its hardware lock configuration with the release of version 7.1. If you are upgrading from v.7.0 
or lower, please contact your reseller or support@datem.com to obtain a WriteLock application. The WriteLock 
application will prepare your lock to run v.7.5.  
  

2. Safenet Sentinel driver version 7.6.8 is provided with DAT/EM version 7.5. It is the same version that was 
provided with 7.2 through 7.4. If version 7.2, 7.3, or 7.4 (release or beta) dated after August 3, 2015 was not 
previously installed, then the first run of the DAT/EM self-extracting executable will install or update the Sentinel 
driver. Answer “Yes” to Sentinel’s firewall question and reboot when asked. 

 

 
It is very important to answer “Yes” to this question 
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If you have a network lock on a network server and it is not already running Sentinel v.7.6.8, install it on the server 
before you install DAT/EM v.7.5 on your DAT/EM workstations. The Sentinel driver version must match on the 
network lock server and all workstations that will access the lock. DAT/EM provides a convenient prerequisites file 
that installs the C++ redistribution files (Microsoft files required to run Sentinel) and the Sentinel driver: 

 http://datemsystems.com/down/Datem_PreReqs_blt_11_06_2017.exe 
 This is www.datem.com > Support > Downloads > Prerequisites > “Prerequisites installation, 

includes Visual C++ Redistributables and Sentinel 7.6.8 - EXE version” 
 Answer “Yes” to Sentinel’s firewall question and reboot when asked (see image above). 

 
 

Stereo Viewing Devices and Drivers 
Please note the following changes, additions, and information about compatible stereo viewing devices and drivers: 

1. DAT/EM now supports 10-bit color and larger tile sizes in the display for AMD graphics. AMD video cards are 
used with high-definition dual monitors such as the Schneider Digital PluraView. The AMD video driver version 
must be current; this capability was added to their drivers in the fourth quarter of 2017. More changes are in 2018 
drivers. (November 15, 2017, updates for later drivers February 26, 2018) 

Note: To set the Windows icons to be larger on high-definition displays, right click on a blank area of the Windows 
10 desktop and select Display Settings. Set the Scale and Layout percentage higher. You may need to log out 
and log back in for this setting to take effect in all applications. 

 

Set the Window Scale and layout percentage higher for high-definition displays 

2. Please note our video driver installation/update recommendations for nVidia Quadro cards: 

 Always run Windows Updates first. 

 DO NOT install the driver on media packaged with a video card. It will be too old. 

 Get the latest driver for your video card and operating system. For nVidia, get the driver from 
www.nVidia.com. During installation, turn on “Custom (Advanced)” and “Perform a clean installation”. 

  

Always choose “Custom” and “Clean” in nVidia driver setup 
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 For nVidia video driver settings, see our video driver installation video here: http://www.datem.com/training/, 
“How to Download and Install NVIDIA Graphics Drivers”. 

 For Windows 10 with nVidia 3DVision, use an nVidia Quadro K-, M-, or P-series graphics card. Do not use the 
Fermi-generation or older cards, such as the Quadro 4000. It is important to install a driver from around the 
same date of your latest Windows Updates to make OpenGL stereo work correctly. 

 There is a new Windows 10 stereo settings guide at www.datem.com > Support > Downloads > Help and 
Troubleshooting (direct link: http://datemsystems.com/downloads/Help/How-to-set-up-monitors-for-OpenGL-
stereo-in-Windows-10.pdf). 

Software Installation, File Locations, and Installed Utilities 
The following has changed for DAT/EM software installation or the location where DAT/EM applications store data: 

1. Version 7.5 does not install for and is not supported on 32-bit operating systems. 

2. The user may specify a custom installation location for both the 32- and 64-bit program files folders. Previously, it 
only asked for the 32-bit location (with a default of only C:\Program Files (x86)\Datem Software).(June 6, 2017) 

3. The obsolete HLP (WinHelp) files are no longer installed. (September 19, 2017) 

4. For MicroStation, the paths in the installed .cfg (configuration) files will now list the correct drive letter when you 
customize the “\Program Files (x86)\Datem Software” folder during DAT/EM software installation.(June 27, 2017) 
 

 
The custom 64-bit location is new 

5. Release Information will now show Summit Evolution Federal version and DAT/EM Point Cloud VR. (May 8, 2017) 
 

 
New Federal Version and Point Cloud VR displays 
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DAT/EM Virtual Reality Products 
The following changes apply to DAT/EM Virtual Reality (VR) products. 

1. DAT/EM VR products are in the process of being reconfigured. At this time, the DAT/EM VR Desktop, which is 
needed to run Summit and LandScape with the Oculus Rift and DAT/EM Point Cloud VR™ (beta) may be 
installed, but are considered in development. Ask DAT/EM about virtual reality support and licensing. (March 2018) 

DAT/EM Keypad 
The following changes have been made to the DAT/EM Keypad products: 

1. The example ESRI.dkf file settings were fixed for buttons 187 and 189. “Call Command” was previously missing 
before the trace multiple user IDs. (July 26, 2017) 

CAD Enabler 
The following changes have been made to the DAT/EM CAD Enabler application: 

1. On start, the CAD Enabler now shows “No Change” instead of all products active. (November 30, 2017) 

 

On start, CAD Enabler shows “No Change” instead of all products active 

2. The CAD Enabler will now attempt to run as Administrator, even if the user is not an Administrator. This isn’t 
always possible, however, especially if the ArcGIS extension registration tool is required. If it can’t run as 
Administrator, it will warn the user about administrator privileges. (November 30, 2017) 

 

CAD Enabler’s new warning for users who do not have Administrator privileges 
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Coordinate Transformations and Elevation Database 
The following changes have been made to the DAT/EM-Blue Marble coordinate transformation selections and elevation 
database. All of the files to activate these changes are installed with the main DAT/EM installation executable. There are 
no changes to the elevation database installation file built in 2015 found here: 
http://datemsystems.com/down/SetupElevationModels%20blt%2003%2015%202015.exe. 

1. The coordinate transformation libraries were updated to match Blue Marble Geographic Calculator 7.3. All 
changed files are included in DAT/EM’s main setup installation. A new elevation database build is not required 
(the current elevation database installation is still dated 15 March 2015, link above). (July 11, 2017) 

2. Vertical system selections will be ignored for geocentric types that are already set. Having these set was 
preventing some transformations from being offered. (December14, 2017) 

3. The default input system for VisionMap A3 projects will no longer have a vertical system set. There should not be 
a vertical selection for geocentric types, which the A3 sensor uses. (December14, 2017) 

 

Summit Evolution 
The following changes have been made to Summit Evolution and the applications that are provided with it.  

 
General Summit Evolution Subjects 

1. There is a new Summit Evolution Federal edition of Summit. This product is intended for users in the United 
States government. This product supports the U.S. DPPDB format imagery, the custom x parallax view corrector 
tool, and the interior distortion removal tool requested by U.S. Government users. If you currently have Summit 
Evolution Professional and have a need for these tools, please discuss it with your reseller or contact 
sales@datem.com.  

2. Summit Evolution Lite Edition now has a File > New project dialog. It can make the project types that already 
have complete orientation or ground coordinates. (May 19, 2017) 

 

Summit Lite’s new File > New dialog offers pre-oriented project types 
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3. The File > New project dialog has a new Generated Stereo from Orthophotos project icon. This is not a new 
project type; it is exactly the same as the existing Lidar stereo and SAR stereo projects. It simply offers a more 
clear selection for building generated stereo projects. (April 26, 2017) 

 

4. Summit will now optionally warn the user when any of the project file paths are broken. The settings are off by 
default. To see the warning, check on Summit > Tools > Options > Project tab > Missing files warning > 
Images, Camera, and Control. After you see a message about missing files, go to Summit > Edit > Project and 
fix the paths for the files shown with a red “X”. (June 2, 2017) 

  

Optional missing files warnings 
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Missing Files appears when files are missing and the warning settings are checked on 

 

After the warning, use Edit > Project and fix the paths for the files with the red “X” 

 

5. Summit > Tools > Options > Project tab > Automatically load next model when outside stereo region now 
offers negative percentage values. The negative values allow you to move beyond the current stereo area for a 
certain distance without changing models. To change models, move an even greater distance beyond the stereo 
area. This allows you to prevent a model change when you’re working near the edge of a model, yet still have a 
quick way to make it change when you choose to do so. (April 4, 2018) 
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6. The Project tab in the Project window now clears if a multi project solution .smtsln file is open at the time a new 
project is imported from File > Import. (April 26, 2017) 

7. DAT/EM Drawing Objects will now appear as superimposition (SI)-like vectors over the embedded bird’s-eye view 
if “Show SI” is on for the embedded view. Right click directly on the view to turn this on from the context menu. 
Note that DAT/EM Drawing Objects are not sent to SI the way Capture vectors are; therefore they will not work as 
input for Contour Creator unless they are saved to and loaded from a vector file format. (August 1, 2017) 

8. Summit will now open the last-opened model (if the setting to do that is on), even if the input device is not found 
on Summit start. (April 27, 2017) 

9. The Move to Ground tool (Summit > Tools > Move to Ground) has the following changes: 

a. Move to Ground will retain the most recently applied dialog list sort method after changing models. (April 
28, 2017) 

b. Move to Ground will give a reminder to open a model if one or no images are currently open. (May 18, 2017) 

c. Move to Ground will now draw and refresh the measured and calculated marks in all open viewports, not 
just the focus viewport. (June 7, 2017) 

 

10. Tools > Shortcuts offers an additional report type that lists both set and “[Not set]” options. (May 1, 2017) 

 

New “Report All” reports all shortcuts whether they are set or not 
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11. Any icons set by the user on Summit’s three Custom CAD toolbars could revert to numbers after Summit was 
running for a period of time. This is fixed. (April 5, 2018) 

12. Cursor ground rings and ground grid (settings in Tools > Cursor tabs) can now work when the project is in 
longitude-latitude coordinates. (November 1, 2017) 

13. NDVI (Normalized Difference Vegetation Index), VARI (Visible Atmospherically Resistant Index), and GEMI 
(Global Environmental Monitoring Index) maps are now supported for the display of 4-band imagery. VARI will 
also work on 3-band RGB, but is not as good as NDVI working on 4-band imagery. The settings appear in 
Summit’s Channel Manager. (May 9, 2017) 

 

Summit’s Channel Manager with the new NDVI settings 

 

Examples of different NDVI channel maps for the same image in multiple viewports 
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For more information on NDVI, VARI, and GEMI, see these independent third-party articles: 

http://desktop.arcgis.com/en/arcmap/10.3/manage-data/raster-and-images/band-arithmetic-function.htm  

https://earthobservatory.nasa.gov/Features/MeasuringVegetation/ 

https://support.dronedeploy.com/v1.0/docs/understanding-ndvi-data  

 

14. Summit’s 3D Vector Split Window is fixed so that it does not crash when showing a large number of 3D building 
vectors. (June 16, 2017) 

15. In some cases when DAT/EM applications (such as Contour Creator or Summit’s Model Bounds) automatically 
wrote new objects to a previously empty level in the DGN file, the Level Manager would not update, and the level 
name would continue to show in plain text. Plain text indicates an empty level. Now it forces a refresh, so the 
levels show in bold text to indicate they contain objects. (February 12, 2018) 

16. The SI Layer Manager has the following changes: 

a. The SI Layer Manager has improvements to fix list refresh issues and to not allow checked layers to be 
set without checking any layers. (May 1, 2017) 

b. The SI Layer Manager now properly retains the Condense Layers setting. Previously, it would always be 
on when the SI Layer Manager reopened. (May 22, 2017) 

c. This fix was for a superimposition for MicroStation issue, but appeared to be an SI Layer Manager 
problem. With Condense Layers off in the SI Layer Manager in Summit, MicroStation reference file 
levels were not being separated properly from same-named main file levels. An object from a reference 
file could be superimposed when its level in the main file was checked on, but its level in the reference file 
was not checked in the SI Layer Manager. In the main and reference files, text might be displayed 
correctly, while shapes, text nodes, and lines were not. (May 22, 2017) 

d. This fix was for a superimposition for MicroStation issue, but appeared to be an SI Layer Manager 
problem. If a layer is turned off for display in MicroStation, it will not be sent to SI unless “All levels” is 
turned on in SI SETTINGS in MicroStation. (November 16, 2017) 

e. The SI Layer manager could not manage more than 10,000 layers. The limit is now 20,000 layers. This is 
the total of main file plus reference file layers, if using AutoCAD or MicroStation. (November 16, 2017) 

17. Any coordinate pasted into the ground coordinate display in the status bar will move to that coordinate, as long as 
the coordinate is valid within some model in the project and the setting to automatically open the next model is on. 
Previously, it would fail to move to some coordinates within the project. (May 18, 2017) 

18. Summit’s Status Tracker was not being installed for 64 bit in v.7.4. This is fixed. (Sept. 5, 2017) 

19. Summit and all other DAT/EM applications that have utilities to load saved settings from .reg files have an 
updated function to load the .reg files more easily in Windows 10. The old function worked fine in older Windows, 
but often gave permissions errors in Windows 10 user profiles. Sometimes the only symptom would be the .reg 
file settings not taking any effect. Other times a permissions error dialog would appear. The application would 
have to be “Run as Administrator” to get around the problem in earlier versions; this is no longer necessary. 
(November 30, 2017)  

20. When Summit’s input device used a button set to Type=Plotter, Action=System Mouse toggle, some of the 
resulting system mouse movement would leak through and move Summit’s cursor a small amount at the same 
time. It could also zoom the Summit view while in system mouse mode. This has been fixed so that the cursor 
only moves the system mouse pointer when toggled to system mouse mode. (April 3, 2018)  
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21. DAT/EM Drawing Objects’ snap types are now on the Drawing pull-down menu, Drawing > Snap > Snap Action > 
Nearest/Vertex/Midpoint. This enables them to appear in the Tools > Shortcuts dialog, so that they may be set to 
shortcut keys. Once on shortcut keys, they may also be set in Button Manager’s Type=Shortcut Key buttons. (June 
15, 2017) 

 

The snap types are added to the menu 
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The snap types now appear in the Tools > Shortcuts > Shortcut keys list 

 

Example of Shortcut Keys set in the Button Manager 
 

22. Terrain Following has a new Load when project loads setting. It automatically loads previously linked Terrain 
Following files when Summit opens the project. (June 8, 2017) 

 

New setting to automatically load Terrain Following files when Summit opens the project 
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23. Summit > Tools > Bing Maps has been removed. It had started to give a script error with the Bing web 
application. We decided that it was not worth fixing, since their web app never offered the ability to mark the 
location of the Summit cursor. (November 8, 2017) 

24. The Tools > Google Maps function is fixed, even for previous releases of Summit. In the past year, there was a 
script error messages that happened every time the system mouse passed over the Google Maps window. This 
error prevented Street View from working. Now you can use it without errors and in Street View, as long as Street 
View is available in the geographic area. (November 8, 2017) 

 The first time you try Summit > Tools > Google Maps, make sure the Google Maps window has Windows 
focus, then press F5 once or twice. This forces a refresh. 

 If you still get script errors when mousing over the Google map area, move the mouse off the window. 
Hold down “N” for “No” until the errors are finished. Move the mouse around the window (staying outside 
the window) and approach the window’s title bar from above. Click on the title bar without mousing over 
the map area. Press F5 again. 

 Google Street View must be available in the area of the Summit project in order to work. If it is not, it will 
automatically set itself back to map view. 

 Use the system mouse to activate Street View and change the viewpoint.  
 If Summit’s cursor moves, so will the Street View center. 
 Remember that Street View and Summit’s cursor will never be at exactly the same place on the ground. 

The offset will be approximately 10 to 50 meters. This is normal and can’t be reduced. 
 If using v.7.4 or earlier, you might need to manually resize the view window. V.7.5 can automatically 

resize the window. 
 The Google Maps tool will only work with an active Internet connection. 
 You must set at least an input coordinate system in Summit > Orientation > Coordinate Conversion 

before the Google Maps tool will work 
 

 
Example of Summit > Tools > Google Maps in Street View mode 

 

25. Summit and other DAT/EM applications will do more automatic sizing depending on the resolution of the display. 
This is to accommodate high definition monitors such as the PluraView. Changes include: 

a. Windows and their components such as toolbars, dialogs, and text should appear the same size 
regardless of the DPI setting of the screen.  
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b. List column widths will scale automatically. 

c. A commonly used font setting function in DAT/EM software will scale the font according to the screen DPI 
setting. 

d. Scaling will only happen as the application starts. If you change the DPI setting of the monitor, you must 
close and reopen the DAT/EM applications to update their scaling. 

e. Summit > Tools > Customize Toolbars no longer has a Large Buttons checkbox. Button and toolbar 
size is now automatic. 

 
 

Note: To set the Windows icons to be larger on high-definition displays, right click on a blank area of the 
desktop and select Display Settings. Set the Scale and Layout percentage higher. You may need to log 
out and log back in for this setting to take effect in all applications. 

 

Set the Window Scale and layout percentage higher for high-definition displays 
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Superimposition 

26. Superimposition has the following changes: 

a. Superimposition has fixes to be more stable with AMD video cards and their drivers. Users who have an 
AMD card may now turn on Summit > Tools > Performance Monitor > GPU Shaders. In the past, DAT/EM 
Support may have suggested to turn this off in order to avoid a text display crash. (Oct. 12, 2017) 

 

b. When using an AMD video card, text will no longer be mirrored. Previously, mirroring might happen to the 
elevation display near the cursor, for example. (Oct. 12, 2017) 

c. A superimposition refresh issue was fixed. Sometimes only part of the objects would draw instead of 
doing a full refresh of stereo superimposition. (February 22, 2018) 

d. On nVidia Quadro cards, the superimposition display could show “shaded triangles” covering Summit’s 
entire main view and/or 3D vector view. This could happen either very rarely or very frequently, 
depending on many factors, such as the age of the video card technology, driver version, and DAT/EM 
software build date. The problem has been verified on Quadro Fermi, K-series, and M-series video cards; 
it is unknown whether P-Series cards are affected. It has been a problem since the manufacture date of 
each generation of Quadro card. Sometimes an SI Update would correct it, but sometimes it would 
obscure the view persistently. DAT/EM traced the source of the problem to corruption in the vertex buffer 
in the Quadro hardware. Since we have no way to fix the hardware, superimposition will now constantly 
refresh the vertex buffer for every frame. This may decrease performance, but it is effective and is 
considered necessary. (March 16, 2018) 

  

Examples of shaded triangles covering Summit’s main view (left) and 3D vector view (right). This is now avoided. 
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Aerial Projects 

27. Aerial projects have the following changes: 

a. The Orientation > Model extents to file option for very large projects is fixed so that the extents for a 
project that has this setting on clears properly when another project is loaded. (May 3, 2017) 

b. Summit Professional’s Import Relative Orientation (RO) for aerial and close-range projects offers a new 
filter to import fewer RO points. Some UAS aerotriangulation packages such as Agisoft can be set to 
create hundreds of thousands of autocorrelated tie points. Typically importing RO is not required in aerial 
projects that have exterior orientation (EO) values available; however, both an RO and an EO are 
required for close-range projects. Summit’s import process becomes very slow and the project file 
becomes very large when there are too many points, and a high RO point density is not necessary. (June 
30, 2017) 

c. Summit Professional’s Import RO for aerial and close-range projects can more reliably automatically 
match the image identification in the RO file to the image names. Previously, in some files, the user would 
need to manually match them, even when they appeared to be identical. (June 30, 2017) 

  

New Use maximum points setting to filter imported relative points 
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d. There are new settings to control the display and cursor direction for oblique models and models with 
mixed oblique and nadir images. A model is automatically considered oblique if both the left and right 
images have an omega and/or phi that is 15º or more. Problems can arise if only one image is considered 
oblique, while the other is closer to nadir (between 0º and 15º). Also, problems can arise if the omega 
and/or phi is close to 90º. The user may need to set how to display and move in such models. (July 13, 
2017) 

The settings are in Summit > Orientation > Oblique Options.  

 

New oblique model display and movement settings 

The settings are as follows: 

Project Settings 

Automatic: Displays the model as oblique if one or both images have an omega 
and/or phi 15º or more. 

Don’t Use Oblique: Forces the display to display as if the images were both nadir, 
no matter what their omega and phi angles are. No oblique display scaling will be 
applied. 

Force Oblique: Forces the display to apply the oblique display scaling algorithms, no 
matter what the omega and phi values are. You might use this settings when the 
angles are close to, but are not quite 15º in omega and/or phi and the default 
movement is does not provide comfortable movement and viewing 

XY Movement 

1. XY movement relative to model’s XY ground (Recommended): The cursor 
(x,y) moves in the directions defined by the (x,y) of the coordinate system 
represented by the exterior orientation values. At this time, this is the only setting 
that is active. 

2. XY movement relative to the screen: (inactive at this time).  

Z Movement 

3. Z movement in and out of the screen: This simulates typical aerial Z 
movement, where movement seems to be perpendicular to the screen surface (in 
and out of the screen). For nadir imagery, movement in and out of the screen is 
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along the Z axis. For oblique imagery, movement will still be in and out of the 
screen, but not be purely along the Z axis. 

4. Z movement along the ground Z axis: The Z movement is just along the Z 
axis, no matter what angle that makes to the screen surface. For nadir imagery, 
movement is along the Z axis and perpendicular to the screen surface. For 
obliques, movement will seem to be at an angle to the screen. For slightly 
oblique imagery, this may be acceptable. For extreme obliques, this setting may 
be annoying to the user, who may choose Z movement in and out of the 
screen as an alternative. 

Epipolar Display 

5. Rotate and scale right image relative to the left: For obliques, this is typically 
what you would want to use. The left remains stationary (no rotations of any sort 
are applied). The right is rotated to match to the left. Visually, this is usually the 
best for obliques. 

6. Like normal aerial, both images are rotated by their epipolar angles: This 
setting is usually for nadir images. Both images are rotated by their respective 
epipolar angles. This results in the images being aligned, but it is not the same 
as simply aligning them to each other. The images are also aligned flat to the 
ground, since they are rotated by the epipolar angles. This can result in a strange 
appearance for obliques. Rotating these extreme phi and omega angles back to 
flat ground does not look good in obliques, since the image is a 2D plane with 
fixed 3D objects. 

The Oblique Options settings are saved in the .smtxml project, so they will be restored when the 
particular project is opened. These project file settings are not backwards compatible with previous 
versions of Summit. 

e. The Earth radius in the aerial Project Edit’s interior corrections dialog will now reset to the default when a 
new project is started. Before this fix, it would keep the previously open project’s Earth radius setting, 
even if that was a custom setting. (August 2, 2017) 

f. For aerial projects exported by Trimble Inpho Photogrammetry Suite. Several users reported elevation 
offsets between Inpho and Summit when opening digital camera aerial projects that were exported by 
Trimble Inpho ApplicationsMaster (prj2sumev.exe): 

 There was a fix to the Trimble Inpho Summit project exporter in Inpho 8.0.7. This should help 
eliminate offsets between Inpho and Summit. It does not solve the entire problem with 
offsets, however. See additional fixes below. (December 2017) 

 Trimble shared an updated Inpho code library for aerial project interior corrections, such as 
Earth curvature correction and atmospheric correction. This was incorporated in DAT/EM 
v.7.5 to match the digital camera interiors used in Trimble Inpho v.8.0.7.x. (March 15, 2018) 

 Summit’s method of setting the pixel origin upon opening a project was shifted ½ pixel for 
digital cameras only. This matches the interior method used by Trimble Inpho-exported 
projects as well as Hexagon (Z/I SSK, ISAT) projects. Together with the changes in Inpho 
and Summit mentioned above, the offsets existing in earlier versions of Inpho-exported 
Summit projects and DAT/EM Summit Evolution are now considered completely resolved. 
There is a more detailed document about this provided with the v.7.5 file downloads at 
www.datem.com. (April 9, 2018) 

g. Aerial projects may now be epipolarized by the pre-existing "Satellite Epipolar" dialog, now called 
“Epipolar Creation”. Previously, this dialog only processed RPC satellite projects. Now it can process the 
following types: RPC, DAT/EM aerial, VisionMap A3 quasi-panoramic, and VisionMap A3 Frame. (January 
22, 2018) 

Use this any time you combine aerial images that are not made from adjoining, same-sized images in the 
flight line. Any two aerial images of any size that overlap in any amount may be epipolarized. In such 
models without epipolarizing, you may see a long, straight road appear to form an "X" without the stereo 
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glasses on. After epipolarizing, the "X" effect and any scale differences will be gone and it will be much 
easier on the eyes to view the images in stereo. 

Instructions: 

 Create the aerial project as you normally would. 

 Create models from any overlapping images you’d like, even if they do not look good to you at 
this time. 

 Keep the project open. 

 Convert the images. Use Summit > Imagery > Epipolar Generation. 

 Provide a minimum and maximum elevation to be found in the models that will be processed. 

 Open the new epipolarized Summit project that was created. The models should now be 
"straight" with respect to each other and will be scaled the same. They will be much easier to 
view. 

 
Close Range Projects 

28. Close Range (Terrestrial) projects: 

a. Summit Professional’s Import RO for aerial and close-range projects can more reliably automatically 
match the image identification in the RO file to the image names. Previously, in some files, the user would 
need to manually match them, even when they appeared to be identical. (June 30, 2017) 

b. Summit Professional’s Import Relative Orientation (RO) for aerial and close-range projects offers a new 
filter to import fewer RO points. Some UAS aerotriangulation packages such as Agisoft can be set to 
create hundreds of thousands of autocorrelated tie points. Typically importing RO is not required in aerial 
projects that have exterior orientation (EO) values available; however, both an RO and an EO are 
required for close-range projects. Summit’s import process becomes very slow and the project file 
becomes very large when there are too many points, and a high RO point density is not necessary. (June 
30, 2017) 

 
Satellite RPC Projects 

29. Satellite RPC projects: 

a. RCP files in the PerúSAT format are now supported. There are no new user settings or procedures; the 
files will be found and read automatically. (August 8, 2017) 

b. The Imagery > Satellite Epipolar menu item has been renamed to Imagery > Epipolar Generation. 
The following project types may be epipolarized: RPC, DAT/EM aerial, VisionMap A3 quasi-panoramic, 
and VisionMap A3 Frame. (For RPC projects, this is merely a menu name change.) (January 22, 2018) 

 
VisionMap A3 Projects 

30. VisionMap A3 projects: 

a. In A3 projects, the vertical system has been removed from the input coordinate system settings. It is not 
necessary to be set for geocentric systems, and the A3 has a geocentric input system. Having it set to 
Ellipsoidal Height was preventing some transformations from being offered in the subsequent selection 
dialogs. (December 14, 2017) 

b. A newer VisionMap VM frame model is installed. It affects VM frame models only; the quasi-panoramic 
model is unchanged. (December 20, 2017) 
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c. A3 Quasi-Panoramic and VisionMap A3 Frame may now be epipolarized using the Epipolar Creation 
dialog. This dialog was previously called Satellite Epipolar. It can now process the following project 
types: RPC, aerial, VisionMap A3 quasi-panoramic, and VisionMap A3 Frame. 

Use this any time you combine A3 images that are not made from adjoining, same-sized images in the 
flight line. Any two A3 images of any size that overlap in any amount may be epipolarized. In such models 
without epipolarizing, you may see a long, straight road appear to form an "X" without the stereo glasses 
on. After epipolarizing, the "X" effect and any scale differences will be gone and it will be much easier to 
view the images in stereo. Instructions: 

 Create the A3 project as you normally would. 

 Create models from any overlapping images you’d like, even if they do not look good to 
you at first. 

 Keep the project open. 

 Convert the images. Use Summit > Imagery > Epipolar Generation. 

 Provide a minimum and maximum elevation to be found in the models that will be 
processed. 

 Open the new epipolarized Summit project that was created. The models should now be 
"straight" with respect to each other and will be scaled the same. They will be much 
easier to view. (January 28, 2017) 

 

A3 Quasi-Panoramic “odd model” before epipolarization (left) and after (right) shown in a Summit Solution 
.smtsln file with two open viewports 

 
Imported Projects 

31. Imported Projects: 

a. The Hexagon or ZI SSK project [ISAT aerotriangulation (AT)] import has changed to make a slightly 
different Summit .smtxml project file. The project file contains a flag to shift the interior orientation by ½ 
pixel to better match the ISAT interior orientation when using a digital camera. (April 18 and May 9, 2017) 

There are multiple theories on how an interior orientation should be done with respect to different 
methods of pixel origin and image size use. There is no one right or wrong way, and it’s possible that 
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different third-party AT vendors use different methods. DAT/EM does its best to try to match the method 
used by each third-party AT vendor, often having to guess what that method is. In the case of ISAT 
orientations and previous versions of Summit Evolution, the ground control was not matching well enough 
after importing, so DAT/EM made two adjustments. The first adjustment was included in v.7.4, and helped 
somewhat, but for best results, this second v.7.5 adjustment is required. 

The setting can only be used when the project is imported. It will not change projects that were previously 
imported. If you have an older imported project and would like to discuss it, please contact 
support@datem.com.  

 
Button Manager 

32. Button Manager has the following changes: 

a. The GGS Mouse can now use both shift buttons at the same time, so now it supports normal (unshifted), 
left shift, right shift, and both shift buttons. Set the double shift buttons in Button Manager. The double 
shifts are buttons 17, 18, 19, and 20. (November 1, 2017) 

 

Button Manager showing the GGS Mouse 

Note: Due to hardware limitations, double shifts are not possible in the Immersion SoftMouse and 
Immersion-emulation devices. For those devices, do not set buttons 17 through 20. 
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b. Some display issues were fixed in Button Manager. There are also newer button diagram images that 
look better on higher-resolution displays. (November 1, 2017) 

c. Groups (defined on the Groups tab of the Project window) can now be toggled from a button. This is 
useful if you have two sets of imagery in the same area that you want to keep separate, but you want to 
switch from one to the other in one viewport or a focus viewport. When this button is pressed, the current 
group will close and the next Group will open. (February 7, 2018) 

 If there is a model in the new Group in the cursor location, it will open the best model from the 
new Group. 

 If there is no model at the cursor location, no model will open, giving you a chance to toggle back 
to the original Group without losing the cursor position. 

 If there are only two Groups defined, it is a true toggle. If there are three or more Groups, the 
button will always open the next group as shown on the Project Window Groups tab. It will cycle 
back to the first group only after the last group. 

 

Setting for the Group Toggle button 
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Example, Part A: This six-Group project has a model from the 1999 Group open 

 

Example, Part B: The Group Toggle button opens the best model from each Group in turn 
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Point Translator 

33. Point Translator has the following changes: 

a. The Point Translator window is now resizable. (Sept. 14, 2017) 
Image Creator 

34. Image Creator has the following changes: 

a. NDVI (Normalized Difference Vegetation Index) imagery is now supported. (May 9, 2017) 

b. The raw image format reader has been updated. This allows the Image Creator to convert new-format 
raw files such as CR2 successfully. Raw image types should be converted with Image Creator to a 
different format; Summit and DAT/EM Image Viewer do not open them directly. (August 2, 2017) 

c. The Image Creator’s browse dialog will now allow you to search for multiple files in multiple folders, and 
the result will have the correct folder paths associated with each file’s original location. Previously, the 
first file’s path would be applied to all files. (January 2, 2018) 

d. Image Creator now shows a progress count above the progress bar. (April 6, 2018) 

 

 

Stereo Mate Creator 

35. Stereo Mate Creator has the following changes: 

a. The Stereo Mate Creator can now input BigTiff images. If the input is BigTiff, the output stereo mate will 
also be BigTiff. Note: This was done in order to directly process Pix4D’s BigTiff mosaics. (April 27, 2017) 
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Project Viewer / Ortho+Mosaic 

36. Project Viewer / Ortho+Mosaic has the following change: 

Ortho+Mosaic has new settings that can improve individual image boundary generation. Boundary generation is 
the best when the elevation of the model is known, so adjoining stereo areas can be calculated accurately. The 
existing method always used the average project elevation, which was just one elevation value set in aerial 
projects in Summit>Edit>Project>Average elevation. This works well for flat terrain, but the more elevation 
change throughout the project, the more the size and placement of the boundaries could be off. The two 
additional methods offer ways to generate the boundaries based on better elevation values. (March 28, 2018) 

  

New elevation methods to make better boundaries in projects that have a large elevation range 

The new settings are as follows: 

 Generate using project average elevation. For flat terrain; ground elevation in all models is near 
the average project elevation. This is the pre-existing method, which uses the average elevation in 
the .smtxml file. In aerial projects, you'll see this elevation displayed in Summit > Edit > Project > 
Average elevation. It may be set to either a key-in or the average elevation of the control file. 

 Generate using DTM for elevations. For hilly or mountainous terrain; ground elevation in at least 
one model is far from the average project elevation. This uses the DTM points that are loaded already 
in Ortho+Mosaic's Select DTM Files and/or Import Vector Files options. It is important to load the 
points first, then generate boundaries. It may be the slowest to process, but potentially provides the 
most elevation information. 

 Generate using individual heights set in Summit. For hilly or mountainous terrain; ground 
elevation in at least one model is far from the average project elevation. This uses the per-image 
heights elevations currently set in the Summit > Edit > Project > Interior Corrections > Use 
Heights > Per Image Heights values. These individual image heights usually originate in newer 
versions of Inpho Match-AT aerotriangulation software. This method could be used for Inpho-
exported Summit projects as long as the Inpho software has output varying per-image elevations into 
the Summit project. 
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LandScape 
The following changes were made to Landscape: 

1. Interactive editing with the system mouse has been improved. 

2. LandScape > Tools > Options > Capture now offers a zoom ratio slider. This sets the zoom ratio between 
LandScape and MicroStation/AutoCAD/ArcGIS/Global Mapper. The default Zoom Value is applied to what should 
be an equal zoom, but it’s possible that some project properties can affect Landscape's calculation of a good 
zoom box. This lets users adjust it to what they want. Bigger values zoom in on the CAD, smaller values zoom 
out. (June 22, 2017) 

 

New LandScape Capture Zoom slider 
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3. Color Classify has a new sample area selection tool that populates the filter parameters based on a selection in 
the Landscape points view. For example, you could select a typical area of trees in a data set that has color 
values and automatically classify similarly colored points as vegetation. (June 27, 2017) 

 

New Select sample area allows you to populate the filter parameters from a selection 
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4. Class counts now appear for each previously loaded file in the Project window: 

 

New LandScape Project Window class counts display 

 

DAT/EM Capture for ArcGIS - ArcMap 
DAT/EM v.7.5 is compatible with ArcGIS 10.0 (service pack 4), 10.1 (service pack 1), 10.2, 10.2.1, 10.2.2, 10.3, 10.3.1, 10.4.x, 
10.5.x, and 10.6.x (plus any available service pack as they are released). 

DAT/EM v.7.5 may be compatible with ArcGIS 9.1, 9.2, 9.3 (service pack 1), 9.3.1(service pack 2). BE ADVISED: Testing no longer 
occurs for DAT/EM Capture with ArcGIS 9.x. It still installs for it and no code has been removed, so you may use 9.x as long as it 
continues to work for you. Any issues will not be corrected. ArcGIS 9.x support may be dropped completely in a future release. Please 
continue to make plans to upgrade any remaining ArcGIS 9.x version to 10.x. 

The following changes were made to DAT/EM Capture for ArcGIS: 
Capture for ArcGIS subjects 

1. The Coplanar tool is new. It creates lines and polygons with vertices that are coplanar. It is similar to using the 
point-to-point tool, except that the first three digitized points have a double purpose: They are the first three points 
in the sketch and they define a virtual snapping plane. All subsequent vertices in the sketch are forced to snap to 
the elevation of the plane. 

The Coplanar tool can work with snapping off or with 2D or 3D snapping on. Both 2D and 3D snapping will 
behave like 2D snapping. The virtual snapping plane has a higher priority than the 3D snap, so the points will 
snap to the plane rather than taking the elevation of the 3D snap. 

The command ID to use with CallCommand on the Keypad and digitizer buttons is: 

CallCommand capturearcinfo.coplanartool 

 

 

Summit’s command text area shows how many points are needed to define the plane 
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Example of the coplanar tool used to digitize a polygon around the plane of a large roof surface 

 

2. SetEditTemplate [“layer name”:]“template name” is a new keyword that sets a feature class template from the 
DAT/EM Keypad, a Button Manager Custom CAD button, and Summit’s Custom CAD toolbars. (March 14, 2018) 

a. Like our other keywords, SetEditTemplate is not case sensitive. It may be setedittemplate, for example. 

b. An edit session must be active. This is an ArcMap requirement. You may use a StartEditing command to 
begin the edit session before using SetEditTemplate.  

c. The quotation marks are only necessary if the layer name or template name contains a space character 
or contains any other DAT/EM keyword, such as the word draw or target or apply. For example: 

SetEditTemplate “Blue Draw Road”:Centerline 

SetEditTemplate “Blue Draw Road”:“Left edge” 

d. “Layer name”: is only necessary if there are two layers that have the same template name. For example, 
if there are two layers called Wall and Chimney and both have templates called Brick and Concrete, 
then it is necessary to include the layer name as follows: 

SetEditTemplate Wall:Brick 

SetEditTemplate Wall:Concrete 

SetEditTemplate Chimney:Brick 

SetEditTemplate Chimney:Concrete 

The following is an example of a template that has a unique name among all the layers and does not 
contain spaces or keyword matches: 

SetEditTemplate water23 

The following are examples for layers that have some of the same template names. 

SetEditTemplate Buldings:“Commercial 2” 
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SetEditTemplate Buildings:“Residential 1” 

SetEditTemplate “Commercial 1” (this template name is not used in another layer!) 

SetEditTemplate Foundations:“Commercial 2” 

SetEditTemplate Foundations:“Residential 1” 

 

 

 

3. There is a significant change in the way the DAT/EM drawing tools and the current task interact with each other. 
The tools will stay enabled and fix the Task settings rather than the other way around. (November 3, 2017) 

This change can reduce the number of button clicks necessary to start creating or modifying a feature. It can also 
prevent the confusion and delays caused by having the wrong combination of settings. (December 14, 2017) 

In the past, Capture tools were disabled based on the active task. This is the way that ArcMap worked back in 
ArcGIS versions 8 and 9. This change makes it the opposite. Now the tools are always enabled and each tool 
sets the task. This is similar to the way Create Features works in ArcMap 10. 

If a tool can operate in the currently active task, then it won’t change the task. For example, if Modify is set and 
the point-to-point tool is selected, Modify will stay set. In this case the point-to-point drawing tool is capable of 
working in multiple tasks, so it did not change. You will need to manually set Create to draw a new object. 

A tool that only works in one task will force that task to be set. For example, if the task is set to Create when the 
Clip tool is selected, the task will change to Modify, because Clip only works with Modify.  

 

 

As another example, if the DAT/EM Circle drawing tool is selected, the task will change to Create, because the 
circle tool only works with Create. 
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“(Unsupported)” is a new task placeholder that appears on the task list. The (Unsupported) task indicates that 
either there is no task selected or a task is set that DAT/EM tools never use. It might appear when ArcMap first 
starts or when a native ArcGIS ArcMap tool sets a task that isn’t used by DAT/EM tools. The task will be changed 
to a supported tool the next time a DAT/EM tool is selected. 

 

4. Previously, the Clip tools and Create could be on at the same time, but they are incompatible. Now they each 
automatically turn on or off the compatible settings: (November 3, 2017) 

a. Selecting a Clip tool automatically sets the Modify task. 

 

b. Selecting the Create task automatically turns off the Clip tools. 

 

5. The snap state was assuming all layer names were unique; this is not always true, since ArcMap allows two or 
more layers of the same name. It will use the data source to help distinguish one from the other. (Oct. 30, 2017) 

6. The following changes affect snapping and snap-related settings: 

a. 3D Snap is fixed to use the full (x,y,z) of the closest object when multiple objects are within the snap 
radius. Previously, it would snap to the (x,y) of the object that was closest to the cursor, but would take 
the elevation from the object that had the highest elevation. (Oct. 30, 2017) 

b. The above fix will be visible in the results of Auto Complete. Due to the same snapping problem, Auto 
Complete could leave vertices at the wrong elevation. Since the snap is fixed, Auto Complete will seem to 
be fixed. The generated polygon will have the z values of the original polygon. (Oct. 30, 2017) 

c. Snapping was not working with Trace Multiple. The snap ring was there, but the snap line was not, and 
the actual snap would not happen. This is fixed. Note that overall, DAT/EM recommends using the Auto 
Complete function instead of Trace Multiple. (September 19, 2017) 
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d. Snap selection is greatly improved for cases when there is more than one potential snap at the same 
cursor position. This happens when there are multiple objects inside the snap ring. 

Previously, the snap would always pick the closest object in elevation, and would not offer all other 
potential snaps. 

This change applies to the stream, point-to-point, arc, and square drawing tools while they’re in the 
Create, Modify, and Cut task modes. 

To get the snap you want: 

 Get ready. Turn on 2D or 3D snap, set a snap radius, and check on the layers for snapping in 
the Classic Snapping Environment.  

 Start one of the DAT/EM drawing tools: Stream, point-to-point, arc, or square. 

 Place the Summit cursor near the desired snap location. Press the pick button, but do not 
move the cursor. 

 As you hold the Summit cursor still, view the highlighted object, which is the current snap 
consideration. If it is the wrong object, pick again, but again hold the cursor still. View the next 
highlighted object. Keep picking in the same place until the correct object highlights. 

 To accept the currently offered snap, simply move the cursor in (x,y). 
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Here, anaglyph stereo in superimposition shows the correct elevation at the snap 

 

7. A message appears when you attempt to modify a non-polygon while the DAT/EM Clip tool is turned on. Note that 
Modify and Clip are generally compatible; in fact, Clip automatically turns on Modify. However, they can only work 
together to cut interior rings into polygons, so the message warns of wrong object type selections. (November 3, 
2017) 

 

You can’t modify a non-polygon with Clip on 
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8. DAT/EM Systems Options has the following changes: 

a. The Snap Tolerance field will show more decimal places. This is useful for distances in decimal degrees 
units, where a snap tolerance might be a value such as 0.000001. Previously, the value would be set 
successfully, but might be truncated in the display so it could not be viewed properly. (Aug 15, 2017) 

 

More characters display now in the Snap tolerance field 

b. Insert Vertices for snapped objects is new in the ArcMap-side DAT/EM Options Snap settings. Use it 
together with the existing DAT/EM drawing tools in both Create and Modify modes. When an in-progress 
DAT/EM drawing tool sketch snaps to other lines and polygons, a point is added at each snapped 
intersection on those objects upon completion of the sketch. It does not change the elevation of the 
snapped-to objects at the new intersection points, regardless of whether it is a 2D or 3D snap; it 
interpolates the z value along the original object’s segment. (April 26, 2017) 
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Example of new vertex from Insert vertices into snapped objects 

9. There is a superimposition (SI) fix to consistently show vectors for the in-progress object when the drawing tool 
toggles from stream mode to another drawing tool. Previously, the vectors might disappear when the tools were 
toggled, and the object would not draw completely in SI until it was finished. (July 27, 2017) 

10. This is a potential fix, but not guaranteed to work. In previous versions, when you drew the first line or polygon in 
an ArcMap session, the superimposition for it during drawing was often black and sometimes dashed or even 
invisible. This is because ArcMap does not publish the color and attributes for the layer until it finishes drawing the 
first object on the layer. DAT/EM Capture asks ArcMap for the color. If it returns nothing, Capture will default the 
color to green while drawing the object. Unfortunately, often ArcMap returns bad values, which Capture can’t 
distinguish from good values. If ArcMap returns bad values, the in-progress line or polygon may not be visible or 
may be badly colored or oddly dashed until the object is finished. The line may turn green at other times such as 
when the model changes or when a DAT/EM Options setting is changed while drawing. (April 25, 2017) 

 

11. If you sent the “SaveEdits” keyword through the DAT/EM Keypad or a digitizer button to ArcMap, and ArcMap 
could not save those edits for some reason, it would seem to have worked when in fact it did not. For example, if 
the Keypad sent the save command when ArcMap had actually lost connection to the ArcMap SDE server and 
could not save, the Undo buffer would clear and the Save button would appear used (or inactive) in ArcMap. After 
this, ArcMap would not prompt for a save when exiting the editor, so the edits could be lost. Now DAT/EM will 
display any error message that is returned from ArcMap. It may appear like this: 
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“Unspecified error” returned when ArcMap could not save successfully 

Note that the wording in the error is what ArcMap provides. If you see this error, remember that the save you just 
attempted did not work, and you should immediately try another method to save. Do not exit the ArcMap editor 
while the connection to ArcMap SDE is not available. 

12. Superimposition refresh will now be done immediately after a create event with the ArcGIS Production Mapping 
tools. (Users of DAT/EM tools in standard ArcMap should not notice any change.) (Oct. 13, 2017) 

13. The “ArcMap zooms Summit” option is fixed. It could have failed for the case when Summit had not yet sent a 
ground coordinate. At other times, it could have been unresponsive. (March 23, 2018) 

 

ArcMap makes Summit zoom is fixed 

14. The Extend Line tool has the following changes: 

a. Extend Line will now complete the extension if the target line is from a read-only reference. Previously, it 
would ignore read-only layers. (Oct. 30, 2017) 

b. Extend Line will no longer accidentally turn off the rubber band display. (Oct. 30, 2017) 

15. The object selector could sometimes search the wrong layer when doing a select. When that happened, the 
select of the object or objects near the cursor would fail. This is fixed. (November 17, 2017) 

16. The command text sent to superimposition will now show the exact task that is set. Previously, it showed "draw" 
instead of "create", "edit" instead of "modify", and Auto Complete was missing. (December 12, 2017) 

17. Undo during a sketch with 10 or more vertices would not refresh superimposition (SI) completely. This was 
originally done to optimize the time it takes to redraw the sketch. Customers complained that the incomplete 
redraw in SI was a problem. The optimization has been removed, so that the full redraw takes place. The side 
effect is that it may be slower. (December 13, 2017) 

18. If an object is read-only, it can no longer be selected for modification. The previous version let the user perform all 
the modifications on the read-only object and then failed when the changes were committed. Now it immediately 
stops the edit operation and cancels the rubber band. (November 3, 2017) 
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Airfield3D 

19. Airfield3D: 

a. Airfield3D reports have the following changes: 

 The reports for NVG (non-vertically guided) surfaces were opposite to what they should be and 
are now corrected. (July 24, 2017) 

 Airfield3D is disabled for ArcGIS 9.x due to incompatibility with some newer features. (Sept 6, 2017) 

 Manmade and natural objects splits have been fixed. 

b. Airfield support for Non-Vertically Guided runways and Part 77 runways has improved. Runway ends now 
have the "High-numbered/Low-numbered" values we added to the Vertical runways along with Left/Right 
view from the approaching airplane. The reports and status view on the Arc side reflect these changes. 
(Sept 6, 2017) 

c. The calculations of the NVGHS measurements were corrected. They were being made from the runway 
end point. They are now being calculated correctly from the edge of the NVGAS, which in most cases will 
be 200’ extended beyond the runway endpoints. Reference section 2.7.1.3.4 of the 18b specifications. 
(partly done August 31, 2017 and finished Dec. 7, 2017) 

d. Airfield3D can now handle having the runway centerline vertex order in either direction. Previously, the 
runway centerline direction affected which side was considered right or left. It will now detect the name of 
the lower-numbered end to help establish the right and left sides. (March 7, 2018) 

 

DAT/EM Capture for ArcGIS – ArcGIS Pro (Beta) 
This beta version is compatible with ArcGIS Pro versions: 

 ArcGIS Pro v.2.0 and 2.1.2 only. Please ask DAT/EM about any higher version numbers as they are released. 

 If you have Capture for ArcGIS and want to try Capture for ArcGIS Pro, please ask DAT/EM Support to enable the API 
on your hardware lock. If DAT/EM Setup finds both ArcMap and ArcGIS Pro with API licensed on the computer, it will 
install Capture for both. 

The following changes were made to DAT/EM Capture for ArcGIS Pro: 

1. ArcGIS Pro changed the compiler, which forced DAT/EM to drop support for ArcGIS Pro 1.x. DAT/EM version 7.5 
is only compatible with ArcGIS Pro 2.0 and 2.1.2. Please ask support@datem.com about any higher version 
numbers as they are released. (Sept. 6, 2017) 
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DAT/EM Capture and MapEditor for AutoCAD 
Changes apply to: 

32-bit AutoCAD 2004-2008 versions with the latest service packs, as long as you can get them to install on your 64-bit 
operating system (OS). DAT/EM no longer tests on 32-bit OS, so these must be running on 64-bit OS. DAT/EM is not responsible 
for helping to install a 32-bit version of AutoCAD on a 64-bit OS and cannot guarantee that this will succeed. 

64-bit AutoCAD 2009-2018 versions with the latest service packs. Exception: 64-bit AutoCAD 2008 is not supported. 

When referring to a year/version number in the lists above, it includes "plain" AutoCAD, Civil3D, and Map3D. It does not 
include AutoCAD LT, which is a 2D product, and therefore will never work with a 3D cursor. 

Reminders: 

 Install all available AutoCAD service packs and updates before installing DAT/EM software. 

 Before installing DAT/EM software, run each version of AutoCAD and make sure its license is active. Do this for each 
version whether or not you intend to use every version with DAT/EM Capture. 

DAT/EM software will install for multiple AutoCAD products of different year numbers on the same computer; however, it will only 
install for one of any multiple same-year versions. For example: 

 It will install for AutoCAD 2015, 2016, 2017 Civil3D, and Map3D 2018 , because they are all different year versions. 

 It will not install for both AutoCAD 2017 and AutoCAD Civil3D 2017 at the same time, because they are both the same 
year. In the case of multiple same-year versions, only one of them will receive the DAT/EM files at installation. To activate 
DAT/EM Capture in all of them, the AutoCAD \datem folder and the DAT/EM wintab driver file may be copied from the one 
that received the files to the other same-year versions. Contact DAT/EM Support for instructions. 

Autodesk Infrastructure Design Suite installs three same-year AutoCAD versions (AutoCAD, Map3D, and Civil3D). Using the rules 
outlined above, you must run each version and register/”accept” each one before installing DAT/EM software whether or not you 
intend to run every version with DAT/EM Capture. DAT/EM software will install completely for only one of them, and we don’t know 
which one until after installation. The files may be copied manually to the others. Contact DAT/EM Support for instructions. 

The following changes were made to DAT/EM Capture and MapEditor for AutoCAD: 
 

DAT/EM Capture for AutoCAD 

1. Version 7.5 is the first version to be compatible with 64-bit AutoCAD 2018 versions. (May 8, 2017) 

2. Summit Evolution’s tablet calibration for projects with negative x and/or y coordinates was not working for 
AutoCAD. This is fixed. (April 18, 2017) 

 

MapEditor for AutoCAD 

1. Launching the MapEditor for AutoCAD dialog could corrupt the layer table in the drawing. This is fixed. (March 2018) 

2. Several commands that offer to create a Visit file now have an append option. This allows you to create a Visit file 
and add to it later, without losing the original file contents. The commands are: CROSSCHECK, SLOPECHECK, 
TOUCH, and SQUARE. (March 28, 2018) 

3. CROSSCHECK and TOUCH’s “Add Vertex” function no longer writes vertices in the wrong order. (September 19, 
2017) 

4. DENSIFY was locking up. This is fixed. (March 15, 2018) 

5. FILTER was making the wrong backup layer name, then it couldn’t write the backup objects to the correct layer, 
because it didn’t exist. It would then write the backups onto the original layer with the edited versions, and it was 
very difficult to separate them. This is fixed so that the correct backup layer name is made. (September 19, 2017) 
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6. JOIN has the following changes: 

a. JOIN no longer gets stuck at the “Configuring Join” message. It will now continue with the join process. 
Note that there could still be some problems with Join, because it relies on Autodesk AutoCAD’s intersect 
function, which has underlying problems and fails to report valid intersections. (October 16, 2017)  

b. JOIN was giving errors and corrupting the layer table. These problems have been fixed. (March 15, 2018) 

7. TOUCH and CROSSCHECK’s “Add Vertex” function no longer writes the new vertices in the wrong order into the 
polyline. (September 19, 2017) 

8. Volume Calculation has several fixes and changes: (November 13, 2017) 

a. Accuracy of volume calculation from the triangulation was improved.  

b. A layer parameter was added to define pile boundaries. This additional parameter (“Within Polygons”, by 
Layer) was added to differentiate piles, whether or not objects reside on the same or different layers. 

  

New Within Polygons setting in the Volume Calculation tool 
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When this parameter is set, surface volumes are calculated based on objects within the boundaries. 

 

Example of objects that will be processed based on boundaries 

  

Volume results before these changes (left) and after these changes (right) 

 

9. XYZIN is now optimized to read and place points from comma- and space-delimited files faster. (October 10, 2017) 

 



DAT/EM Systems International RELEASE 7.5 Release Notes 
 

 42 

DAT/EM Capture and MapEditor for MicroStation 
Changes apply to Capture for MicroStation. DAT/EM software installs for the following MicroStation versions on 64-bit 
operating systems:  

 MicroStation V8 and V8 2004 Edition: Version should be 08.05.00.34 or higher. 

 MicroStation XM: Version should be 08.09.04.88 or higher. 

 MicroStation V8i, V8i-based Bentley Map and Map Enterprise SelectSeries 1 (1 not recommended), 2, 3, and 4; 
MicroStation PowerView SelectSeries 3 and 4; Power GeoPak* SelectSeries 3 and 4 

 PowerCivil SelectSeries 3 or 4 

If you upgrade from Select Series 1 to 2, 3, or 4, you must reinstall DAT/EM software after installing the Series upgrade.  

DAT/EM will install for all versions of MicroStation that are present on the computer at the time of the DAT/EM installation. 
 
*Note about Power GeoPak Select Series 3: DAT/EM Software installs for Power GeoPak SS3, but has initial loading 
conflicts that affect the GeoPak and DAT/EM menus. Bentley has offered a workaround for this issue. If you have the Bentley 
Power GeoPak SS3 product, please contact DAT/EM for further installation instructions. 
*Note about Power GeoPak Select Series 4 (which runs with MicroStation Select Series 3): This product seems to be 
more successful running together with DAT/EM applications. There still could be issues. Please contact DAT/EM Support if 
having problems installing for or using this version. 
 
Note for MicroStation CONNECT Edition (64-bit MicroStation): DAT/EM version 7.5 does not contain an interface to 
MicroStation CONNECT Edition. DAT/EM plans a limited beta interface available during the early part of the next development 
cycle. Please contact DAT/EM Support if you are interested in beta testing with MicroStation CONNECT. 

The following changes were made to DAT/EM Capture and MapEditor for MicroStation: 

 
General Subjects in Capture and MapEditor for MicroStation 

1. MapEditor Replace Object commands were improved for robustness and efficiency. Previously, runs that caused 
a huge number of individual edits could cause MicroStation’s undo buffer to run out of memory and crash 
MicroStation. The higher the SelectSeries number, the less available memory there might be, and the more likely 
it would be to crash. Replace Object commands now support extremely large numbers of edits, but do not disable 
the undo buffer. If you have a DGN and parameter file that requires so many edits that it still crashes, you may try 
setting generic keyins in the PAR file: SET UNDO OFF at the beginning of the file and SET UNDO ON at the end 
(in this case, you are deliberately disabling the undo buffer, so be careful!). (May 11, 2017) 

2. The browse dialog for naming the MapEditor log file no longer appends .dgn to the log file name. It now works 
around a problem in the MicroStation mdlfile commands and appropriately appends .log. (May 9, 2017) 

3. The paths in the installed .cfg (MicroStation configuration) files will now list the correct drive letter when you 
customize the “\Program Files (x86)\Datem Software” folder during DAT/EM software installation. (June 27, 2017) 

4. Superimposition (SI) for MicroStation has the following changes: 

a. Shared cells in reference files are now displayed in SI. (July 6, 2017) 

Note that white or partially white shared cells can be expected in SI for nested or multilevel cells. This is a 
known MicroStation issue (https://communities.bentley.com/products/microstation/f/z_-archived-
microstation-v8i-forum/64649/drop-shared-cell-bug). 
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Demonstration of the superimposition results of a MicroStation bug reporting the color of 
nested or multilevel shared cells. DAT/EM can’t fix this issue for superimposition. 

 

b. This fix was for an SI for MicroStation issue, but appeared to be a Summit SI Layer Manager problem. 
With Condense Layers off in the SI Layer Manager in Summit, MicroStation reference file levels were not 
being separated properly from same-named main file levels. An object from a reference file could be 
superimposed when its level in the main file was checked on, but its level in the reference file was not 
checked in the SI Layer Manager. In the main and reference files, text might be displayed correctly, while 
shapes, text nodes, and lines were not. (May 22, 2017) 

c. This fix was for a superimposition for MicroStation issue, but appeared to be an SI Layer Manager 
problem. If a layer is turned off for display in MicroStation, it will not be sent to SI unless “All levels” is 
turned on in SI SETTINGS in MicroStation. (November 16, 2017) 
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5. The Selection Sets Editor has the following enhancements: 

a. There were miscellaneous fixes in Selection Sets for cells in the “All Element” type filters. (May 25, 2017) 

b. Selection members can now be sorted by clicking on the column headers to sort the lists, for example to 
sort by level name or cell name: (May 24, 2017) 

 

 

Examples of sorting by column in the Selection Sets Editor 
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6. The display of levels in level picker dialogs was being truncated to 20 characters. Now it will show up to the 512-
character limit for level names (levels that long require the horizontal scroll bar to be used). In addition, the width 
of the level list in the picker lists was quite narrow; now it is wider to show more characters in the level names: 
(may 23, 2017) 

 

Wider level picker list display 

7. The maximum number of MicroStation levels that can be handled by the superimposition application has been 
increased from 25 thousand to 40 thousand. If this number is exceeded, a message will appear: 

 

Message that appears if more than 40 000 levels are sent to superimposition 

 
New Commands in Capture and MapEditor for MicroStation 

8. ANNOTATE is a new family of commands to place a cell with a separate text element. It is very much like SPOTX 
for spot elevation placement, except that instead of elevation text, it places the character string you specify. 

  

Example results and settings dialog for the new ANNOTATE commands 
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To run, make settings in ANNOTATE SETTINGS or use the settings keyins listed below, then select one or more 
cell center locations using ANNOTATE. ANNOTATE will be active immediately after accepting the ANNOTATE 
SETTINGS dialog, or start it again any time after making the settings. 

The following keyins may be used in the MicroStation key-in browser, the DAT/EM Keypad, and Custom CAD 
buttons in Button Manager: 

 ANNOTATE – runs ANNOTATE command to place a cell and text using the most recent settings 

 ANNOTATE SETTINGS – raises ANNOTATE command settings dialog 

 ANNOTATE TEXTHEIGHT <height/width> - sets the size of text characters placed using the ANNOTATE 
command 

 ANNOTATE ACTIVETXT – sets size of text characters (placed using the ANNOTATE command) to the 
active text height 

 ANNOTATE XOFFSET <distance> - text string x offset (from cell origin)  

 ANNOTATE YOFFSET <distance> - text string x offset (from cell origin)  

 ANNOTATE CELLNAME <cell name>- sets the cell to place with ANNOTATE command 

 ANNOTATE KAPPA - Places ANNOTATE cell and text at the kappa angle of the current stereoplotter 
model. If a stereoplotter model is not open, the MicroStation active angle will be used instead. 

 ANNOTATE NOKAPPA – Places ANNOTATE cell and text at the MicroStation active angle. 

 ANNOTATE TXTLEVEL <level name> - Sets the level where text placed with ANNOTATE will be placed 

 ANNOTATE DEFAULTTXTLEVEL - Text placed with ANNOTATE will be placed at the active level 

 ANNOTATE TEXT <text string> - sets the string that will be placed with ANNOTATE 

 ANNOTATE SHAREDCELLS – cells placed with ANNOTATE will be placed as shared cells 

 ANNOTATE CELLS - cells placed with ANNOTATE will be placed as regular cells 

9. MEFINDPARTIAL is a new command to find partial duplicate elements. This entry includes changes to the 
existing MEFINDDUPLICATES command, which was modified to work together with MEFINDPARTIAL. (April 28, 
2017, plus later modifications) 

MEFINDPARTIAL finds partial duplicates, whereas the existing MEFINDDUPLICATES finds only full duplicates. 
MEFINDPARTIAL can work together with the MEFINDDUPLICATES interface to view the results. 

 

New MEFINDPARTIAL “Find Partial Duplicates” command dialog 
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MEFINDPARTIAL dialog settings: 

 minimum % of overlap for match – If checked on, this adds two checks to determine whether elements 
are considered partial matches: 1) The bounding boxes for elements must overlap by the specified 
percentage, and, 2) The elements must have a minimum percentage of common vertices.  

o Match More – The percent of the smaller (in terms of range) element and the element with the 
fewer number of vertices is compared to the % setting. 

o Match Fewer – The percent of the larger element (range) and the percent of overlapping vertices 
of the element with the greatest number of vertices is used to calculate whether the percentage of 
overlap meets the configured minimum. 

 maximum non-matching consecutive vertices – If checked on, a maximum threshold for the number of 
consecutive vertices that, if they do not match, the elements are no longer considered partial matches. 

 Interior vertices must match – If checked on, only starting and ending vertices are allowed to vary for 
elements to be considered partial duplicates. 

 

 

Interface to the familiar “Find duplicates” from MEFINDDUPLICATES to view the results 

This “Find duplicates” interface has been expanded to include a Save for Visit button to (optionally) create a 
VISIT file. When pressed, the button will prompt for a filename used to store results. Results of MEFINDPARTIAL 
or MEFINDDUPLICATES are then saved in a DAT/EM Visit file, after which the user can optionally switch to 
running VISIT. 



DAT/EM Systems International RELEASE 7.5 Release Notes 
 

 48 

 

New Save for Visit button for both MEFINDDUPLICATES and MEFINDPARTIAL 

Most elements that work with selection sets will be scanned for partial duplicates. Element types are currently 
included in the checks (for example, overlapping curves will not be compared against strings, cells will not be 
compared against shared cells, shapes will not be compared against strings). 

Find Partial Duplicates (MEFINDPARTIAL) has the following additional changes: 

a. Find Partial Duplicates has its Delete and Delete All buttons disabled. Note that the buttons will continue 
to work in Find Duplicates (MEFINDDUPLICATES, which finds whole duplicates). (March 13, 2018) 

b. Find Partial Duplicates will continue to intercept individual edits; however, changes to the selected 
element in the list (resulting in invalidation of the displayed file position) will not result in automatic entry 
reselection/change of view for either MEFINDPARTIAL or MEFINDDUPLICATES. The user will need to 
manually select a new entry when the current selection is invalidated by direct edits. (March 13, 2018) 

The weight of the bounding box used in these commands has been changed from 4 to 2 to prevent obscuring the 
objects inside the box. (April 4, 2018) 

 
Changes to Existing Commands in Capture and MapEditor for MicroStation 

10. 3DOFFSET: When the number of vertices varied significantly, 3DOFFSET could create an offset that set every 
vertex to the same elevation instead of following the changing elevations of the input object. This is fixed. (April 20, 
2017) 

11. BREAK and BREAK ELEMENT will now briefly flash the lines as feedback that the break is complete. (March 28, 
2018) 

12. CHECKATTRIBUTES has reduced the line weight of the bounding box from 4 to 2. This is to prevent obscuring 
features inside the bounding box. (April 4, 2018) 

13. Close Line String’s (MECLOSE’s) dialog now keeps the settings in the lower part of the dialog if you set them 
before setting the selection criteria. (April 12, 2017) 

14. CROSSCHECK had a gross range check problem that was occasionally causing CrossCheck to bypass 
legitimate endpoint-to-segment intersections. This is fixed. (August 2017) 

15. DATDRAW has the following enhancements:  

a. DATDRAW PSQR is fixed so that it does not create double elements or crash when “Close on Reset” is 
checked on and the resulting element has more than three segments. (August 7, 2017) 

b. DATDRAW TRACE <0/1> and DATDRAW TRACE2D <0/1> are added to work with DATDRAW 
AUTOARC, DATDRAW STREAM, and DATDRAW PSQR. These allow you to trace along the edge of 
another object so that the vertices are coincident for the designated path. This is helpful for drawing 
parking lots that run along a building footprint or drawing adjoining farm fields, for example. (February 5, 
2018) 

 DATDRAW TRACE2D applies the most recently digitized elevation across the traced section 
added to the element in progress. 
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 The optional parameter <0 or 1> defines how closed elements are traced. By default, or if this 
optional parameter is “0”, the longest section of a closed element is traced. If the parameter is “1”, 
the shortest section (closed elements) is traced. 

 

 

Dialog enhancements:  

The DATDRAW AUTOARC, DATDRAW STREAM, and DATDRAW PSQR dialogs have been 
enhanced with two buttons [Trace] and [Trace 2D]. 
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A related option specifies how Closed elements are handled when tracing (either [Use longest 
section] or [Use shortest section]). 

 

Process to Trace: 

When digitizing with a DATDRAW command, the user may either enter DATDRAW 
[TRACE|TRACE2D] or push the [Trace] or [Trace2D] buttons on the command dialog. An existing 
element is selected at the beginning of the trace. Finally the last point (on the same element) is 
selected to specify the section of the element to be appended to the element being drawn. After the 
trace section is added to the element being drawn, DATDRAW resumes (in whichever command was 
running prior to TRACE). Trace may be run multiple times when creating a new element. 

See also: PSQR trace options, below. 
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16. ELEVATE has the following changes: 

a. ELEVATE and MEVOLUME have been enhanced to more efficiently process large lidar files by scoping 
the range of lidar processing to match the extents of the master model. It now processes large DTM/Lidar 
files much faster. (January 29 and February 9, 2018) 

b. ELEVATE (Drape) has a new setting, Drape each element to a single elevation, which:(October 3, 2017) 

 …drapes elements to a single elevation for all vertices. 

 …causes multi-vertex elements (simple and complex lines, line strings, shapes, splines, arcs, etc.) 
will be draped to a single (fixed) elevation interpolated from DTM source(s) near the midpoint of the 
element. 

 …preserves the original element type. For example, an arc will be “elevated” as a 2D arc, with both 
endpoints at the same elevation. 

 …when not checked (off), arcs, curves, and splines are stroked into small segments that simulate the 
original object’s appearance. Varying elevations interpolated from DTM source(s) are applied to each 
of these vertices. 

 …whether on or off, point elements (cells, text, points) will have the same elevation results. 

 

New setting in Elevate (Drape) 
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This setting may be especially useful for arcs that you want to preserve as arcs instead of stroking to 
a series of short line segments. Although MicroStation supports 3D arcs (where the endpoints are at 
different elevations), 2D arcs tend to be nicer looking in top-view maps and more usable when 
exported to other formats that don’t support 3D arcs. 

The following is an example of ELEVATE results for a type 16 arc with and without the new option 
selected: 

 

Type 16 arc before ELEVATE 

 

 

ELEVATE results with Drape each element to a single elevation 
unchecked (off): 3D type 4 line string with varying elevations 
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ELEVATE results with Drape each element to a single elevation checked on: 2D (flat) type 16 arc 

 

17. ELINE NEARESTZ no longer mistakenly creates a complete duplicate of the original line if it is canceled before 
finishing. In previous versions, the duplicate element could happen after picking the start editing point, drawing at 
least one new vertex, submitting three or more resets, and starting ELINE again or running a different command. 
(July 14, 2017) 

18. EZEDIT has a handy new option to mark the vertices in an object with temporary numbers. This is useful to detect 
near vertices, duplicate vertices, and malformed elements, or simply to get a quick vertex count. To use, do the 
following: 

 Start the EZEDIT command. 

 Set Whole Element. 

 Set Show vertex numbers. 

 

EZEDIT’s new vertex numbers reveal problems with “switchback” segments 

 When you pick another element, the previous vertex numbers will disappear. 
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19. FILTER (MEFILTER) and CHANGE TEXT (MECHANGETEXT) will now retain settings in the lower parts of their 
dialogs if you make those settings before using the element selection options in the top part of the dialog. (July 12, 
2017) 

20. Find Duplicates (MEFINDDUPLICATES) has a new Save for Visit button. This is described above in 
MEFINDPARTIAL in the New Commands section on page 45. 

21. JOINIT has the following changes: 

a. JOINIT will now preserve vertex direction when joining elements that already go the same direction. That 
is, if it joins the end vertex of one element to the first vertex of another, it will preserve the original vertex 
direction. In the past, it would reverse the vertices when it made the joined element. JOINIT will not 
enforce any particular vertex direction for elements that originally go different directions, that is, when 
joining a first vertex to a first vertex or a last vertex to a last vertex. (April 2, 2018) 

b. JOINIT (semi-interactive version) will now briefly flash the line as feedback that the join is complete. (March 
28, 2018) 

22. LD CP DLG (Load Control Points Settings Dialog) has the following changes: 

a. LD CP DLG has a potential fix for an issue where it would crash when the “Accept Settings/Load 
Coordinates from File” button was selected. This could not be reproduced in debug mode, so the fix could 
not be tested by DAT/EM. (August 16, 2017) 

b. LD CP DLG previously truncated the display of very long cell names in tooltips and cell lists. It would use 
the entire cell name correctly when selected, but it was difficult to know which long cell name to select if 
multiple cells shared the same initial characters. (May 26, 2017) 

 

Long cell names are no longer truncated in horizontally scrolled cell name displays 
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23. MEXPORT, used primarily for a Dept. of Transportation client in the U.S., has the following changes: (June 2, 2017) 

a. If a level identifier is not defined in a design file when the EXP file is loaded, it now makes a temporary 
level. The popups that previously warned the user when a level was not defined will no longer appear. 

b. It uses level codes instead of level identifiers in order to be more user friendly. 

c. There is a new Clear All button to clear all settings and leave the display blank. (June 7, 2017) 

 

24. NEARESTZ, which was new in v.7.4, has been modified to briefly highlight the selected objects. This gives 
feedback that the objects were successfully selected. (July 10, 2017) 

25. PATTERN ALL in both the semi-interactive and parameter file version has a new Snappable Pattern checkbox. If 
checked, created pattern components will be snappable. By default (unchecked), they are not snappable. This 
setting is not enabled by default; therefore it is not enabled in previous versions of parameter files. 

 Customers who do not want snappable patterns do not need to modify their existing parameter files. 
Pattern All will continue to work the way it has in the past without any changes. 

 Customers wishing to have snappable patterns must modify their existing parameter files. 

 

To enable pattern snapping in an existing parameter file with minimal effort, the user can simply open the file in 
the Parameter File Editor, save it, and replace the default setting with a text editor. Instructions: 

 Make a backup copy of your parameter file. Open the PAR file using the DAT/EM parameter file editor. 

 Save the file ([File pull down][Save or Save As]). This will create a default entry for each PATTERN call 
“SNAPPATTERN: 0”. (Note that the entry didn’t exist before, and now you’re creating it and initially setting 
it to off.) 

 Edit the updated PAR file and replace the “SNAPPATTERN: 0” setting to “SNAPPATTERN: 1”. 

 Save the file and run the updated parameter file as before. Created patterns will now be snappable. 

If you need help doing this or need more detailed instructions, please contact support@datem.com.  
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26. PSQR and/or PSQR SELECT have the following changes: 

a. PSQR and PSQR SELECT have a new Do not close option. When checked on, this prevents the closing 
segment from being added. It continues to adjust the last-digitized point so that if the element were to be 
closed, it would close at right angles to both the starting segment and second-to-last segment. If the last 
corner is not digitized, it continues to add what would be the second-to-last segment if it were to be 
closed (referred to as the second-to-last segment in the graphics below). (July 28,2017) 

There is an additional PSQR CLOSE NOCLOSE keyin option that affects both PSQR and PSQR 
SELECT. To toggle back to closing, use the PSQR CLOSE SHAPE, PSQR CLOSE LSTRING, or PSQR 
CLOSE TOGGLE keyins. PSQR CLOSE TOGGLE now scrolls through the three closing options; the 
word “toggle” usually means there are two settings, but we kept the word so users’ keypad settings will 
still work. All of the keyin options are: 

PSQR CLOSE <SHAPE | LSTRING | TOGGLE | NOCLOSE> 

  

New Do not close setting in PSQR and PSQR SELECT 

b. PSQR SELECT (not PSQR) has been updated to allow two-vertex entries in Corners mode with the Do 
not close setting. This allows it to make a single line segment that is either parallel or perpendicular to a 
segment selected on another object (usually on an existing building shape). The behavior depends on the 
current Closing mode: (September 7, 2017) 

 If Closing is set to Do not close, a two-vertex line string will be placed at the two selected 
vertices (constrained by the selected object’s angle). This is the best setting for drawing building 
ridge lines. 
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 If Closing is set to Linestring or Shape, the two digitized vertices are treated as a diagonal 
along a rectangle formed from the selected angle. Do this only if you really do want a rectangle to 
be placed; Depending on the pick locations for the second vertex, the rectangle could be very 
narrow and difficult to tell apart from a line string. 

 

c. PSQR and PSQR SELECT can now pass through and act on specific snapping commands that are 
submitted while drawing. The commands are: (September 14, 2017) 

 TENTATIVE ON 

 TENTATIVE OFF 

 ACCUSNAP TOGGLE 

 SNAP KEYPOINT 

 SNAP MIDPOINT 

 SNAP NEAREST 

 SNAP ORIGIN 

 SNAP INTERSECTION 

 SNAP CENTER 

 SNAP MULTISNAP 1 

 SNAP MULTISNAP 2 

 SNAP MULTISNAP 3 

 ACCUSNAP OFF 

 ACCUSNAP ON 

 ACCUSNAP TOGGLE 

 

Only the above list and the pre-existing key-ins, such as “A” and “S”, will work during PSQR digitizing. 
The implementation is flexible in that additional command translations can easily be added at a later date; 
however, there is a fundamental restriction: 1) pass-through commands must not clear the current 
command state and 2) commands must either be publically defined (MDL) or must reside in the 
COMMONMDL command table. 

d. PSQR and PSQR SELECT (also DATDRAW PSQR) have a new "Trace" mode. This allows users to 
trace a section of an existing element and add the other element’s vertex locations to the building being 
digitized. Trace mode is only available when digitizing with the Corners setting and is entered through 
one of the following keyins: (January 11, 2018) 

 TS or ts – enter trace mode. 

If tracing a closed element (shape or string whose ends are snapped), the shortest 
section of the traced element will be added to the building being drawn. If the element 
being traced is not closed, this is equivalent to the tl keyin. 

 TL or tl – enter trace mode. 

If tracing a closed element (shape or string whose ends are snapped), the longest section 
of the traced element will be added to the building being drawn. If the element being 
traced is not closed, this is equivalent to the ts keyin. 
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 TS2d or ts2d – enter trace 2D mode. 

If tracing a closed element (shape or string whose ends are snapped), the shortest 
section of the traced element will be added to the building being drawn at the elevation of 
the vertex preceding the trace section. If the element being traced is not closed, this is 
equivalent to the tl2d keyin. 

 TL2D or tl2d – enter trace 2D mode. 

If tracing a closed element (shape or string whose ends are snapped), the longest section 
of the traced element will be added to the building being drawn at the elevation of the 
vertex preceding the trace section. If the element being traced is not closed, this is 
equivalent to the ts2d keyin. 

Procedure for PSQR and PSQR ELEMENT “Trace” mode: 

 After entering trace mode (through one of the PSQR trace keyins), the user will select a 
location on an existing element to be appended to the building being digitized. 

 The trace element selected may be a line (3), shape (6) or string (4). 

 A second point must be selected on the same trace element to identify the end point of 
the trace. 

 After this second selection the trace section is appended to the current PSQR element 
and trace mode is exited. The user may finish the building using other PSQR options 
and/or re-enter trace mode with another keyin. 

  

 



DAT/EM Systems International RELEASE 7.5 Release Notes 
 

 59 

27. RCENTERLINE has a change to the surface utility it uses. It previously had a threshold of four breaks/stitches, 
but now it allows up to twenty. The change should allow it to succeed in more cases. (July 21, 2017) 

The reason it does not succeed in some cases is that the surface utilities in MicroStation have problems that are 
beyond DAT/EM’s control. The threshold for breaks/stitches is our attempt to go around the problems as much as 
possible, but there is no perfect workaround. 

RCENTERLINE enforces a recursive threshold to prevent crashes in the worst test cases. This means if there 
really is no best path, due to such things as curves and greatly differing left and right inputs, it may not draw the 
resulting line or the resulting line may diverge from what you visually perceive to be the best path. 

If RCENTERLINE is not satisfactory for particular inputs, try breaking the lines and running RCENTERLINE in two 
or more stages. You may also send the DGN to support@datem.com for further evaluation. 

 

RCENTERLINE results (yellow line in center) where the left and right input lines have a greatly 
different number of vertices. Previously, the yellow line would run outside the input lines in some places. 

 

28. ROAD has the following changes: 

a. ROAD SETTINGS now has the Stroke Tolerance setting enabled, even if the Stroke Elements setting is 
not checked. Arc stroking may be used for cases where an arc offset failed, so it should be set for all the 
drawing modes to potentially use. Note: Remember that the stroke tolerance method changed a couple 
versions ago; a tolerance of 0.1 is more common now than a tolerance of 64. 64 will give very bad results. 
If you set it to 0, it will use the old algorithm. (January 26, 2017) 

b. ROAD SETTINGS has a text display reminding the user to set a stroke tolerance. (January 29, 2017) 

c. ROAD has a new way to create closed objects automatically. In ROAD SETTINGS, check on and set a 
distance in the new Snap Ends within Tol(erance) setting. If the cursor is within that tolerance of the 
starting point when drawing ends, it will close the object automatically. This will help to draw medians and 
islands in the road without having to plan ahead to toggle a snapping mode. In order to close, you only 
have to remember to place the last point within the tolerance of the first point. Or, to prevent closing, 
place the last point outside the tolerance. If you don’t ever want it to close automatically, simply uncheck 
the setting. (Oct. 2, 2017) 
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This new setting has three associated keyins to use on the Keypad or in Buttons: 

 ROAD SNAPENDS_ON <optional tolerance in master units> 

 ROAD SNAPENDS_OFF 

 ROAD SNAPENDS_TOL <tolerance in master units> 

  

  

ROAD Snap Ends within Tol automatically closes if the last point is within tolerance of the start point. 
The offsets will also be end-snapped line strings. 
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Note that MicroStation SelectSeries 4 does not allow a single arc element to have snapped ends 
(essentially forming a circle). To prevent errors, if a single arc is placed with its endpoints within the 
tolerance, it will stroke the arc with many short line string segments before closing. The offsets will also be 
stroked line strings. This will happen whether or not Stroke Elements is currently on. 

  

When ROAD snaps the endpoints of an arc, the resulting circle is stroked into many short line segments 

 

29. SI SETTINGS has the following changes: 

a. The SI Tentative color selection in SI SETTINGS is now saved properly. (December 14, 2017) 

b. SI SETTINGS has a new Show cells as points in SI setting. (November 3, 2017) 

 When on, every cell will be displayed as a point in Summit’s superimposition. This enables 
Summit’s Terrain Visualization tool to create proper contours. If the setting is off, the Terrain 
Visualization contours will seem to go around the vector components of each cell, because each 
cell is changed into its individual vector components in superimposition. 

 The setting should usually be unchecked (off) when not using Terrain Visualization. 

 Note that the color of the point depends on the type of cell. If the color is available, it will be used, 
otherwise it will be red. 

 

New Show cells as points in SI setting to use with Summit’s Terrain Visualization 
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30. STROKE ELEMENT was fixed as follows: Previously, if the Stroke Element dialog was left open while a different 
command was activated, MicroStation would encounter a fatal error message when the Stroke Element dialog 
was later closed. (December 8, 2017) 

31. VISIT and its family of commands have the following changes: 

Reminder: VISIT is for lists of coordinates in external xyz files; VISIT ELEMENT is for existing objects in the 
design file. 

a. VISIT has a new option to zoom to the element extents. (May 23, 2017) 

 

New Zoom to element extents option in all versions of VISIT 
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b. VISIT ELEMENT had some areas that might make the user think that the file listed in the dialog was the 
same as for VISIT, that is, could be read for listing coordinates. The file is actually only for creating a new 
or appended file from the current list of coordinates. This was clarified by adding some prompts and 
messages for appending to an existing file. Edit is a new button to open the file in Notepad after it’s 
created. (Dec. 20, 2017) 

 

Updated VISIT ELEMENT file area with new Edit button 
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32. VOLUME (MEVOLUME) has the following changes: 

a. MEVOLUME for MicroStation now supports point data in v.7.5. DTM point files are now accepted as 
input. In addition, the software permits selection of point and cell elements in the master design .dgn file 
(for extracting elevation statistics). 

 

MEVOLUME can now use surface files  

Note: Automated edge detection (from point data) is still not robust enough, which means surface shapes 
are still needed for pile identification. DAT/EM plans to allow other closed or near-closed shapes to be 
permitted to identify pile edges in the future. 
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33. XYZIN can now place text from a file that does not have an Element Type field set to the word “TEXT”.  

 Note that it still must have the word “TEXT” and “Element type” in the line format when there are multiple 
types of objects to be placed, such as text, points, and strings. This change affects cases where only text 
strings will be placed from every line in the input file. 

 The minimum contents of the file would be X Y Z <text string> in any order. 

 Note that it still requires text strings that have spaces or commas in them to be enclosed in double 
quotes, such as: 

175.98 900.45 12.01 “This is my friend’s text string, not mine” 0 0 0 1 

175.98 900.45 12.01 “This is my text string, not yours” 0 1 0 1 

This line format would be: X Y Z Text Skip Skip Skip Skip: 

  

Example of placing text only from a file without an Element Type field 

 

34. ZCHECK has a new option to write markers to the design file. (March 7, 2018)  

 

ZCHECK’s “Write marker to design” setting 
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DAT/EM Capture for Blue Marble Global Mapper 
Changes apply to Capture for Global Mapper. DAT/EM Capture for Global Mapper is supported for the following 
Global Mapper versions: 

 16.x dated after March 2, 2015 

 17.1.2 or higher 

 18.x 

 19.x (up to the date of this DAT/EM release). For Global Mapper 19 versions after the date of this document, please ask 
DAT/EM Support whether the version is compatible. 

Version notes: 

 If Global Mapper 17 or 18 is the only version of Global Mapper on the computer, DAT/EM will install a new 
extension that uses Global Mapper’s v.17 API. If v.16 and/or v.15 are also on the computer, the older extension 
using the older API will be installed for all versions.  

 To see which extension version is running, select Global Mapper > Help > Module/Extension License Manager: 

 

The DAT/EM multiplatform DLL appears as “DAT/EM Capture for Global Mapper” 

 

Old DLL that uses the pre-v.17 SDK 
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The new DLL that uses the v.17 SDK appears as “DAT/EM Capture for Global Mapper 17”: 

 

New DLL that uses the Global Mapper v.17 SDK 

 

Advice for disabling and re-enabling the DAT/EM Capture extension: 

 If you would like to disable the Capture extension, please close Global Mapper and use the DAT/EM CAD 
Enabler instead of unchecking it in Global Mapper’s Help > Module/Extension License Manager. To start 
the CAD Enabler, select Windows Start > All Programs > Datem Software > Utilities > CAD Enabler. Set 
Global Mapper to “Disable” and OK. 

To enable again at any time, run the CAD Enabler again and set Global Mapper to “Capture”. Note that 
“Capture” will be the default in the dialog every time it appears, because it doesn’t check the currently 
enabled status of any of the products. 

  

To disable, use the CAD Enabler instead of unchecking the extension inside Global Mapper. 

Close Global Mapper before running the CAD Enabler. 
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The following changes were made to Capture for Global Mapper and its instructions: 

1. The instruction manual was updated for DAT/EM Capture for Blue Marble Global Mapper. It is available at 
www.datem.com > Support > Downloads > Manuals > Global Mapper Plugin > DAT/EM Capture for Global 
Mapper v.7.5. 

2. Visit is a new editing and quality control tool. It provides Capture for Global Mapper users with the ability to 
save pick locations to a file, drive to coordinates read from a file, drive to absolute (x,y,z) locations, and drive 
to vertices associated with selected features: 

 Saving Coordinates (via Pick Locations) to file:  

 

 Set Visit Mode to Record to file. 

 Type in or Browse for a file to which coordinates will be saved (Note: if the file already exists, 
newly selected coordinates will be added at the end). 

 Press [Go] to begin recording coordinate picks. 

 While recording the coordinate entered with each pick (<left><click>) will be recorded at the end 
of specified file. 

 You may end recording at any time by pressing the Pause Button (||). It can be resumed again by 
pressing [Go]. 

 Revisiting Coordinates recorded to file: 
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 Set Visit Mode to Play from file. 

 Type in or Browse for a file to which coordinates will be read. 

 Press [Previous] or [Next] or [Go] along with [>>]or [<<] to move through previously recorded 
Coordinate picks. 

 If you are automatically playing through coordinates in a large file you can adjust the delay 
(Pause seconds) or stop playing at any time with the Pause Button (||).You may switch files at 
any time by pausing, setting a new file name and reloading (the new file) with the [Go] button. 

 Driving to an absolute X, Y, Z location: 
 

 

Visit will drive Global Mapper, but will also drive Summit Evolution if DAT/EM Capture Settings are set to 
“Move Stereo plotter to Tentative”. If you don’t want Summit to move with VISIT, uncheck the option: 
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 Visiting Features. Visit can be used to drive to specified locations on select features. 
 

 

 Set Visit Mode to Visit Features. 

 Specify the characteristics of the features you wish to visit by pressing the [Set Feature Criteria] 

button: . The Visit Selection dialog is used to set feature characteristics of 
interest. These can be manually configured in the dialog or extracted from a selected feature 

using the [Pick Feature]  button. 
 

 
 
To select a representative feature (for extracting Feature Criteria), first make sure the Global 

Mapper Feature Information Tool is running, . Next set any filters you wish to apply (for 
example, if you wish to filter only on Feature Attributes, only the Attribute Filter(s) box would be 

checked). Press the [Pick Feature]  button and, in Global Mapper, select a 
representative feature. After selection, the dialog will be populated from information extracted 
from the selected feature. You may make any changes to the Feature Criteria configuration. 
Press [OK] to save/apply the desired configuration. 
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 After configuring the features to Visit, you may have several options for where (on each feature) 
to move. Visit will always drive to the origin of Point features. Options for driving to Area and Line 
features include: 

All vertices 
Start/middle/end 
Start only 
Middle only 
End only 

 

 

 If  is checked, Visit will set the Global Mapper Zoom around the current 
feature. Otherwise, if not checked, the Zoom level will not be changed during Visit. 

 After the configuration is set (or whenever the configuration is changed), press [Go] to load 
feature information. 

 The [<<][>] and [>>] buttons are used to automatically move to each feature location at a speed 
set with the Pause (seconds) setting. This can be paused at any time with the [||] button. 
Alternately, you can manually step through the locations using the [Previous] and [Next] buttons. 

3. The DAT/EM Keypad tools have been improved for use with Capture for Global Mapper. DAT/EM encourages 
you to select “DAT/EM Keypad” during software installation, even if you don’t have the DAT/EM Keypad 
hardware. If “DAT/EM Keypad” was not selected during installation, you can start it manually from 
"C:\Program Files (x86)\Datem Software\KeypadController.exe". Anyone may use the Keypad Controller on 
screen, even without the Keypad hardware. The Keypad for Global Mapper has the following enhancements: 

a. The new Visit commands mentioned above have been added to the example keypad configuration 
that is installed, "C:\ProgramData\Datem Systems\keypad\GlobalMapper.dkf". 

 

Visit tools on the example DAT/EM Keypad overlay 
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b. The following is the keyword list to be used for the DAT/EM Keypad and Button Manager buttons, 
including new and existing keywords: 

AddVertex 

DeleteObject 

Draw Line2D 

Draw Line3D 

Draw Stream2D 

Draw Stream3D 

Draw StreamSettings 

Draw Spotx 

CallCommand MoveToCmd 

CallCommand StopMoveToCmd 

CallCommand Close  

CallCommand Open  

Cancel 

FitView 

ModifyFeatureApply 

ModifyFeaturePt 

ModifyFeatureReview 

ModifyFeatureStream 

 

 

RefreshView  

SI On 

SI Off  

SI Update 

ToggleDatemCursor 

Undo – Limited to ongoing digitizing 
VisitSettings 
VisitRecord 
VisitFile 
VisitFeature 
VisitPlayBackward 
VisitPlayForward 
VisitPause 
VisitPrevious 
VisitNext 
VisitGO 
VisitDefine 
VisitZoomON 

VisitZoomOFF 

 ZoomPlotter 

 

 

c. Visit Settings  raises the Visit dialog in the Global Mapper Window. 

 

This is the same as running Visit through DAT/EM Editing Tools. 
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Visit as seen in the DAT/EM Editing Tools dialog 

d. Record for Visit  sets the Visit mode to Record to file. 

 

 

e. Visit from File   sets the Visit mode to Play from file. 

 

 

f. Visit from Feature Selection   sets Visit to drive to select Features. 
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g. Define Features   raises the Visit Selection dialog in the Global Mapper Window to configure 
the characteristics of the Features that Visit will be driving to.  

 

h. Zoom On  and Zoom Off   are used when visiting Features. When Zoom On is selected, 
Visit will adjust the Global Mapper and Summit Zoom levels to scale around the current feature being 
Visited. When Zoom Off is selected, Visit will drive to the current feature but will not adjust the zoom. 

   

i. Reload/Go   starts Visit by loading coordinates according to the current configuration settings. 
Then Visit will move to the first location and will pause there waiting for further user input.  

 

j. Previous  and Next  move back to a previous coordinate or forward to the next 
coordinate, then stopping for further input. 

k. Remaining buttons  are used to move automatically through specified Visit locations 

at the previously configured speed . The  button moves in reverse 

order through selections.  The  button moves forward through specified locations.  The Pause 

button  either stops recording coordinates or stops moving through specified locations. 

 

-End- 
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