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The following changes have been made to DAT/EM products between Release 7.5 and Release 7.6. Please review these 
revisions made to the software and update your software to implement changes. As always, DAT/EM welcomes 
comments and suggestions from you, our clients, so please don’t hesitate to contact our support department at 
support@datem.com or call us with your requests. 
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Operating Systems and Microsoft Updates 
DAT/EM software no longer supports 32-bit operating systems. If you attempt to install the software on a 32-bit operating 
system (OS), some parts may work, but DAT/EM will not guarantee that everything will work. DAT/EM will not fix any 32-
bit OS-related problems. DAT/EM will not support any 32-bit OS at any time in the future. 

Any reference to an OS in the remainder of this document refers to the 64-bit version of that OS only. 

DAT/EM Release 7.6 is supported on the following operating systems: 

 64-bit Windows 7 Ultimate and Professional with all Windows Updates applied, until support for it ends on 
January 14, 2020. 

o DAT/EM will stop supporting Windows 7 when Microsoft ends extended support on January 14, 2020. 

o The active term for DAT/EM Version 7.6 may extend beyond January 2020. Although it was built to work 
with Windows 7, DAT/EM will not support v.7.6 on Windows 7 after January 14, 2020. If you have not 
already done so, please plan to upgrade to Windows 10 before January 2020. 

 64-bit Windows 8.1 Professional and Enterprise with all Windows Updates applied. 

o Microsoft and DAT/EM no longer support Windows 8.0. Microsoft recommends Windows 8.1 as a service 
pack for 8.0, but recommends Windows 10 above 8.1. 

o DAT/EM will stop supporting Windows 8.1 when Microsoft ends extended support on January 10, 2023. 

o If you need to choose between Windows 8.1 and 10, DAT/EM recommends Windows 10. 

 64-bit Windows 10 Professional and Enterprise with all Windows Updates applied. Windows 10 notes: 

o It is the client’s responsibility to be sure that the video card is new enough to work in Windows 10 and 
your existing stereo display method. 

o If you have any questions about video cards, please contact DAT/EM Support. 

 

Hardware Locks/Dongles 
Install Microsoft Updates before applying lock reset programs. Network licensing should have the same Sentinel driver 
version on both the server and the local computers running the software. 
 

1. The Gemalto Sentinel driver version 7.6.9 is provided with DAT/EM version 7.6. DAT/EM v.7.6 is the first DAT/EM 
version to use Sentinel 7.6.9. If Sentinel 7.6.9 was not previously installed, the first run of the DAT/EM self-
extracting executable or DAT/EM’s newest prerequisites installation will install or update the Sentinel driver to 
7.6.9. Answer Upgrade to the Confirm Upgrade dialog, accept the license agreement, and answer “Yes” to 
Sentinel’s firewall question and reboot when asked. (November 13, 2018) 
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It is very important to answer “Yes” to this question and reboot when done 

 
Sentinel Driver on Network Lock Servers: If you have a network lock on a network server and it is not already 
running Sentinel v.7.6.9, DAT/EM strongly advises you to install Sentinel 7.6.9 on the network lock server to 
match the version on the DAT/EM workstations. Please be aware that in our tests so far, Sentinel 7.6.9 seems to 
communicate well with Sentinel 7.6.8. This means you can schedule the update to Sentinel 7.6.9 on your 
network lock server for a convenient time, either before or after you update the workstations. For example, 
you could install it right before its next scheduled reboot. DAT/EM provides a convenient prerequisites file that 
installs the C++ redistribution files (Microsoft files required to run Sentinel) and the Sentinel 7.6.9 driver: 

 Datem_PreReqs_blt_11_15_2018.exe 
 This is www.datem.com > Support > Downloads > Prerequisites > “Prerequisites installation, 

includes Visual C++ Redistributables and Sentinel 7.6.9 - EXE version” 
 Highlights of the driver are listed here at the Gemalto website: 

https://supportportal.gemalto.com/csm?id=kb_article_view&sysparm_article=KB0016451  
 Answer “Yes” to Sentinel’s firewall question (see images above). 
 Reboot the server after installation. 

Please do not completely skip the update for the network lock server. The newer Sentinel driver works 
better, and the best communication can be expected when the Sentinel versions match. 
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Stereo Viewing Devices and Drivers 
Please note the following changes, additions, and information about compatible stereo viewing devices and drivers: 

1. AMD graphics cards are sometimes used with Schneider Digital PluraView displays. Summit 7.6 betas from 12 
November 2018 to 10 January 2019 disabled calls to the OpenGL function ARB_Imaging. This avoided a problem 
in AMD drivers that caused a crash when Summit started. AMD corrected the issue, and DAT/EM reactivated the 
ARB_Imaging calls in v.7.6 betas after 14 January 2019. If you are using AMD graphics and Summit crashes on 
opening, please contact AMD for a driver dated February 2019 or later. (January 14, 2019) 

2. NVidia 3D Vision is the most widely used stereo display system for DAT/EM users at this time. NVidia has 
announced that it has released its last nVidia 3DVision driver (display and emitter driver bundle) as of April 2019. 
NVidia 3DVision is essentially end-of-lifed by the manufacturer. What does this mean to existing 3DVision users? 

 Install the April 2019 driver and do not update it again. 

 If stereo works one day and not the next, check Device Manager > Display Adapters properties for the 
date of the video driver on the Quadro card. If necessary, reinstall the April 2019 driver (instructions link 
below). Make sure Windows 10 is not set to automatically update the video driver. 

 NVidia 3DVision has never worked for Windows 10 with the oldest Fermi-generation Quadro cards, such 
as the Quadro 4000. Only K-, M-, and P-series Quadro cards will work with Windows 10. 

 There is a 3DVision setup guide for Windows 10 at www.datem.com > Support > Downloads > Help and 
Troubleshooting (direct link: http://datemsystems.com/downloads/Help/How-to-set-up-monitors-for-
OpenGL-stereo-in-Windows-10.pdf). 

 The above instructions file may be used for Windows 7, except the dialog shown in Step 7 on Page 5 and 
on the last page does not exist in Windows 7. (Windows 7 supported only until January 2020.) 

 See DAT/EM’s opinion on 3DVision here: http://www.datem.com/wp-
content/uploads/2019/04/DATEM_Opinion_on_3DVision_12April2019.pdf  

3. For older Planar dual-screen stereo setups on Windows 10, it appears that an April 2019 Windows 10 update may 
have disabled the stereo capabilities of all available Windows 10 drivers for nVidia Fermi-generation Quadro 
cards (such as the Quadro 4000). NVidia long ago stopped releasing updates for Fermi generation cards on 
Windows 10, so we do not expect that nVidia will fix this. The main symptom of the failure is that the same 
Summit image appears on both Planar screens, despite having the proper Windows 10 3D mode on, the nVidia 
Control Panel stereo enable setting on, and nView clone mode on. Use a K-, M-, or P-series Quadro card with the 
April 2019 nVidia driver. If necessary, contact DAT/EM Support for more information on Planar dual-screen setup. 

 

DAT/EM Virtual Reality (VR) Products 
DAT/EM’s VR products are not installed with v.7.6. With the recent release of the higher-resolution VR devices, DAT/EM 
is relaunching development for VR devices. Please contact DAT/EM Support if you are interested in beta testing.  

 

Software Installation, File Locations, and Installed Utilities 
The following has changed for DAT/EM software installation or the location where DAT/EM applications store data: 

1. This was a v.7.5 change that was missed in the v.7.5 Release Notes: DAT/EM now installs a batch file called 
“C:\Program Files\Datem Software\SentinelRestart.bat”. The Sentinel hardware lock driver has three services that 
must be running in order for the lock to be found and operate correctly. If one or more of the services show 
“Stopped” in the Device Manager Services tab, run this batch file to stop and restart all of the services. 
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Summit API (for Third-Party Developers) 
The following changes have been made to the DAT/EM Summit API used by third-party developers: 

1. The 32-bit 2017 API has been reinstated. It had been discontinued in several v.7.6 betas, but was still needed by 
one of Summit’s API developers. (December 4, 2018) 

2. The following function has been added. (February 12, 2019) 
// This function requests the last coordinate from Summit. It will be transmitted through the 
pCoordCallback_ function  
virtual bool requestLastGround ();  

 

DAT/EM Keypad 
The following changes have been made to the DAT/EM Keypad products: 

1. The new keywords for Global Mapper, CAPTURE SETTINGS and SI SETTINGS have been added to the 
example Keypad overlay file for Global Mapper, GlobalMapper.dkf. (May 31, 2018) 

2. The Standalone DAT/EM Keypad for AutoCAD now supports AutoCAD 2015, 2016, 2019, and 2020. The 
Standalone DAT/EM Keypad sends strings of commands into AutoCAD, even if AutoCAD is not the focus 
window, without any other DAT/EM products present. It can be used on screen or with any of the DAT/EM 
Keypad hardware options. (July 26, 2018) 

3. There is a new Summit output type in the Keypad’s Edit Key dialog. The first set of Summit commands available 
are for storing coordinates and moving Summit back to them. Moves may be 2D (xy only), 3D (xyz), and Z only. 
Set the output type to Summit and use syntax in the Text field as follows: (November 2, 2018) 

 M:<variable name that is an integer> – This stores Summit’s current (x, y, z) cursor position in the 
named variable. Set <variable name that is an integer> to any positive integer. It may be convenient for 
you to name it the same as the Keypad key number being set, but this is not a requirement. For example, 
if you’re setting Keypad key 3, you could set it to M:3 to easily remember it, but you could just as well set 
it to M:11299. Just remember the variable name when you want to retrieve it with the R key (shown 
below). 

 R<2|3|Z>:<memorized variable name> – This moves Summit to the stored (x, y) position if set to R2, 
the (x, y, z) position if set to R3, and the (z) only if set to RZ. The <memorized variable name> must be a 
name that was previously used to store a coordinate using an M:<variable name that is an integer> 
key. For example, if you had previously used a key that is set to M:3, then you could use RZ:3 to move to 
its memorized elevation. Or, if you had previously used a key that is set to M:11299, then you could use 
RZ:11299 to move to its memorized elevation. 
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New Summit Keypad output to store and retrieve coordinates for moving Summit 

Example: 
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Example: This Keypad key moves Summit to the elevation stored on key 127 

4. Next is a new keyword used in Airfield3D (Capture for ArcGIS ArcMap). It moves Summit’s cursor automatically 
to the center of the next obstruction area grid cell. This may be used from the DAT/EM Keypad or from a Button 
Manager button. Next will do nothing if an ObstructionArea polygon is not selected. (February 2019) 

5. There are a few changes to the main and Airfield3D ESRI.dkf overlays. See the Capture for ArcGIS Airfield3D 
section below. (January 2, 2019) 

6. The maximum keypad Text string character limit has been increased from 199 to 399. The truncation notification 
message will now appear when 400 or more characters are entered. (January 3, 2019) 

7. Previously, when the character limit was 199 characters, it would report that it was truncating longer strings to 199 
characters, but sometimes it would actually truncate to 198 characters. This was fixed, and the fix will now apply 
to the newly increased 399 character limit mentioned above. (January 2, 2019) 

8. The DAT/EM TouchPad is a legacy hardware option for use with the DAT/EM Keypad Controller. We discovered 
that the USB driver we had for Windows 10 does not work for the TouchPad. Sometimes it does not work on 
Windows 7, either, and we assume not on Windows 8.1 (8.1 not tested). We have found a workaround to allow it 
to use its operational COM communication option, yet plug into a USB port on the computer. See instructions: 
http://www.datem.com/wp-content/uploads/2019/04/How_to_get_a_TouchPad_working_on_Windows_7_-
8.1_and_-10.pdf . 

 

Coordinate Transformations and Elevation Database 
There have been no changes to the elevation database installation file built in 2015 found here: 
http://datemsystems.com/down/SetupElevationModels%20blt%2003%2015%202015.exe. If you already installed that file 
with previous DAT/EM versions, you do not need to reinstall it. Any changes have been added to the DAT/EM setup 
installation, so that you do not need a new, separate Elevation Database file. 
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*NEW PRODUCT!* DAT/EM Stereo Viewer 
The DAT/EM Stereo Viewer is a new DAT/EM product. Its purpose is to perform a pseudo relative orientation only to 
produce good stereo viewing. This allows stereo viewing only. It does not give ground coordinates. It does not require a 
camera file. 

Stereo Viewer will typically be used for historical imagery where the control and/or camera details are unknown and 
measured distances in ground units are not required. 

Stereo Viewer is included in the same setup installation file with all the other DAT/EM software.  

Stereo Viewer is included with all Summit editions and may also be sold separately as a stand-alone license. 

 

Example of Stereo Viewer Image Pair (may be pseudo stereo or quad buffered stereo) 

For instructions on how to use the Stereo Viewer, please see the new Stereo Viewer Operation Manual available from 
www.datem.com > Support > Downloads > Manuals > Stereo Viewer. 

 

Summit Evolution 
The following changes have been made to Summit Evolution and the applications that are provided with it.  

 
General Summit Evolution Subjects 

1. Summit and all other DAT/EM applications that read images now support a new ZIP-like compression found in 
some images originating with the ADS sensor. The compression method could be in other images from other 
sources as well. Previously, the images would appear completely black when opened in DAT/EM applications. 
Now they will appear with their colors as given in the image before compression. (July 23, 2018) 

Note: This does not affect any header mistakes in ADS imagery that may state it is a 16-bit image when fewer bits 
are actually used. If the image looks dark, but contains color variations, that is a separate problem that may be 
fixed by applying a histogram adjustment. 
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2. There were fixes for tiling in two parts: 

 There was an image tiling problem in Summit in the original release of v.7.5. This was fixed and released 
as a patch for v.7.5. The tiling fix is also applied to v.7.6. Symptoms of this problem were very slow tile 
drawing and the inability for the auto localized histogram tool to work. (May 7, 2018) 

 Tiling priority at certain zoom levels was not working efficiently. Which zoom level was affected depended 
on a combination of the tile setting in Summit>Tools>Options>Main View>Tiling and the tile size in the 
image. Now (May 7, 2018)  

3. There is a new Model Switch menu group and toolbar. The options are: (September 26, 2018) 

 

 

 Auto Model switch toggle – Not a new tool. It was previously available on the Quick Options 
toolbar. It is the same as checking and unchecking Summit > Tools > Options > Project > 
Automatically load next… 

 Reopen previous model – Reopens the previously open model after “Automatically load next…” has 
activated. If you didn’t really want the model to change, you can get the previous model back with this 
option. 

 Show All Models at Cursor – This is similar to Move To Ground’s Model tab, except that it shows all 
the models at any coordinate rather than only at specific control point coordinates. It opens up to nine 
models in multiple viewports. 

 Single Viewport – Closes all viewports except the focus viewport. May be used to return to a single 
viewport after Show All Models at Cursor, Move to Ground > Model, or View > Viewports have 
opened multiple viewports.  

Hint: Since these items are available on a toolbar, they can also be set on a shortcut using Summit > Tools > 
Shortcuts, and then a shortcut can be set on a digitizer button using Summit > Tools > Button Manager. 

 

4. Summit’s three Custom CAD toolbars had a problem reloading some .reg files that were exported earlier from the 
editor on the Custom CAD toolbar. Commands that contained a return enclosed in [ ] brackets would miss the 
ending ] bracket. Some whole commands would not be imported. These items are fixed. (November 6, 2018) 
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5. This as a v.7.5 change that was missed in the v.7.5 Release Notes. Summit > Tools > Options > Main View tab > 
Texture Pixels > Tile has more tile settings. The new settings are for higher definition monitors such as the 
Schneider PluraView. If Summit’s tiling seems slow or there are “too many squares” in the view as it pans, set a 
higher value. There is no harm in trying the settings, simply zoom in and out and pan to see which setting 
performs better than the others. 

As a general rule, lower-end video cards should use smaller tiles. Larger tiles can cause a jerk in the movement 
as too much tile data is passed to a lower-end video card. (The lower the nVidia model number, the lower-end it 
is. For example, a P4000 is a well-performing, mid-range card, while a P1000 or P620 is lower-end.) 

 

 

6. Several customers with Quadro video cards complained of very slow tiling, even with local images on a solid state 
drive and the v.7.5 patch or later version. The tile setting described above did not solve the problem. Historically, 
Summit has had code that favored smooth panning over tile loading. This code may have been needed only for 
the much older nVidia cards, such as the obsolete Quadro FX series. This code is removed. (August 17, 2018) 

7. Check for 10 bit is a new checkbox located in Summit > Tools > Performance Monitor.  

a. Check for 10 bit should be off for all nVidia Quadro video cards. NVidia publishes that Quadro video 
cards support 10-bit color, but this is not actually true. 

b. Check for 10 bit should be on for AMD video cards and the Schneider Digital PluraView monitors. The 
user will need to check this on, since the setting is off by default. 

 
 

Check for 10 bit should be off for nVidia Quadro video cards and on for AMD video cards 
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8. The editor for the Custom CAD Toolbar buttons (located at the left of the first of three Custom CAD toolbars) has 
the following changes: 

a. It now offers to update the path of all the referenced toolbar icon images. (April 25, 2018) 

b. It now offers to export and import the Custom CAD toolbar settings and path. It does this by writing and 
reading .reg settings files. Note that .reg files may be shared with other same-version Summit 
workstations. (April 25, 2018) . 

c. Text strings no longer need to be wrapped in quotation characters. (August 29, 2018) 

 

 

The Custom CAD Button Editor can export and import settings and change the images’ path 
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9. There are new slope percentage and distance options for the heads-up text near the Summit cursor. They show 
the slope percentage, 2D distance, or 3D distance from the last-digitized point, whether or not there is an active 
digitizing command. The setting is located in Tools > Options > Main Text > Heads-up Coordinates. The 
distance of this text from the cursor center is set by the same Location, relative to cursor settings that control 
the coordinates text. (April 19, 2018) 

 

    

Examples of text near Summit’s cursor showing % Grade, Length XY, and Length 3D results 
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10. Summit > Tools > Move to Ground has the following changes: 

a. Move To Ground’s Model tab now refreshes properly when Summit opens a different project while Move 
To Ground remains displayed. Previously, the Move To tab would refresh for the newly opened control 
file, but the Model tab would continue to show the old project’s control list. (August 16, 2018) 

b. Move To Ground’s Model tab now has new settings for showing points in the list: Points in Models, All, 
and Points in Active Model. (August 16, 2018) 

 

New Move To Ground Model Tab Show options 

11. The Summit > Tools > Shortcuts > Shortcut Keys dialog can now expand the width of the “Select a macro” 
display. This allows better viewing of all the characters in the listed items. (August 16, 2018) 

12. Summit’s Control Editor (Summit > Edit > Control File) now has the “Transforms” button added to the output 
system on its coordinate conversion tool. (September 7, 2018) 

13. Tools > Norgeskart Maps is new. It works very similarly to Tools > Google Maps, except that it activates 
Norgeskart (Norway Maps), and uses Leaflet Java code to access the Norgestkart map server. (December 13, 2018) 

Before using Norgeskart, set Summit > Orientation > Coordinate Conversion > Input Coordinate System… The 
Output Coordinate System may also be set if Summit is translating coordinates. When Norgeskart is started, the 
window will synchronize with the Summit cursor only if Summit has enough information in “Coordinate Conversion 
for Project” to translate Summit’s ground coordinates back to WGS84. The Summit project area must also be 
located in Norway. 

 

Example of Summit > Tools > Norgeskart Maps 
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14. If the Camera Editor or the Control Editor is started by double clicking on the file listed in the Project Edit dialog, 
the window will open in front. Previously, it would open in front of Summit, but behind the Project Edit dialog. 
(January 9, 2019) 

15. The Epipolar Creation dialog has new labels for its compression scale. (January 7, 2019) 

16. Summit > Tools > Options > SI > Main Text has a new SI text setting that shows the Z difference between the 
cursor height and the loaded Terrain Following surface or loaded Terrain Project surface height (see the new 
Terrain Project information below). (January 25, 2019) 

  

New Distance to Surface setting and display for Terrain Following or Terrain Project Following 

17. The Xbox controller has the following changes: 

a. Xbox R stick speed Multiplier is a new setting in Summit > Tools > Input Speed. It is used when the 
Xbox controller is set as the input device. See more information about new settings for the Xbox controller 
on page 25. (February 11, 2019) 

b. The Xbox One/360 Controller checkbox will now be disabled for Summit Lite in Tools > Options > Input 
Devices. Previously, it could be selected with Summit Lite, but it wouldn’t have actually worked, since the 
System Mouse option is the only valid option for Summit Lite. (February 28, 2019) 

18. The Status Tracker tool was not installing. It has been reinstated. Now Summit > Tools > Status Tracker will 
launch this 32-bit application. If you use the Status Tracker, please let DAT/EM Support know how often you use 
it and to give an opinion on what should happen to it in the future. (February 26, 2019) 

19. Summit’s DAT/EM Drawing Objects would not draw (would cancel the tool selection) if using the system mouse 
as digitizer and setting mouse button 2 to Generic CAD and Cancel in the Button Manager. Button 2 also starts 
and stops digitizer control in Summit, and this was canceling the DAT/EM Drawing Objects tool. Now the button 
can do both without canceling the tool. (February 28, 2019) 
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20. Summit’s cursor ground rings and ground grid (Summit > Tools > Cursor > Ground Rings and Ground Grid tabs) 
have been drawn only in 2D in previous versions. Now they will continue to draw in 2D when there is no source 
for elevation, but they will draw in 3D if a Terrain Project is loaded and Summit > Terrain > Drape Cursor 
Rings/Grid is checked on on the pull-down menu. (February 28, 2019) 

 

Example of 3D cursor ground rings as they are draped on a Terrain Project 

 

 
*NEW!* Terrain Project Tool Set 

21. *NEW* Terrain Project tool set. Terrain Project (Summit > Terrain > Create Terrain Project, Load Terrain Project, 
etc.) is a new tool set based on DAT/EM VR technology without the need for VR viewing devices. It offers 
improved, additional terrain following, point cloud viewing, and stereo mate generation methods. Both old and 
new methods will be available, but all future development and enhancements will concentrate on the new Terrain 
Project tools. The tools are: (starting July 11, 2018) 

a. Create Terrain Project (Summit > Terrain > Create Terrain Project) is the foundation for all Terrain 
Project-based tools. It builds the original Terrain Project that the others need as input. (July 11, 2018) 

To create and use a Terrain Project, do the following: 

 Start Summit > Terrain > Create Terrain Project. 

 Either drag and drop Lidar (or other point format) files into the window or use the browse option. 
Disk space for the output project is essentially the only limit to the number of points you can add. 

 Specify an output Terrain Project name. 

 Set Lidar filters if desired. (January 2, 2019) 

 The “Create Mesh” option is only for visualization and is NOT need for Terrain Following. It will 
also significantly increase processing time. The user is warned if they pick it. 
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New Create LIDAR Terrain Project to generate the Terrain Project folder and files 

A Terrain Project consists of an xml file with the extension “.vrldr” and a folder name such as 
"ProjectName_vrldr". The folders under this folder describe an upper-level octree. At the leaves of the 
octree are LAS Files and associated octree files. The data structure is essentially an octree of files where 
each file is a further octree. This structure allows us to drill down to find the data in an area efficiently. The 
structure also allows partial loading. Only leaves of the upper tree near our areas of interest are loaded. 

b. Load Terrain Project (Summit > Terrain > Load Terrain Project) is used to load an existing .vrldr project 
for the purposes of terrain following (see below). 

c. Close Terrain Project (Summit > Terrain > Close Terrain Project) is used to close any .vrldr project that 
was loaded earlier by Load Terrain Project. 

d. Follow Project Terrain (Summit > Terrain > Follow Project Terrain) is turned on by default after Load 
Terrain Project loads a .vrldr. It may be checked off from the menu without actually unloading the .vrldr. 
The purpose of Follow Project Terrain is to control the elevation of the Summit cursor throughout the 
entire project, or at least in any location where you have supplied it with DTM/DEM input (we’ll use DTM 
as an inclusive term), no matter how large or how dense the DTM files are. Follow Project Terrain is an 
improved version of the older Terrain Following (summit > Terrain > Follow Terrain) method. 

Advantages of the new Terrain Project over the older Terrain Following: 

 Accepts a practically unlimited number of points. The limit is essentially disk space. 

 The old Terrain Following has a limit of around 10 million points. After this limit was reached, 
points were skipped. The new Terrain Project never skips points. 

 The new Terrain Project is compatible with VR viewing. These projects can be directly used with 
DAT/EM's VR viewer (optional).No problem showing surrounding points near the cursor. The 
older Terrain Following method could only show the surrounding triangle points. 

 No noticeable terrain file loading when the model changes. 

 No need for clip settings to limit point loading to the current model size. 

Disadvantage of the new Terrain project over the older Terrain Following: 

 There is a preprocessing step, which is to generate the Terrain Project .vrldr from DTM files, such 
as LAS. For 100 million points, it takes a few minutes. Over a billion points could take an hour, 
but of course this is very dependent on hardware specifications. If writing to external hard drive, 
do not connect by USB 2.0.Note that the preprocessing step could save time overall if you have 
large DTM files that exceed the 10-million-point limit of the old Terrain Following. 
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To use Follow Project Terrain, do the following: 

 First generate an .vrldr project using Summit > Terrain > Create Terrain Project. 

 Select Summit > Terrain > Load Terrain Project. 

 If it is not already on, select Summit > Terrain > Follow Project Terrain (it will be on by default 
after loading the .vrldr) 

 Choose additional options or actions: 

o To follow terrain at a constant elevation offset, select the Summit > Terrain Project Z 
Offset option. Enter the offset value. It will be applied to the cursor position so that the 
cursor is a constant elevation above or below the surface. (August 16, 2018) 

o To show terrain points around the cursor, select Summit > Terrain > Show TP 
Surrounding Points. 

o To show an overview of the Terrain Project, select Summit > Terrain > Show Terrain 
Overview. 

o To be able to toggle Project Terrain from a digitizer button, set a Button Manager button 
to Type=Plotter, Action=Terrain follow toggle. The same button setting works for 
either the old and new terrain following methods, whichever is active. (August 16, 2018) 

 

Button Manager setting to toggle terrain following 

o To close the project and free it from memory, select Summit > Terrain > Close Terrain 
Project. 

e. Lidargrammetry is a new tool to generate orthophoto and stereo mate images from Terrain Projects (see 
Terrain Projects above). Although Summit > Imagery > Generate Lidar Image (“old method”) is still 
available, Lidargrammetry Image (“new method”) is better and is meant to replace the old method. 

 

New Lidargrammetry Image makes better images and stereo mates from point files 
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The advantages of Lidargrammetry Image over the old method: 

 The stereo generation is new and faster. 

 It works for a large number of points. In DAT/EM’s tests, it processed 100 million points in under 
20 minutes. It took several hours to process a billion points. The size of the images for the billion 
points was 39602x26572. The old method could not process billions of points. 

 It’s more consistent and successful. DAT/EM tried 100 million points with the old method and 
found strange artifacts in the imagery, which made it useless. 

 After generating the 1-billion-point images (orthophoto and stereo mate), DAT/EM ran it in 
Summit and loaded the Terrain Project. It was then possible to do terrain following on the images 
with 1 billion points. It is able to show surrounding points to demonstrate how the images were 
generated from the points. 

 Since no points are skipped, the elevations are true everywhere. The old method would skip 
points if there were too many for it to manage. 

f. Point Cloud is for visualization and collection on Terrain Project point clouds. It works similarly to 
Summit, but Summit is not needed for collection via Point Cloud. (August 28, 2018) 

Point Cloud has superimposition (SI) built in. Just start a CAD/GIS command using the Keypad or the 
CAD/GIS interface as you are used to doing with Summit and Capture, except this time it is Point Cloud 
and Capture. 

Point Cloud can be used in quad buffered stereo, anaglyph stereo, or mono display modes. It opens .vrldr 
Terrain Projects (instructions to build a Terrain Project are above): 

In Point Cloud, use the left mouse button to PICK and collect into CAD; Point Cloud will control CAD just 
like Summit. In Point cloud the cursor will snap to points automatically. In this way, you can select a 
corner of a building by moving the cursor (center of screen) near the point. Once the cursor is where you 
like, you simply PICK (left click) and collect in CAD. The whole idea is to not use photogrammetry at all 
and instead use dense LIDAR to collect roads, buildings, and other features. This requires being able to 
view massive amount of points dense enough to see actual features. The stereo view of the points lets 
the user see the depth of the points so they can tell where features are in relation to each other. The 
snapping makes it possible to easily move the cursor without adjusting it in and out. Simply aim the cursor 
and it snaps to the right XYZ. By contrast, Lidargrammetry turns the points into stereo images so that we 
can collect using Summit. Point Cloud uses the points themselves and no images are required. 

 

Terrain Project’s new Point Cloud application 
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Point Cloud has no problem opening large Terrain Projects. RAM usage is managed well with larger 
projects. A project with over 3 billion points uses about 1GB RAM. 

The properties are saved per project unless “Project Settings” is set to “No –global”. The first three 
properties (Project Settings, Display Mode, and Stereo base) are always global properties. You can set 
different speeds, backgrounds, point size, etc. for each project. Properties are always applied and saved 
instantly. 

To control it, it supports system mouse and keyboard and the various 3DConnexion SpaceMouse 
devices. Go to Point Cloud > Help > Show controls to see how the keyboard and mouse work together. 
They work just like typical game controls. Mouse and keyboard work really well, but the 3DConnexion 
SpaceMouse devices really shine for flying around the points. 

SI display and vector collection are supported. The Button Manager is used to set system mouse buttons. 

 Typically the left button will be “Pick”. 

 Typically the center button will be “CAD cancel”. 

 The right button is always used to switch in and out of mouse/keyboard control and it does not 
make sense to assign this button in Button Manager. 

 Similarly, the 3DConnexion SpaceMouse buttons are also supported in Button Manager. 

 

Button Manager showing typical settings for Point Cloud system mouse control 

 

 
Superimposition 

22. Superimposition (SI) has the following changes: 

a. “Multi Source Superimposition” (multi SI) has been added. This is a major change to SI. In the past, only 
one source of SI was allowed, so, for example, you could not use Summit, LandScape, and MicroStation 
all at the same time, because either LandScape or MicroStation would be the only source of SI vectors. 
With multi SI, LandScape and MicroStation could be used at the same time to supply SI vectors to 
Summit. Summit’s SI Lidar tool will not replace SI from CAD, because they will both be accepted as input 
at the same time. (June 11, 2018) 
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b. Summit has a new SI Layer Manager. It works similarly to how it did previously when there was only one 
source of SI, but now it handles the potential multiple sources. (August 8, 2018) 

Terms: 

 Source is the SI source where the data comes from (usually CAD/GIS). 

 Instance is the instance of a particular source, in case it’s running in more than one instance. 

If you open AutoCAD 2004 twice, you will get one source (AutoCAD 2004) and two instances 
(first and second run of AutoCAD 2004). For sources that are only allowed by their manufacturer 
or by a setting to run in one instance, you will only ever see Instance=1.  

The Condense Layers option is saved per source and instance. Every source and instance will have 
unique settings for Condense and Layers all of which are saved. The defaults are Condense 
Layers=Checked On and <All Layers>. 

A source must be open in order to see its settings. All settings for every Source/instance will still be 
saved, but just not always shown. 

For example, you open AutoCAD and MicroStation and set up some SI layers (change between CADs 
using the Source combobox). These are automatically saved. You exit Summit. Now you bring up just 
MicroStation and Summit. The settings for MicroStation are still good and will be shown. You go ahead 
and further change MicroStation. Now you close MicroStation and bring up AutoCAD. The previous 
settings you had for AutoCAD are still there, and so are the new MicroStation levels/layers (you just don’t 
see MicroStation’s settings, since it is closed). 

Now, for example, you open two instances of AutoCAD (same source version), you now have a source 
that has two instances. The default is to show all layers, so the second AutoCAD will display everything. 
Now Instance can be used to set layers for the second instance of the same SI source. 

 

New SI Layer Manager for multi-source superimposition 
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Aerial Projects 

23. Aerial projects have the following changes: 

a. In Summit > Edit > Project for aerial projects, when adding or subtracting control files and when changing 
the Average Elevation setting from Keyin to Control, the displayed average elevation will update 
immediately after each change. (Sept. 7, 2018) 

b. The EO dialog will now show the values for the left and right open images on Left and Right tabs. 
Previously, it only showed the values for the left image. (October 15, 2018) 

 

The EO dialog previously showed only the left image 

c. Oblique models have the following changes: 

 Cursor movement has been improved for some oblique models. Previously, it was difficult to 
return to the same location by spinning the Z control up and then down again. It would drift away 
from the original XY as it moved. Now it is possible to return to the location much like the 
movement in a nadir aerial project. (October 8, 2018) 

 The Oblique Options dialog has changed. All settings in this dialog are now saved in the .smtxml 
project. Previously only the “Project Settings” were saved in the project.  

The dialog also has a new option for XY movement. The default XY movement option moves 
along the epipolar angles in ground coordinates. For close range obliques, this would always be 
the choice, and the second option probably would not work. The XY movement lock Z option 
allows a locking of the Z while moving around. This will work for projects that are more “aerial” 
like. Projects that used the Oblique dialog successfully before might need to change to XY 
movement lock Z, since it is like the old movement method. (October 24, 2018) 

 

Updated Oblique Options dialog. Settings are saved to the .smtxml. 

Other changes were made to support the “Close Range” case of oblique. 



DAT/EM Systems International RELEASE 7.6 Release Notes 
 

 22 

 Summit > Tools > Move To Ground was odified to show the points correctly for close-range 
oblique models. It was weeding out points based on 2D extents, which was not good for a more 
3D case such as close-range obliques. 

 The Stereo View angle for close-range obliques had to be recalculated (this is the angle that 
makes stereo view exactly left to right). Previously, this was calculated assuming an aerial type 
view. This has been changed to handle the oblique or close-range oblique case. Below is an 
example of about 15 degrees stereo angle, which makes object in the scene left to right of each 
other. This is not the same as the epipolar angles. 

 

Improved stereo view angles help this close-range stereo UAV model work well 

 
ADS40/80/100 Projects 

24. ADS40/80/100 (ADS) projects: 

a. The Summit > Edit > Project dialog for ADS projects can now apply “Modify Paths” to one or more 
selected images. Previously, it would set the same path for all images. (May 30, 2018) 

b. ADS projects can now activate binary extents, which aerial projects already offered in previous versions. 
By activating binary extents, Summit takes a snapshot of the project’s image information at the time its 
activated. It then accesses a binary file instead of checking the .smtxml and recalculating stereo extents 
for all the models. Use this option on projects that are so large, they become extremely slow. (January 7, 
2019) 

To use binary extents for ADS projects: 

 First completely prepare the ADS project. Verify it is complete. Save the .smtxml. 

 Select Summit > Orientation > Model Extents to file. 

 Check on Use Model Extents from file. Then select both Update Extents and Save. It is 
important to use both buttons. 

 

Check the setting on and use both buttons 
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 Select OK, but always remember you have the binary extents option on. 

 Any time you need to change the project, for example add or subtract images or change the 
average elevation by adding a control file, you must go back to Summit > Orientation > Model 
Extents to file and select both Update Extents and Save. 

 If you move the project to a different location, repeat this process in the new location. 

 

 
VisionMap A3 Projects 

25. VisionMap A3 projects: 

a. The Project window’s Models tab will now build models for A3 projects using the “hammer” icon, . 

b. Version 7.5 introduced A3 epipolarization to the Summit > Imagery > “Epipolar Generation [Epipolar 
Creation]” tool, which previously only worked with RPC satellite projects. Since that time, we received an 
A3 project that was very sensitive to the elevation range that must be manually entered for this tool. 
When the elevation range is too small, there could be xy offset issues in the resulting project. 

For 7.6, DAT/EM added to the existing epipolar generation tool. It now generates two Summit .smtxml 
projects. The epipolar images are the same for both projects; it is only the .smtxml files that are different. 
The DAT files from the original project will also be copied (quasi orientation). The user can try both 
projects and choose the one that is better for the purpose. (June 6, 2018) 

 The first project is an RPC model of the epipolar images; it will have ‘_epi_rpc’ added to the 
project name. This is the same project we originally made in v.7.5 and the RPC is calculated 
using simulated control. The user should still be careful to enter a good elevation range in the 
Epipolar Creation dialog. The user should also be very careful to check control and check the 
coordinates in all areas of the model against the original quasi-panoramic model (use a 
Summit solution .smtsln file to view both projects together and compare coordinates.) Some 
lateral models will not work well. For models that do work well, the RPC may be used, and is 
much faster to calculate the ground position in the “_epi_rpc” than in the “_epi” model. If the 
project does not work, use the “_epi” project described below. 

 The second project generated uses the original A3 orientation and a 5th degree polynomial 
that was used to generate the epipolar. It will have “_epi” added to the file name. Since 
DAT/EM is just using the information used to generate the epipolar image and not 
recalculating an orientation (RPC), we can guarantee that this model will work (assuming the 
epipolar generation is good). The epipolar images must be generated at 1x for this project to 
work. This project contains polynomial information instead of RPC data. This polynomial goes 
from epipolar pixel to original pixel and back, and uses the A3 orientation to go from original 
pixel to ground coordinates and back. There is no recalculation or change of orientation 
models for this case.  

Added July 2, 2018: Although the epipolar images described immediately above were 
generated correctly, Summit’s ground calculation for the cursor position needed to be 
improved for some lateral models. Instead of the 5th order polynomial, it needed to use the 
inverse of the 5th-order polynomial, which is mathematically impossible to do, so now it uses 
an iterative process to obtain the position. In betas dated after July 2, 2018, the “_epi” project 
will give correct ground values for the cursor position when they are opened in Summit. The 
changes are all in the calculation of the cursor position, so it can still use the epipolarized 
imagery that was generated in the June 7-June 29, 2018 betas. 

Initial testing of the “_epi” model shows its coordinates match the original A3 quasi-panoramic 
model position very well, while sometimes in difficult lateral models, the “_epi_rpc” does not 
work. 
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Left: Original quasi-panoramic lateral model. Center: New “_epi” epipolar model ground solution (after July 2, 2018). 
Right: Failing case of the epipolar RPC “_epi_rpc” model. 

These are shown together in a Summit solution .smtsln project, recommended for checking A3 projects. 

 

 
Imported Projects 

26. Imported Projects: 

a. If a Z/I Import project contains the Earth radius in feet, Summit will automatically do a “Super Earth” check 
and convert the number from U.S. feet to meters. The number for the Earth radius in Summit > Edit > 
Project > Interior Corrections must be expressed in meters. There is nothing in a Z/I project that 
distinguishes U.S. feet from International Feet, so the conversion will always be from U.S. feet; the 
difference between them is only 13m across the entire Earth, so it will have an insignificant effect on the 
Earth Curvature Correction if it is actually International Feet. The user is welcome – even strongly 
encouraged – to review the interior corrections and make sure they are right after the import. The user 
may replace the Earth radius with the International-Feet-to-meters value if desired. (April 9, 2018) 

b. Summit > File > Import > ISM DiAP Models can now import Applanix-type Diap projects, which have a 
slightly different camera setup than the previously supported types. For this type of model, uncheck the 
following setting in the import dialog: (December 10, 2018) 

 

This setting must be off (unchecked) to import an Applanix-type ISM DiAP projects 
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c. The Pix4D project importer has the following changes: 

 If the processed images (such as SMTIs) are not found, the message that appears will now 
give a hint to run the Image Creator before importing the Pix4D project. 

 Immediately after importing the Pix4D project and subsequently making models, 
“Automatically load next model when outside stereo region” will work. Previously, it would 
only change models after closing and reopening Summit. 

 
Button Manager 

27. Button Manager has the following changes: 

a. The Xbox Controller tab and Xbox controller handling is improved. First, it now offers up to two shift 
buttons. (February 11, 2019) 

  

The Shift buttons can be any button you choose. There can be no shift, one shift, or two shift buttons. 

 When no shift is set, there are 16 buttons remaining to set. 

 When one shift is set, there are 30 buttons. Two items will be blanked out (they both 
would have been on the button that is now the shift button). 

 When two shifts are set, there are 42 buttons. Six items will be blanked out (these six are 
the buttons that would have been on the buttons that are now the shift buttons). 
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To further support the Xbox controller settings, Xbox R stick speed Multiplier is a new setting in 
Summit > Tools > Input Device Speed for Xbox controllers: 

 

Xbox R stick speed Multiplier is the speed difference in the X vs. Y axis of the Right stick. The default 
value is 0.1, which means the X axis of the Right stick moves the Z 10x slower than the Y axis of the 
stick. In this way, the right stick can have both fine and course Z movement. If you set the value to 1, then 
the X and Y axis would move Z at the same speed and you would no longer have a “fine and course” 
movement. If you made the value to 10, for example, then the X would now be moving 10 times faster 
than the Y. The result would be “courser and course”. You could also change the Z magnitude to 10 times 
smaller and the result would be “course and fine” or a reverse of X and Y axis. Typical values to use are 
around 0.5 – 0.05 (or ½x to 20x slower). 

Note: Both the Xbox 360 and Xbox One controller models will work. 

Note: Here’s a link for help setting up an Xbox One controller in Windows: https://support.xbox.com/en-
US/xbox-on-windows/accessories/connect-xbox-one-controller-to-
pc#1575701221b94acc960dedc070293fdc. 

 

b. Some of Button Manager’s pictures of the devices wouldn’t refresh correctly if the window moved. This is 
fixed. (February 12, 2019) 

 
Project Viewer / Ortho+Mosaic  

28. Project Viewer / Ortho+Mosaic has the following changes: 

a. In Ortho+Mosaic’s Generate Orthophotos, the Images at Once (thread count) options were increased 
from 4 to 10 for compatible processors. A higher setting will make it faster on newer processors; however, 
this does not mean that setting 10 images at once will be 10 times faster than 1. There are other limiting 
factors that affect the processing time. The maximum possible increase is 2.5 times faster. (August 15, 2018) 
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b. Ortho+Mosaic has a new Automatic Azimuth setting on Create Mosaic’s Image tab. Each mosaic 
boundary will be individually evaluated for its most vertical (closest to the y axis direction) side, and the 
azimuth will be set to match it. (August 15, 2018) 

 

New Automatic Azimuth setting for rotating the mosaic output 

 

 For rectangular mosaic boundaries, including rectangular grid boundaries, this will completely 
eliminate any background-colored pixels at the edges of the mosaic. 

 For non-rectangular polygons, it will still rotate to its most vertical (north-south) side. Background 
pixels will fill in the gaps between the bounding rectangle at that vertical azimuth that includes the 
whole mosaic. The following are two examples: 

  

Example 1: Results of a nonrectangular mosaic boundary. 

The mosaic azimuth is aligned to the boundary’s most vertical side, on the left in this case 
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Example 2: Results of a nonrectangular mosaic boundary. 

The mosaic azimuth is aligned to the boundary’s most vertical side, on the right side in this case 

 

c. Using the existing North Azimuth setting on Create Mosaic’s Image tab could cause extremely slow 
processing. This was fixed along with adding the Automatic Azimuth setting mentioned above. (August 15, 
2018) 
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LandScape 
Landscape has the following changes: 

1. Landscape Control Report is a new tool in LandScape that compares a control surface to the surface in the 
current project. To use it: (December 10, 2018 or earlier) 

 Select LandScape > Tools > Landscape Control Report. 

 

 Load the control surface using the  button. 

 Calculate the two surfaces using the  button. 

 Save the results to a CSV or ASCII file using the  buttons. 
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2. LandScape has a new set of color options that apply separately to the profile window. Previously, the main view 
color options applied to both the main view and the profile window. (January 24, 2019) 

  

 

New “Color Profile By” setting on the View menu and Point Colors toolbar 

 

Example of the main view colored by elevation and the profile window colored by class 

The new icons have been added to the end of the Point Colors toolbar. This makes the toolbar longer. After an 
update installation, the longer toolbar may be positioned on a new toolbar row. To optionally organize the toolbars 
better, select LandScape > Tools > Reset Toolbars to Default. Note that the Point Colors toolbar will now be 
positioned in the center row of toolbars after the reset; previously it was located in the top row. 
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3. LandScape now has Input Filters on the majority of its interactive edit tools in the Interactive Point Edit dialog. 
The only tool where it doesn’t appear is Add, because it didn't make sense to add it to that tool. For the Fill 
Points tool, the filter is used to identify points used for Snap to Surface. (January 18, 2019) 

 

New LandScape Input Filters in Interactive Point Edit 

 

DAT/EM Capture for ArcGIS - ArcMap 
DAT/EM v.7.5 is compatible with ArcGIS 10.0 (service pack 4), 10.1 (service pack 1), 10.2, 10.2.1, 10.2.2, 10.3, 10.3.1, 10.4.x, 
10.5.x, 10.6.x, and 10.7.x. (plus any available service pack as they are released). 

DAT/EM v.7.5 may be compatible with ArcGIS 9.1, 9.2, 9.3 (service pack 1), 9.3.1(service pack 2). BE ADVISED: Testing no longer 
occurs for DAT/EM Capture with ArcGIS 9.x. It still installs for it and no code has been removed, so you may use 9.x as long as it 
continues to work for you. Any issues will not be corrected. ArcGIS 9.x support may be dropped completely in a future release. Please 
continue to make plans to upgrade any remaining ArcGIS 9.x version to 10.x. 

DAT/EM Capture for ArcGIS has the following changes: 
Capture for ArcGIS Items 

1. Version 7.5 would not send the ArcMap-assigned line weight to Summit’s superimposition when “Show line 
patterns” was on in the ArcMap-side DAT/EM Systems Options SI settings. This is fixed. (May 24, 2018) 

2. The Draw Stream tool previously required you to draw the two points that define the first segment before it would 
start streaming. Now it starts streaming immediately after the first point is digitized. (July 19, 2018) 

3. Snapping to multiple potential snappable objects (“multi snap”) has changed. Keep the cursor in the same place 
and keep picking if you don’t like the current snap suggestion. Snaps will be done in the following order: (July 11, 
2018) 
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 It offers the current rubber band snap first, which might be any of the potential snap distances. 

 Pick again in the same (x,y) location. For this second pick and any subsequent picks in the same spot, it 
sorts the snaps by distance. 

 The only snap not sorted by distance would be the first one, which would always match what the rubber 
band indicated. 

The following changes needed to be made as a result of the new multi snap: 

 When starting in point-to-point mode, the DAT/EM Autocomplete tool stopped working if a snap occurred. 
This is fixed. (March 22, 2019) 

 The DAT/EM Remove Vertex and Shift Vertex tools did not multi snap if there was a coincident vertex on 
another object at the first snap location. Follow the prompts in Summit’s SI (usually in the upper right 
corner of Summit). You must move the cursor away from a multi snap point in order for it to know you 
have selected the desired snap point. This only occurs when multiple objects are within the snap radius 
of the first pick. (March 22, 2019) 

   

   

For multi snap, hold the cursor’s xy still and pick again until the desired object is snapped. Move xy to accept. 

4. The previous snap wasn’t clearing if snap was turned off. This is fixed.  (April 9, 2019) 

5. The Filename browse dialog in the ASCII Import tool now offers .csv (comma separated variables) format in the 
types of preset file extensions. (July 25, 2018)  

6. When the settings were made to fill a field with the elevation value (DAT/EM Capture for ArcGIS > ArcMap side > 
DAT/EM Capture Options > Elevation Fields settings), and when digitizing points, it would not populate the 
elevation field for the first-drawn point in the “Create” session or for the first-drawn point on a point layer after a 
“Cancel” button was received. This is fixed. (November 1, 2018) 

7. The DAT/EM Cut tool will now clear previous ArcMap selections before it begins. Previously, if there were active 
selections as it started, it would not work at all. (November 30, 2018) 

8. The select tool button has been removed from the DTM Collection tool. The user must preselect the boundary. 
The select tool was causing the command to get out of sync with the edit session. (November 29, 2018) 

9. The “Cut polygon with existing polyline” tool would work well for the first selected line and polygon, but not for the 
next selected line and polygon. This is fixed. (February 20, 2019) 



DAT/EM Systems International RELEASE 7.6 Release Notes 
 

 33 

10. When starting in "Point to point" mode, the "Autocomplete" tool only worked when starting on a vertex of an 
existing polygon. The same problem didn’t happen when starting in stream mode. Now it’s fixed so that it can 
start near the existing polygon instead of snapped to it. (February 20, 2019) 

11. The following is fixed: In v.7.5, when the map was saved in layout view and then reopened, it would ignore 
coordinates until the user switched from layout to data view and then saved and reopened the document. (February 
20, 2019) 

12. In the Field Update tool (and Airfield3D), the “Apply” button might need to update a field that was turned on for 
ArcMap labeling. The label would previously update in the ArcMap data view, but not in superimposition (SI). Now 
labels will update in SI after every “Apply”. (March 12, 2019) 

13. Zoom (mostly) independently is a new zoom method available in the ArcMap-side DAT/EM Systems Options 
“Summit Zoom” settings. It will prevent ArcMap’s zoom scale from changing on a model change. “Mostly” means it 
will initially zoom together when the applications open. (December 6, 2018) 

 

Zoom (mostly) independently is a new option to prevent zooming on model changes 

14. ZoomControl <Summit | Arc | Both | Neither> is a new keyword that enables you to set the Zoom method 
(shown in the previous item above) from the DAT/EM Keypad or a Summit Button Manager UserCAD button. The 
strings for the Keypad or button are as follows: 

a. ZoomControl Summit  sets Zoom method to Summit makes ArcMap zoom. 

b. ZoomControl Arc  sets Zoom method to ArcMap makes Summit zoom 

c. ZoomControl Both  sets Zoom method to Summit and ArcMap both zoom 

d. ZoomControl Neither  sets Zoom method to Zoom (mostly) independently 

Hint: You can set a toggle or cycle on one Button Manager button using the : character to separate them, such as: 

ZoomControl Summit:ZoomControl Arc:ZoomControl Neither 

 

15. An alert user discovered that the field setting string for the Keypad, which uses a colon character : to divide the 
layer name from the field name and the field name from the value, does not work as a Summit Button Manager 
User CAD string. The Button Manager string parser already uses : for another purpose, which is to break a string 
into separate consecutive or “next” strings. Now there is a substitute character, ~, that will work and will not break 
the string if used from the Button Manager. The new character is also now compatible with the Keypad and 
Summit’s Custom CAD toolbars. 
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16. The following works from the DAT/EM Keypad and Summit’s Custom CAD toolbars. It does not work from the 
Button Manager: 

SetFieldValue Layername:Fieldname:value 

The following works universally. It works from the Keypad, from Summit’s Custom CAD toolbars, and from a User 
CAD Button in Button Manager: 

SetFieldValue Layername~Fieldname~value 

The following is a specific example that could be used in Airfield3D to digitize a tree or skip jump started from a 
Button Manager User CAD button: 

target Obstacle CreateNewFeatureTask SetFieldValue Obstacle~OBSTACLETY~TREE draw pointtopoint 

target Obstacle CreateNewFeatureTask SetFieldValue Obstacle~OBSTACLETY~"SKI JUMP" draw pointtopoint 

 

17. ClearCheckMarks is a new keyword that causes DAT/EM Field Update to uncheck all of its previously checked 
checkboxes. This may be used from the DAT/EM Keypad or a Button Manager button. There is also a button for 
this on the DAT/EM Field Update dialog. (April 3, 2019) 

 

ClearCheckMarks keyword and dialog button clear all checkboxes in Field Update 

18. 2D layers were not working with the method to automatically add Summit’s cursor elevation to a field for objects 
digitized with DAT/EM drawing tools. These 2D layers have no Z vertex defined, but instead are set to use an 
elevation field that is checked on in the ArcMap-side DAT/EM Systems Options Elevation Fields settings. The 
problem is fixed, so that the elevation is properly set in the field. A related fix was made to properly refresh the 
elevation label in superimposition, if labeling is on in ArcMap for the elevation field. (March 13, 2019) 

19. DAT/EM Autocomplete will now only work to draw on a polygon layer. Previously, it would also allow drawing on a 
polyline layer. It was necessary to remove the polylines layer capability in order to make the polygons work 
correctly. If the target layer does not have polygon geometry, you will see a message, “Please select a polygon 
layer as a target.” (March 2019) 

20. While starting ArcMap and loading the Capture extension, Capture will now check to see whether Auto Update is 
on at startup before performing the initial SI Update. If auto update (ArcMap-side DAT/EM Options SI tab) is off, 
SI won’t update right away. This could prevent a long wait and would give you access to other settings sooner. 

21. The Trace tool is very slow to add many points to an object, when many points are traced. We can’t speed it up 
very much, because that’s how long ArcMap takes to add the vertices to the object. We tried to optimize it as 
much as we could by no longer drawing the rubber band to each vertex as it is added. It may be only slightly 
faster than before, but every little bit helps! (March 16, 2019) 
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Airfield3D 

22. Airfield3D has many significant changes: 

a. Very important new setting! There is an area near the 10,000 foot limit where the conical and horizontal 
surfaces are below the approach surface. Previously, when Lock to Surface was on, the cursor always 
stayed on the upper surface. Users reported that sometimes they want it to follow the lowest surface to 
see if there are objects penetrating the lowest surface that do not penetrate the higher surfaces. Now 
there is a setting to let you choose whether it will return the highest or lowest surface. This affects all 
activities, such as Lock to Surface, the Measure Status tool, and reports. You may wish to turn the setting 
on for digitizing and viewing purposes, then back off to make reports. (August 2, 2018) 

To make the highest/lowest setting, start the options next to the FAA 18b setting in the Airfield3D dialog. 
Chose a setting for Follow lowest surface: 

 For Lock to Surface and Measure Status activities, your preference, on or off. 

 For reporting, off (unchecked). 

 

Turn off for reporting. The rest of the time, it’s your choice. 

In the end, this setting is given to try to deal with one of the many ambiguities in the 18b specifications. 
The FAA defined the surfaces so that there can be more than one at the same (x,y), but they did not 
define how to handle obstacle collection there. You, as the user, will need to be very careful how you use 
this new Follow lowest surface setting. Check it often, especially before generating reports. 
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b. Warning! This tool has been added, but do not run it more than once on the same polygon(s). The 
ArcMap cutting tool DAT/EM calls can corrupt the polygon if it already has a shared edge with the 
cutting line (which is made the first time you run it!). Clip Obstruction Areas is a new tool in 
Airfield3D that clips the polygons on the Obstruction Layer using Runway Obstruction ID Surfaces as 
cutting edges. (July 30, 2018, correction added ) 

It is not necessary to insert the Runway Obstruction ID Surfaces into the ObstructionIDSurface layer 
before running this tool. 

To use Clip Obstruction Areas: 

 Pick the  button on the Airfield3D Update dialog to launch the Clip Obstruction Areas dialog.  

 While the dialog is open, use the Runway list to select the runways whose surfaces will be used 
as clipping edges for the obstruction area polygons. 

 Select the Delete original obstruction area check box if needed, then press the Clip button. 

 The tool will find the intersections of Polygons on the Obstruction layer and the polygons that 
make up the Runway Obstruction ID Surfaces and insert them into the Obstruction layer, 
assigning the new polygons to the elevation of the Runway Obstruction ID surface. 

 If Delete original obstruction area is checked on, the original polygons will be removed.  

 

Obstruction Area Polygons are clipped at the obstruction area edges 
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c. Airfield3D Calculate Height Above Ground is a new recalculation setting in the Airfield Recalculate 
tool. (August 1, 2018) 

 

 
 If the Use Auto Height DTM to calculate Height Above Ground field is checked, then the 

Airfield3D Recalculate tool will set the Above Ground Level field to the difference between the 
measured location of the obstacle and the DTM elevation from the DTMs in the Options Auto 
Height dialog (see below). 
 

 Recalculate if not set is a new option that only resets a field value if it currently contains the 
default value for that field. This is different than the Recalculate which will always modify a field if 
a value is calculated or Set Default if not calculated, which always modifies the field value, 
setting either the new calculate value or the default value if a new value cannot be calculated. 
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d. The Airfield3D dialog may be minimized to remain displayed, but take up half the maximized display area. 
Note: This may cause some smearing effects with some video drivers. If the display is not good, expand 
the dialog again. (July 30, 2018) 

e. The Summit-side Airfield3D toolbar has a new mandatory setting for coordinate systems. It is required to 
set the systems here in order to generate the correct offset value for the ellipsoidal height offset fields in 
the obstacle points. (Sept. 7, 2018) 

If the coordinate systems are not set on the Summit side, starting Airfield3D in ArcMap will give a 
message. Close the message, close Airfield3D, and set the coordinate systems in Summit before 
continuing. 

Once the coordinate systems are set, any existing blank or incorrectly set ellipsoidal height fields in 
ArcGIS can be corrected using the ArcMap-side Airfield3D Recalculate tool. 

To make the settings, select the “Mandatory Coordinate Systems Setup” icon on the Summit-side 
Airfield3D toolbar*.  

 

*To see this new toolbar item, you may need to select Summit > Tools > Reset Toolbars to Default. 

 

 

 

The coordinate system of the models – This is the full coordinate system definition of the control used 
to create the exterior orientation values, as long as Summit > Orientation > Coordinate Conversion is not 
checked on. If it is checked on, this is the output system set in Summit > Orientation > Coordinate 
Conversion. In other words, it’s the system represented by Summit’s current ground coordinates. This 
may be filled in automatically if the input (with conversion checkbox off) or input and output systems (with 
conversion checkbox on) are set in Coordinate Conversion. 

The coordinate system of the ellipsoidal height – This is the same horizontal system and unit as the 
input, but with the vertical set to “Ellipsoidal height” and the correct transformation set. 

After you OK the dialog, save the Summit project (Summit > File > Save). These settings are saved in the 
.smtxml, so they only need to be set once per project. 
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Hint: Like any other DAT/EM-presented Blue Marble coordinate system settings, any time you receive this 
message, you must answer “Yes” and choose a 3D points style from the resulting list. If you answer “No”, 
Airfield3D will not be able to calculate the ellipsoid height offset correctly on the default 2D point style. 

 

f. There is a new way to apply a Z offset to the Lock to Obstruction Surface tool on the Summit-side 
Airfield3D toolbar*. Select the 3rd icon on the toolbar. Key in an offset value. It lets you lock to a surface at 
a keyed-in elevation offset value. A reminder of the offset will appear in the “Above” display in the heads 
up text. The actual elevation of the surface appears right below it in the “OIS” display. (Remember if you 
want to pick the offset instead of keying it in, set the cursor to the offset amount and use the first icon, 
Follow Obstruction Surface.) (Sept. 7, 2018) 

*To see this new toolbar item, you may need to select Summit > Tools > Reset Toolbars to Default. 

 

New tool to lock to a surface with a keyed-in elevation offset value (far right) 
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g. Airfield 3D has improvements to define, import, export, and apply Part 77 end definitions separately to the 
two ends. (August 23, 2018) 

To set the Part 77 Custom specification, select  in the specification dropdown. 

The button displays the current runways and their Part 77 Custom Type (see below): 

 

Runway surface definitions can be managed using the  button, which launches the Part 
77 Custom dialog. 
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Part77 Custom dialog with new  buttons to apply custom end definitions 

Use the following options: 

 Create new Part 77 specifications by picking the  button. 

 Copy existing specifications using the  button  

 Delete existing specifications using the  button. 

 Double click any entry in the Name column to change its value. 

 Double click any entry in the Value column to modify its contents. New values must be positive. 

 Custom runway endpoint approaches appear in the Runway End list. They can be assigned to 

the Approach 1 values with  and to the Approach 2 values with . 
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 To define new runway end approach values, select the  button, which brings up the 
Airfield3D Part 77 Custom Runway Ends dialog shown below. 

 

Dialog to define or import/export custom Part 77 ends 

 

 The runway ends are managed using the  buttons, which is the same method used 
in the Part 77 Custom dialog. 

 Double click entries in the Values column to modify runway end approach definitions. 

 In both dialogs, the  buttons may be used to import or export the settings to 
share with other computers. Valid file formats are Registry files (.reg), or Comma Separated 
Variables (.csv). The CSV format for each may be found by exporting existing settings. The file 
that is generated will have a header identifying the order of the fields and their meanings. 
Registry files may be modified using Regedit or an ASCII file editor such as Notepad. CSV files 
may be modified using a spreadsheet tool or ASCII Editor. Importing new settings will merge with 
the current settings. If a name already exists, its values are overwritten. 
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h. There is a new tool in the Airfield3D dialog to automatically place the Airport Reference Point (ARP), 
Touchdown zone end points (TDZEs), Airport Elevation (AIRPORT_ELEVATION), and Runway Ends. 
The runway ends include a choice for non-vertically guided and SPHS 2 settings. These points are 
automatically calculated from existing runway centerline(s). (August 28, 2018 and later additions) 

This affects the superimposed display in Summit only. 

Note: It is the user’s responsibility to place the runway centerlines accurately before using this tool. 
DAT/EM takes no responsibility for points misplaced due to mistakes in the runway centerline(s).  

 

New tool to generate the ARP, runways ends, etc. based on an existing runway centerline 
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i. There is a new option to select individual surfaces for display purposes. This is located in the Summit > 
Airfield3D toolbar > Airfield Select List > Airfields dialog. When a runway is selected from the upper list, 
the list below will reflect the surfaces available for that runway. Check on the ones you would like to view 
in superimposition. 

 

New option to check on individual surfaces for viewing in superimposition 

j. Automatically edit Obstacles is a new option. If it is turned on when you launch Airfield3D and/or click 
on the Airfield3D button while Airfield3D is displayed, it will begin an edit session on the Obstacle layer 
automatically. 

 Automatically edit Obstacles is on by default, and version 7.5 and earlier behaved as if this 
were always on.  

 When on, Start Editing is done automatically, and typically the first layer named “Obstacle” that is 
encountered is selected automatically for the active workspace. 

 You would want Automatically edit Obstacles unchecked (off) when you have multiple layers 
called “Obstacle” in multiple potential workspaces. You might have those conditions when you 
have multiple years of obstacle studies added to the same ArcMap TOC. In that case, use Start 
Editing before starting Airfield3D. Pick the workspace that contains the Obstacle layer you want to 
edit at this time. Then when Airfield3D starts, it will not override your workspace selection, but 
instead, it will digitize and edit the Obstacle layer in the workspace you selected manually. 

 If you need to change this setting, open Airfield3D, change the checkbox, close Airfield3D, and 
reopen it to activate it with the desired setting. Typically you’ll keep the setting the same 
throughout the rest of the project. 
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New Airfield3D Automatically edit Obstacles setting 

k. Airfield3D can now insert the quadrant lines when exporting the surfaces onto ArcMap layers. There are 
two sets of lines that are super imposed over the two ObstructionIDSurfaces. They were both left for this 
screen capture. Quadrant lines only insert for 18B VG runways. There are two reasons they are written to 
an external shapefile: 1) The FAA 18B does not specify quadrant lines as a deliverable, therefore they do 
not provide a template layer for them, and 2) They are lines, and lines can’t be written to the 
ObstructionIDSurface polygon-geometry layer. (October 1, 2018) 
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l. The Summit-side Airfield3D options Colors tab now offers Colors Per Surface for individual surface 
color settings. The setting is turned on by default, but may be turned off to set it back to just one color as 
in previous versions. The default VG (Vertically Guided) colors are selected to match a diagram provided 
by the FAA (see images below). You may set them to any colors. (February 5, 2019) 

  

New Summit-side Airfield3D Options Colors settings 

 

Results of individual colors applied to the superimposed surface outlines 



DAT/EM Systems International RELEASE 7.6 Release Notes 
 

 47 

 

The default Vertically Guided colors are based on this illustration from the FAA 

m. There were naming problems on runways that had the highest number first. Symptoms were varied, 
including reporting issues and that Summit would only show half of the name of the runway, for example, 
“30” instead of “12/30”. This is fixed.  (August 2, 2018) 

n. Airfield3D will now find data such as runway centerlines in layers that are arranged in any level of nested 
groups of layer groups within the TOC. Previously, it would only look one layer group level deep, and 
wouldn’t find layers in groups of layer groups. (September 26, 2018) 

o. When defining multiple custom Part 77 ends in the same dialog session, all of the new end names would 
be saved, but only the last-made end’s field settings would be retained. This is fixed so that all new 
settings are saved. (October 31, 2018) 

p. The Surface Insert tool will no longer write the OEI (One Engine Inoperable) lines to the 
ObstructionIDSurface layer. It will only write the main polygonal areas of the OEIs. Previously, it 
attempted to write the lines as well, which corrupted the ObstructionIDSurface layer by trying to write lines 
to this polygon-geometry layer. Note: Anyone who attempted to write the OEIs with lines using an older 
version or beta should fix the ObstructionIDSurface layer using ArcToolbox > Data Management Tools > 
Features > Repair Geometry. (Late 2018) 
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q. The Airfield3D overlay in ESRI.dkf is modified. There are keys to preset the fields and drawing tools for all 
the obstacle and obstruction area polygon types. (January 2, 23, and 30, 2019) 

 

r. In past versions and betas, if you tried to set field values from the DAT/EM Keypad before an object on 
the layer was drawn and/or selected in the current edit session, the attempted field values would apply as 
-1 until you exited and reopened ArcMap. This problem applied to Airfield3D and any other object for 
which you tried to preset the field values from the DAT/EM Keypad. DAT/EM engineers found a way 
around this ArcMap issue. This enabled us to put the Obstacle and ObstructionArea type keys on the 
keypad and be confident they will work for the first-drawn object in the edit session. (January 2019) 

s. The Measure Status (stoplight) tool has the following changes: 

 Measure Status has some corrections concerning left and right labeling. (Jan. 8 and Feb. 26, 2019) 

 “VGRPS Low end 200 feet” appeared as a single surface in Measure Status. This has been split 
into two subsurface areas: “Low numbered end of runway to 200 feet, left” and “Low numbered 
end of runway to 200 feet, right”. (This change is also reflected in the reports tool and the SI 
head’s-up text. Reports were further fixed for these new split surfaces on February 26, 2019, 
including substitution of a ; for a , so that the comma-delimited file would not get off by a cell in 
Excel.) 
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 “VGRPS High end 200 feet” appeared as a single surface in Measure Status. This has been split 
into two subsurface areas: “High numbered end of runway to 200 feet, left” and “High numbered 
end of runway to 200 feet, right”. (This change is also reflected in the reports tool and the SI 
head’s-up text. Reports were further fixed for these new split surfaces on February 26, 2019, 
including substitution of a ; for a , so that the comma-delimited file would not get off by a cell in 
Excel.) 

 (In beta versions only) For the above two area splits, when double clicked to move to the center 
of the area, Summit would move to the opposite side. That is, if you double clicked on the 
subarea “Left” side, it would move to the “Right” side instead. (Adding an obstacle there would 
correctly update in the “Right” side list in Measure Status.) This is fixed. (February 27, 2019) 

 Measure Status now shows the Object ID, Z value, obstacle type, and Pen [penetration] value 
field settings in the lower list of vertices. The lists may be sorted by clicking on the new column 
headings above the list. Note: If the obstacle type is not set, it will show “Unknown”. For any 
“Unknown” points, double click the coordinate line to move to the point, select the point, select 
the correct obstacle type key from the keypad, make any other necessary field settings, and use 
Apply to apply the proper fields (measure the ground height after Apply, if asked). (January 22 and 
February8, 2019) 

 

New Point Z, object ID, obstacle Type, and Pen Value fields added to sortable columns 

 The labels of the areas in Measure Status and the SI head’s-up text have been changed to better 
match each other and the areas they describe. 

 Measure Status will now retain the highlight in the upper list after you click or double click on a 
point in the lower list. (January 9, 2019) 

 Measure Status will now automatically update its points list, object count list, and color of the area 
dot after an obstacle point is deleted. (These previously updated only when an obstacle was 
added.) (January 9, 2019) 
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 Measure Status has added the five most penetrating list to the VGAS according to the FAA 18b 
section 2.7.1.2.3. (February 8, 2019) 

 “VGAS High/Low Numbered End Entire VGAS” lists would remain at 0 points, even if there were 
points in all the sub sections of the VGAS. This affected reporting, too. This is fixed. (Jan. 26, 2019)  

 The VGAS report didn’t match the VGAS areas shown in Measure Status. The Runway End 
wasn’t being handled correctly in the report and, on the Measure Status dialog, obstacles in the 
VGAS were defaulted to Natural if their type was “unknown”. These problems are fixed..(January 26, 
2019) 

t. The superimposition (SI) Head’s-Up text labels on the Summit side have been changed to better match 
the Measure Status tool labels and the areas they both describe. 

u. A warning appears about the Group Code when an obstacle is inside multiple ObstructionArea polygons. 
The text in this warning has been corrected and a hint about using the Recalculate tool has been added. 
(January 23, 2019) 

v. Airfield3D reports have some surface name fixes. See the Measure Status items above for more report 
changes that were tied in with Measure Status changes. (February 26, 2019) 

w. The VGATS reports now have “S” added to the file names. They are now <runway name> - VGATS.csv. 
(February 26, 2019) 

x. In the Airfield3D dialog, the “Apply” button might update a field that was turned on for ArcMap labeling. 
The label would update in the ArcMap data view, but the newest label would not update in 
superimposition (SI). Now the newest label will update in SI after every “Apply”. (March 12, 2019) 

y. There was an extra “Start Editing” procedure when the Airfield3D dialog initialized. This has been 
removed. (April 3, 2019) 

z. Next is a new keyword to move Summit’s cursor automatically to the center of the next obstruction area 
grid cell. This may be used from the DAT/EM Keypad or from a Button Manager button. Next will do 
nothing if an ObstructionArea polygon is not selected. (February 2019) 

DAT/EM Capture for ArcGIS – ArcGIS Pro (Beta) 
This beta version is compatible with ArcGIS Pro versions: 

 ArcGIS Pro version 2.3, 2.3.1, and 3.x up to 3.3.2. Please ask DAT/EM about any higher version numbers as they are 
released. 

 If you have Capture for ArcGIS and want to try Capture for ArcGIS Pro, please ask DAT/EM Support to enable the API 
on your hardware lock. If DAT/EM Setup finds both ArcMap and ArcGIS Pro with API licensed on the computer, it will 
install Capture for both. 

DAT/EM Capture for ArcGIS Pro has the following changes: 

1. Capture for ArcGIS is compatible with ArcGIS Pro v.2.3, 2.3.1, and 3.x up to 3.3.2. It is not backwards compatible 
to earlier ArcGIS versions. For versions higher than this, check with DAT/EM Support before installing. (March 4, 
2019) 

2. Version 7.5 did not pass the ArcGIS line width to Summit’s superimposition when the ArcMap-side DAT/EM 
Options > SI page > Show line patterns was on. This is fixed in 7.6. (May 31, 2018) 
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DAT/EM Capture and MapEditor for AutoCAD 
Changes apply to: 

32-bit AutoCAD 2004-2008 versions with the latest service packs, as long as you can get them to install on your 64-bit 
operating system (OS). DAT/EM no longer tests on 32-bit OS, so these must be running on 64-bit OS. DAT/EM is not responsible 
for helping to install a 32-bit version of AutoCAD on a 64-bit OS and cannot guarantee that this will succeed. 

64-bit AutoCAD 2009-2020 versions with the latest service packs. Exception: 64-bit AutoCAD 2008 is not supported. 

When referring to a year/version number in the lists above, it includes "plain" AutoCAD, Civil3D, and Map3D. It does not 
include AutoCAD LT, which is a 2D product, and therefore will never work with a 3D cursor. 

Reminders: 

 Install all available AutoCAD service packs and updates before installing DAT/EM software. 

 Before installing DAT/EM software, run each version of AutoCAD and make sure its license is active. Do this for each 
version whether or not you intend to use every version with DAT/EM Capture. 

DAT/EM software will install for multiple AutoCAD products of different year numbers on the same computer; however, it will only 
install for one of any multiple same-year versions. For example: 

 It will install for AutoCAD 2015, 2016, 2017 Civil3D, and Map3D 2018 , because they are all different year versions. 

 It will not install for both AutoCAD 2017 and AutoCAD Civil3D 2017 at the same time, because they are both the same 
year. In the case of multiple same-year versions, only one of them will receive the DAT/EM files at installation. To activate 
DAT/EM Capture in all of them, the AutoCAD \datem folder and the DAT/EM wintab driver file may be copied from the one 
that received the files to the other same-year versions. Contact DAT/EM Support for instructions. 

Autodesk Infrastructure Design Suite installs three same-year AutoCAD versions (AutoCAD, Map3D, and Civil3D). Using the rules 
outlined above, you must run each version and register/”accept” each one before installing DAT/EM software whether or not you 
intend to run every version with DAT/EM Capture. DAT/EM software will install completely for only one of them, and we don’t know 
which one until after installation. The files may be copied manually to the others. Contact DAT/EM Support for instructions. 

DAT/EM Capture and MapEditor for AutoCAD have the following changes: 
 

DAT/EM Capture for AutoCAD 

1. Version 7.6 is the first version to support AutoCAD 2019 (June 12, 2018) and AutoCAD 2020 (April 9, 2019). 

2. Superimposition (SI) for AutoCAD MTEXT (multi-line text) is fixed for AutoCAD versions higher than AutoCAD 
2004. Previously, SI could crash upon encountering an instance of MTEXT. Most MTEXT will draw in SI now, but 
some of the more complicated instances will not draw. (May 4, 2018)  

3. The Standalone DAT/EM Keypad for AutoCAD now supports AutoCAD 2015—2020 year versions. (July 26, 2018) 
 

MapEditor for AutoCAD 

1. The block and layer name displays have been widened to show more characters in long names. (November 6, 2018) 

2. After running MapEditor, sometimes a subsequent AutoCAD AUDIT command would make AutoCAD crash. 
MapEditor had not completely closed or finished processing events and then it failed while AUDIT was running at 
the same time. This is fixed. (March 2019) 

3. The AutoCAD tool MapEditor calls to copy objects can (and does!) fail on some polylines. MapEditor now makes 
a second call to copy another way if the first method failed. (March 2019) 
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DAT/EM Capture and MapEditor for MicroStation (32-bit versions) 
Changes apply to Capture for MicroStation. DAT/EM software installs for the following MicroStation versions on 64-bit 
operating systems:  

 MicroStation V8 and V8 2004 Edition: Version should be 08.05.00.34 or higher. 

 MicroStation XM: Version should be 08.09.04.88 or higher. 

 MicroStation V8i, V8i-based Bentley Map and Map Enterprise SelectSeries 1 (1 not recommended), 2, 3, and 4; 
MicroStation PowerView and Bentley Map PowerView SelectSeries 3 and 4; Power GeoPak* SelectSeries 3 and 4 

 PowerCivil SelectSeries 3 or 4 

If you upgrade from Select Series 1 to 2, 3, or 4, you must reinstall DAT/EM software after installing the Series upgrade.  

DAT/EM will install for all versions of MicroStation that are present on the computer at the time of the DAT/EM installation. 
 
*Note about Power GeoPak Select Series 3: DAT/EM Software installs for Power GeoPak SS3, but has initial loading 
conflicts that affect the GeoPak and DAT/EM menus. Bentley has offered a workaround for this issue. If you have the Bentley 
Power GeoPak SS3 product, please contact DAT/EM for further installation instructions. 
*Note about Power GeoPak Select Series 4 (which runs with MicroStation Select Series 3): This product seems to be 
more successful running together with DAT/EM applications. There still could be issues. Please contact DAT/EM Support if 
having problems installing for or using this version. 
 

DAT/EM Capture and MapEditor for MicroStation have the following changes: 

 
General Subjects in Capture and MapEditor for MicroStation 

1. Two mdl utilities were fixed to adjust for non-zero global origins in the DGN file properties. The problems affected 
elevation translations, especially, but not limited to, reference files that had a different Global Origin that the main 
file. This could cause superimposition of the reference file to be missing from Summit’s main view, among various 
other symptoms. Many commands were affected, but most would not have been noticeable to the user, so they 
will not be listed. If the fixes affected a command more noticeably, it will be mentioned with the command in the 
“Changes to Existing Commands” section below. (April 24, 2018) 

2. The MapEditor Selection Sets Editor has a new combined object type group made up of both type 3 and 4 simple 
line strings. Zero-length strings are excluded so that points are not selected. (May 8, 2018) 

  
MapEditor’s new Simple Linestrings (type “SLS”) object type group 

 

3. PLACE FENCE (MicroStation) command has the following superimposition-related changes: 

a. PLACE FENCE SHAPE was missing its superimposition (SI) rubber band. This is fixed. (August 16, 2018) 

b. PLACE FENCE SHAPE and PLACE FENCE BLOCK have added dynamic graphics in Summit’s SI, so 
you can see the potential fence in SI as you’re drawing. Please note that depending on the MicroStation 
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version, the dynamic graphics will only appear in SI if the fence command is activated from a keyin or a 
keyin-like method, such as from the DAT/EM Keypad, Summit Custom CAD toolbar, or Button Manager 
button. If you start the fence command from a MicroStation toolbar (particularly in V8i versions), there is 
no way for DAT/EM to detect that a fence has been started, so it won’t know to perform the dynamic 
graphics; in this case, the fence will only appear in SI when its placement is finished. (January 31, 2019) 

4. The Datem Editing Tools toolbar has new icons to activate RCENTERLINE, NEARESTZ, BREAKLINEFILTER, 
BREAKLINEFILTER PICK, BREAKLINEFILTER LAST, and BREAKLINEFILTER CHOOSELAST. These 
commands existed previously as keyins only. (April 4, 2019) 

 

New command icons on the Datem Editing Tools toolbar 

Note that the ustn.m33 (toolboxes) file does not always get installed properly in the folder (this could be a 
Windows permissions issue): 

"C:\ProgramData\Bentley\<MicroStation installation folder>\WorkSpace\Interfaces\MicroStation\default\ustn.m33" 

If you do not see the new icons after installing v.7.6, please contact DAT/EM Support or download the file: 

http://datemsystems.com/downloads/Help/FixMissingDATEMToolboxesForMicroStation.zip  

 
New Commands in Capture and MapEditor for MicroStation 

1. MECHANGETAG and MEADDTAGS are new tools for adding and editing groups of MicroStation tags based on 
attributes and geographical locations of (attached) elements. Tags can also be edited based on tag 
characteristics. The instructions for these new commands are in a separate document called 
“7.6RelNotesSupplement-MECHANGETAG&MEADDTAGS.pdf”. (May 24, 2018) 

2. ROAD SAVEPICKXYOFFSET is a new ROAD family command. It behaves exactly like ROAD PICKXYOFFSET, 
except that after selecting the offset, it prompts for an .rcfg "road configuration" file name to save the newly 
digitized configuration. Either enter the file name to save the configuration or [Cancel] if you do not wish to save it. 
Note that the ROAD SETTINGS and 3DOFFSET dialogs can load the file later, as well as the keyins: ROAD 
LOADFILE <file name> and 3DOFFSET ROADFILE <file name>. (October 18, 2018) 

3. SLOPEHATCH and SLOPEHATCHLAST are new commands to draw slope patterning according to a specific 
customer’s requirements. SLOPEHATCH is available as an interactive command and as a batch version in 
MapEditor. (October 1, 2018) 
 
The keyins are: 

 
 SLOPEHATCH – raises the settings dialog to allow the user to set parameters and, optionally, hatch 

groups of elements at once. 
 

 SLOPEHATCHLAST – uses most recent settings and hatches between interactively picked element 
pairs. 

 
 



DAT/EM Systems International RELEASE 7.6 Release Notes 
 

 54 

 
Settings for the new SLOPEHATCH command 

The settings are as follows: 

 The following settings define the element pairs that will be scanned (for potentially adding slope ticks) 
when running SLOPEHATCH. These settings are ignored when running SLOPEHATCHLAST. 

 



DAT/EM Systems International RELEASE 7.6 Release Notes 
 

 55 

 The following criteria are used to determine whether or not to create hatch ticks between elements when 
running SLOPEHATCH. These settings are ignored when running SLOPEHATCHLAST. 

o Max distance between edges – edges further apart than this will not be considered. 

o Minimum Slope to Hatch – minimum slope (as a percent) between edges. Hatch ticks will only 
be added between elements that meet or exceed this slope threshold. 

o Measure buttons are used to set a (respective) value with a two click measurement. 

 

 The following criteria describe what the hatch lines will look like when running SLOPEHATCH and 
SLOPEHATCHLAST. 

 

o Distance between slope ticks - Distance (XY) between ticks (element with highest average 
elevation) 
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o Number of short ticks per long tick 

 

 

o Short line length as a % of max – short line lengths are constant (XY) and based on a 
percentage of the longest (Max Tick) length. If the maximum tick length is 4.0 (in XY), a short line 
length setting of .25 will result in all short ticks having an XY length of 1.0. Because these lines 
are 3D, the actual length will vary (unless there is a zero slope between element intersections). 

o Max tick length – maximum XY length of long tick lines. Long ticks are not constant and may be 
truncated to the XY intersection between elements. However, if elements are further apart than 
this value, the XY length of long ticks will be constrained by this setting. 

o Custom Symbology. If this value is not checked, short and long ticks will be set to the current 
active symbology. If Custom Symbology is checked, long ticks will have the symbology set in 
Major Ticks and short ticks will be set according to Minor Ticks settings. 

 When running SLOPEHATCH, users have the following options for logging/visiting hatched areas: 

o No Logging: The command runs and performs the specified hatching, but no log is made. 

o Log hatched edges: Hatch pairs are logged to a Visit file. 

o Log potential edge pairs to hatch: No hatching is done. It logs potential hatch pairs to a Visit 
file. The user may visit the locations to verify or to perform single area hatching later. 
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4. Still in development past the v.7.6 release date. Please let DAT/EM know if you would like this command to work 
differently. THREESHOT is a new family of commands to place cells at different x and y scale values. 
THREESHOT commands are an extension of the existing TWOSHOT commands. It is used for active cell 
placement with interactive rotation (optional) and scaling. Unlike TWOSHOT, height and width (scaling) are 
independent of one another. (July 6, 2018) 
 
Keyins: 

THREESHOT  
THREESHOT SCALE     
THREESHOT SCALE RELATIVE  
THREESHOT SCALE ABSOLUTE  
THREESHOT RELATIVE  
THREESHOT ABSOLUTE  
THREESHOT SIBBOX ON  
THREESHOT SIBBOX OFF 

Notes: 
THREESHOT does not support text placement. 
THREESHOT does not support fixed scaling (ANGLE). If this is needed, use TWOSHOT ANGLE. 

Steps: 
 Set an active cell for placement. Parameters such as True Scale will affect how THREESHOT places 

the text. 
 Start one of the THREESHOT commands.  
 The first pick will set the origin for the cell being placed. 
 The second pick will set width of the cell being placed and, optionally (if THREESHOT SCALE 

<RELATIVE|ABSOLUTE> is not being run), set the angle of the cell being placed. At this interim 
point, cell height will be scaled (one-to-one) with width. 

 The third pick will set the height of the new cell and complete cell placement. 
 

 
Changes to Existing Commands in Capture and MapEditor for MicroStation 

1. AUTOARC has the following changes: 

a. AUTOARC has increased error handling. In the case of an error, a message or dialog will appear. If you 
receive one of these messages or dialogs, please inform DAT/EM what the message said, what steps 
you had just done, your MicroStation version, and your operating system. (October 31,2018) 

b. AUTOARC could crash if NEARESTZ was run before it. See NEARESTZ below. (November 7 ,2018) 

2. BREAK, BREAK ELEMENT, and JOINIT were not always refreshing their modified elements in the MicroStation 
view at the end of processing. This is fixed so that it refreshes automatically instead of waiting for the user to force 
a refresh. (April 16, 2018) 

3. CHANGE ATTRIBUTES INTERIOR and DAT/EM FIX COMPLEX have a workaround to help with the specific 
case of a complex shape with one line string component. Bentley’s MicroStation Fix Complex function in all 
MicroStation versions (V8, XM, V8i) fails to simplify this complex shape type, so any DAT/EM command that 
called Bentley’s Fix Complex function could not simplify the element. (August 13, 2018) 

 This affected MapEditor’s FIX COMPLEX tool by leaving the element unchanged. With the new 
workaround, FIX COMPLEX drops the element to a simple shape. 

 This affected CHANGE ATTRIBUTES INTERIOR by making it process very slowly. The command fell 
back on a slower method to determine whether objects were inside or outside the oddly complex shape. 
With the new workaround, CHANGE ATTRIBUTES INTERIOR internally drops the element to a simple 
shape and runs much faster. (August 13, 2018) 
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4. CROSSCHECK has the following enhancements to reduce the number of intersections being logged. (December 7, 
2018) 

a. Separate logging was implemented for "Visit" and "Edit and Visit" modes. Additional filters are possible 
with the "Edit and Visit" mode, reducing the number of logged entries. 

b. Snapped endpoint intersections are no longer logged. 

c. Ignore XYZ (snapped) intersections is a new option. When checked on, it ignores intersections that are 
already exactly at the same 3D location, whether intersecting at a vertex or at a segment crossing. This is 
applied to any of the CROSSCHECK modes or operations. By default, this is disabled and 
CROSSCHECK operates as it did previously. (February 7, 2019) 

 

New Ignore XYZ (snapped) intersections option 

 

5. DATDRAW has the following changes: (August 21, 2018) 

a. The DATDRAW command dialogs now offer a third tiebreaker algorithm for tracing closed elements: Pick 
side to trace in addition to Use longest section and Use shortest section. This has been added, 
because sometimes it is not easy to guess which is the shortest or longest section of a shape element. 

   

New “Pick side to trace” options in DATDRAW commands 
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When either the Trace or Trace2D button is selected, the DATDRAW operation in progress will be 
suspended while the user is prompted to select two points on an existing element to trace. 

 If the traced element is not closed, the select tiebreaker algorithm will have no effect, and vertices 
between the selected points will be appended to the element being digitized. 

 If the traced element is closed (either a shape or a string with snapped end points), the user will 
be prompted to select a third point on the element being traced. This third pick identifies which 
section (between the previously selected points) will be appended to the element being digitized. 
This third point can be anywhere on the traced section, even very close to the second (end-of-
trace) point. 

 

 

Examples of pick locations for DATDRAW’s “Pick side to trace” option. 
The third pick location can be anywhere on the traced side, even very close to the second pick. 

. 
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b. The DATDRAW TRACE <option> and DATDRAW TRACE2D <option> keyins now accept another 
option to match the new option discussed in a. above. This applies when the traced element is closed: 

 0 = choose longest subset 

 1 = choose longest subset 

 2 = another pick to choose trace segments 

6. DATEM SETTINGS was resetting some of MicroStation’s active settings, such as the active angle and active 
scale, to 1 when closing the dialog. Now it checks whether these parameters are set. If not set, it sets them to the 
same values DAT/EM has been setting. If they are already set, it leaves them unchanged. (July 20, 2018) 

7. DENSIFY (MEDENSIFY) had a problem with duplicating vertices instead of placing the new vertices at the proper 
location along the original long segments of 3D strings. It was updated to specify that density is treated as a (3D) 
max distance between vertices, specify a very small distance tolerance (to accommodate numerical truncation), 
and to simplify any resulting complex elements (if possible). Simplification includes removing duplicate vertices 
and reducing complex strings of fewer than 5000 vertices to have fewer strings or to be simple elements, if 
possible.(July 16, 2018) 

8. ELEVATE has the following changes: 

a. ELEVATE and several other commands have a fix so they will work better in DGN files that have a Global 
Origin that is greatly offset from (0,0,0). (April 16, 2018) 

b. ELEVATE has a new Densify option. Users extracting elevations from linear elements may now specify a 
density factor for sampling along the (linear) elements. When Densify is on, long input segments will 
influence the output elevations as if they had a vertex every Delta units along the existing segments. This 
is particularly useful in smoothing elements based on nearby (sparsely populated) linear elements. 
Densify will be off by default. (May 3, 2018) 

To use the new option:  

 Check the Densify checkbox to add virtual interpolated coordinates along linear elements to the 
DTM Sources coordinates. If this is not checked, only actual vertices will be used as DTM 
sources. 
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 Specify Delta in ground units. This is the sampling resolution for linear elements used as DTM 
sources. 

 

ELEVATE’s new Densify and Delta settings 

Note: The new Densify setting eliminates the need to run MapEditor’s MEDENSIFY tool on the input 
elements before using them in the ELEVATE command. 

c. ELEVATE has a fix for properly elevating lines and points. (August 14, 2018) 

d. ELEVATE could have areas where it applied slightly incorrect elevations. The elevations would be 
somewhat higher or lower than the surface made by the input points at that location, then a short distance 
away, it would recover and begin placing the correct elevations again. This is fixed. (May 15, 2018) 

9. ELINE could crash if NEARESTZ was run before it. ELINE SETTINGS could also be affected. See NEARESTZ 
below. (November 7 ,2018) 

10. FACESHIFT POLYSET <setname> <tolerance> is a new keyin to run FACESHIFT POLYGON on all selected 
polygons from the <setname> selection set. For each polygon in the selection set, it shifts all the points found 
inside it to the surface generated from the polygon’s vertices. (July 25, 2018) 

<Setname> may contain shapes and/or ellipses to define the polygons. 

The <tolerance> field is optional. It works like the tolerance in the other FACESHIFT commands, that is: 

 If <tolerance> is used, compare the Z of the DTM point and the Z of the polygon face; shift the point only 
if the Z difference is greater than the tolerance. Example key-in: faceshift polyset MyPolygonSet 0.5  

 If <tolerance> is not used, it assumes that <tolerance>=0, and is the same as entering the key-in 
faceshift polyset <setname> 0. All points that fall within the XY boundaries of the polygon are shifted in 
Z. Example keyin: faceshift polyset MyPolygonSet 

This first implementation of the command is a keyin only; it does not display a dialog. A dialog may be added in 
the future. 

Note: To make a named selection set, use SELECTIONSET to launch the Selection Sets Editor. 
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11. Find Duplicates (MEFINDDUPLICATES) and Find Partial (MEFINDPARTIAL): Now when the user clicks on the 
file position in the results dialog, the selected duplicate element will flash briefly. This will help the user identify the 
specific element when there are various other objects inside the duplicates’ extents area. (January 4, 2019) 

12. JOINIT has the following changes: 

a. JOINIT, BREAK, and BREAK ELEMENT were not always refreshing their modified elements in the 
MicroStation view at the end of processing. This is fixed so that it refreshes automatically instead of 
waiting for the user to force a refresh. (April 16, 2018) 

b. JOINIT recently added a flash and refresh element to give feedback when elements have been joined. 
This turned out to be too slow when run on large files. Now it will only flash and refresh if “Elements to 
Modify” is set to “Elements”. (August 27, 2018) 

c. JOINIT’s directionality check that was added in v.7.5 is now optional. When off, processing will be faster. 
When on, it will preserve directionality when joining lines of the same direction, that is, when joining a 
start point to an end point. (May 29, 2018) 

 

13. LABELIT and ZLABEL have a potential custom font timing fix. This is difficult for DAT/EM to test, since we can’t 
reproduce it, so we can’t guarantee that it solved the problem. (September 17, 2018) 
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14. LD CP (Load Control active or file) has the following changes: 

a. LD CP DLG has new Load Settings and Save Settings buttons. The Save Settings button allows you to 
save the current dialog settings to a .reg file, which can be loaded later from the Load Settings button. 
The .reg file may be shared with another same-version DAT/EM workstation. (June 5, 2018) 

 

b. LD CP has some fixes to correct the most recently used settings that are saved in the registry. They 
previous settings will appear more consistently the next time you start the dialog. (June 6, 2018) 

 

15. MEXPORT was changed to prevent it from unexpectedly saving unwanted changes to the .exp when the dialog 
was closed for the first time. (November 28, 2018) 

16. NEARESTZ has the following changes: 

a. NEARESTZ will no longer crash if you enter a <Reset> when it is expecting you to pick the second 
element. (May 4, 2018) 

b. NEARESTZ was interfering with common software used by commands such as AUTOARC and ELINE. A 
crash could occur if NEARESTZ was run immediately before AUTOARC; after an AUTOARC element 
was placed the software would, incorrectly, attempt to resume ELINE editing (instead of AUTOARC 
editing). The bug could also have interfered with ELINE settings. This is fixed. (November 7 ,2018) 

17. PSQR has two new keyins, TPICK and TPICK2D. These are a variation of the trace commands that were added 
to PSQR and DATDRAW in v.7.5. They are being evaluated as a replacement of the v.7.5 method, which 
required the user to guess the longer side of the closed object, and users found it difficult to guess correctly every 
time. To use: 

 While digitizing in PSQR, key in one of the new keyins: TPICK to trace the element at the element’s 
elevations, or TPICK2D to trace the element at the elevation of the cursor at the first pick point. 

 It will prompt for a start point on the element to trace. 

 It will prompt for an end point of the trace. 

 If the traced element is not closed, this will work the same as the other trace keyins. However, if tracing a 
closed element (such as a shape), it will prompt to pick the section of the element to be included in the 
trace. If you hover over the section of the element for the third pick, the underlying section (candidate for 
tracing) is highlighted (but you need to be fairly close to the element for this to happen). 
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18. Replace Cell (MEREPLACECELL) has the following changes: 

a. Replace Cell (MEREPLACECELL) in an existing parameter file that listed a broken path to the .cel cell 
library file would result in making the cell disappear. Now if the cell library is not found, it will report the 
problem in the log file (providing the log file option is on) and leave the original cell unchanged. (June 29, 
2018) 

b. The “Fixed Scale (1.0 1.0 1.0)” setting in Replace Cell (MEREPLACECELL) has been redefined to allow 
for any fixed scale to be entered. The scale settings have been combined onto a menu and the existing x: 
y: z: fields are now used for any selected setting. (Oct. 16, 2018) 

  

New scale menu and Fixed scale (X Y Z) settings in MEREPLACECELL 

 

19. ROAD’S UNDO processing now separates the drawing/digitizing step from the step that creates the offset 
elements. This will help you fix offset problems without having to redigitize the road line. Previously, UNDO after 
ROAD would remove everything placed during ROAD digitizing, including the offsets and the digitized 3D and 2D 
lines. Now: (February 21, 2019) 

 The first UNDO will remove all offsets that were recently placed.  

 The second UNDO will remove the most recently digitized 3D (Plan) and 2D (Discontinuity) linear 
elements.  

If you want to remove the entire ROAD operation, submit two UNDOs. 

If you want to remove the offsets, but leave the digitized line(s), submit one UNDO. With the digitized line still 
present, you have the opportunity to use 3DOFFSET to place the offsets on the other side or to place a different 
offset configuration. Depending on the correction you need to make, use the same .rcfg in 3DOFFSET that was 
used in ROAD and pick the other side, or use a different/corrected .rcfg, or use the manual offset selection 
method to place a custom offset. (Note: To make a .rcfg file if it doesn’t already exist, use the “Save” button in the 
ROAD SETTINGS dialog. This may be used in both ROAD and 3DOFFSET.) 
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20. ROADCLIP has the following changes: 

a. ROADCLIP would crash with Single segment checked (interactive method) if you selected four times on 
the same section to be clipped. Error handling was improved. (November 1, 2018) 

 

b. ROADCLIP could treat a nearby (not intersecting) element as if it intersected the road. This problem was 
isolated to an error in the Bentley MicroStation mdlIntersect_allBetweenElms function. The function was 
replaced in order to fix this. (November 1, 2018) 

 

 

c. ROADCLIP previously only considered the first intersection of a string (we’ll call it a driveway) with the 
road. If it was a single driveway line that both started and ended on the road, it would miss the ending 
intersection. Now it will process multiple intersections of the same element with the road. (November 21, 
2018) 

d. ROADCLIP could delete the selected input road line before checking whether the proposed clipped 
section was valid or whether the clipped section could be generated into an element successfully. Error 
handling was improved. It will now leave the selected road line unchanged in case of errors. (November 21, 
2018) 
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21. SLOPECHECK has a change to avoid a bug found in later versions of MicroStation (V8i). This bug causes 
MicroStation V8i to lock up if a modal dialog is called from a model dialog. That was happening with 
SLOPECHECK’s “Sets” button, which would call the Selection Sets Editor dialog. (February 25, 2019) 

22. The SPOTX DECIMALS keyin didn’t work for numbers higher than 4, while the dialog entry did allow higher 
numbers. Now both will accept numbers from 0 to 99. (June 7, 2018) 

 

23. TENTATIVEDISPLAY has a fix and an enhancement. It is now refreshing correctly to show the intended value, 
which is the difference between the current cursor elevation and the tentative point elevation. It will now also show 
the active MicroStation snap lock, the current DAT/EM 2D or 3D snap mode, and the DAT/EM tentative drive 
setting. Note: These DAT/EM settings are made by DATEM SETTINGS > Tentative to XY only and Move 
stereoplotter to tentative or by the TENATIVE ON/OFF and TENTATIVE MOVE ON/OFF commands. (November 
27, 2018) 

 

TENTATIVEDISPLAY is fixed 

24. TOUCH and TOUCH BATCH commands have the following fixes: (October 25, 2018) 

a. TOUCH BATCH processing of (From) complex elements previously resulted in disjoint sub elements 
instead of an edited complex element The result of editing (with Match Z on) a complex string is now an 
edited complex string. 

b. If both start and end points of a complex string needed to be edited, only the start point would be edited, 
since the stored end point was now the end point of a sub element instead of the original complex 
element. This might also result in erroneous edits to sub element end points. End points of complex 
elements as a whole are now correctly processed. 

25. TWOSHOT SIBOX_ON was drawing the superimposed proposed cell bounding box at Z=0 for point cells. This is 
fixed so that it draws at cursor elevation. (Sept. 7, 2018) 

26. VISIT ELEMENT has the following changes:  

a. Dialog settings will be properly retained if they’re followed by “Hide Details” and “Restore Details” buttons. 

b. The Inside Fence option was fixed to work properly. (October 9, 2018) 

27. XYZIN has the following changes: 

a. XYZIN_FILE is a new method to run from a keyin: (Sept. 4, 2018) 

XYZIN_FILE <input file path and name> <optional settings file path and name> 
 

 <input file path and name> is an ASCII file with coordinates and other element attributes (ref 
XYZIN dialog). 
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 <optional settings file path and name> is an optional .ISET XYZIN configuration file. An .ISET 
file is produced by pressing the [Save] button in the XYZIN dialog once the desired settings have 
been configured. .ISET files from previous versions are not compatible due to many missing 
configuration settings; you must recreate them in the new version. If this parameter is not 
specified, the most recently applied XYZIN configuration settings will be used. 

XYZIN_FILE may be run from the MicroStation keyin browser or from a “Generic Keyin” command in a 
MapEditor parameter file. 

b. XYZIN has also been added to the list of commands to add to MapEditor parameter files. It appears as a 
pair of menu items in the Command menu: Import from File and Import Settings. 

 
 Import Settings allows the user to select or create an ISET (XYZIN LOAD/UNLOAD) file to 

define XYZIN/IMPORT active settings. 
 

 Import from File creates elements from an ASCII import file using either the most recent settings 
or settings specified in an ISET file. 

 

c. When importing multipoint elements, with individual levels specified in the import file, XYZIN might over-
write the imported element’s level with that of the next element in the file. This is fixed. (April 4, 2019) 

28. XYZOUT was reporting a bad last vertex for simple type 15 arcs and type 16 ellipses. This is fixed. (August 23, 2018) 

29. ZLABEL’s Export button was exporting the last-saved-to-the-registry settings. Now it will export the current 
settings shown in the dialog, whether or not they have been saved to the registry. It will also save/apply the dialog 
settings when the Save to file button is selected. (October 1, 2018, Oct. 9, 2018) 
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*NEW!* DAT/EM Capture for MicroStation CONNECT Edition (Beta) 
Changes apply to the beta of Capture for MicroStation CONNECT Edition (CONNECT). DAT/EM software installs for the 
following CONNECT versions on 64-bit operating systems:  

 MicroStation CONNECT Edition Version 1.x Updates 10-12. 

 Certain earlier CONNECT versions may work with DAT/EM software, but are not supported. 

 For higher versions and update numbers, contact DAT/EM Support for information. 

DAT/EM Capture and MapEditor for MicroStation CONNECT Edition have the following changes: 

1. DAT/EM v.7.6 is the first version to contain a limited beta of Capture for MicroStation CONNECT Edition 
(“CONNECT”). In the v.7.6 release, it provides Summit communication and limited Capture commands. No 
MapEditor commands are active as of the 7.6 release date. 

The following commands are active:  

BUTTON MANAGER 

DATPAN <ON/OFF/TOGGLE/SETTINGS> 

DATEM COORDS 

DATEM FIT 

DATEM SETTINGS 

MEASUREHEIGHT and MEASUREHEIGHT <SETTINGS/DECIMALS/TEXTHEIGHT/XOFFSET/ 
YOFFSET/CELLNAME/LEVELNAME/CELLSON/CELLSOFF> 

MV TENTATIVE 

SPOTX and SPOTX <SETTINGS/DECIMALS/TEXTHEIGHT/XOFFSET/YOFFSET/CELLNAME/ 
KAPPA/NOKAPPA/ACTIVETXT/NOACTIVETXT/TXTLEVEL/DEFAULTTXTLEVEL> 

SPOTMODIFY 

SI <UPDATE/SETTINGS> 

SUMMIT MODELS AREA 

The DAT/EM Keypad Controller communicates with MicroStation CONNECT and uses the same keypad overlay 
as the earlier versions of MicroStation; however, it only activates the above keyins as of the v.7.6 release. 

The Summit Button Manager settings will communicate with MicroStation CONNECT, but “User CAD” and 
“Generic CAD” buttons that call DAT/EM drawing and editing commands are also restricted to the above keyin 
list. Buttons such as “Pick” and “Cancel/Reset/Finish” work. 

We will add the remaining Capture and MapEditor commands gradually during the upcoming v.7.7 beta cycle. If 
you are interested in beta testing during the coming year, and you have not already spoken to us about it, please 
contact DAT/EM Support to be added to the CONNECT beta testers list. 
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DAT/EM Capture for Blue Marble Global Mapper 
Changes apply to Capture for Global Mapper. DAT/EM Capture for Global Mapper is supported for the following Global 
Mapper versions: 

 17.1.2 or higher 

 18.x 

 19.x 

 20.x (up to the date of this DAT/EM release). For Global Mapper 20 versions after the date of this document, please ask 
DAT/EM Support whether the version is compatible. 

Advice for enabling and disabling the DAT/EM Capture extension: 

DAT/EM Software installs the Global Mapper Extension, but leaves it unregistered in Global Mapper by default. 
To use the extension, close Global Mapper, select Windows Start > All Programs > Datem Software > Utilities > 
CAD Enabler, set Global Mapper=Capture, and select OK. Likewise, to disable, set CAD Enabler to Global 
Mapper=Disable. 

   

To register/enable or unregister/disable, use the DAT/EM CAD Enabler 
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Capture for Global Mapper has the following changes: 

1. CAPTURE SETTINGS is a new DAT/EM Keypad keyword that launches the DAT/EM Capture Settings 
dialog. It has been added to the example “GlobalMapper.dkf” file and may be used on Button Manager 
buttons. (May 31, 2018) 
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2. SI SETTINGS is a new DAT/EM Keypad keyword that launches the SI Settings dialog. It has been added to 
the example “GlobalMapper.dkf” file and may be used on Button Manager buttons. (May 31, 2018) 

 

 

-End- 
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