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The following changes have been made to DAT/EM products between Release 7.7 and Release 8.0. Please review these 
revisions made to the software and update your software to implement changes. As always, DAT/EM welcomes 
comments and suggestions from you, our clients, so please don’t hesitate to contact our support department at 
support@datem.com or call us with your requests. 
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Operating Systems and Microsoft Updates 
DAT/EM software no longer supports 32-bit operating systems. Any reference to an OS in the remainder of this document 
refers to the 64-bit version of that OS only. 

DAT/EM Release 8.0 is supported on the following operating systems: 

• 64-bit Windows 8.1 Professional and Enterprise is supported, but discouraged. Notes: 

o *NEW* DAT/EM plans to stop supporting Windows 8.1 before Microsoft stops extended support for it. 
DAT/EM plans to drop Windows 8.1 OS support in the next DAT/EM release after this one.  

o Be aware that it will be very slow for DAT/EM to troubleshoot any Windows 8.1 OS-related issues you 
might encounter. Our Support Department uses Windows 10 exclusively. 

o We strongly encourage any Windows 8.1 OS to be updated to Windows 10 as soon as possible. 

• 64-bit Windows 10 Professional and Enterprise. Notes: 

o 64-bit Windows 10 is DAT/EM’s preferred OS. 

o DAT/EM generally recommends installing all Windows updates; however, if you are using nVidia 
3DVision and a Microsoft semi-annual channel update greater than 21H1, please check with DAT/EM to 
ask whether 3DVision still works with the newer channel update. Let us test it before you do. 

o DAT/EM software does not work with Windows 10 LTSC (Long-Term Servicing Channel), also formerly 
known as LTSB (Long-Term Servicing Branch). 

 

Hardware Locks/Dongles 
Install Microsoft Updates before applying lock reset programs. Network licensing should have the same Sentinel driver 
version on both the server and the local computers running the software. 
 

1. Stacked Capture for Global Mapper is now a locked DAT/EM product. There is a new Stacked Capture and 
annual Support price for Capture for Global Mapper. With a Stacked Capture for Global Mapper order, DAT/EM 
will provide a WriteLock executable to apply to your hardware lock. Please contact your DAT/EM reseller if you 
would like to order Capture for Global Mapper (July 21, 2020) 
 

2. The Thales Sentinel driver version 7.7.0 is provided with DAT/EM version 8.0. This is the first DAT/EM release to 
use Sentinel 7.7.0. The first run of DAT/EM v.8.0 Setup or DAT/EM Prerequisites installation built 4 February 
2021 or later will install or update the Sentinel driver to 7.7.0. Answer Upgrade to the Confirm Upgrade dialog, 
accept the license agreement, and answer “Yes” to Sentinel’s firewall question and “OK” to reboot when asked. 
  

 
It is very important to answer “Yes” to this question and reboot when done 
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Sentinel Driver on Network Lock Servers: If you have a network lock on a network server, DAT/EM strongly 
advises you to install Sentinel 7.7.0 on the network lock server to match the version on the DAT/EM workstations. 
DAT/EM provides a convenient prerequisites setup file that installs the required Microsoft C++ redistribution files 
and the Sentinel 7.7.0 driver: 

• Datem_PreReqs_blt_02_03_2021.exe 
• This is www.datem.com > Support > Downloads > Prerequisites > “DAT/EM Prerequisites … 

Sentinel 7.7.0 …” 
• Answer “Yes” to Sentinel’s firewall question (see images above). 
• Reboot the server after installation. 

Please do not skip the update for the network lock server. The newer Sentinel driver works better, and the 
best communication can be expected when the Sentinel versions match. 
 

 
DAT/EM Virtual Reality (VR) 
DAT/EM Virtual Reality (VR) was re-released in DAT/EM version 7.7, but is still considered in development as of version 
8.0. It is now developed with Amazon Lumberyard®, making it compatible with almost any brand of VR headset. Although 
we say “almost any”, we recommend the highest-resolution options and not the least expensive options. It does not work 
well with the Oculus Quest 2, for example. There were no changes to DAT/EM VR between v.7.7 and 8.0. 
Amazon Lumberyard is a trademark of Amazon.com, Inc. or its affiliates in the United States and/or other countries. Oculus Rift is a trademark of 
Facebook Technologies, LLC. HTC Vive is a trademark of HTC Corporation. 

   

Stereo Viewing Devices and Drivers 
Please contact DAT/EM Support if you have any questions about setting up nVidia 3DVision, buying 3DVision-compatible 
monitors, or setting up any other brand of stereo monitor. There is too much information to include here. 

 

DAT/EM Administration Tool *New!* 
The new DAT/EM Administration Tool combines a few tools that DAT/EM has offered separately in the past, plus some 
new tools. All can be accessed from one convenient location now. 

Start the tool with Windows Start > Datem Software > Datem Administration Tool (as Admin). This launches the tool 
as Administrator; if you receive a message asking you to confirm running as Administrator, answer Yes. 

 
Launch the new DAT/EM Administration Tool 

http://datemsystems.com/down/Datem_PreReqs_blt_02_03_2021.exe
http://datemsystems.com/down/Datem_PreReqs_blt_02_03_2021.exe
http://www.datem.com/
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DAT/EM Administration Tool descriptions: 

• Release Information button: Runs DAT/EM Release Information. 

• Check for Updates: Checks your version against the latest DAT/EM release and latest beta. It requires an 
Internet connection. 

• Change License Server: Allows you to key in a new machine name (preferred) or IP address of a DAT/EM 
network lock. 

 
New hardware lock server name entry in the new DAT/EM Administration Tool 

• CAD Enabler: This tool replaces the older stand-alone CAD Enabler, which is no longer installed. It allows 
you to choose a CAD or GIS package and enable or disable the licensed DAT/EM components or extension 
for that package. This performs one additional function over the previous stand-alone CAD Enabler: It can 
enable Capture alone without enabling MapEditor, so the choices are Capture, MapEditor, or both Capture 
and MapEditor for AutoCAD and MicroStation. Note: Like the older standalone CAD Enabler, the current 
activation or even installation status of any product is neither checked nor displayed. 

 
Example: Capture & MapEditor setting for “MicroStation 64” (CONNECT-
based products) in the new DAT/EM Administration Tool’s CAD Enabler 

• Share Settings: This tool is just like the old Share Settings application, except now it’s located here. Share 
Settings is still available from Windows Start as well, but it is the same no matter where it is started. 

• Sentinel Restart: Stops and restarts the three Sentinel services: SentinelKeyServer, 
SentinelProtectionServer, and SentinelSecurityRuntime. Try this tool if you see a “hardware lock not found” 
error when trying to start a DAT/EM application and you know the hardware lock is plugged in. 
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• Esri Tools:  

 
New Esri-related Tools in DAT/EM Administration Tool 

o Use Clear ESRI Template when your ArcGIS template is corrupt, which is especially noticeable 
when it won’t allow the DAT/EM Capture extension to register. 

o Use Go to template folder when you want to view or rename the template instead of deleting it. 

o Use Disable/Enable ArcMap Capture when you want to disable and enable Capture without actually 
unregistering/registering the extension. When disabled, it will not take a Capture for ArcGIS license 
from the DAT/EM hardware lock, but leaves the extension registered. This can be used without full 
Administrator privileges. Disable ArcMap Capture is the same as using the Enable and Disable 
buttons from the DAT/EM Capture Coordinates dialog inside ArcMap; it is not the same as using the 
CAD Enabler tool to disable or enable the extension.  

• Clean up SI: Close all DAT/EM software and close the CAD/GIS software before running this tool. Run this 
tool if obsolete superimposition (SI) vectors appear in Summit/LandScape/Ortho+Mosaic/Point Cloud/Contour 
Creator, even when CAD/GIS is not running or when a different CAD file is loaded. Clean up SI removes SI 
remnant files that may have been left on the disk after an SI source application abruptly stopped due to a 
crash or power outage. 

 
New Esri-related Tools in DAT/EM Administration Tool 
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Point and Image File Formats (Affecting Multiple DAT/EM Applications) 
DAT/EM applications read a variety of file formats that contain points and images. The code is shared among several 
DAT/EM applications, so when one can read a certain format, so can the others. The following changes have been made 
to the list of supported formats: 

1. Large, tiled TIF DEM files could cause DAT/EM Point Translator to crash on processing. This is fixed. (June 2020) 

2. The open-source LAZ library that DAT/EM and most developers use was changed by its author. Using the old 
method to read and write LAZ caused crashing in DAT/EM applications or the CAD/GIS programs running 
DAT/EM commands. DAT/EM v.8.0 updated to the new LAZ library. While this restored the ability to read and 
write LAZ in DAT/EM stand-alone applications and some Capture and MapEditor products, it was not possible to 
restore LAZ read/write in other products. The new LAZ library is not compatible with old compilers used for old 
CAD/GIS versions. Capture and MapEditor CADs/GISs that will no longer offer LAZ include: (August 31, 2020 with 
further fixes for true 16-bit color September 10, 2020) 

o Bentley MicroStation V8 2004 Edition, XM, V8i SelectSeries (up to and including SelectSeries 10) 

o Autodesk AutoCAD 2010 and earlier 

o Blue Marble Global Mapper 

o Esri ArcGIS versions 9.x 

In these applications, if LAZ is presented in a list of formats by DAT/EM commands such as DAT/EM “Elevate”, 
which reads DEM files, it will not crash, but it will simply do nothing if you select a LAZ file. Where possible, the 
application or command will not show LAZ as a format choice. 

Applications and tools that use newer compilers, for example DAT/EM Point Translator and the DAT/EM Capture 
for ArcGIS 10.x “Elevate” tool, will now read/write LAZ successfully. 

If you need to read a LAZ file in one of the applications that no longer supports it, convert the LAZ to a LAS file 
using DAT/EM Point Translator, then use the LAS file instead. 

3. DAT/EM applications will now read TFW files that do not have a blank line feed after the last text field in the file. 
TFW are “Tiff World” files that define coordinates for a TIF orthophoto image. Previously, if this final line feed was 
not in the file, it would misread the Y corner coordinate, resulting in the Y origin being 0 (zero) for DAT/EM image 
displays such as in Summit and DAT/EM Image Viewer.  (October 2, 2020) 

4. The Image Information tool offered in various DAT/EM applications will now show compression as “JPEG” for 
compressed JPG files. Previously, it showed compression as “Not known”.   (October 2, 2020) 

5. JPG files with JGW world files did not display at the correct coordinates in DAT/EM applications. This is fixed to 
properly position the upper left coordinate from the JGW at the upper left corner of the JPG. Note that world files 
give the (x,y) of the upper left pixel corner, not the center of the upper left pixel. This only affected JPG format, 
which is read by the new GDAL library that was first implemented in version 7.7.  (October 2, 2020) 

6. Image browsing dialogs had a misspelling so that *.jp appeared instead of *.jpg. In addition, .jpg and .mrf files 
were not properly showing as files in the folder for selection. The browse format lists and the files offered in the 
folder are now corrected and match the valid image file formats.  (October 5, 2020) 
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7. DAT/EM received an untiled JP2 image at 21248x23574 pixels with 3 channels and 2 bytes per channel. This 

image was essentially one giant tile, and it crashed our previously existing image readers and several other 
common third-party image reading applications. DAT/EM updated the OpenJPEG library version and applied this 
reader successfully to the file. DAT/EM applications are now able to open this file type and display it without 
having to add tiles. The speed and memory use are generally acceptable, but if you’d like to speed it up and 
reduce memory use, use the DAT/EM Image Creator v.8.0 or higher to convert this file type to a tiled JP2 or tiled 
TIF/BigTiff (all Image Creator output is tiled automatically).   (November 5, 2020) 

8. DAT/EM applications will now correctly read an additional variation of TIF format that has LZW compression in the 
image levels.  (March 16, 2021) 
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DAT/EM Keypad 
The following changes have been made to the DAT/EM Keypad products: 

1. There are new buttons to quickly set the previous or next overlay. (May 29, 2020) 

 
New Keypad overlay previous and next buttons 

These new buttons should appear on the toolbar to the right of the overlay name. If you don’t see them, select 
Keypad Controller > Tools > Customize > select “Overlays” > “Reset” button. 

 
If necessary, do this to make the new previous/next overlay buttons appear on the toolbar 

2. The example DAT/EM Keypad file called ESRI.dkf has been generally reorganized and updated to show the new 
DAT/EM Replace Geometry tool options. (August 14, 2020) 

3. There is a new example DAT/EM Keypad file called MicroStation64.dkf for demonstrating with 64-bit MicroStation 
versions such as CONNECT and OpenRoads. Note that the key-in to set a level now needs quotes around the 
level name if the level name contains a space character. (June 23, 2021) 

4. The Standalone Keypad for 32-bit MicroStation (such as V8i SelectSeries) might fail to load if the full version of 
DAT/EM Capture was previously installed on the same computer. This is fixed. (January 28, 2021)  
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5. The DAT/EM Keypad Controller’s Summit/LandScape output type now has a set of keywords to activate Summit 
and LandScape application tasks from the Keypad. The lists of keywords are presented in two separate 
documents: 

• For Summit keywords, see “SummitKeypadKeywords_<date>.pdf” offered for download from 
www.datem.com  

• For LandScape keywords, see “LandScapeKeypadKeywords_<date>.pdf” offered for download from 
www.datem.com.  

To set a Keypad key for Summit or LandScape, set the output type to Summit/LandScape in the DAT/EM 
Keypad Controller’s Edit Key dialog. Then set the Text field to the keyword string from the above documents. (July 
9 and 10 and November 6-12, 2020) 

 
New Summit and LandScape output type keywords are available 

 

http://www.datem.com/
http://www.datem.com/
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6. To demonstrate the new Summit and LandScape output type keys described in the item above, there are new 
example DAT/EM Keypad .dkf files called: 

"C:\ProgramData\Datem Systems\keypad\SummitOutput+DrawingObjects.dkf"  

“C:\ProgramData\Datem Systems\keypad\LandScapeExample.dkf”.  

The Summit example contains most of the Summit output keys, with the exception of the Airfield3D-specific keys. 
It can be used to view examples of how to use the Summit output keys or as a keypad for DAT/EM Drawing 
Objects (these are the Summit environment drawing tools found on Summit’s three “Drawing…” toolbars; they are 
not for Capture into an external CAD/GIS). The LandScape file contains many examples, which you can use as 
templates to set up your own configuration. (November 16, 2020) 

   
New example keypad .dkf files for Summit- and LandScape-type output keys 

 

Coordinate Transformations and Elevation Database 
There have been no changes to the elevation database installation file built in 2015 found here: 
http://datemsystems.com/down/SetupElevationModels%20blt%2003%2015%202015.exe. If you already installed that file 
with previous DAT/EM versions, you do not need to reinstall it. Any changes have been added to the DAT/EM setup 
installation, so that you do not need a new, separate Elevation Database file. 

1. The CHGeo2004 geoid for Switzerland is now available on request. It consists of two files to manually place in 
folder as “custom” geoid files. Contact DAT/EM Support at support@datem.com to ask for the files. The files may 
be used with DAT/EM v.8.0, v.7.7, and some earlier versions. (August 25, 2020) 

http://datemsystems.com/down/SetupElevationModels%20blt%2003%2015%202015.exe
mailto:support@datem.com
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DAT/EM Stereo Viewer 
The DAT/EM Stereo Viewer was added in DAT/EM version 7.6. For instructions on how to use the Stereo Viewer, please 
see the new Stereo Viewer Operation Manual available from www.datem.com > Support > Downloads > Manuals > 
Stereo Viewer. There have been no specific changes to the DAT/EM Stereo Viewer for v.8.0; however, some of the 
general image file format changes listed above apply to it. 

 

Summit Evolution 
The following changes have been made to Summit Evolution (Summit) and the applications that are provided with it.  

 
General Summit Evolution Subjects 

1. Summit now has two choices for how it can process system mouse digitizer input. The previously existing method 
was called Raw Input, and the new method is called Windows Messaging. Windows Messaging may be most 
useful for remote students who log in to an account at the University to run Summit for an assignment of limited 
digitizing with anaglyph stereo. Windows Messaging is not recommended for commercial use due to the slow 
response and anaglyph stereo limitations. (June 10, 2020) 

The Raw Input method should be used by Summit users who use the system mouse as the Summit digitizer on a 
local Summit workstation. Raw Input is faster and more reliable for local users; however, raw mouse input does 
not work over the Internet. The new Windows Messaging method is intended for users who log in using VPN and 
Remote desktop to a remote computer or Virtual Machine (VM) to run Summit remotely. Windows Messaging is 
slow, but it is the only way for the mouse button hits to be logged correctly in Summit over the Internet. 

To select the mouse technique, select Summit > Tools > Options > Input Devices > System Mouse (check on) 

and then the system mouse options button . Select either Raw Input for performance or Windows 
Messaging for VPN or VM. 

  
Settings for the system mouse Raw Input or Windows Messaging methods 

 

 

http://www.datem.com/
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2. The Automatic Model Generator found on the Project Window’s Models tab has a new option to make models 
from only selected images. Regular Expressions with partial matching functionality are used. So, to name a few 
examples, you could search for images that have a recognizable string such as “Right”, “Left”, “Nadir”, “RGB”, or 
“2019” and use only those images for model generation. If Regular Expressions are a new concept for you, 
DAT/EM offers a quick tutorial document for downloaded at www.datem.com. (February 19, 2021) 

    
New selected images filter in the Generate Models dialogs 

3. Any existing Summit SMTXML project may now be used as a template for starting a new project. Summit > File > 
New Project has a new From Project button that allows you to browse for projects. All the project settings will be 
“imported” into the new project. The camera will be retained as well as project settings such as coordinate system 
settings and aerial project interior corrections options (Earth Curvature Correction, Dynamic Terrain, units, etc.). 
Images and control files will not be retained; you should add them to the new project manually. (May 29, 2020) 

This template capability will be especially useful to users who often work with the same camera, same project 
type, or same coordinate system settings. 

 

http://www.datem.com/
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4. Named Image Adjustments has a new Local Histogram option. (June 10, 2020) 

To use, start Summit > Imagery > Named Image Adjustments. Select an existing adjustment or create a new 
one. Check on the Local Histogram option. Note that Histogram Equalization and Local Histogram are 
mutually exclusive, so you may not have both on at the same time. 

 
5. The Models at Cursor tool on the Model Switch toolbar (and View > Model Switch > Show All Models at 

Cursor) could return an incomplete list of models for the location. This is fixed. (May 11, 2021) 

6. Summit > Tools > Point Collector has the following changes: 

a. Point Collector now prompts the user if there are unsaved changes upon closing the window. (July 24, 2020) 

b. The Point Collector has a new Collect checkbox to toggle recording. When checked, points picked in 
Summit are recorded. When unchecked, nothing is recorded in Point Collector. Note: If there is an active 
Capture, points are always sent to it as usual no matter whether Point Collector is currently recording or 
not. (January 29, 2021) 
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c. The Point Collector window can now be optionally docked in your choice of positions around the Summit 
window edges. (January 29, 2021) 

 
Point Collector docked at the lower edge of the Summit window 

 
Point Collector undocked 
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d. The Point Collector now offers coordinate translation when saving to an external file. 

 
Point Collector’s new “Save and Convert Points” button 

 
Point Collector’s new method to convert coordinates before saving 
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7. Realtime Contour Visualization has the following changes: 

a. The Realtime Contour Visualization > Bounds tab > Static Area > Current View button will now fetch 
the correct view area for UAS imagery models. Previously, the view area was calculated as offset from 
the cursor location, so it was possible that the contours would be generated in an area outside the view. 
(September 9, 2020) 

b. The Start/Stop button and the positioning of some other dialog components was fixed. (September 9, 2020) 

8. DAT/EM Drawing Objects’ Text Labeling toolbar icon was bringing up the Spot Labels tool, and the Spot Labels 
toolbar icon was missing. They now have separate toolbar icons that launch the matching tool. (December 1, 2020) 

 

    
The DAT/EM Drawing Objects’ Text Labels and Spot Labels tools now have the proper toolbar icons 

9. Summit > Orientation > Parallax Shift is modified to be able to set different parallax shifts in multiple viewports. 
As long as the Parallax dialog stays displayed, it will keep track of the parallax shift setting for each viewport. Its 
display will show the setting for the focus viewport (the one that has the blue title bar). If you click on another 
viewport to give it focus, the Parallax dialog will change to that viewport’s existing shift value. When you close the 
Parallax dialog, all settings will revert to zero/off in all viewports. (February 25, 2021) 

10. A problem was fixed in Summit > Project window > Images tab > Sort option. Summit could crash if sorted by 
column or by selected images, then the OK button was selected. Note that sorting by drag and drop method 
would not crash. (August 12, 2020) 

11. Summit > Tools > Corner Detection could crash on starting the tool. This is fixed. (August 12, 2020) 

12. Summit > Tools > Status Tracker was not working in the previous version, mostly due to using a no-longer-
supported Jet database. To fix it, the following changes were made: (August 11, 2020) 

• The database type is now SQLite3, for which the source is available, so is not expected to go obsolete. 

• It now works with newer compilers. 

• Status Tracker is now a 64-bit application. 

• It can use the most recent Blue Marble versions. 

This new version of Status Tracker is not compatible with any older version. The databases are different. There 
are no plans to convert the old MDB Access database to SQLite3.  
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13. The following additional preset multiple viewport layout choices have been added: Four Right, Five Left, Five 
Right, Seven Left, and Seven Right. Hint: These layouts allow you to widen the Summit window to span two 
monitors, put a stereo model in the “main” right or left viewport and position it on the stereo monitor, then open 
orthophoto (mono) projects in the column of multiple viewports on the other side. Use Summit > File > Create 
Multiple Project Solution to combine different types of projects.  (March 23, 2021) 

 
More multiple viewport presets are now offered 

 
Terrain Project Tools (except Point Cloud) 

14. Terrain Projects and Terrain Project-related subjects (except Point Cloud) have the following changes. Note: Point 
Cloud application items are in the next section of this document. 

a. Show surrounding terrain points is now working properly in multiple viewports. Previously, it would only 
work in the first viewport, even when that viewport no longer had focus. (June 26,,2020) 

b. Summit > Terrain > Terrain Project Options > View percent is a new option for reducing the number of 
terrain points in the display while Show Surrounding Points is on. Use this option when there are so many 
points that it becomes difficult to see the imagery under the points. The setting is in for display only and 
does not affect the surface generation for Terrain Following, which always uses 100% of the points in the 
area. Processing priority is given to surface generation; no attempt is made to filter to an even 
distribution, because it would be too “expensive” as additional processing: (March 21, 2021) 

 
New View percent filter for showing surrounding terrain points 
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100% is set to view on the left; 25% is set on the right. 

An uneven distribution is expected. 
 

c. There is a new 3D distance filter for Terrain Project Terrain Following. During Terrain Project Following, 
points used to generate the surface are filtered by XY and Z in a spherical shape with the cursor at the 
center and at a user-defined radius. This is different from the existing Z filter, which could prevent large 
elevation jumps, for example from a road to the top of a tree or overhead bridge. This new spherical 
distance filter was designed to help with areas where there is a small elevation jump nearby, which you 
don’t want to affect the surface generation. (August 4, 2020) 

For example, it could be used to keep the cursor on the road surface where there is a curb nearby. You 
would still need to keep the cursor beyond the radius distance away from the curb in XY, so you couldn’t 
use this to digitize the bottom or top of the curb line at the vertical elevation drop of the curb. You could 
use it to digitize the outside/sidewalk side of the curb line or the outside/road edge of the gutter line, then 
use a set of automatic 3D offsets to draw the rest of the curb lines. 

This tool works best with dense terrain points. If you plan to filter curb and gutter points, then these 
features must be well defined by points both on top of and below the curb. It will not be productive if the 
radius is smaller than the distance between points, which often might leave no input points inside the 
surface generation sphere. 

To use, first use Summit > Terrain > Create Terrain Project, Load Terrain Project, and Follow Terrain 
Project (on). Then select Terrain > TP Filter Distance. Check the “On” box and enter the radius. Even if 
you have a larger radius set to show points, it will reduce the points display within the spherical shape at 
the given radius. This way, you can see which points will affect the surface generation: 

 
New Terrain Filter Distance tool 
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d. TP Filter Distance, TP Filter Z, and TP Options have been added to the Terrain Project toolbar. (August 27, 
2020) 

e. The Terrain Project toolbar will now be installed as “on” by default in new installations. (August 27, 2020) 

f. Summit > Tools > Options > Project > Terrain is a new setting to show a warning if a linked Terrain 
Project file is not found. (December 9, 2020) 

 
Tools > Options > Project > Terrain gives a warning when the linked .vrldr file is not found 

g. The Terrain Project Lidargrammetry and Stereo Mate from Orthophotos tools have the following changes: 

 There are speed improvements for generating a stereo mate image from a Terrain Project. In 
one test, a very large BigTiff image that previously took 11 hours to generate was reduced to 
3 hours. (January 7, 2021) 

 Lidargrammetry had an overflow error while creating images larger than 32768 pixels in width 
and height. This is fixed so that large image generation is now successful. (December 28, 2020) 

 Lidargrammetry will now make images where the origin pixel starts at the nearest whole 
ground unit. This applies to both the generated image and its stereo mate. (February 16, 2021) 

 Lidargrammetry will now create an intensity image where the tiles are color blended or 
normalized to the next tiles. Previously, the tile edges were very distinct, so although there 
was nothing wrong with the image, it wasn’t pleasing to view as a whole. (February 16, 2021 and 
further tiling corrections March 2, 2021) 

 Lidargrammetry could give an ambiguous “invalid operation” error message, which was 
traced to an OpenGL error. This is fixed. (March 1, 2021) 

 There is a new Lidargrammetry application called LidargramUI.2017.exe that offers three 
user interfaces (UIs) and runs from a command line. Command line runs may either be silent 
or start a dialog. This represents significant additions to the Lidargrammetry functionality. The 
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new application can produce output approximately 10 times faster than the old applications. It 
never filters points (the old ones filtered to around 10 million input points). (June 14-15, 2021) 

One method to start the three different UIs is from Summit > Terrain > Lidargrammetry: 

 
A) Summit > Terrain > Lidargrammetry > Lidargrammetry starts a dialog that asks 

for one existing Terrain Project (TP) as input and outputs one orthophoto. Most of this 
dialog may be familiar from previous versions, but it also has a new option to Select 
Area, which can to quickly generate a small area to check for the ideal pixel shift 
value and other settings. Once you know the best settings, you can generate the 
whole image using those values.  

 
Summit > Terrain > Lidargrammetry > Lidargrammetry 

This dialog can also be started from a command line or shortcut without any flag: 
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B) Summit > Terrain > Lidargrammetry > Lidargrammetry (multiple) starts a dialog 
that asks for multiple input Lidar files or multiple existing Terrain Projects. It outputs 
one orthophoto image per input file. This is most useful if you have already tiled Lidar 
files in the exact areas you want for in each output file. For any input Lidar files, a 
temporary Terrain Project will be generated automatically in the output folder and will 
be removed when finished. 

 
Summit > Terrain > Lidargrammetry > Lidargrammetry (multiple) 

This dialog can be started from a command line or shortcut using the -multi flag: 

 
Note: Since this “multiple” dialog does everything better and faster than the old 
Summit > Images > Generate LIDAR Image option, that menu item will also launch 
this new dialog. That older menu item may be removed in the future. 
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C) Summit > Terrain > Lidargrammetry > Stereo Mate from Orthophotos was a 
previously existing option and looks the same as the Terrain > Stereo Mate from 
Orthophotos option in version 7.7. It asks for existing orthophotos and one existing 
Terrain project as input. It outputs one stereo mate per orthophoto. 

 
Summit > Terrain > Lidargrammetry > Stereo mate from orthophotos 

This dialog can be started from a command line or shortcut with the -mate flag: 

 
 

To perform silent Lidargrammetry launches with a command line, there is a new “sister” 
application called LidarGramCmd.exe. It has the following syntax and flags, which can be 
displayed at any time using the Lidargrammetry Help command line: 

LidarGramCmd -Help 
This option displays help information about all the other command line flags. 
 
Syntax (this is a wrapped line; do not use line feeds): 
LidarGramCmd -out <folder> [-f <filename>]... [-indir <folder>] [-type: 
<colorType>][-gpp <value>][-pixelShift <value>][-nomate][-noortho] 
 
Flags: 

-out <folder> : An output folder for the resulting image(s). 

-f <filename> : Input point file. <Filename> should be a complete path and 
filename with extension. Multiple can be added, each starting with flag -f. 
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-indir <folder> : An input directory. The folder is searched for LAS files to 
process. Can use with or without -f 

-type: <colorType> : Image Type. Where colorType is one of: 'rgb', 'intensity', 
'cbe' (cbe is color by elevation plus intensity), or 'elev' (color by elevation only). 
Default cbe. 

-gpp <value> : User-defined ground per pixel. 

-pixelShift <value> : User-defined pixel shift per elevation unit. 

-span <span type> or <value> : Span areas, where spanType is one of: ‘Most’ 
(equivalent to 100 times gpp), ‘Some’ (equivalent of 25 times gpp), ‘a Little’ 
(equivalent of 12 times gpp), or ‘Hardly’ (equivalent of 5 times gpp), or a positive 
value multiplier times the original ground per pixel. The default is Not Used (no 
span filtering). 

Examples: ‘-span Hardly’ is the same as entering ‘-span 5’. ‘-Span 3’ 
will use a value of 3 times the gpp value to remove triangles. If Hardly is 
removing too many triangles, you could try a value of 8, which is 
between Hardly (5 x gpp) and a Little (12 x gpp). 

Important! If you make the span value very small, there will be areas of 
black pixels or even a mostly or completely black image. This will happen 
when the span filter length is greater than the distances between points 
in the input, so too many triangles are removed. If you are not sure which 
settings to use, generate one image set first and inspect water areas (for 
enough span removal) and vegetation or building areas (for too much 
span removal). Find the best span setting to match the input and other 
processing settings. 

-nomate : Do not generate mate. Orthophoto only. 

-noortho : Do not generate orthophoto. Mate only.  

-project <filename>: Generate a Summit project. <Filename> should be the 
complete path and filename.smtxml. If not listed, no .smtxml will be created. 

Example (this is a wrapped line; do not use line feeds): 
C:\Program Files\Datem Software\LidarGramCmd -out "F:\MyFolder\cmdOut" -f 
"F:\MyFolder\test.las" -f "F:\MyFolder\test2.vrldr" -type cbe -span 9    
-project C:\MyFolder\Summit\SummitProject.smtxml 

In this example, an output folder of "F:\MyFolder\cmdOut" is used. Two input files are 
used: test.las and test2.vrldr. The -type cbe (color by elevation plus intensity). This 
would result in four images being generated:  

"F:\MyFolder\cmdOut\test.tif", "F:\ MyFolder \cmdOut\ test_mate.tif", 
"F:\ MyFolder \cmdOut\test2.tif", and "F:\ MyFolder \cmdOut\test2_mate.tif". 

An output folder is always required -out. You specify one or more input files using -f 
and/or use a folder via -indir (only for LAS file input). Therefore, an output folder and 
some input files are required, and all other arguments are optional. The default color type 
is cbe (color by elevation plus intensity). By default, it generates both mate and ortho. By 
default, gpp (ground per pixel) and pixelShift are calculated. A custom span filter of 9 (9 
x gpp) is specified. The resulting images and stereo mates would be added to the listed 
“Generated Stereo” type Summit project. 
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Point Cloud Application 

15. Point Cloud has the following changes: 

a. Point Cloud will now give a warning if the data files associated with the .vrldr are not found. The data files 
should be in a subfolder with the .vrldr file. (December 9, 2020) 

b. .Vrldr loading speed is now faster. On a specific testing platform, a project with 1.3 billion points that 
previously took 82 seconds now takes 20 seconds. (January 13, 2021) 

c. There is a new Point Information docking window. Example: (January 13, 2021) 

 
Point Cloud’s new Point Information docking window  

d. Point Cloud now offers clipping planes on the View menu. There is currently a limitation of 2 clip planes. 
Set a plane by setting the Plane number to 1 or 2 and then measuring 3 points or by positioning the view 
interactively and selecting ‘done’:  (January 13, 2021) 

 
Point Cloud’s new Clipping Planes dialog 

 
Example of two clip planes set to clip to the front and back of some houses 
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Aerial Projects (traditional and UAS) 

16. Aerial projects (traditional and UAS) have the following changes: 

a. Absolute Orientation (AO) was using default standard deviation sigmas of 0.1, 0.1, 0.1, even if different 
values existed in the control file. Symptoms of this problem were that changing the sigmas in the control 
file had no effect on the AO residuals. This is fixed to properly use the values in the AO calculations. 
(January 20, 2021) 

 
Superimposition 

17. Superimposition (SI) has the following changes: 

a. Superimposition (SI) of dashed line styles originating in the CAD/GIS environment could look as if it 
changed elevation along the vector it represented, so the pattern in SI didn’t match up well in the viewer’s 
eyes and didn’t seem to keep to the elevation of the original vector object. The OpenGL shader making 
up this dash in superimposition has been changed to reduce this effect. (June 8, 2020)  

b. Superimposition could become very slow when certain Capture commands were in progress, such as 
MicroStation DATDRAW. Too many vectors would be added to the SI database until the object was 
finished drawing. This is fixed. (June 11, 2020) 

c. Superimposition was optimized to better handle MicroStation’s “unselect all” calls. If selected object 
highlighting was on, it could be very slow on tentative point snaps, etc. (April 29, 2021) 

d. Superimposition (SI) did not show any vector object that extended outside the Summit model’s valid 
ground coordinate area, even if part of the object crossed the current model’s stereo display area. This 
was particularly noticeable in projects that used a coordinate conversion, because the total valid ground 
coordinate area is smaller for such projects. For example, an aerial project with an active coordinate 
conversion has a ground coordinate area of about 15 times the size of the model, whereas it is almost 
unlimited when there is no coordinate conversion. Since ADS sensor and satellite RPC projects always 
have a coordinate conversion, they were especially susceptible to missing SI objects. Now when any 
object returns an invalid ground-to-pixel coordinate conversion for SI, the part of the object inside the 
model will be displayed in SI as follows: (September 24, 2020) 
 

• On an SI UPDATE or model change, it detects and flags when an object (or part of it) is unable to 
be converted from ground to pixel coordinates for SI display. 

• A flagged object is clipped in ground coordinates on the model extents boundary. 
• After clipping, the remaining part of the object is successfully converted from ground to pixel 

coordinates and displayed in SI. 
• There will be very little to no slowdown in SI processing, since clipping is only done when 

necessary. It is possible that many of the most distant objects that do not cross the current stereo 
area will be completely clipped. 

• Important! Clipped objects will only appear after an SI UPDATE or model change. This means if 
you are actively drawing a new out-of-bounds object (usually an object started in a far-away 
model and having model changes during drawing), it will not show up until an SI UPDATE or 
model change. This does not affect the drawing tool, so keep drawing. When the object is 
finished, it will most likely do its own SI UPDATE, and it will then be clipped and appear in SI. If it 
does not, manually submit SI UPDATE from Summit or from a Capture command. This limitation 
is intentional and is not likely to be changed in the future. 

e. Superimposition has increased the maximum allowed number of layers/levels to 200 000 layers/levels 
total in combined main files and reference files.  (May 27, 2020) 

f. Superimposition (SI) could leave obsolete folders and files on the hard drive, which could in turn display 
vectors in SI that no longer exist in the SI source. This is fixed so they will not be left in normal operating 
circumstances. The new DAT/EM Administration Tool (see page 3) offers to delete such files that are 
from older versions of DAT/EM software or that might be left after a power outage or crash leaves the files 
on the drive.  (July 21, 2020) 



DAT/EM Systems International RELEASE 8.0 Release Notes 
 

 26 

g. Superimposition in v.7.7 could leave folder trees on the hard drive that were variations of the folder that is 
actually used: "C:\ProgramData\Datem Systems\Common\SIUpdate". For example, these folder names 
might exist: 

• C:\SIUpdate  

• C:\Common\SIUpdate 

• C:\Datem Systems\Common\SIUpdate 

• C:\Datem Systems\SIUpdate 

• C:\ProgramData\SIUpdate 

• Etc. 

The reason for these folders being made is that a Microsoft compiler function that we used successfully 
for many years suddenly stopped working the same way. 

The new DAT/EM Administration tool (shown on page 3) will not delete these folders, because DAT/EM 
does not want to be responsible for deleting folders on the user’s hard drive. You may investigate whether 
you have such folders. If you do, close Summit and delete the folders manually. The only folder that 
should be retained is the fully named “C:\ProgramData\Datem Systems\Common\SIUpdate". Even if you 
accidentally delete this folder, it will be made again next time superimposition starts, so you will not lose 
anything by doing so. (July 2020) 

h. Superimposition with Capture for ArcGIS has some improvements for highlighting the selected object 
using the settings in Summit > Tools > Options > SI tab > Selected Objects area > Object and Line. It 
will now highlight an object selected before any edit session is active, keep highlighting the line after an SI 
Update, and correctly highlight selected lines along shared edges. (July 21, 2021) 

i. Superimposition in multiple viewports could draw the rubber band and Capture for ArcGIS snap line in the 
wrong color. This is fixed. (August 13, 2021) 

 
ADS40/80/100 Kit Projects 

18. ADS40/80/100 (ADS) Kit projects: 

a. There were some ADS image configurations where it was difficult or impossible to properly position the 
embedded bird’s-eye overview. The same project might have trouble with determining stereo vs. pseudo 
stereo and stereo rotation on screen (for left-right rather than top-bottom viewing). It could also have 
trouble building stereo models. These issues were all related and they are all fixed. (June 16, 2020) 

b. A new ADS40 Kit project will now have Automatically rotate view up or right and Combine split 
imagery blocks on by default. Note: If you set up a lot of ADS project where you want these off by 
default, you may save a project with them off and then use the new Summit > File > New Project > 
From Project button instead of picking the ADS project icon. (May 29, 2020) 

c. ADS40 Kit and Orthophoto Feature Collection projects with a large number of images could be extremely 
slow to load in the Summit > Edit > Project dialog. It would appear to be ‘locked up’, but was actually 
working extremely slowly while setting the path field in the project tree control. The slow function is in a 
third-party software, so DAT/EM can’t optimize or fix it. Instead, we now avoid showing the path in the file 
list in this dialog when there are more than 300 images. (March 10, 2021) 

 
Orthophoto Feature Collection (Summit) Projects 

19. Orthophoto Feature Collection projects (in all Summit editions): 

a. Orthophoto Feature Collection and ADS40 Kit projects with a large number of images could be extremely 
slow to load in the Summit > Edit > Project dialog. It would appear to be ‘locked up’, but was actually 
working extremely slowly while setting the path field in the project tree control. The slow function is in a 
third-party software, so DAT/EM can’t optimize or fix it. Instead, we now avoid showing the path in the file 
list in this dialog when there are more than 300 images. (March 10, 2021) 
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Imported Projects 

20. Imported Projects have the following changes: 

a. The Summit > File > Import > Hexagon Z/I (ISAT) import process now offers a new option called 
‘Given_parameters’ keyword. This is just one more list of exterior values found in the ISAT file set (there 
are at least four sets of exterior values in the ISAT files). 

Important! DAT/EM is not responsible for the contents of the Hexagon ISAT files. DAT/EM believes that in 
most ISAT projects, the “Given” parameters are the initial GPS/IMU values, and therefore would not be 
desired in a Summit project. If you have the GPS/IMU list, you could verify whether the values match it 
once you import using “Given” and look at the EO values in Summit’s EO dialog. However, it is possible 
that any EO values from any source could have been given to ISAT in place of typical GPS/IMU values. It 
is up to you whether to use “Given parameters” or not. 

It remains the user’s responsibility to select the option that contains the best exterior values. Prove the 
results using Summit > Tools > Move to Ground and check control points carefully. Note that usually 
the goal is to import Use Exteriors Parameters from > Photo File > ‘EO_parameters’ keyword, 
because DAT/EM believes that option contains the results of the ISAT aerotriangulation. The options now 
look like this:  (March 8, 2021 and July 26, 2021) 

 
New ‘Given_parameters’ option for Hexagon Z/I (ISAT) imports 

b. The Summit > File > Import > BLK file import process has been improved. It can now handle special 
characters encountered in the camera file information and it can detect when a camera is a digital camera 
and set the digital camera flag in the resulting Summit camera file. (March 18, 2021) 
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Point Translator (and point manager code) 

21. Point Translator and the point manager code used by several DAT/EM applications to read terrain point files have 
the following changes: 

a. Large, tiled TIF DEM files could cause DAT/EM Point Translator to crash on processing. This is fixed. 
(June 2020) 

b. Image Creator could crash while copying a rarely used TIFF tag when converting a TIF to the SMTI or TIF 
output type. This is fixed.  (November 17, 2020) 

 

 
DAT/EM Image Viewer  

22. DAT/EM Image Viewer has the following changes: 

a. DAT/EM Image Viewer has a new Point Collector tool. It is very similar to Summit Evolution’s Point 
Collector tool. One of many purposes for this tool may be to create a control file to use in Summit’s 
Relative Tie Points orientation as an alternative to using Summit’s Control Transfer tool. To use:  (July 15, 
2020) 

• Open an orthophoto image in Image Viewer (an orthophoto is necessary to provide xy ground 
coordinates). 

• Collected points will be (x,y) only unless a terrain file is loaded. If (x,y,z) points are desired, use 
Image Viewer > Terrain > Load DTM File and load a terrain file for the area of interest.  

• Select Image Viewer > Tools > Point Collector or the toolbar icon, . 

• Position the red “+” cross mark in the center of the Image Viewer display on a feature of interest. Note 
that it is the red cursor cross that must be on the object, not the system mouse cursor. Positioning 
may be done using any of the following methods: Use the system mouse and Image Viewer’s Tools > 
Pan tool, or press and hold down the system mouse wheel button and move the mouse to pan, or 
use Summit to position the cursor when Image Viewer > Tools > Move with Summit is on. 

 

• If it is not already on, select the Image Viewer’s Selection Pointer tool: 
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• Pick with the left mouse button anywhere in the Image View area to digitize. Digitizing must be done 
with the Selection Pointer tool on. The 2D or 3D point will be recorded in the Point Collector list at the 
location of the red cursor cross, not at the mouse pointer position. 

Note: If a terrain file is loaded in Image Viewer when a 3D point is picked, it will use the Z (elevation) 
of the terrain file, even if “Move with Summit/Landscape” is currently on. (changed September 25, 2020) 

• If desired, edit the assigned Identifier. Point Collector will assign an integer. Click directly on the 
number in the Identifier column and key in any alphanumeric string. 

 
Edit the point identifiers if desired 

Note about Identifier: There are no checks to make sure the user does not assign the same 
Identifier to multiple points. This is allowed in case you want to use it as a common description rather 
than a unique ID. During the same Point Collector session, it will automatically assign the next integer 
to any new points, even if you have deleted previous points. The numbering will reset for new files/run 
sessions. 

• When finished, optionally use the Write button to save to a choice of formats, including (but not 
limited to) .txt and DAT/EM .con control file format. 

• If there are unsaved changes upon closing the dialog, it will prompt the user and give a choice of 
returning to use the Write function. 

• To revisit the points from any file of a compatible format or to append to an existing file, open any 
orthophoto of the same coordinate system and geographic area of the points in the file. If you want to 
add 3D points to the file, load a terrain file. Select Tools > Point Collector > Load button and 
browse for the existing file. Click on points in the list to move to the locations. Digitize more points to 
append to the file, if desired. Save again, if desired. 

• The file made by Image Viewer’s Point Collector is compatible with Summit’s Point Collector. 
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b. Image Viewer can now show information about a selected pixel location. With the cursor in “arrow” mode 
(arrow highlighted on the toolbar), left click on a pixel. It will give a tooltip for the pixel located at the 
mouse arrow. It will not give a tip if another tool is in use. For example, if Point Collector, Move by Pick, 
or Rotates the View are active, then no pixel tip is shown. The tip will always give the true pixel values 
found in the image. All image adjustments of any kind are ignored. The number of values correspond to 
the number of channels in the images. Note: The range of color values varies depending on the number 
of bits in the image, for example 0-255 for 8-bit images and 0-65535 for 16-bit images. (July 20, 2020) 

 
Image Viewer showing a pixel coordinate and color value tooltip for the picked location 

c. Image Viewer’s zoom level, pixel coordinates, and ground coordinates that appear in the window’s lower 
right corner are now all editable. Click on a value and enter a new value. If you key in a new value, it will 
zoom or move to the value, if possible. You can also right click on a value to receive a variety of “Copy” 
options, such as “Copy as space delimited” or “Copy as comma delimited”, then paste the coordinate in 
the selected format into another application. (July 15, 2020) 

 

 
Project Viewer / Ortho+Mosaic  

23. Project Viewer / Ortho+Mosaic has the following changes: 

a. Ortho+Mosaic previously read a Terrain Project (.vrldr) in v.7.6 to provide the surface points, but after 
reading, it would treat it just like any of the other formats, so processing would not be faster than other 
formats. Now it takes full advantage of the Terrain Project format to offer faster surface processing. If you 
have many input points, it may be fastest to use Summit > Terrain > Create Terrain Project to generate 
the .vrldr, then use as input in Ortho+Mosaic for the fastest surface processing. (June 2020) 

b. There is a new method to delete a single vertex from a seam line. First click on the seam line to edit, 
which adds vertex markers. Then click one time on the vertex to delete and press <Delete>, X, or x on 
the keyboard. Previously, Ortho+Mosaic could crash if the <Delete> key was used in this manner and it 
would ignore the X key, but these issues are fixed as well as activating the keys for valid edits. (July 27, 
2020) 
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c. Ortho+Mosaic has a new, smoother edge panning method that takes effect while drawing and editing 
boundaries and seamlines. It pans slightly near the edge when the cursor reaches the edge of the current 
view. Previously, it would perform a center pan, which could seem rather visually distracting. (April 2, 2021) 

d. Ortho+Mosaic’s drawing and editing tools will now allow a transparent mouse wheel-button pan while in 
an active draw/edit task. Hold down the mouse wheel button to perform the pan without breaking out of 
the drawing/editing command. This allows you to pan to an area of your choice if the edge pan did not 
show you the whole area you wanted to see. (April 2, 2021) 

e. Ortho+Mosaic’s Edit Seamline tool will now leave the edited seamline selected after the edit is finished. 
This will allow another edit on the same seamline without having to reselect it first. Hint: Key in 
<Control>E to activate the seamline edit tool again and make another edit on the previously edited, still-
selected seamline. (April 2, 2021) 

f. The following problem is fixed: Ortho+Mosaic > Mosaic > Generate Mosaic > Image tab > Use scale of 
orthophotos would display the correct pixel size of the input orthophotos, but would process the mosaic 
at a slightly different size. The mosaic would be correct at that different pixel size, but it would not match 
up to a well-planned mosaic boundary that was made for the displayed pixel size. Note that it would work 
well if User defined pixel scale was used instead with the pixel size keyed in. (May 13, 2021) 

g. The Ortho+Mosaic > Orthophotos > Orthophoto Generation has a slight change to how it chooses the 
edges of the orthophotos with respect to the position of the boundaries. Now the pixel center coordinates 
are always contained inside or on the boundary. (May 17, 2021) 

If the boundary is arbitrary and you check on Ortho+Mosaic > Orthophotos > Orthophoto Generation 
> Main tab > Closest Whole Number on, this can happen: 

    
Notice the yellow boundary might not touch the pixels. This is because the pixels are discrete and are 
forced to a whole number. Setting to a whole number forces a shift, but it will remain contained. 

If Ortho+Mosaic > Orthophotos > Orthophoto Generation > Main tab > Closest Whole Number is off, 
then the upper left corner will always be like this: 
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The lower right may or may not land on the center of the pixel depending on the width of the boundary 
area and the size of the pixel (ground per pixel). So, you might get something like this: 

 
The lower right pixel’s center coordinate should always be contained within or on the boundary. 

DAT/EM recommends to check on the Closest Whole Number setting and make exact boundaries when 
you are going to use the orthophotos as deliverable products. Often, they are only an intermediate stage 
before making a mosaic, in which case you can use the automatically generated boundaries without too 
much worry, as long as they allow enough rows and pixels of overlap to generate a nicely 
feathered/blended final mosaic. If the mosaic is the main deliverable, then spend the time making the 
mosaic boundary exactly as you want it. See the next item below for more information on changes to 
mosaic boundaries. 

h. The Ortho+Mosaic > Mosaic > Generate Mosaic > Main tab > Inclusive and Overlapped settings have 
been removed. Pixels will always be processed at the boundary according to a new fitting method, which 
is most like the old Inclusive setting: (May 13, 2021) 

Exact fit (1.0):  

The yellow lines are a boundary. Notice it hits dead center of the pixel. (A pixel is really a point, but we 
represent it as a color-filled square centered at the pixel coordinate.) Pixels must be discrete, but a 
boundary can be continuous. Rounding is used to decide whether to add a pixel row/column or not. 

Fit (0.75):  
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Here a boundary is past the center of the lower right pixel (yellow boundary not in the center of the pixel). 
It is off, but not enough to add another pixel in the row/column. In this case, the actual corner pixel is 
center coordinate is slightly inside the boundary. If the boundary is > 0.5 pixel width units past the center 
of the pixel, then another row/column of pixels is added like this: 

pixel row and column added:  

A row may be added without adding another column, or a column without another row, but this depends 
on the (x,y) location of the pixel center compared to the boundary. Above, we showed rows and columns 
to be equally offset from the pixel center for simplicity. 

 
LandScape 
Landscape has the following changes: 

1. LandScape is fixed so it can load a LandScape .lndscp project by double clicking on the file in File Explorer, while 
LandScape has the “Load last project on start” option on. Previously it could crash due to a conflict while trying to 
load the double-clicked project and also the last project.  (August 19, 2020) 

2. Some LandScape tools and settings can now be launched by the DAT/EM Keypad Controller using 
“Summit/LandScape” output keys.  

• There is an example LandScape keypad .dkf file installed in “C:\ProgramData\Datem 
Systems\keypad\LandScapeExample.dkf”. 

• For a list of the new keywords to use in the Keypad Controller’s text strings for LandScape, see the 
separate document called “LandScapeKeypadCommands<date>.pdf” available for download from 
www.datem.com. (December 7, 2020 -- February 2021) 

3. The Interactive Point Edit FaceShift tool is fixed so that it will properly show the TIN lines when the Show TIN 
option is on. (January 2021) 

4. The method of processing input from all types of 3D mouse devices was changed to better suit operation in newer 
versions of Windows 10. Previous symptoms could include the mouse becoming unresponsive in LandScape and 
“Give up” and “Get 3D device” would not help get the mouse going again. (March 24, 2021) 

5. There is improved inter-process data access that may prevent some application freeze errors. (April 29, 2021) 

 

http://www.datem.com/
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DAT/EM Capture for ArcGIS - ArcMap 
This version is compatible with ArcGIS 10.0 (service pack 4), 10.1 (service pack 1), 10.2, 10.2.1, 10.2.2, 10.3, 10.3.1, 10.4.x, 10.5.x, 
10.6.x, 10.7.x, and 10.8 (plus any available service pack as they are released). 

This version may be compatible with ArcGIS 9.1, 9.2, 9.3 (service pack 1), 9.3.1(service pack 2). BE ADVISED: Testing no longer 
occurs for DAT/EM Capture with ArcGIS 9.x. It still installs for it and no code has been removed, so you may use 9.x as long as it 
continues to work for you. Any issues will not be corrected. ArcGIS 9.x support may be dropped completely in a future release. Please 
continue to make plans to upgrade any remaining ArcGIS 9.x version to 10.x. 

DAT/EM Capture for ArcGIS has the following changes: 
Capture for ArcGIS (ArcMap) Items 

1. DAT/EM Replace Geometry is a new DAT/EM Capture for ArcGIS tool. It may be used to replace the geometry 
of an ArcMap object without affecting its tabular data. It works with the Capture Drawing tools. The steps for its 
use are:  (July 16, 2020) 

 Begin an ArcMap editing session. 

 Select the Replace Geometry button  . 
Note: the same button may be used to turn off Replace Geometry. 

 Select the object to be replaced using the 3D cursor. 

 Draw the new object using the Datem Drawing tools Point-to-Point, Stream, or Square. Point-to-Point is 
chosen by default. The drawing mode may be changed during drawing, but only to another one of these 
three drawing tools. 

 When finished, use the Cancel/Reset/Finish Sketch button on the 3D cursor as usual to find Polygon or 
Polyline drawing. Exception: Point-geometry objects will automatically update as soon as the new point is 
picked, so Finish Sketch is not required for points. Replace Geometry will stay active until either the 
button is selected again or an un-supported drawing tool is chosen. 

 
The keywords to use on the DAT/EM Keypad and Summit’s Custom CAD buttons are: 

ReplaceGeometry On 

ReplaceGeometry Off 

These are not case sensitive, and they may be combined with the drawing tool, such as: 

replacegeometry ON draw square 

You may want to add ReplaceGeometry Off to the beginning of existing Keypad keys or buttons that start Point-
to-Point, Square, and Stream mode in regular, new-object drawing mode. This would ensure that DAT/EM 
Replace Geometry is not still active when drawing a completely new object. Example: 

ReplaceGeometry off CreateNewFeatureTask draw point-to-point 
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2. Contour Up and Contour Down  are new tools to move the Summit Evolution stereoplotter up or down 
in elevation to the nearest even contour interval. For example, with a contour interval of 5.00, move Summit from 
its current elevation of 102.79 to 105.00 and then from 105.00 to 110.00. The contour interval may be set by a 
keyword or from DAT/EM Systems Options > Streaming tab > Contour interval: 

 
New Contour interval setting to use with Contour Up and Contour Down 

The keywords to set and use these commands from the DAT/EM Keypad Controller or Button Manager are: 

ContourUp   Moves Summit up to the nearest even contour interval. 

ContourDown   Moves Summit down to the nearest even contour interval. 

ContourInterval <value> Sets the contour interval. Example: ContourInterval 2.0 

 

3. Explode Polyline  is a new tool to break a polyline into its component line segments and copy the original 
polyline’s database attributes, including field values, into each line segment. The new lines are placed on the 

original polyline’s line-geometry layer. Use DAT/EM Systems Options  > Edit Tools > Keep original 
polyline to choose whether or not to retain the original polyline in addition to the new line segments. (April 12, 2021) 
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Explode Polyline setting in the Edit Tools options 

The keyword to activate Explode Polyline from the DAT/EM Keypad Controller or Button Manager is: 

ExplodePoly 

 

4. The example DAT/EM Keypad file called ESRI.dkf has been generally reorganized and updated to show the new 
DAT/EM Replace Geometry options. (August 14, 2020) 

5. The Extend one line to another object tool now has two options for the type of extension it will use. Set the type 
in the ArcMap-side DAT/EM Systems Options Edit Tools settings: (October 14, 2020 and modifications in April 2021) 

     
The settings are: 

• Extend to point – This is the preexisting method. It adds a segment to the extending object (Object 1) so 
that it meets the point you picked on the extend-to object (Object 2). It preserves the picked point, 
therefore does not enforce the original end segment angle on Object 1. 

• Extend to extruded line – This is the new setting. It extends the end segment of Object 1 at its original 
angle until it meets Object 2. If there is no natural intersection with the Object 2, it virtually extrudes the 
closest end segment of Object 2 to create a virtual intersection with the extension of Object 1. If an end 
segment extrusion is done, the new endpoint of Object 1 will not have a real intersection with Object 2; 
there will be a gap. Hint: If you run it again and swap the order of picking Object 1 and 2, it will perfectly 
fill the gap without changing the end segment angle of either object. 
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The keywords to toggle this setting from the DAT/EM Keypad or a Button Manager button are: 

ExtendToExtrudedLine on 

ExtendToExtrudedLine off 

 

6. The Faceshift tool has a new keyword, Faceshift, to use on the DAT/EM Keypad or on a Button Manager User 
CAD button. Previously, you could only use its command ID with CallCommand. Either one of these command 
strings will now work: (May 29, 2020) 

Faceshift 

Or,: 

CallCommand Capture.ArcInfo.Faceshift 

7. Feature Shift has the following changes: 

a. Negative numbers keyed in to the distance fields will now have the negative signs preserved and 
implemented. Previously, they would be treated as positive numbers. (October 26, 2020) 

b. The Feature Shift dialog will now stay visible until another command is started. To close it, pick another 
command such as the point-to-point drawing tool. This solves a problem where the user would attempt to 
close the dialog, and it would disappear, but it would not easily reappear again. (October 26, 2020) 

c. FeatureShift is a new keyword. When used alone, it launches the Feature Shift dialog.  

d. FeatureShift dialog settings keywords are a new way to set the Feature Shift tool dialog settings 
automatically from the DAT/EM Keypad or a Button Manager button without launching the Feature Shift 
dialog. FeatureShift is the keyword to begin; it only needs to appear one time. It is followed by the 
specific settings keywords as follows: 

#Keyword to begin and to start the Feature Shift tool. Use any of the following settings after it: 
FeatureShift 

MakeCopy On | Off 
 

#Using Summit (These automatically turn on “Use Summit to shift”): 
SummitHor | SummitVert | SummitBoth 
SummitRotate On | Off 
SummitScale On | Off 

#These turn off “Use Summit to shift” if it is on: 
ShiftHorX [value] 
ShiftHorY [value] 
ShiftZ [value] 
SetZ [value] 
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Examples: 

 
FeatureShift MakeCopy off Summitboth Summitrotate off Summitscale off 
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FeatureShift MakeCopy on ShiftHorX 10.0 ShiftHorY 5.0 ShiftZ -2.5 

 

 
FeatureShift MakeCopy off SetZ 175.0 

 

8. Both Field Update and Airfield3D have new export and import buttons to save and reload previously used field 
values. The purpose is to save you from having to re-key complicated field values, particularly long text strings.  
(October 6, 2020) 

• The files saved by Field Update and Airfield3D are the same format and may be imported later by either 
of these dialogs. 

• All user-entered field values will be exported for the layer of the currently selected object. Automatic field 
values will not be exported. 

• There is a limit is 20 saved field values per field. 
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• During import, field values will be matched, regardless of the layer of the selected object; current and 
imported field values will appear in the pull-down menu for the field in the “New Field Value” column. For 
example, if a selected object on Layer1 exports a field called “Description”, it may be imported later for a 
selected object on Layer2 that also has a field called “Description”.  

• A field does not need to be checked on in order to be exported.  

• Field names that don’t match at the time of import will be ignored. 

• The saved files are text files, and may be carefully edited with a text editor. That is, you may edit the field 
values listed there, but do not change the overall file format. Do not exceed 20 field values per field. 

 
New field value export and import tools for Field Update and Airfield3D 

 

9. Field Update has a new automatic field, “Measure Vertical Field Delta” <MeasureVFieldDelta>. 
<MeasureVFieldDelta> is useful when measuring an object that has an elevation that changes over time and 
already contains a Height above Ground field and an older Z vertex elevation. Such a field requires two 
measurement points to fill initially, but can be updated by a single measurement. This option may be useful in 
airport obstruction projects to update existing tree obstacles after the trees have grown; in this case, switch to 
using the Field Update tool instead of Airfield3D. (February 10, 2021) 

<MeasureVFieldDelta> performs two operations based on one measurement: 

1) It sets the new field value to the current field value + the difference between the new measured 
location Z and the current object elevation in the drawing. 

2) It also sets the elevation of the object to the measurement’s Z value.  

The calculation for the field value looks like this: 

NewValue = CurrentFieldValue + measuredPoint.Z - selectedObject.Z 

An example would be a tree with a top at 110 meters and a measured Height Above Ground of 10 meters, and 
which has grown 3 meters since the previous measurement that was made in older imagery. The tree needs to be 
updated to reflect its new 113-meter height and the Height Above Ground field needs to be updated to 13 meters. 
The calculation would be: 

NewValue = 10 (current field value) + 113 (new measured location) – 110 (original location) 
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To use this tool: 

 Begin an edit session. 

 If desired, select the object to edit now. Selecting it later is described below. 

 Launch the Field Update Tool and select <MeasureVFieldDelta> in the New Field Value column 
for the field to be updated. 

 If not already selected, select the object to be edited now. Use either the ArcMap Edit Tool or 
Selection Tool with either the system mouse in the ArcMap view or the Summit pick button. 

o Note: If you want to pick the object using Summit while the Field Update dialog is active, 
turn off the DAT/EM Cursor from the ArcMap-side DAT/EM Capture Tools toolbar, pick 
the object using Summit, then toggle the DAT/EM Cursor back on. Leave Field update 
running while you do this. 

 
The DAT/EM Cursor is off if it is plain on the toolbar; it is on if it has a box around it 

Normally, the DAT/EM Cursor toggles off automatically when a native ArcMap tool is 
selected and on when a DAT/EM tool is selected (as long as the ArcMap-side DAT/EM 
Systems Options > Cursor > Automatically toggle DAT/EM cursor is checked on). 
However, since Field Update turned the cursor on, and Field Update is still running, it will 
not turn off automatically when you start the edit or selection tool. This is why the manual 
toggle must be done if you want to select with Summit instead of the system mouse. 

 Press the Apply button on the dialog or from an Apply button set on a Button Manager cursor 
button. 

 When prompted, measure the new elevation for the object using Summit’s cursor. This may either 
be higher or lower than it was before. For example, a tree that has grown will be higher, but a tree 
that has broken off in a windstorm will be lower. 

 
MeasureVFieldDelta prompts to measure the new height, then edits the field and the object’s Z 
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10. The SetFieldValue:<layer>:<field name>:<field value> keyword for the DAT/EM Keypad has a special, new 
<field value> option called PromptForValue (also AskUser works the same way). These are not case sensitive, 
so PromptForValue works the same as promptforvalue. If the Keypad submits a string such as: 

SetFieldValue:LayerName:FieldName:PromptForValue 

Or, 

setfieldvalue:LayerName:FieldName:askuser 

Then when this Keypad key is pressed, a dialog appears asking for the user to key in the field value.  

It is the user’s responsibility to enter a value that conforms to the particular field type definition and/or preset field 
values. Preset text field values are case sensitive in ArcMap. For example, enter a text string up to 55 characters 
for a 55-character text field, enter a short integer for a short integer field, or enter TREE (not Tree) for a preset 
allowed text field value of TREE. The Enter Input dialog can’t verify the entry, but Field Update will reject it upon 
Apply if it does not conform to the field type definition and/or preset value. 

 
Example of the DAT/EM Keypad’s Edit Key dialog with SetFieldValue…PromptForValue set, the resulting 
Enter Input dialog with user entry, and the New Field Value showing in the Field Update dialog in ArcMap. 
After Apply to Field Update, the value will be set in the selected object’s Current Field Value list. 

 

11. The Shift Features tool wasn’t snapping correctly if the DAT/EM Systems Options > SI > Quick Snap setting 
was on. This is fixed. (December 2, 2020) 

12. The Square drawing tool now offers a first-point perpendicular snap. If the Square tool starts drawing with a snap 
to a segment on another object, it will take its first squaring angle from that snapped-to segment. As long as you 
don’t exceed the squaring angle set in DAT/EM Systems Options > Squaring, the first segment of the new 
square mode object will be perpendicular to the snapped-to segment. (If you do not want a perpendicular snap, 
use the point-to-point tool instead for the first segment, then resume the square mode tool when needed.) (April 1, 
2021) 
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13. The ZoomPlotter keyword submitted from the DAT/EM Keypad or Button Manager buttons wasn’t activating in 
Capture for ArcGIS. This is fixed. (March 17, 2021) 

14. Superimposition with Capture for ArcGIS has some improvements for highlighting the selected object using the 
settings in Summit > Tools > Options > SI tab > Selected Objects area > Object and Line. It will now highlight 
an object selected before any edit session is active, keep highlighting the line after an SI Update, correctly 
highlight selected lines along shared edges, and correctly highlight during DAT/EM multisnap operations. (July 21, 
2021) 

 
Airfield3D 

15. Airfield3D has the following changes: 

a. Airfield3D’s Measure Status tool listing speed is improved. Previously, it could be very slow if there were 
tens of thousands of entries (obstacles) to count and list. Now if there are more than 1000 points in the 
selected surface’s area, the list will be truncated to show a total only. (May 29, 2020) 

  
Measure Status showing fewer than 1000 points (left) and a count only for more than 1000 points (right) 
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b. The Part 77 Custom end setup has a new Approach dog ear distance field and surfaces. This allows 
you to add the “level surface” sections as shown in the FAA’s “Engineering Brief No. 99A, Changes to 
Tables 3-2 and 3-4 of Advisory Circular 150/5300-13A, Airport Design” document. Below is Figure 1 from 
that document, which shows the new sections in yellow, which DAT/EM nicknames “dog ears” in these 
instructions and in the Airfield3D Custom Part 77 custom end dialog settings: (July 15, 2021) 

 
The yellow sections in this FAA graphic can now be added in the Custom Part 77 end definition 

Important note! There’s often ambiguity in FAA obstruction surface publications, and this one is no 
exception. Figure 1 in the document labels the yellow sections as “level surface” and Figure 2 shows the 
surface starting and ending at 304’, but also connected to the outermost corner of the light blue Section 1 
and 2 surfaces: 

 
The FAA document’s Figure 2 show the yellow surfaces starting and ending at 304’. This is impossible. 
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However, if we enter these distances into the various formulas, and find the following: 

• Starting elevation: 6160’/40 + 150’ = 154’ + 150’ = 304’. This agrees with Figure 2. 

• Elevation at the end of the Section 2: 12152’/40 = 303.8’. This does not agree with Figure 2. 
Thus, the end elevation is not 304’ as indicated on the diagram; rather, it is 303.8’, indicating an 
elevation change occurs along the so-called “level” dog ear surface. 

• There is also a problem with the “500’” distance label in Figure 2. In the diagram, 500’ is marked 
from the center of the runway to the outer corner (closest to the runway end) of the Section 2 
area. This is not the distance you need to use for the Airfield3D Custom Part 77 custom end 
“Approach transition distance from approach” or in the “Approach transition” calculation. What the 
FAA has marked as 500’ is not actually a straight line on the plane of Section 2; instead, it is the 
length of two non-colinear segments added together: From the center of the end of the runway to 
the outer corner of the runway plus the outer corner of the runway to the outer corner of Section 
2. To calculate the “Approach transition distance from approach”, you must subtract ½ of the 
width of the runway from 500’. So, for example, let’s say a runway is 76’ wide; in this case, 
calculate “Approach transition distance from approach” as [500’ – 0.5(76’)] = 462’. Then calculate 
“Approach transition” as 462’/150’ = 3.08. These values will be different depending on the width 
of the runway in your particular project. (See example entries in graphic below.) 

The new setting is found in the ArcMap-side Airfield3D dialog > Part 77 Custom > Options  button 
>  Define Runways button > Part 77 Custom dialog > Approach dog ear distance. The dog ear is the 
distance of the start of the dog ear (starting closer to the runway). It can be disabled by setting to 0 (zero), 
which is the default value for a new custom runway end. 

The Approach transition distance from approach and Approach transition fields are also important 
and take some manual calculation to get them right; calculate them as described above. 

 
Part 77 Custom runway end with the new “Approach dog ear distance” set to 6160’. 

Your project may use a different value than 6160’. 
If “Approach dog ear distance” is set to 0 (zero), it will not be drawn. 

This example is for a runway width of 76’ to match the example calculations above. 
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Example of the new dog ear surfaces being generated to the left and right sides. 

The green Summit cursor with yellow elevation text is located in one of the dog ears. 
This example is simplified by removing the conical and horizontal surfaces. 

The actual size of the dog ears in your project may not be similar to this example. 

c. Related to the new “dog ear” surface addition shown above, superimposition surface clipping by the 
conical surface was deactivated. This was done, because clipping could prevent the “dog ear” surfaces 
from displaying at all, depending on the distance definition of the conical surface. (July 19, 2021) 

d. There is a new report called the “VGPS High End Only”. (July 29, 2020) 

e. The NVGPS was reporting points on the opposite sides (left instead of right and vice versa). This is fixed. 
This affects the superimposed head’s-up text, the Measure Status dialog lists, and reports. (September 3, 
2020) 

f. The NVGAS has added high/low numbered end definitions. Previously, the two ends were grouped 
together. This affects the superimposed head’s-up text, the Measure Status dialog lists, and reports. 
(September 3, 2020 and additional reports clarification July 12, 2021) 

g. If the Follow Lowest Surface flag is turned on, points in the VGPCS will now also be checked against 
the VGAS, and the point will be assigned to the lowest of these two surfaces. If the Follow Lowest 
Surface flag is turned off, it keeps working as it did previously, that is, if a point is in the VGPCS, it is not 
included in the VGAS check, and it is left in the VGPCS. (July 12, 2021) 

h. Both Airfield3D and Field Update have new export and import buttons to save and reload previously used 
field values. The purpose is to save you from having to re-key complicated field values, particularly long 
text strings.  (October 6, 2020) 

• The files saved by Field Update and Airfield3D are the same format and may be imported later by 
either of these dialogs. 

• All user-entered field values will be exported for the layer of the currently selected object. 
Automatic field values will not be exported. 

• During import, field values will be matched, regardless of the layer of the selected object; current 
and imported field values will appear in the pull-down menu for the field in the “New Field Value” 
column. For example, if a selected object on Layer1 exports a field called “Description”, it may be 
imported later for a selected object on Layer2 that also has a field called “Description”.  

• A field does not need to be checked on in order to be exported.  

• Field names that don’t match at the time of import will be ignored. 
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• The saved files are text files, and may be carefully edited with a text editor. That is, you may edit 
the field values listed there, but do not change the overall file format. 

 
New field value export and import tools for Field Update and Airfield3D 

i. Part 77 Transitional surface generation was incorrect on one end in some runway configurations. On one 
end, the Approach and Transitional surfaces would correctly share an edge; on the other end, they could 
diverge from each other, so you might see a mismatch similar to this example: (December 17, 2020) 

  
Correct edge sharing shown on the left; this situation in Part 77 is now fixed so the Transitional and 

Approach correctly share an edge on both ends of the runway 

j. Please note the new DAT/EM Keypad Summit-controlling keywords listed above in the DAT/EM Keypad 
section, item 4., starting on page 9. The table of keywords shows some Airfield3D keywords to toggle 
following the surface. (July 10, 2020) 

k. If a point on the RunwayEnd layer has a blank or <Null> Runway End Designator field, a message will 
appear and the runway will be skipped. (May 17, 2021) 
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DAT/EM Capture for ArcGIS – ArcGIS Pro (Beta) 
DAT/EM Capture for ArcGIS Pro is compatible with versions: 

• ArcGIS Pro versions 2.3 through 2.8.1. Please ask DAT/EM about any higher version numbers as they are released. 

• The API no longer needs to be present on the hardware lock. If you have Capture for ArcGIS and want to try Capture 
for ArcGIS Pro, use the DAT/EM CAD Enabler (standalone or located in the DAT/EM Administration Tool) to activate 
the extension for ArcGIS Pro. 

DAT/EM Capture for ArcGIS Pro has the following changes: 

1. Compatibility with ArcGIS Pro versions 2.5.1 through 2.8.1 has been added. (up to July 26, 2021) 

2. XYZOut is a new tool in Capture for ArcGIS Pro. It exports selected information from an ArcGIS Pro feature layer 
to a text file.  

 
New XYZOut toolbar button and dialog in Capture for ArcGIS Pro 

To use XYZOut: 

• Start the command using the toolbar icon shown in the graphic above or from the DAT/EM Keypad or a 
digitizer User CAD button using the following keyword: 

xyzout 

• Select the layer to be exported using the Layer drop-down menu. 

• Select the fields to export using the Fields to export list. Fields will be exported in the order of the list. 
The order of the list cannot be modified at this time. 

• Adjust the decimal precision using the Precision controls (Horizontal for x,y and Vertical for z). 

• The Record Type control identifies the method that will be used to export each object on the layer. Select 
the type most appropriate for your use: Place shape at end of fields will create 2 lines per object. The 
first line will contain the field contents, and the second field will contain the vertices that make up the 
shape of the object. Duplicate all fields on each vertex writes a new line that includes all fields for every 
vertex in the object. 
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• Open following export will call the system to open the output file following export. This may cause a 
CSV file to be opened by a spreadsheet tool, for example, or Windows may ask you which application 
should open the file type, depending on your system settings. 

• The Export button performs the export. 

 

3. Zoom to Selected is a new tool in Capture for ArcGIS Pro. It zooms Summit or LandScape to the features 
currently selected in ArcGIS Pro. (March 15, 2021) 

 
Summit and ArcGIS Pro zoomed to the same area using Zoom to Selected 

Zoom to Selected may be launched using the DAT/EM Capture ribbon button shown below. It may also be 
launched from the DAT/EM Keypad or a Button Manager User CAD button using the following keyword or 
CallCommand plus the Command ID: 

ZoomSummitToSelected  

CallCommand CaptureArcPro_ZoomSummitToSelected 

    
Zoom to Selected shown on the DAT/EM Capture ribbon as small icons (left) and large icons (right) 

Note: Both icon sizes are available in ArcGIS Pro’s Project > Options > Customize the Ribbon. The default is 
currently Large Icons. To display the Command IDs in the Ribbon screen tips, check on Show command IDs on 
ScreenTips. 
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Hint to be able to see the DAT/EM command IDs in the ribbon menu icon’s tooltip 

  

DAT/EM Capture and MapEditor for AutoCAD 
DAT/EM Capture and MapEditor for AutoCAD are compatible with the following AutoCAD versions: 

• 32-bit AutoCAD 2004-2008 versions with the latest service packs, as long as you can get them to install on your 64-bit 
operating system (OS). DAT/EM no longer tests on 32-bit OS, so these must be running on 64-bit OS. DAT/EM is not 
responsible for helping to install a 32-bit version of AutoCAD on a 64-bit OS and cannot guarantee that this will succeed. 

• 64-bit AutoCAD 2009-2022 versions with the latest service packs. Exception: 64-bit AutoCAD 2008 is not supported. 

When referring to a year/version number in the lists above, it includes "plain" AutoCAD, Civil3D, and Map3D. It does not 
include AutoCAD LT, which is a 2D product, and therefore will never work with a 3D cursor. 

Reminders: Install all available AutoCAD service packs and updates before installing DAT/EM software. Before installing DAT/EM 
software, run each version of AutoCAD and make sure its license is active. Do this for each version whether or not you intend to 
use every version with DAT/EM Capture. 

DAT/EM software will install for multiple AutoCAD products of different year numbers on the same computer; however, it will only 
install for one of any multiple same-year versions. For example, it will install for AutoCAD 2015, 2016, 2017 Civil3D, and Map3D 
2018, because they are all different year versions; however, it will not install for both AutoCAD 2017 and AutoCAD Civil3D 2017 at 
the same time, because they are both the same year. In the case of multiple same-year versions, only one of them will receive the 
DAT/EM files at installation. To activate DAT/EM Capture in all of them, the AutoCAD \datem folder and the DAT/EM wintab driver 
file may be copied from the one that received the files to the other same-year versions. Contact DAT/EM Support for instructions. 

Autodesk Infrastructure Design Suite installs three same-year AutoCAD versions (AutoCAD, Map3D, and Civil3D). Using the rules 
outlined above, you must run each version and register/”accept” each one before installing DAT/EM software whether or not you 
intend to run every version with DAT/EM Capture. DAT/EM software will install completely for only one of them, and we don’t know 
which one until after installation. The files may be copied manually to the others. Contact DAT/EM Support for instructions. 

DAT/EM Capture and MapEditor for AutoCAD have the following changes: 

1. DAT/EM version 8.0 is the first version to install for AutoCAD 2022 versions. 

2. MapEditor’s Touch and Square dialog displays had some settings that displayed over other settings. This was 
visual, and did not affect processing. This is fixed.  (July 20, 2020) 
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DAT/EM Capture for 64-bit MicroStation CONNECT Editions 
This section applies to Capture for 64-bit MicroStation CONNECT Editions (CONNECT). DAT/EM software installs for the 
following CONNECT versions:  

• MicroStation CONNECT Edition Version 1.x Updates 10-15. Note: Update 14 contains a fix for the CONNECT 3D Offset 
function, which improves the results of DAT/EM commands that call it, such as 3DOFFSET and RCENTERLINE. “Update” 
numbers vary for the other products listed below. It is best if they are from a version concurrent with the DAT/EM release date. 

• OpenRoads Designer CONNECT Edition 

• OpenCities Map CONNECT Edition 

• OpenCities Map Enterprise CONNECT Edition 

Certain earlier CONNECT versions may work with DAT/EM software, but are no longer supported. For higher versions and 
update numbers released after the DAT/EM release or software build date, contact DAT/EM Support for information. 

Starting March 24, 2020, DAT/EM software will install for CONNECT version values greater than 100000000 and less 
than 109900000 with a ProgramPath anywhere under the Software\Bentley\Installed_Products key in the registry. If 
your CONNECT version has a number older than this, we suggest updating it. Despite installing for some rather old 
versions, we do not guarantee Capture will work with them if CONNECT itself has bugs in functions that the DAT/EM 
applications access. In that case, please update the CONNECT version and then reinstall DAT/EM software. 

General information about Capture for MicroStation CONNECT: 

• DAT/EM v.8.0 is the first release version of Capture and MapEditor for MicroStation CONNECT. 

• There are a few commands that were in previous DAT/EM versions for 32-bit MicroStation that have not been 
activated for CONNECT as of the release of v.8.0. Some of them may be activated during the next development 
cycle. Any Capture or MapEditor that has active support is eligible for the next version betas. Contact DAT/EM 
Support if you would like a beta to try any newer command additions. 

• The DAT/EM Keypad Controller communicates with MicroStation CONNECT and uses the same keypad overlay 
as the 32-bit versions of MicroStation, with the exception of needing quotation marks around layer names that 
contain spaces (see table below). 

The following table shows some similarities and differences between Capture/MapEditor for 32- and 64-bit MicroStation: 

 

Is this true? 32-bit MicroStation 64-bit MicroStation 

MS_DGNAPPS is used to load .cfg files 
automatically from “C:\Program Files 
<(x86)>\Bentley\<MicroStation version 
name>\MicroStation\config\appl”.  

Yes Yes 

MS_DGNAPPS must not be modified to 
become a “User” variable, because that 
prevents properly loading the .cfg files. 

Yes Yes 

The CAD Enabler tool sets .cfg files to 
hidden (read only) or not hidden status. 

Yes No. Unlike 32-bit MicroStation versions, 64-bit 
MicroStation versions load all .cfg files, 
whether they are hidden (read only) or not. For 
64-bit MicroStation versions, DAT/EM 
Administration Tool > CAD Enabler toggles 
the extension between .cfg and .HIDEcfgHIDE 
to toggle loading. (See “DAT/EM Administration 
Tool *New!*” on page 3.) 

Menus are provided as toolbars and pull- Yes No 
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down menus in a file called: 
C:\ProgramData\Bentley\<MicroStation 
version name>\WorkSpace\Interfaces\ 
MicroStation\default\ustn.m33” 

Menus are provided as ribbon workflows 
located in .dgnlib files. The DAT/EM .cfg 
files set MS_GUIDGNLIBLIST to point to 
the folder that contains the DAT/EM .dgnlib 
files, so that they will load automatically. 

No Yes. The ribbon menu files are in “C:\Program 
Files\Datem Software\MicroStation\Connect” 
and are called: 

• DATEM_MapEditor.dgnlib 
• DATEM_Capture.dgnlib 
• DATEM_Common.dgnlib 
• DATEM_DTM.dgnlib 

Each file contains a ribbon workflow for a 
single DAT/EM .ma application. All four are 
provided with Summit Professional; fewer for 
other products or Lite products. 

DAT/EM Keypad Controller .dkf file 
commands that set a level require quotes 
around level names that contain spaces. 

No Yes. You will need to edit your Keypad .dkf file 
for any level name that contains spaces. 
Example: LV=”Level With Spaces”{RET} 

Tentative point event notifications allow 
DAT/EM superimposition to show tentative 
point text and markers. 

Yes No. An early 8.1 beta may include this 
functionality. 

 
 

DAT/EM Capture and MapEditor for MicroStation (32-bit versions) 
Changes apply to Capture for MicroStation for 32-bit MicroStation versions. DAT/EM software installs for the following 32-bit 
MicroStation versions:  

• MicroStation V8* and V8 2004 Edition*: Version should be 08.05.00.34 or higher. 

• MicroStation XM*: Version should be 08.09.04.88 or higher. 

• MicroStation V8i and V8i-based products in SelectSeries numbers 3*, 4*, and 10 (SS10 recommended). DAT/EM 
software may install for SelectSeries 1 and 2 in some of the products, but those SelectSeries versions are not 
recommended. The V8i and V8i-based products are V8i, Bentley Map, Map Enterprise, PowerView, Map PowerView, 
Power GeoPak**, and PowerCivil. 

If you upgrade to a higher Select Series number, you must reinstall DAT/EM software after installing the Series upgrade.  

DAT/EM will install for all supported versions of MicroStation (also including 64-bit CONNECT products) that are present on 
the computer at the time of the DAT/EM installation. 
 
*Note about all 32-bit MicroStation versions up to SelectSeries 4: Be aware of the situation! DAT/EM v.8.0 is only 
supported on Windows 8.1 and Windows 10 (Windows 10 recommended). The only 32-bit MicroStation version that Bentley 
officially supports on Windows 10 at this time is SelectSeries 10. Therefore, DAT/EM is in the difficult position of supporting 
more 32-bit MicroStation versions than Bentley itself supports. DAT/EM will continue to support V8, V8 2004 Edition, XM, and 
the older SelectSeries versions as long as possible; however, if Bentley stops allowing DAT/EM to license them for our 
development environments, then we will not be able to compile for them any longer. If that happens, we will be forced to drop 
installation and support for all 32-bit MicroStation versions except SelectSeries 10. This could happen at any time during our 
next version development cycle. 
 
**Note about Power GeoPak Select Series 3: DAT/EM Software installs for Power GeoPak SS3, but has initial loading 
conflicts that affect the GeoPak and DAT/EM menus. Bentley has offered a workaround for this issue, but DAT/EM doesn’t 
think it’s worth the time. Please upgrade to Power GeoPak SelectSeries 10. 
Note about Power GeoPak Select Series 4 (which actually contains SelectSeries 3 in conflict with its name): This 
product seems to be more successful running together with DAT/EM applications. There still could be issues. Please upgrade 
to Power GeoPak SelectSeries 10. 
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DAT/EM Capture and MapEditor for 32-bit MicroStation versions have the following changes: 

1. Undo following MicroStation’s PLACE SMARTLINE command could sometimes leave a “ghost” line in Summit’s 
superimposition. This is fixed.  (January 25, 2021) 

2. CHECKATTRIBUTES has enhanced error checking so that it will not crash when configured for symbology-based 
verification. (February 23, 2021) 

3. CLEARLEVELS had a display issue, which is now fixed. (May 28, 2021) 

4. The DATEM COORDS (coordinate and SNAPZ display) dialog was so small, the “snapz” display could be cut off 
and there was no area in the title bar that would work to grab it and drag it to a different screen position. It is now 
wider, displays “snapz” and the elevation in full, and can be moved. (April 15, 2021) 

5. DTMEDIT enhancements include the following: 1) the Fence button has been replaced with an Apply Fence 
checkbox. The previous version’s Fence pushbutton used to add elements inside a fence to the processing list. 
The new Apply Fence checkbox is aligned with other commands: If set, it will limit processing based on the range 
and settings for an active fence. 2) Dialog settings are better synchronized to prevent configuration loss.  (July 28, 
2020) 

 
DTMEDIT’s fence option has changed to Apply Fence 

 
If a fence does not exist when the option is on, a message appears 
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6. ELINE now simplifies its result to be non-complex when possible, or to have the least possible number of 
component strings when a complex result is required. (April 19, 2021) 

7. PATTERN and PATTERN INTERIOR (MEPATTERN, MEPATTERNINTERIOR) and ROAD (see also ROAD 
section below) have several changes. DAT/EM’s commands that patterned elements were not following Bentley 
conventions for marking patterns and associated elements. This caused both DAT/EM’s unpatterning commands 
and Bentley’s delete pattern commands to fail or reject elements patterned by DAT/EM tools. DAT/EM’s 
patterning tools now follow Bentley patterning conventions, as well as the additional changes: (December 17, 2020 and 
January 14, 2021) 

a. The pattern and unpattern scanners were not checking for deleted elements or handling other common 
errors, which could cause a crash. 

b. The unpattern element scan was rejecting all elements that were not in the linear pattern class. This 
check is appropriate for the pattern (an appropriate check takes place later on), but not the element 
(selection set member) that is patterned. 

c. Unpattern was rejecting all elements that were not part of a graphic group. This is no longer a 
requirement and the software will now work whether or not the elements are part of a graphic group. 

d. MEPATTERNINTERIOR code was updated to handle clipping/patterning shape elements. 

8. Replace Cell (MEREPLACECELL) has the following changes: (April 23, 2021) 

a. Replace Cell (MEREPLACECELL) has new Relative Fence option.  

 
Replace Cell has a new option to process by fence 

If you want to check on Relative Fence, set the active MicroStation fence mode before running Replace 
Cell. It will only apply to cells relative to the active MicroStation fence settings: 
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The active MicroStation fence mode applies to the Relative Fence setting in Replace Cell 

b. Replace Cell (MEREPLACECELL) has increased error handling for cases such as having no cells in the 
file, no cell library attached, or an empty list box. 

 

9. ROAD and ROAD SETTINGS have the following changes: (October 2, 2020) 

a. RCFG (road configuration) files made in earlier versions of DAT/EM software were not loaded correctly 
and errors could occur. Error handling and reporting for old RCFG files was improved. The “Snap Ends 
within” checkbox and “Tol[tolerance]” values were not in the old format files. These parameters have been 
added and a “Version 2” appears in the RCFG comments section. If an old file is read, a message will 
appear unless the user has previously chosen to suppress it. 

Note: It is easy to replace the old RCFG with the new format: First load the old RCFG, then make the 
new “Snap Ends within” and “Tol” settings, then use “Save” to save the settings to the new file format. 

b. A “ghost element” (invisible fragment of an element) on the Default level could be left after running ROAD 
for the first time in the MicroStation session with an old-format RCFG file loaded. This partial element 
could be invisible, but would respond to deletion with the MEDELETE command. There are new checks 
to make sure such a ghost element will not be made.  (October 2, 2020) 

c. A bad column sort result was detected when clicking the offset column title in ROAD SETTINGS. Either 
nothing would happen or MicroStation V8i SelectSeries 10 would crash. The column sort was removed to 
avoid the problem, since it could not be fixed by DAT/EM.  (October 5, 2020) 

d. The patterning options in ROAD were updated to follow Bentley patterning conventions. See also the 
PATTERN section above.  (January 14, 2021) 

10. MELSCALE, which runs MESCALE “last” using the most recent settings, but without showing the dialog, was 
missing from the command dispatch. The command is now available. (February 23, 2021) 

11. The DAT/EM superimposition (SI) application would crash when attempting to send an SI UPDATE on type 11 
curve fragments that had only two or three vertices. SI Updates now successfully transfer these curve fragments. 
(August 5, 2021) 

12. XYINSERT can now add a vertex after the end point of a linear element. Previously, it would add a vertex before 
the first vertex and in between any two vertices, but not after the end vertex.  (August 18, 2020) 

13. XYZIN could place a graphic cell with cell header information that was set to the Point cell attributes settings. 
This is fixed so that graphic cells will properly keep their own level and attributes definitions, and the Point cell 
attributes settings will only apply to point cells.  (July 7, 2021) 
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DAT/EM Capture for Blue Marble Global Mapper 
Changes apply to Capture for Global Mapper. DAT/EM Capture for Global Mapper is supported for the following Global 
Mapper versions: 

• 17.1.2 or higher 

• 18.x – 22.x up to the time of the DAT/EM v.8.0 build date. Please ask DAT/EM Support whether later versions are compatible. 

Notice: If you use DAT/EM Capture for Global Mapper, please contact support@datem.com or your reseller immediately 
for a quote for a Stacked Capture for Global Mapper. Starting in July 2020, v.8.0 beta versions will need a licensed 
Stacked Capture for Global Mapper and this will need a WriteLock to add it to the hardware lock. This is to help offset the 
extra cost that Blue Marble charges DAT/EM to include their license to use their Global Mapper SDK in DAT/EM software. 

Advice for enabling and disabling the DAT/EM Capture extension for Blue Marble Global Mapper: 

DAT/EM Software installs the Global Mapper Extension, but leaves it unregistered in Global Mapper by default. 
To use the extension, close Global Mapper, select Windows Start > Datem Software group > right click on 
DAT/EM Administration Tool > More > Run as Administrator. Set CAD/GIS Package=Global Mapper, 
Action=Capture, Apply. Or, to disable at any time, set it to Action=Disable, Apply. 

 
To register/enable or unregister/disable, use the DAT/EM Administration Tool’s CAD Enabler 

mailto:support@datem.com
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Alternatively, you may toggle the extension from the Global Mapper > Help menu > License Manager. 
Note that it is correct to be called “DAT/EM Capture for Global Mapper 17 n-bit”. This file is the same for 
17.x to 22.x versions matching the supported versions listed above. 

 
The DAT/EM Capture extension may be toggled from the Global Mapper License Manager dialog 

1. DAT/EM Capture for Global Mapper will now install for Global Mapper v.22.x up to the date of the DAT/EM v.8.0 
release. 

2. Stacked Capture for Global Mapper is now a locked DAT/EM product. Previously, if Blue Marble Global Mapper 
was found on the computer, the DAT/EM Capture extension would be installed for it. There will be a small 
Stacked Capture for Global Mapper and annual Support and Maintenance cost for it. With a Stacked Capture for 
Global Mapper order, DAT/EM will provide a WriteLock executable and a new installation keycode to enable 
Capture for Global Mapper. Please contact your DAT/EM sales representative or reseller to discuss Capture for 
Global Mapper activation. 

 

 

-End- 
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