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The following changes have been made to DAT/EM products for release version 8.2. If you have questions about version 
8.2 or requests for new development, contact DAT/EM Support at  support@datem.com. 
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Operating Systems and Microsoft Updates 
DAT/EM software no longer supports 32-bit operating systems. Any reference to an OS in the remainder of this 
document refers to the 64-bit version of that OS only. 

DAT/EM Release version 8.2 is supported on the following operating system: 

• Windows 11 Professional and Enterprise. 

• Windows 10 Professional and Enterprise. 

Notes: 

o DAT/EM generally recommends installing all Windows updates; however, if you are not sure whether your stereo 
settings will still work after a major update, please contact DAT/EM Support for information. 

o DAT/EM software does not work with Windows Home Edition or LTSC (Long-Term Servicing Channel), formerly 
known as LTSB (Long-Term Servicing Branch). 

 

DAT/EM Software Installation 
1. DAT/EM Setup no longer asks about obsolete Polytel keypad hardware. It now only asks, “Would you like to 

launch DAT/EM Keypad on Startup? (Yes/No).” The DAT/EM Keypad application is always, as it was before, 
but will be added to the Windows startup applications only if you choose Yes. (April 4, 2023) 

2. There is a new Prerequisites file called “Datem_PreReqs_blt_11_29_2022.exe” (from 29 November 2022). It 
contains the same Sentinel version 7.7.1 as the previous prerequisites and version 8.1 Setup installations, but it 
has new Microsoft C++ redistribution packages and Visual Studio 2022 added. If needed to install alone on a 
network lock server, download: https://datemsystems.com/down/Datem_PreReqs_blt_11_29_2022.exe (no 
password required). (November 29, 2022) 

 
3. Installation for 64-bit MicroStation with Summit Lite Edition will no longer place the unlicensed DTM .ma 

application and try to load it. (October 20, 2023) 

Hardware Locks/Dongles 
Install Microsoft Updates before applying lock reset programs. Network licensing should have the same Sentinel driver 
version on both the lock server and the local workstations running the software. 
 

1. The Thales Sentinel driver version 7.7.1 is provided with DAT/EM version 8.2. This is the same version that was 
supplied with v.8.1, and an update from the one provided in v.8.0. (2022) 
 
Sentinel Driver on Network Lock Servers: If you have a network lock on a network server, DAT/EM strongly 
advises you to install Sentinel 7.7.1 on the network lock server to match the version on the DAT/EM workstations. 
DAT/EM provides a convenient prerequisites setup file that installs the required Microsoft C++ redistribution files 
and the Sentinel 7.7.1 driver: 

• Download it from www.datem.com > Support > Downloads > Prerequisites > “DAT/EM 
Prerequisites … Sentinel 7.7.1 …” 

• Answer “Yes” to Sentinel’s firewall question. 
• Reboot the server after installation. 

Please do not skip the update for the network lock server. The newer Sentinel driver works better, and the 
best communication can be expected when the Sentinel versions match.  
 
 

https://datemsystems.com/down/Datem_PreReqs_blt_11_29_2022.exe
http://www.datem.com/
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DAT/EM Virtual Reality (VR) 
The following changes have been made DAT/EM Virtual Reality (VR): 

1. The cursor in VR will now be positioned correctly for all Windows Display Settings configurations of the physical 
monitors. Previously, the cursor in VR could be offset from its proper position when the midpoints of multiple 
physical monitors were offset vertically or horizontally from each other. (July 26, 2023) 

 

 
The VR cursor will now be positioned correctly when multiple physical 

monitors are vertically or horizontally offset in Windows Display Settings 

 

2. We have confirmation from users that DAT/EM VR works with the Meta Quest 3 headset. (October 18, 2023) 

 

DAT/EM Administration Tool 
The following changes have been made to the DAT/EM Administration Tool: 

 
1. The DAT/EM Administration Tool will show the result of running CAD Enabler on ArcGIS Pro.  (March 13, 2023) 

 
2. In the CAD Enabler tool, when registering the extension for ArcGIS Pro, if the ArcGIS Pro installation folder is not 

found listed in the HK Local Machine registry key, it will then look in HK Current User. This is to accommodate the 
difference between ArcGIS Pro installations for all users or only for a single user login.  (March 13, 2023) 
 

3. The Check for Updates tool can now download the next version’s development betas. DAT/EM Support will send 
the download credentials on request for supported licenses.  (March 13, 2023) 
 

4. The Sentinel tool has an added button: Reset prereqs installed state. This clears DATEM’s registry key that 
prevents the same version of the Prerequisites Setup file (Microsoft C++ redistribution files and Sentinel driver) 
from attempting to install the same versions again. Use this together with Reset Sentinel installed state after 
either Prerequisites or DAT/EM Setup were canceled or otherwise failed to complete their installation process.  
(September 13, 2023) 
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Point, Image, and Vector File Formats (Affecting Multiple DAT/EM Applications) 
DAT/EM applications read a variety of file formats that contain points, images, and vectors. The code is shared among 
several DAT/EM applications, so when one can read a certain format, others can, too. The following changes have been 
made to the list of supported formats: 

1. DAT/EM Image Creator can now read and write COG “Cloud Optimized GeoTiff” format. COG is a special 
GeoTiff. When writing COG, Image Creator will use *.tif for the file name extension; however, when DAT/EM 
applications read COG, then extension may be either .tif or .cog. The GDAL library is used to create the COG 
using all the GDAL defaults, including LZW compression, so the user will not be offered a compression option or 
scale. There is only one user option that affects the output: Write as BigTiff on or off. (November 4. 2022) 

 
Image Creator can now output COG 

To see if a .TIF file is really COG or not, use “Image Information”  in any DAT/EM applications that offer it, 
such as Summit Evolution, DAT/EM Image Viewer, and Image Creator. 

 
Image Information showing COG in the File Type display 

The concern with cloud-based imagery has always been whether it can be fast enough to draw image tiles. A beta 
tester tried Summit referencing images in COG format from Google Drive and reported it worked, “…as normal.” 
We will not be performing rigorous speed tests for COG format, because speed is highly dependent on Internet 
service and other factors. If you try COG format from a cloud source, let us know how you found the performance. 



DRAFT / DEVELOPMENT - DAT/EM Systems International RELEASE 8.2 Release Notes 
 

Page 5 of 48 
 

2. DAT/EM applications now read and write JPEG XL (JXL) image format and compression. JPEG XL is a newer 
format released by the Joint Photographic Experts Group. JPEG XL supports both lossy and lossless 
compression options. Like JPG before it, “JXL” can be either the name of the file format (.jxl) or the compression 
standard used inside another file format, such as a .tif. (November 4, 2022) 

• DAT/EM uses the GDAL library to read and write JXL images and compression. 

• DAT/EM applications that open and display imagery, such as Summit Evolution and DAT/EM Image 
Viewer, will read JXL automatically when it is found in the file and/or compression. 

• DAT/EM Image Creator can now both read and write JXL and JXL compression. DAT/EM Image 
Creator has a new JXL compression option and a Lossless checkbox for Type = TIF, SMTI, and 
New TIF & PYR output. When Lossless is unchecked, the user can set the amount of lossy 
compression using the slider; when Lossless is checked on, the lossless JXL compression type is 
used and the slider is not available. 

 
New JXL compression and Lossless compression option in Image Creator 

Note: If you intend to output JXL imagery or compression for use by a third-party application, first be sure 
the application supports JXL. 

 

DAT/EM Keypad 
There are no changes to the DAT/EM Keypad products. 
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Coordinate Transformations and Elevation Database 
There are no changes to the elevation database installation file built in 2015 found here: 
http://datemsystems.com/down/SetupElevationModels%20blt%2003%2015%202015.exe. If you already installed that file 
with previous DAT/EM versions, you do not need to reinstall it. Any changes have been added to the DAT/EM setup 
installation, so that you do not need a new, separate Elevation Database file. 

There are newer files and changes, but they are all included in the main DAT/EM software installation: 

1. The Blue Marble libraries licensed and included in DAT/EM software are updated to match the Blue Marble 
versions available as of April 2023. (April 2023) 

 

DAT/EM Stereo Viewer 
There are no specific changes to the DAT/EM Stereo Viewer for v.8.2; however, the image file format changes listed 
above may apply to it. 

 

Summit Evolution 
The following changes have been made to Summit Evolution (Summit) and the applications that are provided with it.  

 
General Summit Evolution Subjects 

1. Markout Exclusion Areas is a new tool in Summit Evolution Professional Edition. It inputs an existing Summit 
project referencing original raw images and a CAD/GIS file containing 3D polygons to define markout (also known 
as “mask”) areas. It generates a new set of partially marked-out raw images and a new Summit project that 
references the new images. (April 5, 2023) 

Marking out (or masking) has typically been done to orthophotos in later processing stages; with Markout 
Exclusion Areas, it can be done to raw imagery, so that the result is still a stereo raw imagery project. This 
enables individuals who have lower security clearances to view and digitize in stereo in the remaining, unmarked 
parts of the stereo models. 

  
Example 1, a.) 3D Markout Exclusion Area polygons drawn around sites in the original 
stereo raw image models (shown rotated to the stereo model’s kappa and zoomed in) 

http://datemsystems.com/down/SetupElevationModels%20blt%2003%2015%202015.exe
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Example 1, b.) Resulting marked-out left and right images shown separately in DAT/EM Viewer windows. 

These two images make a stereo model in the resulting marked-out Summit project. 

 
Example 2: 3D Markout Exclusion Area results based on building polygons 

(This shows a regenerated raw image that is part of a stereo pair. It is not an orthophoto.) 

Note: An image that has either no orientation or no polygon coverage will simply be copied. To prevent copies 
from being made by mistake, DAT/EM recommends you reserve time to do quality control checks at various 
stages: In the original Summit project, in the polygon distribution, for polygon integrity (such as to find unclosed 
polylines in AutoCAD format), and in the final marked-out project. There are some hints below for various checks. 
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To use the new tool, select Summit Professional > Imagery > Markout exclusion areas. 

 
New Markout exclusion areas option on the Imagery menu 

 
New Markout Exclusion Areas tool dialog 

Make settings in the dialog and process the marked-out imagery: 

• Select Summit project: Browse for any Summit .smtxml project. 

Note: The project must be complete. The paths to referenced images and camera(s) must be current. The 
project’s models must have full orientation and be able to show “Ground” coordinates in the lower right 
corner of Summit’s display when each model is open. 

Note: Any Summit project type will work to generate the marked-out images; however, projects with 
images that contain embedded orientation information, such PCI/CATALYST PIX imagery and satellite 
images with embedded RPC information, will not write the embedded information into the marked-out 
images. For ADS40-format projects, it will make a new marked-out image set that may be substituted for 
the original images, but it will not make copies of the SUP, ODF, ODF.ADJ, or CAM files. 
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Note: Technically, even a Summit “Orthophoto Feature Collection” project will work, but the tool was not 
especially designed for rewriting orthophotos. It will still retain the geographic information and the marked-
out image will still be an orthophoto; however, the marked area applies to the whole image. The results 
may look strange in a rotated orthophoto that has background color and for polygon input over the 
background color area. Example: 

 
Example result of the Markout Exclusion Areas tool on a rotated orthophoto that has exclusion polygons 

in the background color area. It  was not especially designed to run on orthophotos. It was designed to 
work best with raw images in a Summit stereo project. 

• Select CAD file of exclusion areas: A CAD file that has the 3D exclusion closed polyline/shape/polygon 
areas. Formats accepted: DWG, DGN, DXF, and SHP. The term for a polygon varies depending on the 
source CAD/GIS, but we will refer to them all as “polygons” in these instructions. 

Note: If the polygons are only 2D (x,y), then you will need to make them 3D (x,y,z) with a elevation source 
(DTM/DEM file) and one of DAT/EM’s ELEVATE commands or a third-party drape function. Having 
elevation in the polygons is essential. 

Note: The CAD file should only include the polygons to be used for marking out. The interior of all 
polygons on all layers/levels will be processed as markout areas. For simplicity, the tool does not offer 
layer selection. 

Note: You may optionally use the original Summit project and DAT/EM Capture for CAD/GIS or Summit’s 
built-in DAT/EM Drawing Tools to draw the polygons in 3D. 

Note: Optionally use DAT/EM MapEditor for AutoCAD or MicroStation to ensure all the polygons are 
closed polylines or are shapes.  

Note: Optionally perform a Quality Control (QC) check of the polygons and/or the final, marked-out 
images by opening the CAD/GIS file in AutoCAD, MicroStation, or ArcGIS (whichever one is provided with 
your Summit Professional). Use the XYZOUT or VISIT tool to generate a Visit file of the starting point of 
each polygon in the file. Use this Visit file in VISIT later to check the input polygons or look at the marked-
out areas in the new project. If you have questions about these tools, please ask DAT/EM Support. As an 
alternative, use an (x,y,z) list of the polygon locations and Summit’s Point Collector tool to visit the 
locations in Summit (without CAD/GIS). 
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• Select destination folder for new images: The marked-out images and new Summit project will be 
written to this folder. The Summit project is almost a copy of the original, except it references the newly 
generated, marked-out images. 

• Color: Select the markout color, which will fill in the polygon areas in the output images. The default is 
pure black. We suggest you use a color that is not likely to be found in nature or in human construction – 
such as magenta, pure white, or pure black -- so it will not be the same color as any pixel colors 
remaining in unmarked areas. 

• TIF image generation options: Choose specific COG or TIF format options. Notes: 

o If you turn on Jpeg compression for 4- or more-band imagery, the output will be 3-band imagery. 
The JPEG compression standard does not support more than 3 bands. If you want to retain 4 or 
more bands in a TIF, do not turn on JPEG compression. 

o COG has lossless compression and can be used for any number of bands. With COG, all images 
will be 3-band or greater. Gray single-band images will become color. 

o Check on Write as Big Tiff for TIF output if the output images are likely to exceed ~4.2GB. You 
can use the original image size as a guide for the BigTiff setting, but keep in mind that if the input 
image is greatly compressed and the output image is not compressed, the output image could be 
larger than the input image. If you are not sure, try one model as a test. 

o If the output image has more than 3 bands, the markout color in 4th and higher bands will be set 
to 0 in those bands. Only the first 3 (RGB) bands can be set to the color you selected in Color. If 
you need to use or set higher bands to a color other than 0, contact DAT/EM Support for 
information on rewriting the image with DAT/EM Image Creator. 

• Select Process. The algorithm will convert Ground to Pixel for each polygon using the stereo model. If 
any polygon is on the image, it will regenerate the image using the pixel version of the polygons to mark 
out the image. If no polygons are found on the image (or the image is missing orientation!), then it will 
only be copied. 

Note: A QC check is suggested to make sure the imagery has been properly marked out. Open the new 
project in Summit Professional. Visit the polygon locations using an automatic move tool such as 
Summit’s Point Collector or Capture’s VISIT. 
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2. Superimposition (SI) rubber band color and appearance have more custom settings: (December 13, 2022) 

a. Summit > Tools > Options > SI tab > Rubber banding width, Dashed, and Invert background options 
are new. These are various methods to help you to better see the rubber band against a variety of 
background colors and textures. 

 
New settings added for the superimposition rubber band 

 

   
Example of the rubber band set to a single color (pink), width of 3, and Dashed 

 

   
Example of the rubber band set to Invert background 
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The inverted rubber band has multiple contrasting colors over multiple background colors 

b. Button Manager has a new Rubber band Color type. This lets you use a button to scroll through a list of 
custom rubber band colors. Every time you press the button, the next-listed rubber band color will be 
applied, even during active drawing. The syntax for the Button Manager Action color list is: 

R1,G1,B1:R2,G2,B2:R3,G3,B3:…Rn,Gn,Bn  

…where “n” is the number of colors in your list. These are 8-bit values, so the values go from 0 to 255. A 
comma ,  character separates the color values. A colon :  character separates the color sets.  

 
New Rubber band Color type in Button Manager 



DRAFT / DEVELOPMENT - DAT/EM Systems International RELEASE 8.2 Release Notes 
 

Page 13 of 48 
 

To use: 

 Determine the 8-bit RGB values of the rubber band colors you wish to set. If desired, use the 
Rubber banding color picker in Summit > Tools > Options > SI tab > Rubber banding color 
picker > More Colors button – or any color picker in any dialog, or an Internet search such as 
“Yellow RGB values” -- to find the RGB values of colors you like.  

 
 For example, if you like red, yellow, black, and pink, these colors are:  

o red=255,0,0 

o yellow=255,255,0 

o black=0,0,0 

o pink=233,240,210 

 Start Summit > Tools > Button Manager and set a button to Type=Rubber band Color. 

 Set Action=255,0,0:255,255,0:0,0,0:233,240,210  

 During drawing, use this button whenever you would like to set the next-listed rubber band color. 
For example, you could use it when the image colors change from dark to light, so that you set a 
better-contrasting rubber band color.  
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3. Summit > Imagery > Epipolar Generation has a new option to output .COG format. 
 

 
New option to output COG format from the Epipolar Creation dialog 

 

4. There is a new import tool for Vexcel UltraMap .eo Exterior Orientation (EO) files. To use, select Summit > File > 
Import > Vexcel UltraMap EO file. (October 5 and November 6, 2023) 

 
New Summit > File > Import > Vexcel UltraMap EO file option 
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Vexcel UltraMap Import dialog (left) with addition of Rotation angles (right) (November 6, 2023) 

 First, select the .eo file. Either use Add Images to browse or drag and drop the images into the dialog. 
Add only the images you want, for example, this could be the Nadir images, or Left and Right images, or 
even all the images from all the camera directions. 

 Next choose a Rotation (November 6, 2023). The user must know the rotation angle and horizon up setting 
used in UltraMap; this information does not exist in the .eo file, so DAT/EM cannot set it automatically. 

 The images will be matched automatically to the respective camera and exterior orientation information in 
the .eo file. The exterior angles are converted from YXZ to XYZ Euler angles. The matching is done by 
using the image names to find the corresponding exterior values and camera information in the .eo file. 

 Select an output folder and a name for the new Summit .smtxml project. 

 Select Generate Project. It will make a Summit project and all the camera files. There will be multiple 
camera files, which match each of the camera files for each of the camera heads listed in the .eo file. 

Once the resulting project is open in Summit, select the Project window > Models tab > Generate Models. Set 
model generation criteria that will work well for the flight layout, for example: 
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Generate models for the imported .eo project 

The resulting project will look something like this: 

 
Example of imported Vexcel .eo project with models generated 

(Optional) If you would like to work with the different camera head images in separate Groups, typically also with 
multiple viewports, use the Project window > Groups tab to generate groups. Make a separate Group for each of 
the images from each of the camera heads. Then use Summit > View > Multiple Viewports to set the number of 
viewports to the number of Groups you made. Drag a model from each Group on the Groups tab into each 
viewport. Models will only automatically change within the open Group in the viewport if a model from a Group is 
open in the viewport. For example, if you drag a Forward Group-tab model into a viewport, that viewport will only 
change models to other Forward models. 
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5. The Summit > Orientation > Tie Points > Quick Points > Label using image names option will now replace 
any spaces in the image names with an underscore _ character. Previously, there were two problems with this 
option when the project images contained spaces, 1) Only the part of the image name up to and including the first 
space was added to the point name, and 2) Tie Points Bundle Adjustment would not run if the point names 
contained any spaces. (December 15, 2022) 

6. The Summit > Help > Release Information option has been replaced by Help > DAT/EM Administration Tool. 
The Administration Tool shows more detailed release information than the stand-alone Release Information 
application. (November 9, 2022) 

7. 50/50 Demo Mode is a new option in Summit > Tools >  Options >  Main View > Anaglyph mode. It is 
designed to demonstrate that there are two naturally colored images when showing Summit without a stereo 
display. It is not a true anaglyph mode and there are no special glasses for it; indeed, there is no way to see 
stereo in 50/50 Demo Mode. It might be used to show the concept of stereo during an Internet webinar, for 
example. (June 5, 2023) 

Note: This mode can also be used for screen captures, but for advanced screen capture options, see the special 
stereo-, project-, and model-specific options in Summit > File > Print. 

 
50/50 Demo mode can demonstrate that there are two naturally colored images in a non-stereo display 

8. Summit could sometimes send only two vertices of a triangle to the video card. Most video cards would ignore or 
correct this and would not have a problem, but it had the potential of causing a crash in some video cards. Three 
vertices are now sent to the video card for all triangles. (October 5,2023) 

 
Terrain Project Tools (except Point Cloud) 

9. Terrain Projects and Terrain Project-related subjects (except Point Cloud) have the following changes. Note: Point 
Cloud application items are in the next section of this document. 

a. The Terrain Project creation tool has an additional launch option, Windows Start > Datem Software > 
Create Terrain Project. (November 21,2022) 

b. The display of surrounding points would not work if Terrain > Terrain Project Options > Clip Radius 
was checked on. This is fixed. (November 3, 2023) 
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Point Cloud Application 

10. Point Cloud has the following changes: 

a. Point Cloud now allows you to set how many points will render. It was previously hard coded to 500,000.  
The default is now 1 million and can go up to 5 million. New, recommended video cards may be able to 
easily handle 5 million. Please let DAT/EM Support know if performance degrades, and if so, which 
setting is used and which video card model it is. (December 12, 2022) 

 
New Rendering Points setting in Point Cloud 

 
 

Superimposition 

11. Superimposition (SI) has the following changes: 

Additional CAD/GIS-specific SI changes may appear the Capture sections. 

a. See the SI rubber band enhancements listed above.  

b. Summit > SI > Layer Manager has a new option to Apply to active view only. The active view 
(viewport) is the viewport that currently has the blue title bar. When the setting is on, any settings made in 
the SI Layer Manager apply to that viewport only. (August 1, 2023) 

This setting only works when Summit > View > Viewports > SI objects in all viewports is on. 

This setting is useful when multiple years of imagery are in multiple viewports and the CAD/GIS file 
contains multiple year-named layers. For example, imagine a “Summit Solution File” that has imagery 
from three different years. The images are separated into Groups by year and one year is open in each of 
three viewports. Open the CAD/GIS file that contains all the years’ layers. Set Summit > View > 
Viewports > SI objects in all viewports on. Start Summit > View > Layer Manager and check on the 
Apply to active view only setting. Click on a viewport to give it focus indicated by a blue title bar. Click 
directly on the SI Layer Manager’s Main View layer list. Check on the specific layers for the focus 
viewport. When finished, the settings will be applied in the focus viewport only. Repeat for the remaining 
viewports. 



DRAFT / DEVELOPMENT - DAT/EM Systems International RELEASE 8.2 Release Notes 
 

Page 19 of 48 
 

  
New Apply to active view only setting in the SI Layer Manager 

 
Three viewports with different checked SI layers in each viewport 

Note: These per-viewport settings are temporary. They are not saved in the registry per viewport. Only 
the most recent SI Layer Manager settings will be active in all viewports when Summit is closed and 
reopened. If you restart Summit and want the same per-viewport settings, set them again. 

When Apply to active view only is off, any settings in the SI Layer Manager apply to all viewports. 
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Aerial Projects (traditional, UAS, and imported) 

12. Aerial projects (traditional and UAS) have the following changes: 

a. The Camera Editor for aerial cameras has renamed the 12 parameter distortion method to Coefficients. 
With the addition of B1 and B2, it now has 14 parameters. This matches the method used by PhaseOne 
and Trimble’s Inpho Photogrammetry Suite software. The dialog now looks like this: 

 
“12 parameter” is now “Coefficients” with 14 parameters, adding B1 and B2 

The name inside the Summit camera file has not changed. It is still stored as DISTORTION_12PARAM: 
(with 14 or 12 values following in the file).  

This change is only partially backwards compatible to earlier versions of Summit. Older Summit versions 
will still read the distortion type as the old “12 parameter”, but they will only use the first 12 values, as if B1 
and B2 are 0. Newer Summit versions will always write out all 14 values and will read 12 or 14 parameters; 
if 12 values are in the file, then B1 and B2 will be set to 0. (March 29, 2022) 

  
b. Summit > File > Import > Hexagon or Z/I SSK  can now detect an additional image rotation of 180 

degrees in the imported file set. The angle will be set for the images without rotating the imported point 
measurements. By contrast, if the user set 180 degrees for the images in the Project Edit dialog after 
import, the images and the point measurements would be rotated. (November 20, 2023) 

 
 

Satellite RPC and Epipolar Generation for All Compatible Projects 

13. Satellite RPC projects / Epipolar Generation for all compatible projects have the following changes: 

a. Summit > Imagery > Epipolar Generation previously required that the input project have a coordinate 
system conversion set to the final projected coordinate system. It would then output a Summit 
“EpipolarGen” type project that did not allow you to set any further coordinate conversion. If you wanted a 
different coordinate system than you had originally set, you would have had to reset the output coordinate 
system in the input project and re-run the epipolarization process. For RPC input projects, this meant that 
Summit > Orientation > Coordinate Conversion would be set to convert WGS84 to a projected output 
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system and coordinate conversion was checked on before running Summit > Imagery > Epipolar 
Generation. This is changed so that: (February 10, 2023) 

• Summit > Orientation > Epipolar Generation can be run with an input project that either does or 
does not have a coordinate conversion set. 

• Summit > Orientation > Coordinate Conversion can now be (optionally) set in the output 
EpipolarGen project that is made by Summit > Orientation > Epipolar Generation. 

The changes affect the two existing methods in Summit > Imagery > Epipolar Generation, which are: 

• "RPC piecewise epipolar curve", which only works on RPC orientations. It results in a new project 
with a newly calculated RPC for the new epipolar imagery. 

• “Piecewise epipolar curve, object space”, which is the more generic method. It can work with 
many orientations, including RPC and typical aerial projects. It outputs two new projects: 1) An 
EpipolarGen project, which works by using the original orientation (whether it is RPC, aerial, or 
something else) and contains polynomial information to go from the original pixel to an epipolar 
pixel, something like this: Ground -> original image pixels -> Epipolar image pixels. 2) An RPC 
project, which has "_rpc.smtxml" appended to the filename. Note! DAT/EM software engineers do 
not recommend using this second option, or if you do, check it very carefully. In theory, most models 
could be regenerated using RPC, but this is a possible point of failure, since the RPC is 
recalculated. 

Example 1: You could choose “Piecewise epipolar curve, object space” for a satellite RPC project that 
does not have a coordinate conversion set. This will result in an EpipolarGen project that will be in WGS84 
(default RPC coordinates). In the resulting EpipolarGen project, you can now change the coordinate 
system, for example, into UTM. 

Example 2: You can now have multiple calls to coordinate system changes. For example, let’s say you first 
set the original WGS84 RPC project to output UTM coordinates, then run epipolar generation. In the output 
EpipolarGen project, you set a coordinate conversion from UTM to U.S. State Plane coordinates. This would 
now be allowed and would work, whereas previously, you would have had to reset the input WGS84 RPC 
project to U.S. State Plane and re-run the time-consuming epipolarization process. 
 

b. There is a fix for reading some (not all) of the RPC files provided with Airbus Pleiades NEO sensor 
projects. This was not obvious in the project used for the original development, but was noticeable in 
some newer projects.  (October 24, 2023) 

c. The Epipolar Creation dialog has new Minimum and Maximum Elevation entries. Previously, these 
values were automatically detected based on the RPCs and the elevation from the control file, but they 
were not displayed and could not be modified. DAT/EM received an RPC project where the detection 
could not work for the specific RPC files. To help the process calculate the correct values in most 
projects, add a control file to the project, even if it has only one “fake” Z control with an estimated average 
elevation for the project. The defaults when the dialog starts will be the automatically detected values; if 
they are wrong, enter the correct values. 
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New Minimum and Maximum Elevation entries in Epipolar Creation 

 
 

Project Viewer / Ortho+Mosaic  

14. Project Viewer / Ortho+Mosaic has the following changes: 

a. In Ortho+Mosaic > Image Manager Window > right click menu > Open image in viewer, the path is 
updated to launch the newer 64-bit DAT/EM Image Viewer. (November 10, 2022) 

b. The Images at once setting for the number of images (threads) that can be processed simultaneously 
has increased from 4 to 8. Setting higher numbers may or may not be useful, depending on the 
Input/Output (I/O) speed of the hardware. In DAT/EM's testing, 8 threads were only 5% faster than 4 
threads. Each thread after about 3 or 4 may give increasingly diminishing returns if there is an I/O 
bottleneck. There are more threads being processed, but they are not working as hard, because they 
must wait more for I/O access to be allocated to them. The result is not a big gain in speed (or CPU 
usage), but at the same time, it is not harmful, so you may try it to test the speed on your own hardware. 
At a certain point (probably not much past 8) using more threads will become slower due to context 
switching between threads and more excessive wait states. Based on these concepts and tests, we will 
not consider adding more than 8, even for 16-core processors (as of 2023).  (June 19, 2023) 

 



DRAFT / DEVELOPMENT - DAT/EM Systems International RELEASE 8.2 Release Notes 
 

Page 23 of 48 
 

 
Ortho+Mosaic Images at once (threads) has increased from a maximum of 4 to a maximum of 8 

 
 
 
LandScape 
Landscape has the following changes: 

1. The LandScape > Help > Release Information option has been replaced by Help > DAT/EM Administration 
Tool. The Administration Tool shows more detailed release information than the former stand-alone Release 
Information application. (November 9, 2022) 
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DAT/EM Capture for ArcGIS – 64-bit ArcGIS Pro 
DAT/EM Capture for 64-bit ArcGIS Pro is compatible with versions: 

• ArcGIS Pro versions 3.1.x that were released up to 15 November 2023. 

o Do not use ArcGIS Pro version 3.2.0 or 3.2.1. In 3.2.0, Esri made an initial attempt to implement a 3D input 
device, which takes control of the system mouse and cannot be turned off. DAT/EM reported this issue to 
Esri. Esri did not yet issue a fix as of 3.2.1. DAT/EM will continue to review future versions. 

o For any newer versions, contact support@datem.com to ask whether the version is compatible or to request 
access to DAT/EM v.8.3 beta for supported licenses. 

o If both ArcMap and ArcGIS Pro are installed on the computer, Capture extensions will be installed for both. 
The ArcGIS Pro extension is installed, but not registered automatically. Use the DAT/EM Administration Tool 
> CAD Enabler to activate the extension on demand. DAT/EM recommends to only have one extension 
registered – for ArcMap or ArcGIS Pro – at one time, to prevent taking two licenses if they run at the same 
time and to be sure which application should take input from Summit. 

DAT/EM Capture for ArcGIS Pro has the following changes: 

1. Due to technical differences between ArcGIS Pro version 2.x and 3.0 and again between 3.0 and 3.1, Capture for 
ArcGIS Pro is now only supported for ArcGIS Pro 3.1.x (with “x” as released by Esri within the two weeks before 
the DAT/EM Setup file was compiled). The extension name is called CaptureArcPro3.esriAddinX: (August 17 and 
23, 2023) 

a. ArcGIS Pro 2.x is no longer supported for v.8.2 betas dated after 23 August 2023  

b. ArcGIS Pro 3.0 is no longer supported for v.8.2 betas dated after 17 August 2023.  

c. DAT/EM will not support Esri ArcGIS Pro v.3.2.0 or 3.2.1 due to incompatible ArcGIS Pro behavior that 
DAT/EM reported to Esri. We will wait for a future ArcGIS Pro release to have this fixed so that we may 
continue development.  

For any higher versions as Esri releases them, please contact DAT/EM Support to ask about compatibility. 

2. The DAT/EM extension for ArcGIS Pro is now digitally signed. (October 23, 2023) 

3. ArcGIS Pro uses the COM API, which did not support individual layer indexing until recently. Now that it does, 
Capture for ArcGIS will show individual layer names in Summit > SI > Layer Manager. Users can now turn off 
layers in Summit’s superimposition while those layers are still on for display in ArcGIS Pro. (November 2022) 

4. There is a new DAT/EM Systems setting to toggle superimposition shading inside polygons. (November 2022) 

5. ArcGIS Pro identifies an underlying map as a layer, but it does not name the layer. This caused trouble in 
Summit’s superimposition (SI) “SI Layer Manager,” which queries the ArcGIS Pro for layers with their layer 
names. It could cause various issues in SI, such as (but not limited to) missing SI vectors and blank layer names 
in the SI Layer Manager. A workaround for the missing name is implemented. (February 22, 2023) 

6. There was an error that prevented polygons from being created correctly. This is fixed. (February 28, 2023) 

7. ArcGIS Pro draws overlays based on a grid defined across the map window. Previously, DAT/EM was only 
refreshing that grid when a superimposition (SI) Update was performed. The method is changed to refresh the 
grid any time the map window is reshaped. (March 8, 2023) 

8. ArcGIS Pro could crash if it only had 2D layers and superimposition (SI) was refreshed. This was related to the 
timing of refreshing the SI Layer table for 3D and 2D layers, which did not work when all the layers were 2D. This 
is fixed. (April 3, 2023) 

9. The sketch tools will now draw in superimposition using the correct color instead of black. (August 24, 2023) 

10. The sketch tools will now draw in superimposition using the correct line weight. (October 24, 2023) 

mailto:support@datem.com
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11. The DAT/EM-driven cursor in the ArcGIS Pro view has the following changes: 

a. The cursor location in the ArcGIS Pro view could be offset from the correct Summit location. There were 
multiple problems. The following are changes/workarounds: 

• The cursor could be offset following an ArcGIS Pro window shape change and/or after adding a 
docking window, which also changes the window shape. Since ArcGIS Pro drew its data objects in 
the correct location, but drew its cursor offset from its own data, it appeared that the cursor between 
Summit and ArcGIS Pro were offset from each other. DAT/EM now forces ArcGIS Pro to update its 
view. (March 8, 2023) 

• There could be a cursor offset in ArcGIS Pro due to a monitor having a Windows display scale setting 
other than 100%. At the time of this development with ArcGIS Pro 3.1.1 and older, there is a bug in 
Esri ArcGIS Pro's "WorldToClient" function that only partially takes the scale of the primary monitor 
into account. DAT/EM has added a workaround so that the cursor positions will match no matter how 
the monitors' scales are set. (May 31, 2023) 

Note: There could be more cases where the ArcGIS Pro view needs to be refreshed or sized differently; if 
you notice an offset between Summit and ArcGIS Pro using version 8.2 or an 8.2 beta dated after 1 June 
2023, please contact DAT/EM Support. 

b. The cursor mark is increased size and color contrast. 

c. The Summit cursor may now be used for object selection and clearing a selection when the ArcGIS Pro 
“Select” tools (highlighted below) are active in the following ways:  

1. Use the Summit’s Pick button to select the object under the cursor. 

2. To clear the current selection, use the Summit “Cancel/Reset/Finish” button to pick on the 
same location twice.  

Note: The system mouse will still select objects in the ArcGIS Pro view as described by Esri for the active 
selection tool. (September 21, 2023) 

 

When these ArcGIS Pro select tools are active, the Summit cursor’s Pick button selects 
the object at the cursor, and the double Cancel//Finish button clears the selection  
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12. ARC drawing is done with ArcGIS Pro’s arc sketch tool in combination with DAT/EM Capture Settings’ Stroking 
tab settings to simulate arcs with a series of small segments. The Stroking settings will now be applied correctly to 
create nicer looking simulated arcs. (November 9, 2023)  

13. CLIP SEGMENT is a new tool in Capture for ArcGIS Pro. It removes a series of vertices from a polyline or 
polygon (referred to as the “target object”). If the target object is a closed loop, then the longest part of the target 
object is kept. The first picked point selects both the object to be edited and inserts a vertex that becomes the first 
point in the part to remove. The second picked point is inserted into the target object and all vertices between are 
removed. To clip off the shorter end of a line, pick the second point beyond the end of the line. The tool 
automatically overrides the snap settings if they are not already on. The tool remains active until another tool is 
selected. (August 23, 2023) 

 
Clip Segment 1) Select the first break point on a line or polygon. 

 
Clip Segment 2) On the same line or polygon, select the end of part to remove. To remove the part at the 

end of a line-geometry object, pick beyond the end of the line on the end to remove.  

 
Clip Segment 3) The section is removed and the tool waits for the next clip selections or for another tool to start. 

 

14. The ArcGIS Pro-side DAT/EM Capture Settings > Streaming setting for the Stream digitizing mode now default 
to Streaming Requires Both XY and Angle on. (October 3, 2023) 

15. FIELD UPDATE is a new tool in Capture for ArcGIS Pro 3.x. The non-case-sensitive keyword to use on the 
DAT/EM Keypad and UserCad Button Manager buttons is: (June 30 and September 20, 2023) 

FieldUpdate 
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It is very similar to Field Update in Capture for 32-bit ArcGIS ArcMap, with a few key differences. We will discuss 
these differences here: 

 The biggest difference is that ArcGIS Pro supports multiple objects of the same layer at once. 
When measuring the field values, the Layer, Object Identifier (OID) of the current object, and 
Field name are displayed in the prompt on both the Summit and ArcGIS Pro sides. 

 Field Update has new automatic date and time stamp field options, <Now> and <Today>, which 
fetch the date and/or time stamp at the time the Apply button is used. (Previous versions in 32-bit 
ArcMap did not have these options.) 

 
New automatic fields <Now> and <Today> 

 Export and Import use slightly different file formats than the 32-bit Capture for ArcMap version. 
The File Version is now 2, and the class identifier is the layer name rather than the layer’s COM 
ID. This is a little more flexible than the old method, since you may want to carry values over to 
projects with different, but similar layers. ArcGIS Pro’s Field Update will put up an error if they try 
to load a Version 1 file. 

 

 
To use Field Update: 

 Select one or more objects. If multiple objects are on different layers, the field list will only show the 
field list for the first object found in the selection. (If objects on different layers have different fields you 
want to edit, select them by unique layer later.) If multiple objects are selected and they share the 
same field value when selected, the value will appear in Current Field Value column; if they are 
different, it will display <multiple>. 
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 <multiple> indicates multiple selected objects initially have different field values 

 Select or enter new field values in the New Field Value column. 

o The entered field’s checkbox will select automatically when its New Field Value is changed*. 

* Important! Use the <Enter> or <Tab> keyboard key when finished with the New Field 
Value entry. If the cursor is still at the end of the keyed-in text or if you click into a different 
field, the box will not be checked automatically and the entry will not be applied.  

Fields that have a series of allowed values will offer those values in the field’s pull-down meu 
to the right of the field entry. If a field is longer than the display, hover the system mouse over 
the Current Field Value display and a tool tip will display the full content. For compatible field 
types, automatic or measurement-style fields will be offered, such as <MeasureHeight>, 
which will prompt for a measurement for each selected object after Apply. 

 
Field Update taking entries in the New Field Value column (before Apply) 

 Select Apply on the dialog or use a Keypad or Button Manager button set to the Apply keyword.  

 If any field settings require a measurement, a prompt will appear in the lower area of the dialog; follow 
the prompts to measure the value. Summit will move to each object that requires measurement. If 
multiple objects were selected, each will require a separate measurement for each checked 
measurement-type field. 
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Example of the <MeasureHeight> field prompt after Apply 

The New Field Values will now appear in the Current Field Value column. Unchecked fields remain 
unchanged. The values that were applied remain in the New Field Value column and will be available 
later in the pull-down menu of previously used values (if applicable). 

 
The Current Field Value now shows the fields were applied. 
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As of 20 September 2023, Field Update supports two new automatic fields: <ActiveModel> for string 
fields and <PlotterMean> for double fields (these were previously available in Field Update in 
Capture for 32-bit ArcMap):  

 
New automatic fields <PlotterMean> and <ActiveModel> 

16. RESHAPE FEATURE (DAT/EM version) is a new tool modeled after ArcGIS Pro’s Reshape tool, except that it 
uses the Summit cursor for input and can work with the DAT/EM square, arc, and streaming modes. (October 4-5, 
2023) 

 
The first Summit Button Manager Plotter/Pick button selects the feature being edited and, in the case of multiple 
parts on the feature, which part is being edited (such as an interior or exterior ring of the same feature). It is also 
the first point in the reshape.  

It over-rides the active snap settings for the first point, but uses the active snap settings for all other points. A 
Generic CAD/Undo button will undo the last pick. A Generic CAD/Cancel button completes the edit.  

The non-case-sensitive keyword to use with the DAT/EM Keypad and Button Manager buttons is: 

datem_reshapefeature 

Reshape Feature draws the temporary lines in Summit’s superimposition only. It does not draw them in ArcGIS 
Pro’s view. 

 

 
Reshape Feature 1) Pick the first point on the feature where the reshape will begin 
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Reshape Feature 2) Draw the new edge 

 

 
Reshape Feature 3) Finish using the Cancel/Reset/Finish button 

The tool remains active until another tool is started. 

17. Snapping will now ignore objects on unchecked layers in ArcGIS Pro Contents > List by Snapping. (November 9, 
2023) 

 
Snapping will now ignore objects on unchecked layers in Contents > List by Snapping 
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18. UNDO selected on Summit’s CAD Commands toolbar, a Button Manager button, or from ArcGIS Pro will now 
work properly to undo the last whole tool result or the last vertex in an active sketch. (November 9, 2023) 

19. VIEW LOG is a new tool to display and write operational and error messages. DAT/EM may ask you to use this 
tool to help diagnose problems. The menu in the lower center lets you choose what type of information to view. 
The erase button to the left clears the list. The folder button to the right opens the log file location. Summit’s last 
coordinate appears in the lower right. 

 
New DAT/EM View Log tool to display operational and error messages 

 

20. VISIT is a new tool in Capture for ArcGIS Pro 3.x. Users familiar with VISIT in Capture for 32-bit ArcMap will 
recognize it as the two ArcMap VISIT dialogs combined into one dialog and offering nearly the same functionality. 
The only difference is there is no import wizard for ASCII files in the File input option; it inputs .csv files in x, y, z 
format. (Contact DAT/EM Support if you want us to add an import wizard.) (March 31, 2023) 

VISIT allows you to build a list of coordinates based on objects on a layer, inside a boundary or boundaries, in a 
.csv x,y,z file, or in an active selection. All the points or a random sampling of the points may be added to the list. 
Click on a line in the list to move to the location. Edit, measure, or view at the location.  
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New VISIT tool dialog in Capture for ArcGIS Pro 
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DAT/EM Capture for ArcGIS – 32-bit ArcMap 
This version is compatible with ArcGIS 10.0 (service pack 4), 10.1 (service pack 1), 10.2.x through 10.9.x. 

This version may be compatible with ArcGIS 9.1, 9.2, 9.3 (service pack 1), 9.3.1(service pack 2). BE ADVISED: Testing no longer 
occurs for DAT/EM Capture with ArcGIS 9.x. It still installs for it and no code has been removed, so you may use 9.x as long as it 
continues to work for you. Any issues will not be corrected. ArcGIS 9.x support may be dropped completely in a future release. Please 
continue to make plans to upgrade any remaining ArcGIS 9.x version to 10.x. 

DAT/EM Capture for 32-bit ArcGIS ArcMap has the following changes: 
Capture for ArcGIS (ArcMap) Items 

1. In the ArcMap-side DAT/EM Systems Options > Elevation Fields settings, it will now successfully save the 
ELEVATION field’s checkbox status between ArcMap sessions and ELEVATION can now be deleted from the list. 
(February 21, 2023) 

2. Field Update (and Airfield3D, which is a version of Field Update) have two new automatic field setting options:  
(June 30, 2023) 

a. <Now> adds a date and time stamp to a date-type field upon Field Update Apply. For example, 
6/30/2023 13:15. (Note that .shp shapefiles only store dates, not times, so should use <Today> instead.) 

b. <Today> adds a date stamp to a date-type field upon Field Update Apply. For example, 6/30/2023. (This 
may be used for either a .shp shapefile or database layer that has a date-type field.) 

3. Visit has the following changes: 

a. Visit’s browse button in Select Points > File was inactive. It now correctly opens a browse dialog. (May 17, 
2023) 

b. Visit’s load on start code was not checking to make sure the last layer was a feature layer and/or existed 
before attempting to scan it for points. This is fixed. (September 11, 2023) 

 
Airfield3D (ArcMap) Items 

4. Airfield3D has the following changes: 

a. Airfield3D could cause a crash in ArcMap and/or Summit while accessing data. This is fixed. (December 15, 
2022) 

b. The automatic <Now> and <Today> fields described in the ArcMap Field Update section above also 
appear in Airfield3D dialog, which is a version of Field Update.  (June 30, 2023) 

c. If the "Runway End Designator" on the "Runway Ends" feature is not populated, a message will appear. 
(September 14, 2023) 

d. Dimensions in meters is a new option in the FAA 18B, Part 77, and Part 77 Custom options dialogs. 
When on, the setting scales the surfaces to meters units. When off, units are in U.S. Foot units as called 
for in the FAA specifications. Additionally, Follow lowest surface, which was previously only on the 18b 
settings, is now also on the Part 77 and Part 77 Custom settings options dialogs. When on, where there is 
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a conflict of multiple surfaces being in the same (x,y) location, the lowest surface will be used. When off, 
the highest surface will be used. (March 6 and November 17, 2023) 

 

 
New Dimensions in meters setting in the 18b options 

 
Follow lowest surface and Dimensions in meters settings in the Part 77/Part 77 Custom options 
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DAT/EM Capture and MapEditor for AutoCAD 
DAT/EM Capture and MapEditor for AutoCAD are compatible with the following AutoCAD versions: 

• 32-bit AutoCAD 2004-2008 versions with the latest service packs, provided you can get them to install on your 64-bit 
operating system (OS). DAT/EM no longer tests on 32-bit OS, so these must be running on 64-bit OS. DAT/EM is not 
responsible for helping to install a 32-bit version of AutoCAD on a 64-bit OS and cannot guarantee that this will succeed. 

• 64-bit AutoCAD 2009-2024 versions with the latest service packs. Exception: 64-bit AutoCAD 2008 is not supported. 

When referring to a year/version number in the lists above, it includes AutoCAD, Civil3D, and Map3D. It does not include 
AutoCAD LT, which is a 2D product, and therefore will never work with a 3D cursor. 

Reminders: Install all available AutoCAD service packs and updates before installing DAT/EM software. Run each version of 
AutoCAD to make sure its license is active. Do this for each installed AutoCAD version. 

DAT/EM software will install for multiple AutoCAD products of different year numbers on the same computer; however, it will only 
install for one of any multiple same-year versions. For example, it will install for AutoCAD 2015, 2016, 2017 Civil3D, and Map3D 
2018, because they are all different year versions; however, it will not install for both AutoCAD 2017 and AutoCAD Civil3D 2017 at 
the same time, because they are both the same year. In the case of multiple same-year versions, only one of them will receive the 
DAT/EM files at installation. To activate DAT/EM Capture in all of them, the AutoCAD \datem folder and the DAT/EM wintab driver 
file may be copied from the one that received the files to the other same-year versions. Contact DAT/EM Support for instructions. 

Autodesk Infrastructure Design Suite installs three same-year AutoCAD versions (AutoCAD, Map3D, and Civil3D). Using the rules 
outlined above, you must run each version and register/”accept” each one before installing DAT/EM software even for versions you 
will not use DAT/EM Capture. DAT/EM software will install completely for only one of them, and we do not know which one until 
after installation. The files may be copied manually to the others. Contact DAT/EM Support for instructions. 

DAT/EM Capture and MapEditor for AutoCAD have the following changes: 

1. Version 8.2 is the first version to install and work with AutoCAD 2024. (April 11, 2023)  

2. INS (block insertion) has the following changes:  (November 7, 2022) 

a. INS previously showed a double or “ghost” block in superimposition until an SI Update would clear it. This 
is fixed.  

b. INS now shows a representative block with dynamic graphics in superimposition during block angle 
and/or scale measurement. The actual block design is not available to display before it is placed, so the 
representative block is used as the only possible option. The representative block is approximately a size 
of 1.0 ground unit with center-center justification, which is the recommended size and justification for 
defining blocks to be placed with INS. The purpose of this change is to help select the size and/or angle 
of the block. The actual block design will be shown in superimposition only after the block is inserted into 
the drawing. 
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3. LC (Load Control) and LCF (Load Control from File) have new Offset X and Offset Y text position settings. The 
offsets are the distance from the center of the control block. Enter either positive or negative values in ground 
units. (November 7, 2022) 

 
New LC and LCF Offset X and Offset Y settings to customize the text position 

4. The Selection Sets Editor could crash if you clicked on a list column title with the intention of sorting the list. This 
is fixed.  (July 13, 2023) 

5. SETUP’s map scale setting was not saving to the registry. This is fixed.  (October 25, 2023) 

 

DAT/EM Capture and MapEditor for MicroStation (64-bit versions) 
This section applies to Capture and MapEditor for 64-bit MicroStation CONNECT Editions (CONNECT). DAT/EM software 
installs for the following CONNECT versions:  

• MicroStation 2023 

• MicroStation CONNECT Edition Updates 14-17. Do not use MicroStation CONNECT older than Release 14. “Update” 
numbers vary for the other products listed below. 

• OpenRoads Designer (ORD) CONNECT Edition 

• OpenCities Map Advanced CONNECT Edition 

• OpenCities Map Ultimate CONNECT Edition 

Certain earlier CONNECT versions may work with DAT/EM software, but are no longer supported. For higher versions and 
update numbers released after the DAT/EM release or software build date, contact DAT/EM Support for information. 
 
DAT/EM Capture and MapEditor for 64-bit MicroStation versions have the following changes: 

1. Version 8.2 is the first version to install for MicroStation 2023. (July 18, 2023) 

Note: MicroStation 2023 and any previous CONNECT product can be on the computer at the same time. 
CONNECT does not automatically uninstall when 2023 is installed. DAT/EM software will install for all supported 
32- and 64-bit MicroStation versions it finds on the computer at the time DAT/EM Setup runs. 
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2. More commands that were previously available only for 32-bit MicroStation have been added for 64-bit: 
 

Added Commands for 64-bit MicroStation Description 
CHCELL Replace cells with elevation text. 
CLIPCELL, CLIPCELL LAST To delete point elements (such as DTM mass 

points) from the area covered by cells. 
DATEM PROFILE Moves Summit automatically along an element as 

the user digitizes elevation points. 
DEPRESSION Find depression contours 
DTMDISTRIBUTOR Redistribute or combine DTM input (also known as 

DSM, DEM, point cloud, or points objects, 
depending on source) into a reconfigured file. 

ROADCLIP, ROADCLIP SETTINGS (this represents 
two spelling options for the same command set; they 
were both retained in 64-bit for backwards compatibility 
with custom menus, Keypad overlays, etc.) 

Road clipping. To separate the portion of a road or 
sidewalk that intersects a driveway, then either 
delete it or change its attributes. 

RDCLIP, RDCLIP SETTINGS Same as / redirects to ROADCLIP commands. 
RR DOUBLE, RR SINGLE, RR SETTINGS, RR 
SPACING, RR WIDTH, RR TIELEN 

Draw railroad tracks 

SCALLOP, SCALLOP SIDE LEFT, SCALLOP SIDE 
RIGHT, SCALLOP SIDE PICK, SCALLOP REVERSE 

Tree line scalloping (does not place a MicroStation 
pattern; it changes the line to a series of connected 
arc elements in a complex element.) 

WCLIP Wall clip. Clip and extend an elevation contour to a 
wall it intersects. 

 

3. The MapEditor Parameter File Editor has the following changes: 

a. The Parameter File Editor could crash when returning from editing the second of two Change Attributes 
Interior lines in a parameter file. This is fixed.  (November 29, 2022) 

b. The message confirming the parameter file is saved no longer contains unintended characters. (July 20, 
2022) 

c. CHANGEATTRIBUTES in a parameter file in 64-bit platforms used new fields that caused an error when 
32-bit MicroStation platforms read the parameter file. Both versions have been fixed to accept entries 
created by the other platform. (Ma 2, 2023) 

d. A problem might have occurred after editing multiple TOUCH entries in a parameter file. This is fixed. (April 
27, 2023) 

e. CHANGEATTRIBUTES INTERIOR within the Parameter File Editor could have a dialog lockup issue. 
This has been corrected by disabling direct calls to the Selection Sets Editor from the parameter file 
version of the Change Attributes Interior dialog. (As an alternative, launch the Selection Sets Editor from 
the button offered directly on the Parameter File Editor dialog.) (November 29, 2022) 

f. There was an error on editing the second of two CHANGEATTRIBUTES INTERIOR lines in a parameter 
file using the Parameter File Editor. This is fixed. (November 29, 2022) 

g. Extraneous “Sets” buttons have been removed from the Add/Edit tool dialogs for Clip and Check 
Attributes. (September 18, 2023) 

h. ZCHECK can now be run from a parameter file in 64-bit MicroStation. This is a rather unusual command 
to run from a parameter file, so please be aware: (November 29, 2023 and April 6, 2023) 

• ZCHECK does not perform any actions on the design; it only displays an interactive dialog. Since 
it pauses the parameter file operation and waits for the interactive ZCHECK dialog, it is different 
from the way most MapEditor commands work. The user must proceed through the ZCHECK 
dialog before the parameter file can continue. 
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• ZCHECK was allowed in 32-bit MapEditor parameter files, but was never actually designed as a 
batch command. It is a fully interactive command for viewing elevation differences at 
intersections. Therefore, ZCHECK was not initially implemented for parameter files in 64-bit 
MicroStation. 

• The user should be aware that if there is more than one ZCHECK entry in a parameter file, 
subsequent ZCHECK dialog contents will overwrite earlier ones. 

• DAT/EM suggests using CROSSCHECK as an alternative to ZCHECK in a parameter file for 
finding intersections with elevation differences. 

4. The Class Definition dialog had a “Sets” button that should have been a “New” button. This is fixed. (July 18, 2023) 

5. “Classes” and “Selection Set” selection filters now support custom line styles. (October 3, 2023) 

6. The Selection Sets Editor has the following changes: (July 18, 2023) 

a. The Wizard button now dispatches a modal dialog. Once launched, it must be closed again before the 
original Selection Sets Editor dialog will reactivate. This prevents the user from being able to close the 
Selection Sets Editor while the Wizard is still running. 

b. For long set names, the full name displays as a tooltip when the system mouse hovers over it. 

 
New tooltip shows long set names (the tooltip display is new, the 127-character limit is not new) 

7. When a DAT/EM application for 64-bit MicroStation cannot find a DAT/EM license or it detects another type of 
failure, it now shows the name of the application that is unloading. This may help in troubleshooting. Previously, 
only one generic “Lock Error” message would be displayed. (December 6, 2022) 

 
Example of a message showing which application is unloading when it does not find a license 

These messages indicate a fatal error has occurred; MicroStation will always close after these messages. 

8. MicroStation superimposition (SI) has the following changes: 

a. Superimposition will now display some cells that contained a nested shared cell in their definition. Note 
that DAT/EM recommends using cells made up of simple elements such as lines, line strings, arcs, etc., 
rather than nesting different cell types. (March 8, 2023) 

b. Superimposition has added error handling for incorrectly formed elements, such as incorrectly formed 
bspline curves. (September 28, 2023) 
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9. View independent text was missing the Summit model’s kappa angle adjustment. This is fixed. (March 20, 2023)  

10. When you cancel a tentative point using a <reset> or Cancel button, the tentative mark and/or text will clear from 
both superimposition and the MicroStation view. (August 22, 2023) 

11. Diagnostic messages will now appear in the MicroStation Message Center if zoom synchronization between 
Summit and MicroStation fails. These diagnostics were added to try to find the source of a “zoomCad” function 
failure after a third-party application loaded points into the MicroStation CONNECT environment. These 
messages may help determine whether the third-party application caused MicroStation to lose track of its object 
extents. If these messages appear, right click in the Message Center, save the messages, and send the file to 
DAT/EM Support. (May 17, 2023) 

 
Diagnostics messages in MicroStation Message Center. Right click for export options. 

12. 3DOFFSET has the following changes: 

a. 3DOFFSET’s Define Offset XY offset option set to XY=0.00 now results in the proper zero-(x,y) offset 
instead of applying the cursor pick offset. (September 1, 2023) 

b. 3DOFFSET will now force created elements to be snappable as they are drawn. (September 13, 2023) 

c. 3DOFFSET now supports element templates as follows. (September 25, 2023) 
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If new element symbology is defined by the original element (being offset), any element template 
association will also be added. 

 
If symbology is defined by active settings, any active element template will be also associated with the 
new element. 

 
13. ANNOTATE CELLNAME <cell name> now correctly handles leading and trailing blank spaces in the cell name. 

For example, the key-ins, ANNOTATE CELLNAME <space>TREE and ANNOTATE CELLNAME 
TREE<space> will both work in version 8.2. (December 1, 2022) 

14. CHANGEATTRIBUTES has the following improvements: 

a. CHANGEATTRIBUTES running interactively could result in the wrong "Change to" setting when switching 
between different "Change to" options. This is fixed. (March 7, 2023) 

b. CHANGEATTRIBUTES will process shared cells (type 35) and regular cells (type 2), but only for 
purposes of attaching an active element template. Note: In the case of regular cells, the template 
reference is only attached to the parent element following the convention set by MicroStation’s PLACE 
CELL. The structure allows for different element templates to be attached to the different cell 
components. CHANGE ATTRIBUTES originally was developed in 32-bit MicroStation to change 
symbology for linework and to skip cell elements; since 64-bit MicroStation now allows templates to be 
attached to elements, it now makes sense to process cells for this purpose.  (September 28, 2023) 

c. CHANGEATTRIBUTES will now correctly operate on B-spline curve elements. Previously, it could corrupt 
the B-spline, which further caused a crash in superimposition. Superimposition error handling for 
incorrectly formed elements was also added as part of this fix.  (September 28, 2023) 

15. “Change Attributes Interior” (MECHANGEINTERIOR) has the following changes: 

a. Change Attributes Interior has improved parameter initialization in all 32-bit and 64-bit versions. (April 28, 
2023) 

b. Change Attributes Interior was sensitive to the current MicroStation Preferences setting for Optimized 
Fence Clipping. If the setting was checked on, fence operations such as finding objects inside or outside 
a boundary would not behave as expected. This command now sets the option off before processing. 
(October 16, 2023) 

c. Change Attributes Interior in both Interior and Exterior mode has improved error handling and code 
modernization. (November 2-13, 2023) 

 

16. “Change Cell Last” MELCHANGECELL configuration was not initialized until the dialog had been raised. If 
MELCHANGECELL was run before MECHANGECELL had been used, it attempted to run on uninitialized 
settings and caused a crash. This is fixed  (May 22, 2023) 

17. “Change Text” MECHANGETEXT has a fix to prevent a crash on changing the size of the text. (June 19, 2023) 

18. “Clip” (MECLIP) has the following changes:   

a. Clip is now able to create and perform backups onto the specified backup level. Boundaries defined in 
attached reference files are now supported. (December 1, 2022) 

b. Clip using the Clip under Text setting will now better center the clip. Options to clip objects under text 
and perform exterior mode clipping are now more robust. (September 27, 2023) 

c. Clip’s Exterior mode has enhancements. (November 13, 2023) 
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19. CPLINE now supports copying reference elements to the master design file. (April 10, 2023) 

20. CROSSCHECK has fixes for the following: 

a. CROSSCHECK had a problem when there were multiple CROSSCHECK entries in the same parameter 
file. Upon saving the file, all CROSSCHECKs would be assigned the selection set of the last 
CROSSCHECK entry.  (April 17, 2023) 

b. CROSSCHECK’s parser had an error in the ‘Z Editing’ parameter file read.  (May 16, 2023) 

c. CROSSCHECK had an overflow problem.  (May 16, 2023) 

d. CROSSCHECK now has the option to place circles at intersections (writing them to the design or 
dispatching VISIT, depending on marker settings). The marker options previously had the element marker 
setting, but it was not previously implemented for CROSSCHECK. It has been added to all 32- and 64-bit 
platforms.  (July 20, 2023) 

e. The ellipse elements are placed at the "DATEMCROSSING" level. 

21. DATDRAW has the following changes: 

a. DATDRAW commands will now force created elements to be snappable at final element creation. 
Previously, it set the snappable property earlier in the command, and it had the potential of losing the 
property before finishing. This is a potential fix for an unsnappable element created at a beta tester’s site. 
Since the problem could not be reproduced at the beta tester’s site or at DAT/EM, the source of the 
problem could not be proven. This was determined to be a low-risk, preventative change. 

b. DATDRAW STREAM’s drawing-in-progress rubber band was staying anchored to the first vertex, 
although drawing proceeded normally. The rubber band now correctly extends from the most recent 
vertex. (November 17, 2022) 

22. DATEM SETTINGS has a new capability and setting to toggle tentative point marking in the MicroStation view 
(rather than the superimposition view, which already had a tentative point mark). The setting is in the 
MicroStation-side DATEM SETTINGS > Tentative label, color, and Size options: 

 
New label to mark tentative points in the MicroStation view 

23. DTMDISTRIBUTOR (previously available in the 32-bit version and now newly added to the 64-bit version) has 
increased the number of formats it can read and write. The list of formats is now standardized with other DAT/EM 
points-file-reading options. These changes apply to 64-bit only; they will not be added to the 32-bit versions. 
(February 9, 2023) 

24. DTMEDIT now displays the total number of points being edited, already visited, and remaining. (November 17, 2022) 

25. EZ has a refined snap tolerance calculation, a fix to handle view motion, and direct superimposition element 
handling. (April 20, 2023) 

26. EZEDIT’s Whole Element > Set Elevation command no longer loses the Z settings portion of the dialog after a 
second consecutive edit. (September 1, 2023) 
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27. FACESHIFT commands have the following changes: 

a. FACESHIFT POLYGON: There is a fix for a crash when the first polygon point was followed by a reset, 
which the user might do while attempting to cancel the command. (February 7, 2023) 

b. FACESHIFT POLYGON: The transient drawing element showing the polygon being placed might 
disappear on subsequent runs. This was caused by use of a Bentley-deprecated global transient variable 
reference. (June 29, 2023) 

c. FACESHIFT (surface) calculations lacked error handling and recovery. Now, if a surface cannot be 
calculated from an element, the active FACESHIFT command will be restarted. (June 29, 2023) 

d. FACESHIFT’s TIN failover algorithm (based on creating a surface based on TINs) previously would be 
applied only when all boresite operations failed. Now it will also be applied when boresite calculations 
succeed, but a subsequent range check fails. A range check was added to the failover algorithm to 
ensure against out of bounds results. (June 29, 2023) 

28. FILTER (MEFILTER) now preserves unsaved dialog setting changes when bringing up the Selection Sets Editor 
or Class Editor. (October 3, 2023) 

29. MEMOVE preserves unsaved settings when temporarily closing the dialog (for example, to pick elements or bring 
up the Class or Selection Sets Editor dialogs). (June 9, 2023) 

30. MEXPORT had a problem reading a * level wildcard from the legacy 32-bit EXP format. This is fixed so that * in 
the level field will be used as a level wildcard meaning all levels. Note: DAT/EM continues to encourage use of the 
new EXP2 format introduced in v.8.1. (July 5, 2023) 

31. Pattern Interior’s (MEPATTERNINTERIOR) has performance and robustness enhancements.  (November 13, 2023) 

32. REPLACE OBJECT (MEREPLACEOBJECT) has added text style options to Text > Text Settings. If you want to 
use a text style, set Text Style to the style name. To use individual text attributes, leave Text Style set to Style 
(none). 

 
New Text > Text Settings > Replace Object Text Options text style options  

Notes on backward compatibility: Previous versions of REPLACE OBJECT only offered height, width, font, and 
angle setting. These are mapped into Style (None) and fixed Height and Width settings. It attempts to map the 
previous font number into a defined font (now represented as a name). Fixed attributes are configured now in the 
Replace Object Text Options dialog instead of the Replace Settings dialog (where they are disabled when 
changing elements to Text). 
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33. SCALLOP (MESCALLOP) commands were added to the 64-bit key-in list with the same starting functionality they 
used to have in 32-bit.  New SCALLOP changes for 64-bit only are: (February 20, 2023) 

a. It now allows scallop (and reverse/flip) of simple arcs. Previously, arcs could not be scalloped or flipped.  

b. The "Flip side of existing scallops" setting is now preserved across consecutive runs of the interactive 
Scallop command. Previously, it was reset each time SCALLOP was run. 

34. SELECTIONSET Selection Sets Editor has a new option to add cells found in fence contents. 

 
When [Add Cells] is pushed, cells located in the active design relative an active fence are added to the select 
Selection Set. This follows the precedent ([Add Levels]) that only elements in the active design are considered 
when populating the set. Note that reference elements are not processed in selection sets unless the calling 
application uses an extended interface. For that reason, references are not considered in this generic interface. 

[Add Cells] distinguishes between Cell Types. Entries are identified by Cell Type as well as by Cell name. For 
example, a cell called ABCBOX can have two entries: One for shared cells and one for regular cells if both types 
are located within the Fence. Alternately, new entries could be tagged “All Cells” and identification restricted to 
Cell Name. 
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35. SI SETTINGS has the following changes: 

a. SI SETTINGS has a new Show snap ring, snap ring color, and Locate Tolerance settings. Their 
purpose is to show the current snapping radius in approximate ground units in superimposition (SI). With 
the snap ring on, it will be easier to position the cursor to exclude objects you do not want to snap to, and 
to know when to change the Locate Tolerance to a better value. 

 
New snap ring and Locate Tolerance settings in SI SETTINGS 

Key-ins to control the SI SETTINGS values without showing the dialog are: 

SI SNAPRING <ON/OFF> 

SI LOCATETOL <value> 

The minimum Locate Tolerance is 1 and is entered in positive integer values. This is a MicroStation 
restriction; Locate Tolerance is a MicroStation variable and is defined as a positive integer.  

Hint: If you already have MicroStation’s SET LOCATE <value> key-ins on 
your DAT/EM Keypad Controller overlay or in any custom toolbars, change 
these to SI LOCATETOL <value>. This still sets MicroStation’s variable, but 
in a way that DAT/EM can detect the change and update the snap ring size. 

Always use SI SETTINGS or the key-ins above to set or change the Locate Tolerance. If you use 
MicroStation’s SET LOCATE <value> key-in or the Locate Tolerance field in MicroStation’s Preferences 
dialog, DAT/EM will not be able to detect that the value has changed, and the snap ring in 
superimposition will not update. 

The snapping radius for both AccuSnap and Tentative point snap is regulated by the Bentley MicroStation 
Locate Tolerance variable, which MicroStation defines in display pixel units, not ground units. Since it is 
in pixel units, its ground unit distance is dependent on the zoom level in View 1. The more View 1 zooms 
out, the larger the snapping radius becomes in ground units. Each display pixel represents a greater and 
greater ground distance as it zooms out. The dependence on View 1 display pixel units makes it difficult 
for DAT/EM users to know which objects are inside the snapping radius, especially when the snapping 
distance changes with every zoom change. It will still change, but with the snap ring on, you can now see 
the current approximate snap radius in SI. 

The SI snap ring can only be drawn at an approximate size. This is due to the MicroStation Locate 
Tolerance being in view pixel units, and due to precision loss when attempting to convert the pixel size 
into ground units. To do this, we need to know the exact view size, which is not given precisely. DAT/EM 
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also suspects that MicroStation misreports the view size when is a non-zero kappa value view rotation 
active. The estimate will be closer if MicroStation is maximized on the CAD/Desktop monitor. 

Since the snap ring is approximate, it will never be the exact limit of the snapping/no snapping distance. It 
will give you an idea how big the current snap radius is, within a range near the snap ring. You will have 
to accept it as the estimate that it is. 

The best advantage of the snap ring is if MicroStation zooms far out, you will know that the snap radius 
has become too big. You will see that there are far too many objects inside the circle, and you will know 
why it is snapping to objects far away from the cursor center. 

b. SI SETTINGS Show cells as points checked on was not working. The cell graphics would disappear, but 
no visible points would replace them in superimposition. This is fixed. (October 19, 2023) 

36. SLOPEHATCHLAST now uses a single pick on the first element and a single pick on the second element. This 
makes the prompts match up with the necessary selection picks. Previously it worked if you double picked, and 
the prompts did not match the actions needed. (February 27, 2023) 

37. STROKEELEMENT and MESTROKEELEMENT now preserve template links found on the input elements. Hint: If 
the older versions of these commands removed the template links in the past, you can reinstate the template links 
using CHANGEATTRIBUTES or CHANGEATTRIBUTESLAST in version 8.1 or 8.2 beta or higher. (March 24, 2023) 

38. TOUCH BATCH has been modified to avoid creating tiny segments, which sometimes caused failures during the 
intersect calculation. (May 11, 2023) 

39. TWOSHOT has the following changes: 

a. TWOSHOT and TWOSHOT ANGLE will now show the correct angle in superimposition for all types of 
cells. (September 14, 2023) 

b. TWOSHOT ANGLE has improved dynamic graphics for superimposition. (April 5, 2023) 

c. TWOSHOT was not functioning correctly due to MicroStation SDK (Software Development Kit) changes. 
This has been addressed. (April 5, 2023) 

40. VISIT has the following changes: 

a. VISIT and VISIT ELEMENT now have the correct counts in their “Entry” and “Visited” displays. (November 7, 
2022) 

b. VISIT has a fix for crashing when it moved to the last record in the loaded Visit file. (May 16, 2023) 

c. VISIT’s fence processing mode is now processing correctly. (October 3, 2023) 

41. XYZIN has the following changes: (November 9, 2022) 

a. The code now accepts levels with or without quotation marks around them (“level” or level) in the input 
file. (November 9, 2022) 

b. XYZIN was originally written to expect a data type field in the input file for multipoint elements, such as 
shapes and line strings. If a data type was not specified, the data was interpreted as a point element. It 
previously only accepted point, cell, and text elements when a data type was not specified. It has been 
expanded to extrapolate a data type in cases where only a single multi-point data type is selected in the 
dialog. In a test input file that had no type field, but had an element number field, only the Shapes option 
was checked in the dialog. In this case, it previously placed nothing, but now it places the correct number 
of shape elements. (November 9, 2022) 

c. There was an incorrect level on strings from a nearby two-point string. Before the fix, the level specified 
for a two-vertex STRING might be applied incorrectly to multipoint elements defined near it in the XYZ file. 
(September 22, 2023) 

d. There was an incorrect level applied to strings during "Inside Boundaries" filtering. (September 22, 2023) 

e. Added error handling improvements. (September 22, 2023) 
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42. ZCHECK can now be run from a parameter file in 64-bit MicroStation. This is a rather unusual command to run 
from a parameter file, so please be aware:  (April 6, 2023) 

• ZCHECK does not perform any actions on the design; it only displays an interactive dialog. Since it 
pauses the parameter file operation and waits for the interactive ZCHECK dialog, it is different from 
the way most MapEditor commands work. The user must proceed through the ZCHECK dialog before 
the parameter file can continue. 

• ZCHECK was allowed in 32-bit MapEditor parameter files, but was never actually designed as a 
batch command. It is a fully interactive command for viewing elevation differences at intersections. 
Therefore, ZCHECK was not initially implemented for parameter files in 64-bit MicroStation. 

• The user should be aware that if there is more than one ZCHECK entry in a parameter file, 
subsequent ZCHECK dialog contents will overwrite earlier ones. 

• Note: DAT/EM suggests using CROSSCHECK as an alternative to ZCHECK in a parameter file for 
finding intersections with elevation differences. 

• Note: If requested, block, pause, and reports functions could be added to ZCHECK’s parameter file 
options. Please let us know at support@datem.com if you would like these enhancements. 

43. ZLABEL TEXT SETTINGS’ individual level, attributes, and other settings are now saved properly when the dialog 
closes. (October 13 and 23, 2023)  

 

DAT/EM Capture and MapEditor for MicroStation (32-bit versions) 
Changes apply to Capture and MapEditor for MicroStation for 32-bit MicroStation versions.  

DAT/EM has stopped new development for Capture and MapEditor for 32-bit MicroStation versions. Changes here include bug 
fixes and modifications for the purpose of  backwards compatibility with new development for 64-bit MicroStation. 
 
* 32-bit MicroStation users be advised! DAT/EM v.8.2 still supports installation for several older 32-bit MicroStation versions. 
DAT/EM will continue to install for 32-bit MicroStation versions as long as Bentley continues to provide developer licensing for them. 
When Bentley stops this licensing, DAT/EM will remove 32-bit MicroStation support in betas and the subsequent DAT/EM release. 

DAT/EM software installs for the following 32-bit MicroStation versions. 

• MicroStation V8i SelectSeries 10 and V8i SelectSeries 10-based products. SelectSeries 10 is the only version that both 
Bentley and DAT/EM support for Windows 10. The product names are V8i, Bentley Map, Map Enterprise, PowerView, Map 
PowerView, Power GeoPak, and PowerCivil. 

• MicroStation V8, V8 2004 Edition (version should 08.05.00.34 or higher), XM (version 08.09.04.88 or higher), 
MicroStation V8i and V8i-based products in SelectSeries numbers 3 and 4 (SelectSeries 1 and 2 not recommended). 
None of these versions are supported by Bentley under Windows 10 or 11. DAT/EM will install for them if they are present and 
licensed on the computer. The product names are V8i, Bentley Map, Map Enterprise, PowerView, Map PowerView, Power 
GeoPak, and PowerCivil, except Power GeoPak Select Series 3 is not supported.  

If you upgrade to a higher SelectSeries number, you must reinstall DAT/EM software after installing the SelectSeries upgrade.  

DAT/EM will install for all supported 32- and 64-bit versions of MicroStation that are present on the computer and licensed at 
the time of the DAT/EM installation. 
 

DAT/EM Capture and MapEditor for 32-bit MicroStation versions have the following changes: 

1. CHANGEATTRIBUTES in a parameter file in 64-bit platforms used new fields that caused an error when 32-bit 
MicroStation platforms read the parameter file. Both versions have been fixed to accept entries created by the 
other platform.  (May 2, 2023) 

2. “Change Attributes Interior” (MECHANGEINTERIOR) has the following changes: 

a. Change Attributes Interior for 32-bit platforms has improved parameter initialization. (April 28, 2023) 

b. Change Attributes Interior code has been upgraded. (November 21, 2023) 

mailto:support@datem.com
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3. CLIP’s Exterior mode has enhancements. (November 21, 2023) 

4. CROSSCHECK for 32-bit platforms has the following changes:  (July 20, 2023) 

a. CROSSCHECK launches VISIT successfully if element intersections matching criteria are found. 

b. CROSSCHECK now has the option to place circles at intersections (writing them to the design or 
dispatching VISIT, depending on marker settings). The ellipse elements are placed at the 
DATEMCROSSING level. The marker options previously had the element marker setting, but it was not 
previously implemented for CROSSCHECK. It has been added to all 32 and 64-bit platforms.  

5. Pattern Interior’s (MEPATTERNINTERIOR) has been upgraded.  (November 21, 2023) 

6. A problem could occur after editing multiple TOUCH entries in a parameter file. This is fixed.  (April 27, 2023) 

 

DAT/EM Capture for Blue Marble Global Mapper 
Changes apply to Capture for Global Mapper. The following Global Mapper versions are supported: 

• 24.x and 25.x, released before the time of the DAT/EM v.8.2 build date. 

To start using DAT/EM Capture for Global Mapper, contact DAT/EM or your DAT/EM reseller for a quote for a Stacked 
Capture for Global Mapper. This product is added on to the primary Capture for AutoCAD, MicroStation, or ArcGIS. 

DAT/EM Software installs the Global Mapper Extension, but leaves it unregistered in Global Mapper by default. To use 
the extension, close Global Mapper, select Windows Start > Datem Software group > right click on DAT/EM 
Administration Tool > More > Run as Administrator. Set CAD/GIS Package=Global Mapper, Action=Capture, 
Apply. Or, to disable at any time, set it to Action=Disable, Apply. 

 
To register/enable or unregister/disable, use the DAT/EM Administration Tool’s CAD Enabler 

Alternatively, toggle the extension from the Global Mapper > Help menu > License Manager. Note that it is 
correct to be called “DAT/EM Capture for Global Mapper V24+” for both Global Mapper 24.x and 25.x. 

1. Version 8.2 Capture for Global Mapper is the first version to work with Global Mapper versions 24.x and 25.x. The 
extension for any older versions of Global Mapper is no longer installed.  (2023) 

-End- 
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