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The following changes have been made to DAT/EM products for the version 8.3 release. If you have questions about this 
version or requests for new development, contact DAT/EM Support at support@datem.com. 

Contents 
Operating Systems and Microsoft Updates 2 
DAT/EM Software Installation 2 
Hardware Locks/Dongles 3 
DAT/EM Administration Tool 3 
DAT/EM Virtual Reality (VR) 6 
Point, Image, and Vector File Formats (Affecting Multiple DAT/EM Applications) 6 
DAT/EM Keypad 8 
Coordinate Transformations and Elevation Database 10 
DAT/EM Stereo Viewer 10 
DAT/EM Image Creator 11 
The Summit Evolution 12 

General Summit Evolution Subjects 12 
Terrain Project Tools 23 
Importing Projects into Summit 23 
Aerial Projects 24 
Satellite RPC and Epipolar Generation for All Compatible Projects 24 
ADS40/80/100/etc. Projects 26 
Project Viewer / Ortho+Mosaic 27 
Point Translator 27 

LandScape 28 
DAT/EM Capture for 64-bit ArcGIS Pro 29 
DAT/EM Capture for 32-bit ArcGIS ArcMap 42 

Capture for ArcGIS (ArcMap) Items 42 
Airfield3D (ArcMap) Items 42 

DAT/EM Capture and MapEditor for AutoCAD 43 
DAT/EM Capture and MapEditor for 64-bit MicroStation 43 
DAT/EM Capture and MapEditor for 32-bit MicroStation 53 
DAT/EM Capture for Blue Marble Global Mapper 54 
 
 

mailto:support@datem.com
http://www.datem.com/
mailto:support@datem.com


DAT/EM Systems International Version 8.3 Release Notes 
 

Page 2 of 55 
 

Operating Systems and Microsoft Updates 
DAT/EM software no longer supports 32-bit operating systems. Any reference to an OS in the remainder of this 
document refers to the 64-bit version of that OS only. 

DAT/EM Release version 8.3 is supported on the following operating systems as of the date of the v.8.3 release: 

• Windows 11 Professional and Enterprise. 

• Windows 10 Professional and Enterprise. 

Windows 10 Notice: Microsoft will end extended support for Windows 10 on 14 October 2025. DAT/EM 
will end support for it on the same day. This may be during the time that v.8.3 is the active release. 
Existing DAT/EM versions will not stop working or installing for Windows 10 on that day; however, later 
DAT/EM developments may contain components that do not work on Windows 10. After 14 October 
2025, DAT/EM will no longer fix any problems that are traced to Windows 10 incompatibility. 

Notes: 

o DAT/EM generally recommends installing all Windows updates; however, if you are not sure whether your stereo 
settings will still work after a Windows update, please contact DAT/EM Support for information. 

o DAT/EM software does not work with Windows Home Edition or LTSC (Long-Term Servicing Channel), formerly 
known as LTSB (Long-Term Servicing Branch). 
 

DAT/EM Software Installation 
The following changes have been made to DAT/EM installation packages: 

1. DAT/EM Prerequisites Setup (“Prereqs”) has been updated. The new file name is 
Datem_PreReqs_blt_01_18_2024.exe. This Prereqs installs updated Microsoft C++ redistribution packages and 
Sentinel driver version 7.7.1. (January 18, 2024) 

Previously, Prereqs prevented the Sentinel driver from installing if the same version had already been installed or 
even only started installing followed by a cancel. This led to the inability to reinstall if the installation did not 
complete. Prereqs also restarted immediately without any choice to delay. The new Prereqs will give more options 
so you can try again: 

• If Sentinel 7.7.1 is already installed, it will now offer to Modify, Repair, or Uninstall. If you think you might 
have answered “No” to the firewall question, or you suspect Sentinel is not running correctly for any 
reason, choose Uninstall, restart, log on as Administrator, temporarily deactivate the antivirus/firewall, 
and run Prereqs again “As Administrator” to reinstall Sentinel. Answer Yes to the firewall question. 

• It will now either offer to restart right away or delay the restart. Be aware that the computer must be 
restarted before you install any version of DAT/EM Setup (Datem_Setup_ver_blt_mm_dd_yyyy.exe).  

Hints: 
• Run Prereqs “As Administrator” even if you are already logged on as Administrator. 

• Temporarily deactivate the antivirus/firewall before you run Prereqs, if possible. This offers a better 
chance of success in opening ports and activating Sentinel services. Most deactivations will reactivate 
upon finish and restart; verify reactivation. 

• Any restart after Sentinel installation or uninstallation will take longer than usual. Please wait. Do not use 
the computer’s off/power button during the restart. 

 
2. There was a problem in v.8.2 and early v.8.3 betas with installations using a network lock. The most recognizable 

indications were an “Access D[enied]” message on loading Capture, a blank “Installation Code” display in 
DAT/EM Administration Tool > Release Information, and missing files such as the extension .dll for Capture 
for ArcGIS ArcMap. The installation process for network locks is fixed. (April 2024) 

3. The installation process will now associate .lndscp files with the LandScape application. (June 25, 2024) 

4. See ArcGIS Pro-specific installation changes in the “DAT/EM Capture for 64-bit ArcGIS Pro” section below. 
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Hardware Locks/Dongles 
Install Microsoft Updates before applying lock reset programs. Network licensing should have the same Sentinel driver 
version on both the lock server and the local workstations running the software. 
 

1. The Thales Sentinel driver version 7.7.1 is provided with DAT/EM version 8.3. This is the same version as was 
supplied with v.8.1 and v.8.2. 
 
Sentinel Driver on Network Lock Servers: If you have a network lock on a network server, DAT/EM strongly 
advises you to install Sentinel 7.7.1 on the network lock server to match the version on the DAT/EM workstations. 
DAT/EM provides a convenient prerequisites setup file that installs the required Microsoft C++ redistribution files 
and the Sentinel 7.7.1 driver: 

• Download it from www.datem.com > Support > Downloads > Prerequisites > DAT/EM 
Prerequisites section. 

• Log on locally as Administrator to the network lock server. 
• Temporarily disable the antivirus and firewall for best results. Sentinel needs to open ports. 
• Answer “Yes” to Sentinel’s firewall question. 
• Reboot the server after installation. 

Please do not skip the update for the network lock server. The newer Sentinel driver works better and 
contains security updates. The best communication can be expected when the Sentinel versions match between 
the server and the DAT/EM workstations.  
 
 

DAT/EM Administration Tool 
The following changes have been made to the DAT/EM Administration Tool: 
 

1. The DAT/EM Administration Tool > CAD Enabler > ArcGIS Pro > Set Common Add-In Folder is a new 
option. It allows a user login with Administrator permissions to set a common folder shared across multiple users. 
The folder must be accessible to all users who will be using it. (December 7, 2023) 
 

 
New CAD Enabler > ArcGIS Pro > Set Common Add-In Folder option 

 
If the Common Add-in Folder entry in the dialog is left blank, the default action will be taken, which is to register 
a locally installed extension; that would be appropriate for users who have local ArcGIS Pro settings.  
 

http://www.datem.com/
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If the Common Add-in Folder contains a folder name, then when the Apply button is pressed, a folder named 
DatemAddIn will be added to the common folder and the CaptureArcPro3.esriAddinX file and API for ArcGIS 
Pro will be copied to it. The DatemCOMInterface.2022_64.dll interface from the folder will be registered. The 
CaptureArcPro3.esriAddinX will not be registered, because any esriAddinX file found in the folder will be 
loaded automatically when ArcGIS Pro starts. 
 

 
Example of a common Add-In Folder 

 
To clear the Add-In folder, delete the contents of the DAT/EM Administration Tool > CAD Enabler > ArcGIS 
Pro > Set Common Add-In Folder field and press Apply. That will remove the registry entry from the local 
machine, but will not remove the file from the formerly listed folder, since it may still be in use by others. 
 
The name of the Add-In folder will be added to the Esri section of the Windows Registry in 
HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\ArcGISPro\Settings\Add-In Folders. (December 6, 2023) 
 

 
Example of the registry item for the Common Add-In Folder 
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2. DAT/EM Administration Tool > CAD Information is a new tool to scan the computer for supported CAD/GIS 
packages and list their names, locations, and whether DAT/EM software has been installed for them. The Copy 
to file button may be used to export the list to a CSV (comma delimited text) file. (October 17, 2024) 
 

 
New CAD Information tool with Copy to file option 

 
3. DAT/EM Administration Tool > Release Information now shows the number of licenses being used next to the 

total number of licenses activated on a DAT/EM network lock. For example, if 3 licenses are activated on the 
network lock, and 2 are currently being used, it will show (2/3). (October 21, 2024) 
 
Important concept: The display may be used as a replacement for the Sentinel License Monitor, which showed 
the same information. The Sentinel License Monitor uses an unsecured URL to obtain its information on the 
number of licenses in use; DAT/EM Administration Tool does not use any URL. 
 

 
New licenses in use with total licenses display for a DAT/EM network lock 
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4. The DAT/EM Administration can be run from a command line and check a specified lock number and machine 

location. This was missed in previous Release Notes. To do this: 
 

 Open a Windows Command Prompt using "Run as Administrator" (you can use Windows Search for 
"Command Prompt," right click on the result, and select "Run as Administrator") 

 
 Enter the command using syntax: 

"C:\Program Files\Datem Software\AdminTool.exe" [lock number] [lock server name or IP address] 
 

 
 

5. DATEM Administration Tool > CAD Enabler > MicroStation 64 > MapEditor > Apply was mistakenly hiding 
the .dgnlib file that contains the DATEM_CommonTools ribbon workflow. This is fixed. (June 19, 2024) 
 

DAT/EM Virtual Reality (VR) 
The following changes have been made DAT/EM Virtual Reality (VR): 

1. The following was available in v.8.2, but was missed in the v.8.2 Release Notes. The pixel density now 
automatically defaults to the highest density. (October 30, 2023) 

 

Point, Image, and Vector File Formats (Affecting Multiple DAT/EM Applications) 
DAT/EM applications read a variety of file formats that contain points, images, and vectors. The code is shared among 
several DAT/EM applications, so all can read the same formats. The following changes have been made to the list of 
supported formats: 

1. Adobe Deflate compression type reading that was reported to be added to version 8.1 was not working in 8.2 or 
early 8.3 betas. It is now fixed. (January 17, 2024) 

2. There is a change to reading “new” Hexagon and “old” Z/I images with .tif and .tjp file name extensions, YCbCr 
color, and various corner “Orientation” settings in the image header. Here, we will call these images “new” and 
“old” rather than identify all the additional image properties that also must be present. Both the new and old 
images are now supported, but may need the file extension to be changed if images are found to display 
incorrectly in version 8.3. The problem appeared in the 1:1, 1:2, and 1:4 image levels in DAT/EM image displays 
for some new images, for example: (June 18, 2024) 

 
Before 18 June 2024, DAT/EM image displays had scrambled image blocks for some new Hexagon images. 

The problem was in the 1:1, 1:2, and 1:4 levels only. It was due to an old workaround 
for old Z/I images that had differently rotated zoom levels within the same image. 
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Hexagon aerotriangulation software has a function to apply rotation to images by modifying the “Orientation” flag 
in the TIF image header. The contents of the image are not rotated to match this corner orientation setting. The 
best way to read such files is to ignore the Orientation setting in the image and simply read it “as normal.” 

Many years ago, Z/I, the predecessor of Hexagon, had a different anomaly in the images: There were different 
rotations within the zoom levels of the same image. These images also used the “Orientation” TIF image header 
setting. DAT/EM had a workaround to display these non-standard images; however, now that Hexagon software 
no longer makes images with different rotations within the zoom levels, the DAT/EM workaround for the old 
images was causing a display problem in the new images. We do not want to remove the support for the old 
images, in case someone opens an old Hexagon project that has them. 

Now DAT/EM applications support both the old and new images based on file name extension as follows: 

• If the file name extension is .tif (TIF), DAT/EM will read the image as a new Hexagon image with all 
zoom levels rotated the same way. 

• If the file name extension is .tjp (TJP), DAT/EM will read the image as an old Z/I image with different 
rotations within the zoom levels. 

In any case where you see the scrambled image blocks like the example above, rename.tif to .tjp or .tjp to .tif. 
Notes: 

• In Hexagon projects, some flight lines may be rotated differently than others. Only rename the images 
that show the scrambled block appearance in DAT/EM applications in the 1:1, 1:2, and 1:4. The problem 
will probably appear in entire flight lines. 

• If you rename images, you will need to modify the Summit project to reference the correct file name 
extension. If renaming from .tif to .tjp, this is best done directly in the .smtxml in a good text editor (such 
as Notepad++). If renaming .tjp to .tif, this may be done in Summit > Edit > Project > Change EXT 
[Extension] > set TIF to selected flight line images. Do not use the Modify button and browse for the 
differently named image, because it may lose the original images’ orientation values. 

 
3. DAT/EM applications now support RPC values embedded in images. Some adjusted satellite RPC imagery has 

the adjusted RPC information embedded in the image file. This will most likely be found in COG (Cloud Optimized 
GeoTiff) format, but applies to any format that has a way to store embedded RPC data and that the GDAL library 
supports.  
 
With embedded-RPC images, there may also be an external RPC.txt file that contains the same or different RPC 
information. DAT/EM applications will now prioritize as follows:  

• It will use a valid RPC.txt file, if found.  
• If the RPC.txt is missing or blank, it will then use any embedded RPC. 

Users should be aware of how the adjusted RPCs are presented. If the external RPC.txt file contains the original, 
unadjusted RPC values, and the image file contains the adjusted RPCs, be sure to remove the external RPC files 
so that it will use the embedded values. 
 

4. The BIL (points file) format reader is updated to read elevation values correctly. (August 16, 2024) 
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DAT/EM Keypad 
The following changes apply to the DAT/EM Keypad Controller application: 

1. There are new Keypad keyword strings for the Summit/LandScape output type, as follows: 

a. Two new keywords can set and clear Summit’s Z Index tool. They apply to Summit only: (January 31, 2024) 

zindex delta <value> – Sets and applies Summit > Orientation > Z Index > Delta value without 
launching the dialog. 

zindex clear – clears the Z Index Delta value. 
 
Notes and disclaimers: 
• Red text will appear in the lower right corner of Summit when a Z Index delta is active. 

 
Example of red text in the lower right corner of Summit 

showing a Z Index delta is active 
 

• Objects digitized with an active Z Index will be offset in elevation by the indicated amount. 
• Clear the delta later with zindex clear (shown in table cell below). 
• Do not forget that a Z Index is active. It is up to the user to clear it when true ground elevations are 

needed. DAT/EM will not be responsible for objects digitized at the wrong elevation while a Z Index is 
active. 

• Do not use Z Index to try to correct for a coordinate system mismatch. In this case, apply a coordinate 
system translation instead. 

• Do not use Z Index to try to correct for an interior orientation mismatch between an aerotriangulation 
package and Summit. Ask DAT/EM Support for troubleshooting help. 

• See hints for the best use below in the ArcMap Airfield3D section on page 42. 
 

b. MatchSummitCADZoom is a new keyword to toggle the setting: Summit > Tools > Options > Main 
View > Automatically match the Image view and CAD windows to the same zoom level.  
 
A MicroStation user requested this keyword to easily disconnect Summit and MicroStation’s view 
synchronization. They wanted to use the system mouse temporarily to independently pan and zoom in 
MicroStation’s View 1 without changing Summit’s position, zoom, or model. Later, they wanted to toggle 
back to resume normal view synchronization. 
 
Note! Do not use this keyword for ArcGIS ArcMap or ArcGIS Pro; they are very sensitive to “things that 
happen” in unsynchronized views. They have similar settings in DATEM Capture Settings. 
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New Keypad > Summit/LandScape output > MatchSummitCADZoom keyword 

toggles Summit’s Automatically match the image view… setting 
 
 

2. There is a new example DAT/EM Keypad .dkf file for ArcGIS Pro installed to "C:\ProgramData\Datem 
Systems\keypad\ArcGISPro.dkf". See the “DAT/EM Capture for 64-bit ArcGIS Pro” section on page DAT/EM 
Capture for 64-bit ArcGIS Pro30 for more information. (August 5, 2024) 

3. The Keypad Controller has a new option to launch files or links using the Windows default application. (Default 
applications can be viewed or set in Windows Settings > Apps > Default Apps and related settings.) Set 
Keypad Controller > Edit Key dialog > Executable to open (not case sensitive) and set a file or website name 
in the Parameters field. It will attempt to open whatever is in the Parameters field using the default system 
application. If there is no default application defined, it will show the system dialog to select one. 

Examples: 
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Coordinate Transformations and Elevation Database 
There are no changes to the elevation database installation file built in 2015 found here: 
http://datemsystems.com/down/SetupElevationModels%20blt%2003%2015%202015.exe. If you already installed that file 
with previous DAT/EM versions, you do not need to reinstall it. Any changes have been added to the DAT/EM setup 
installation, so that you do not need a new, separate Elevation Database file. 

There are no newer files or changes included in the main DAT/EM software installation. 

Note: An update is expected early in the version 8.4 release “beta” cycle. This will include transformations to and from 
U.S. geoid 12b and geoid 18 and other new systems. If you need this, contact DAT/EM Support for beta information. 

 

DAT/EM Stereo Viewer 
There are no specific changes to the DAT/EM Stereo Viewer for v.8.3; however, any of the general image file format 
changes listed above may apply to it. 

http://datemsystems.com/down/SetupElevationModels%20blt%2003%2015%202015.exe
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DAT/EM Image Creator 
The following changes have been made to DAT/EM Image Creator. This application can be started by searching Windows 
for the “Image Creator” or from Summit > Imagery > Create Summit Images. 

1. To help support Summit’s new ability to use cloud-based image files, DAT/EM Image Creator now offers more 
compression options for COG format. In addition to the existing LZW, new compression choices DEFLATE, 
LERC_DEFLATE, JXL and JPEG: (September 5, 2024) 

How do you know when to use COG and with which 
compression format? Consider the following: 
The recommendation is to use only COG and no other 
formats for cloud-based imagery. This is important, now 
that Summit supports cloud-based imagery. 

COG has special header information inside to minimize 
cloud GET calls. Even if everything else is similar between 
a COG and an older, non-COG TIFF format, such as tile 
size and compression, the COG will perform better.  

The size of the COG image file matters. In General, the 
smaller the image file, the better the performance. 
Previously, Image Creator only offered LZW compression 
for COG. LZW is still the default compression for COG, 
but that does not mean it is the best choice; more than 
likely it is the worst choice. 

DAT/EM tested the different compression methods for 
COG to help you understand the differences: 

Example of compression on a DAT/EM test file: 
• Original image not compressed - 1.1 GB 
• LZW - 975 MB 
• DEFLATE- 710 MB 
• LERC_DEFLATE - 506 MB 
• JXL lossless - 265 MB 
• JXL lossy - 16 MB 
• JPEG lossy - 19 MB 

 
New COG compression choices in Image Creator 

The performance increase is dramatic using JXL (lossy) or JPEG. The image's tiling seems as fast as local files, 
or close to it. This may surprise you! But look at the difference in the size of LZW at 975MB compared to JPEG 
lossy at 19MB; it is about 50 times smaller. Also, LERC_DEFLATE is almost half the size of LZW and performs 
better; although it is not as dramatic as JPEG lossy, it is still noticeably faster. 

Performance order, best to worst: 
• JXL Lossy (best performance) 
• JPEG Lossy 
• JXL Lossless  
• LERC_DEFLATE 
• DEFLATE 
• LZW (worst performance) 

Based on this list, you might be tempted to always pick the one with the best performance; however, there are 
more characteristics to consider, listed below. 



DAT/EM Systems International Version 8.3 Release Notes 
 

Page 12 of 55 
 

About each format, why or why not to use: 
• JXL Lossy - Lossy. Results in 3 band only. Can be 12 or 8 bit only. 
• JPEG - Lossy. Results in 3 band only with YCbCr color. Can be 8 bit only. 
• JXL - Lossless. Results in 3 band only. Can be 12 or 8 bit only. JXL is not as widely used as other 

compression methods, although it is more modern. 
• LERC_DEFLATE - Lossless. Any number of bands. Can be 8-16 bit. 
• DEFLATE - Lossless. Any number of bands. Can be 8-16 bit. 
• LZW – Lossless. Any number of bands. Can be 8-16 bit, although LZW is not often recommend on 16-bit 

imagery. 

Summary of COG compression choices: 
• If you can tolerate a lossy compression with 3 bands only, and want super performance in a Summit 

cloud-based imagery project, then pick JXL (or JPEG if you are not ready to use the newer JXL 
technology).  

• If you want lossless and 3-band is acceptable, then pick JXL lossless 
• If you need lossless and many channel support, then pick LERC_DEFLATE first, then DEFLATE or LZW. 

See the first item in the Summit section below to learn about cloud-based Summit projects. 
 

The Summit Evolution 
The following changes have been made to Summit Evolution (“Summit”) and the applications that are provided with it.  

 
General Summit Evolution Subjects 

1. Summit now supports cloud- or Internet-based imagery and accessory files. Here, we will refer to all non-local 
files as “cloud” files and their location to be “on the cloud,” which may be a variety of locations, such as a website, 
ftp site, or subscription file storage service. (June 24, July 9, August 28, 2024) 

There is a new project converter in Summit that will change the paths to reference the cloud files and provide 
credentials, if necessary.  

It will not only modify the paths for images, but also (if selected to do this) the corresponding models, viewport 
definitions, internal camera keys, control files, camera files, RPC files, or just about any files that have a path in 
the .smtxml. 

DAT/EM offers a test aerial Summit project referencing COG/TIFF images, camera, camera grid correction .dat 
files, control files, and optional .histohfa (Summit histogram files) located on the cloud. The files are at https 
locations on the datemsystems.com website. The files are not stored or copied locally. The project is available by 
email request to support@datem.com. 

COG is the required image format for cloud-based Summit projects. See the “DAT/EM Image Creator” section 
above to learn about COG format and new COG compression options. 

As part of this effort, GDAL (and cURL, used by GDAL) libraries are updated. Some terms and definitions: 

• GDAL: “The Geospatial Data Abstraction Library is a computer software library for reading and writing raster and 
vector geospatial data formats, and is released under the permissive X/MIT style free software license by the Open 
Source Geospatial Foundation,” -- Wikipedia 

• COG: “A Cloud Optimized GeoTIFF (COG) is a GeoTIFF with an internal organization that enables more efficient 
workflows in the cloud environment. It does this by leveraging the ability of clients issuing HTTP GET range requests 
to ask for just the parts of a file they need. – www.USGS.gov 

Note: DAT/EM Image Creator v.8.2 and higher can output COG format. Version 8.3 has more COG 
compression options than v.8.2. 

http://www.usgs.gov/
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To change a local Summit project to reference cloud-based files, first create the project locally. Then copy the 
images or images plus supporting project files (camera, control, etc.) to the desired cloud location. Finally, select 
Summit > File > Cloud Project.  

   
 

Input Project: After selecting an Input Project, the dialog will automatically 
fill the output Cloud Project file name with <originalProject>_cloud.smtxml. 

 

 
Images and Support Files or Images Only: By default, Images and Support Files is set so that all images, 
camera files, control files, RPC files, etc. are converted to cloud paths. The real benefit comes from cloud 
imagery, so some users may not want all the other supporting files on the cloud. If only the images are on the 
cloud, and all support files remain local, select Images Only to change images paths only.  

Protocol: Depending on the protocol selected, some 
default items and prompts may change for each protocol. 

 
Most protocols are recognizable by their cloud service name. Other allows you set 'other' protocols that GDAL 
supports, but are not offered in this menu. If using Other, you would type in the rest of the prefix, for example: 
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After selecting a protocol, paste in the cloud location. Here is an example of an FTP location:  

 
It does not matter whether the cloud path has "/" on the end or not.  

An example of an AWS S3 Bucket location could just be a name, for example:  

 
Credentials: The Credentials area is a mini text editor. You can cut and paste or key in the KEY names and 
credentials, or use the More Keys button to add KEYs for the selected Protocol. 

 
Some rules and hints: 

• Each line is to have a KEY, '=', followed by its VALUE. 

• There should be no spaces between the KEY, =, and VALUE. 

• It is acceptable to leave a VALUE blank. A KEY without a VALUE will be ignored.  

• Any defaults set here will be ignored if a user does not set them to a VALUE. 
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More Keys button: By default, only a few keys 
are added when you select a Protocol. The More 
Keys button will add most – if not all – the keys 
the protocol can have. For example, if you select 
More Keys with AWS S3 bucket selected, it will 
add keys to the list: 

 
You may also choose to look up the necessary KEYs and copy/paste them. 

Refer to GDAL keys: https://gdal.org/user/virtual_file_systems.html#vsicurl-http-https-ftp-files-random-access  

More about Summit projects with cloud-based files: 

• For speed and simplicity, Summit will, at times, assume cloud files exist even if they do not. Only when 
they are truly accessed will we know whether they exist. You may be accustomed to seeing a red “X” in 
Summit’s Project Edit dialog next to an image that cannot be found at the given local path; the red “X” will 
not appear for an incorrect cloud path. If the file is not found, it simply will not open. 

• Images are not downloaded locally; however, files that are typically smaller will be downloaded to a 
temporary local location. These include control files, camera files, and RPC text files. This works by 
identifying the file as a cloud file using the same method as GDAL, so the name is prefixed with /vsi plus 
the protocol, such as /vsicurl. In the background, the file is downloaded to a temporary file system file 
and used as a normal, local file after that. 

• “Large” projects (with many images) can still use binary extents (Summit > Orientation > Model Extents 
to File) once the project file setup is finished. As with projects that have local files, this will make the 
project faster by preventing frequent recalculation of all the model extents.  

• Previously Summit histogram .histohfa files would be in the same local folder with the local images. They 
are not named in the .smtxml, but used if they are found. These will work from a cloud location as long as 
the .histohfa is already in the cloud folder with its image. They must be generated locally (by Image 
Creator or Summit > Imagery > Project Histogram while the input images are still local) before posting 
to the same cloud location with the images. Images that are already at cloud locations cannot be used as 
input for making .histohfa files. For the example in the Nashville cloud project (available from 
support@datem.com), the .histohfa files were previously generated and provided for the first two images. 

• Performance for cloud-based images will naturally depend on the speed of the Internet connection and 
image format, which should be COG. COG is superior to any other format for streaming large images. 

DAT/EM would appreciate feedback to support@datem.com that includes your download transfer rate, the COG 
file compression choice, and how quickly you perceive the project to open and draw new tiles on panning. 

https://gdal.org/user/virtual_file_systems.html#vsicurl-http-https-ftp-files-random-access
mailto:support@datem.com
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2. Summit now supports Dark Mode (“Dark”) color themes. When you set Summit to a Dark Mode theme, it changes 
all other DAT/EM applications to dark mode at the same time, for example, DAT/EM Keypad, DAT/EM Viewer, 
Point Cloud, and SI Lidar Tool. Here, we will show Summit, since it contains the Dark Mode setting. 

To get the most immersion into Summit’s Dark theme, both Windows 10/11 and Summit can be set to Dark Mode: 
(December 11, 2023) 

 
Windows 11 set to Personalization > Colors > Choose your mode > Dark 

 
Summit > View > Look and Feel > Dark Mode options 

When Dark is set in Windows, many applications will automatically go into Dark mode. Likewise, when Summit 
detects Windows Dark for the first time, it will start in Dark Mode. Summit can switch between Dark and Light 
modes regardless of the Windows Dark/Light Setting using Summit > View> Look and Feel settings.  

Some system dialogs are controlled by Windows. For example, if you set Summit to Dark mode and Windows to 
Light, then the Summit > File > Open dialog may open in Light. Even so, approximately 90% of Summit’s display 
components will display in Dark. 

When switching between Light and Dark mode choices, close and reopen Summit to activate the change. 
Reopening is not required between variations of the same mode, such as from one Dark Mode color to another 
Dark Mode color. 
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Summit in a Dark display mode, set in Summit > View > Look and Feel 

Most – but not all – Summit windows are Dark Mode compatible. Microsoft does not have 100% Dark Mode 
compatibility in their own applications and does not directly support Dark Mode for any remaining Win32 
applications, so it may not be possible to achieve 100% Dark Mode compatibility in Summit v.8.3.  

3. The default shortcut key for Full Screen mode has been changed to F11 (previously F4). Most – if not all – other 
applications use F11 for Full Screen mode; this change complies with the standard. (April 5, 2024) 

4. Side-by-side (half) has been added as an initial setting to begin testing single-panel lenticular lens-type stereo 
displays. Note that we do not know if this is all that is needed for such displays; the setting will allow us to test 
them. This setting is not for use with 3DVision, PluraView, Contour, Vectour, or SeeHawk stereo displays. (April 5, 
2024) 

To use, set Summit > Tools > Options > Anaglyph or Side-by-Side > Side by Side (half): 

 
New Side by Side (half) in the Anaglyph or Side-by-Side options 
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Once set to Side-by-side (half), it works exactly like "50/50 Demo mode" when not in Full Screen display: 

 
It displays the same as 50/50 Demo mode while not in Full Screen display 

This version also changes the default Full Screen toggle shortcut from F4 to F11, as shown in the item above. Of 
course you can customize shortcuts. Press F11 (or your customized shortcut for Full Screen) to switch it to Full 
Screen mode. It will switch to a scaled side-by-side mode automatically: 

 
In Full Screen mode, it will switch to a scaled side-by-side mode 

Notice the stretched appearance, which is normal for this type of side-by-side display. Now you may test the 
stereo view in a lenticular lens-type stereo display. Please send any testing results to support@datem.com and 
we will see that it is shared with Software Engineering. 

Note: During the version 8.4 beta cycle, DAT/EM may be doing direct development for certain brands/models of 
lenticular lens displays. This may require more changes than only the side-by-side mode shown above. If this is of 
interest to you, contact support@datem.com for information after the first quarter of 2025. 

mailto:support@datem.com
mailto:support@datem.com
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5. There is a new “DEMO MODE” label that appears when Summit > Tools > Options > Main View > Anaglyph or 
Side-by-Side > 50/50 Demo mode is on. This is meant to remind you to turn off the demo mode setting before 
setting up a stereo display such as a PluraView, Contour, Vectour, or 3DVision. (October 16, 2024) 
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6. Summit now supports the Stealth H-Type mouse. The H-type will appear in the “HID-compliant game controller” 
area of Windows Device Manager. You do not need to install a special driver. Plug in the H-type mouse, then set 
Summit > Tools > Options > Input Devices > Stealth H-Type: (January 26, 2024) 

  
New Stealth H-Type setting 

Set the button configuration for the H-type in Summit > Tools > Button Manager > Stealth Z or H (previously 
labeled Stealth Z only). The case styles are the same as previous devices, and the button layout and shift button 
options are the same as the previous Z-type: 

 
The Stealth Z and H share the same Button Manager tab 
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7. Summit > Tools > Point Collector has the following enhancements: 

a. Point Collector now offers Ground, Pixel, and both Ground and Pixel output coordinates to be saved to 
the output file. (February 13, 2024) 

 
New Point Collector coordinates type selections 

b. Show is a new setting in Point Collector to optionally superimpose the point locations over the main 
Summit view. Hint: To set the size and opacity of the points, use the Summit > Tools > Options > SI > 
Points > Size and Opacity sliders. (February 29, 2024) 

 
New Show setting in Point Collector 

8. The Summit > Tools > Options > Main View tab > Performance slider setting was removed. It was obsolete. 
(February 12, 2024) 

9. The Button Manager application has fixes for several of the Generic Cad functions. (May 8, 2024) 
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10. Delete Vertex in Summit’s DAT/EM Drawing Objects (found on the Drawing and Editing toolbar and in Summit 
> Drawing > Polyline > Delete Vertex) would not activate for a selected vertex on a selected open polyline. It 
would only work for closed polylines. This is fixed to work with open polylines. (July 3, 2024) 

11. Summit’s Project Edit dialogs for Aerial, PCI ProPack, Corona, and Stitch project types had an error when the 
user dragged and dropped images into a different order in the dialog’s Images list. This is fixed. (July 24, 2024) 

12. The Add Group dialog from the Project window’s Groups tab now saves the dialog size, screen position, and any 
custom column widths. (July 30, 2024) 

13. The editor dialog for Summit’s three Custom CAD toolbars will now be able to export/import strings that include 
“quotation” characters. (August 29, 2024) 

14. Summit > Orientation > AT Export > PatB has the following changes: (September 17, 2024) 

a. It will now export values with three places past the decimal instead of one. 

 
b. Previously, the image name had to be numerical. Now there is a choice between Numerical or Text: 

 

• For Text, the image name will be placed based on its text in the .im file: 

 

Additionally, the .pro file will have “A15” in it: I 

• For Numerical, it will work if the image names (without extension) are numerical, such as 

12345.tif, and the .pro file will have “i15”:  
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15. Terrain Visualization has the following changes: 

a. Terrain Visualization has stability fixes and to improve use in some sensor models. (October 28, 2024) 

b. While the Terrain Visualization dialog is displayed, the SI Layer Manager will not update layers, even if 
the layer list changes on the Capture side (such as a new layers or new reference files). This is to provide 
additional stability. If you need the layer list to update, close Terrain Visualization, make the changes, do 
an SI Update, then reopen Terrain Visualization. (October 15, 2024) 

16. The Summit > Tools > Options > Project > Edge % slider can now be set even when Automatically load next 
model… is off. The slider setting can affect whether the cursor position is retained (when possible) when the user 
changes the model by picking a model in the Project window. (October 14, 2024) 

Terrain Project Tools 

17. Terrain Projects and Terrain Project-related subjects (except Point Cloud) have the following changes. Note: Point 
Cloud application items are in the next section of this document. 

a. Terrain Projects made from certain formats of ASCII files could report an incorrect Z range and/or an 
incorrect number of points. This is fixed. (February 29, 2024) 

 
Importing Projects into Summit 

18. Importing Projects into Summit has the following changes: 

a. Summit's import tool for Vexcel UltraMap .eo files (Summit > File > Import > Vexcel UltraMap EO file) 
has the following enhancements: (July 29, 2024 and later improvements) 

 The .eo import has a better matching algorithm for when the camera name in the .eo does not 
match exactly to the image file name on disk. For instance, the image name "0284-Fwd-RGB.tif" 
will now match to "Lvl02-Oblique-Forward.camera". Before this improvement, when it couldn’t 
find a match, it would assign the same (first) camera to all images in a multi-head camera project. 
Now it will successfully assign each camera file to its own images. 

 It will now use the sensor serial number in the Summit camera file name and match images to 
cameras better as a result. 

 It will now read the unit name from the .eo file and set that unit in the Summit .smtxml file. If the 
unit name is not “m” (meters), it will set feet. The user should still check and possibly reset the 
unit in Summit > Edit > Project for any projects that are not in meters. 

 In the dialog raised by Summit > File > Import > Vexcel UltraMap EO file, the default path now 
shows the folder location that contains the .eo file, as long as that folder has been set. 

b. The wording on the menu Summit > File > Import > Pix4D has been changed to Pix4Dmapper. This 
distinguishes two of the brand’s products, Pix4Dmapper and Pix4Dmatic. Pix4Dmapper projects output 
a photogrammetric camera calibration and exterior orientation values that may be imported to make a 
Summit aerial project. Pix4Dmatic projects do not provide enough information to import an aerial project. 
Note that both Pix4Dmapper and Pix4Dmatic make an orthophoto and point cloud, which may be used 
by Summit > Terrain > Lidargrammetry > Stereo Mate from Orthophotos to make a generated stereo 
project. (July 31, 2024) 
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Aerial Projects 

20. Aerial projects have the following changes: 

a. In the aerial Camera Editor, if you checked on the Grid distortion file by mistake, it would write a path in the 
.cam file, and it would not remove it. The camera file would then give an error about not finding the grid file. 
This is now fixed. (February 27, 2024) 

b. The Project window > Automatic Model Generator  > Minimum Overlap and Maximum Overlap are 
now saved to the registry to be used again by the next instance of the dialog and in the next instance of 
Summit. (June 7, 2024) 

c. The wording only (not the functionality) of the Project window > Models tab > Generate Models  > 
“Don’t regenerate already created models” setting has changed to “Do not replace existing models. 
Append new models.” (July 15, 2024) 

 

 
 
 
 
 

Satellite RPC and Epipolar Generation for All Compatible Projects 

20. Satellite RPC and Epipolar Generation Projects have the following changes: 

a. There is a slight modification to read the .txt RPC file provided with BJ3B tristereo imagery. (December 14, 
2024) 

b. The Epipolar Generator will detect when the Write as BigTiff setting is off, but the file output will overrun 
the ~4.2GB “small” (32-bit) TIF size limit. If the file will be larger than the limit, it will output BigTiff 
automatically. In effect, if Write as BigTiff is on, it will output BigTiff for any file size; if Write as BigTiff is 
off, only files exceeding ~4.2GB will be output as BigTiff. If the project is likely to create a mixture of 
“small” and “big” files, the user may choose to turn on Write as BigTiff to output a uniform format. (January 
9, 2024) 
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c. The Project Edit dialog for RPC and Epipolar RPC projects has the following new options: 

• The Epipolar RPC project now can add a control file. (This option was already available in the 
RPC project, before the epipolar project was generated). This is used to get an average elevation 
for the project and in the Move to Ground tool. It is not used for further adjustments to the RPCs. 
(July 24, 2024) 

• In the RPC project, there is a new choice to set the average ground elevation as a key-in. 
Previously, it could only calculate the average elevation from a control file. Now if there is no 
control file, or if the control file’s average point elevation does not give a very good average for 
the overall terrain, set it to Key In and enter the estimated average ground elevation for the 
project. This will help in many ways, including – but not limited to – initial model opening elevation 
and automatic model generation. (February 26, 2024) 

 

 
New RPC project choice to Key In an average elevation when there is no Control File 

• In both the RPC and Epipolar RPC projects, there is a new option, Automatically rotate view 
with direction combination options, such as Up or right and Up or Left. This is recommended to 
be checked on. Set the direction option to your two most favorite north arrow directions (which 
includes the quadrant in between). Any stereo model has only two possible north arrow 
directions: The default based on model properties and 180 degrees from that. The new setting 
essentially chooses between the two possible display angles, so you do not need to use the “Flip 
180” tool very often. It will open the model’s north direction as close to the two selected screen 
directions as possible, and will prevent sudden near-180-degree screen direction changes when 
the next model opens automatically. (July 24, 2024) 

 

 
New RPC and Epipolar RPC project north arrow screen direction preferences 
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d. Special epipolar model switching has been added. Previously, when Summit > Tools > Options > 
Project > Automatically load next… was on, epipolar projects (such as those made from SkySat RPC 
imagery that was run through Summit > Imagery > Epipolar Generation) had trouble changing to the 
next model at the expected cursor location near the edge of the stereo area. It now examines a small 
zoom level to determine the actual image pixels and black background pixels. The model extents will now 
look something like this: (June 27, 2024 and later updates) 

 
New model extents method for satellite epipolar imagery projects 

Note: This method for extents is fast, but needs to be done every time model extents are calculated 
(usually just on startup). Summit > Orientation > Model Extents to file can be used so extents do not 
need to be recalculated often.  
 

ADS40/80/100/etc. Projects 

21. ADS40/80/100/etc. projects have the following changes: 

a. ADS projects use an ADS40 code library supplied by Leica. The Leica code does not allow paths that 
contain spaces. DAT/EM was using an old function called GetShortPathName to try to remove any spaces 
in a way that would be invisible to the user. This function was not working in all cases, especially with long 
path names and drives formatted in a certain way. DAT/EM will now try more ways to make paths with 
spaces work the user does not need to edit the paths. The entire process is now: (September 3, 2024) 

1) It tries to use the path found in the SUP just as it is. 
2) If 1.) fails, it tries the GetShortPathName method. 
3) If 2.) fails, it tries a new way, which copies files to a temporary folder. This new way also makes a 

special temporary SUP file, but also copies the orientation files to the temporary folder. The 
Windows temporary folder will not have spaces and will look something like this: 
"C:\Users\<UserID>\AppData\Local\Temp". In this way, folder paths do not have to be shortened, 
because there will not be spaces, so it does not need to try GetShortPathName again. 

4) If 1.), 2.), and 3.) fail, then it will give the original Leica error about spaces in the path. Only then 
will you need to rename your project path to remove spaces and possibly reduce the total number 
of characters in the path, and try again. 
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Project Viewer / Ortho+Mosaic  

22. Project Viewer / Ortho+Mosaic has the following changes: 

a. Ortho+Mosaic now allows up to 8 threads to be set for simultaneous processing. (February 27, 2024) 

b. Ortho+Mosaic will now detect the black background in SkySat RPC imagery and treat it as transparent. It 
will no longer obscure valid ground pixel colors of other images in the display. (July 24, 2024) 

c. Ortho+Mosaic will now detect and work around erroneous RPC data in SkySat RPC imagery that caused 
some “zingers” in the Ortho+Mosaic display. The display will now look better. Note that this change does 
not fix or modify the RPCs in any way. (July 24, 2024) 

Point Translator  

23. Point Translator (provided with some Summit license levels and with LandScape) has the following changes: 

a. Point Translator > Conversion tab has new settings to swap the (x,y) order upon input or output. (August 
8, 2024) 

• If Conversion tab > Convert Points is off, Swap XY appears. When on, this will swap the (x,y) 
order that was found in the input file. 

 

• If Conversion tab > Convert Points is checked on, two new swap options appear. If either of 
these are needed, check the one that best describes the timing needed for the swap, before or 
after the translation/transformation stage: 

o Input System swap XY (from northing easting) swaps the order read from the input 
file(s) before the values are translated/transformed. 

o Output System swap XY (to northing easting) transforms the coordinates in the order 
they were read from the input file(s), then swaps (x,y) of the translated/transformed 
coordinates. 
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LandScape 
Landscape has the following changes: 

1. LandScape now supports the Stealth H-Type mouse. The H-type will appear in the “HID-compliant game 
controller” area of Windows Device Manager. You do not need to install a special driver. Plug in the H-type 
mouse, then set LandScape > Tools > Options > Input Devices > Stealth H-Type: (February 1, 2024) 

  
New Stealth H-Type 3D Mouse setting in LandScape 

Set the button configuration for the H-type in LandScape > Tools > Button Manager > Stealth Z or H 
(previously labeled Stealth Z only). The case styles are the same as previous devices, and the button layout and 
shift button options are the same as the previous Z-type: 

 
The Stealth Z and H share the same configuration tab in the Button Manager 

2. The installation process will now associate .lndscp files with the LandScape application. (June 25, 2024) 
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DAT/EM Capture for 64-bit ArcGIS Pro 
Changes apply to DAT/EM Capture for 64-bit ArcGIS Pro in the following versions: 

• ArcGIS Pro version 3.3.x and 3.4.x released up to the time of the version 8.3 release. (The latest two tested versions 
as of the v.8.3 release date are 3.3.2 and 3.4.0.) 

o For any newer versions released after the date of these Release Notes, contact support@datem.com to ask 
whether the version is compatible or to request access to the next version’s betas for supported licenses. 

o If both 32-bit ArcMap and 64-bit ArcGIS Pro are installed on the computer, Capture extensions will be 
installed for both. The ArcGIS Pro extension attempts to register during installation, but login permissions 
or ArcGIS Pro Add-In Manager settings may interfere. Correct the permissions issues, then use the DAT/EM 
Administration Tool > CAD Enabler to activate the extension on demand or to set a common Add-In folder. 

DAT/EM Capture for ArcGIS Pro has the following changes: 

1. See the DAT/EM Administration Tool section above for information on how to set a common add-in folder for 
Capture for ArcGIS Pro. (December 7, 2023) 

2. Capture for ArcGIS Pro is compatible with only ArcGIS Pro version 3.3.x and 3.4.x as released before the date 
indicated on the first page of these Release Notes. (June 3 to remove old versions, November 8, 2024 to add 3.4.x) 

3. DAT/EM’s Setup installation process no longer uses the silent registration mode for the Esri ArcGIS Pro Add-In 
registration tool. It will now bring up a dialog near the end of DAT/EM Setup. Answer Install Add-In to complete 
the Capture extension registration: 

 
Dialog during DAT/EM Setup installation. Select Install Add-In. 

This is no guarantee that it will succeed. If it fails, please take a screen capture of the resulting message to send 
to support@datem.com. 

mailto:support@datem.com
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Note: The ArcGIS Pro Add-In Manager must be set to allow “signed” or “all” Add-Ins for this to work: 

 
The Capture extension will register only if either of the highlighted 

settings are current in the ArcGIS Pro Add-In Manager 

4. There is a new example DAT/EM Keypad .dkf file for ArcGIS Pro installed to "C:\ProgramData\Datem 
Systems\keypad\ArcGISPro.dkf". It may be used for demonstration or you may copy it to a different name (to 
prevent overwriting with software updates) and modify the copy to suit your own projects. Another use is to copy 
keywords from the Keypad and paste into Button Manager’s UserCad buttons without having to look up the 
keyword list in the User Guide. (August 5, 2024) 

 
New example DAT/EM Keypad .dkf file for ArcGIS Pro 
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5. DAT/EM Capture Settings > General > ArcGIS Pro moves system mouse from 3D cursor is a new setting. It 
makes it possible to use ArcGIS Pro v.3.2.x and higher. It should be off (unchecked) in most cases, especially for 
Summit Professional/Feature Collection using a 3D input device such as a Stealth or GGS mouse. If it is on, a 3D 
input device configured in Summit and that is also supported by ArcGIS Pro will move the system mouse around 
wildly when you are trying to move the cursor in Summit. The new setting is a workaround for ArcGIS Pro’s 
implementation of 3D input devices in ArcGIS Pro version 3.2, which cannot turn off its own use of a 3D input 
device to move the system mouse. (February 22, 2024) 

 

 
ArcGIS Pro moves system mouse from 3D cursor = off makes it possible to use ArcGIS Pro 3.3.x and higher 

 

6. DAT/EM Capture Settings > General > Move Summit with ArcGIS Pro is a new setting. When on, Summit’s 
pan (not zoom) makes ArcGIS Pro pan (not zoom) to match, and ArcGIS Pro’s system mouse pan and zoom 
makes Summit’s view pan and zoom to match. When off, Summit makes ArcGIS Pro pan and zoom, but ArcGIS 
Pro does not control Summit’s view at all. Use it only if the results are acceptable for the work you are doing. 
(February 22, 2024, with improvements July 10, 2024) 

 
Setting to change the Summit  ArcGIS Pro view synchronization method 
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7. StartEditingTarget is a new keyword to set a target layer in the Create Features pane from the DAT/EM Keypad 
or Button Manager buttons. This keyword sets a target layer automatically as if you had clicked with the system 
mouse on that layer in the Create Features pane. This also activates the default drawing tool for that layer as 
usual upon selecting a layer. Layer groups, nested layer groups, and subtypes are supported.  

The full keyword with all the options: 

StartEditingTarget “Layer Group 1: SubLayerGroup2:AnyMoreNestedLayerGroups: 
SubLayerGroupN:Layername|subtype” 
Note! There are no line feeds in the above syntax. The line is wrapped to fit in this document page width. 
Do not include return characters. 

The StartEditingTarget keyword syntax has several rules and variations: 
• Layer groups, nested layer groups, and layers are each separated by a : character.  
• Layer and subtype are separated by a | (vertical line) character. Note: Subtypes must be supported by 

the ArcGIS Pro license level to work properly. 
• If there is at least one space character in any component of the string, enclose the string (past 

StartEditingTarget) in double quotation “ ” characters. If there are no spaces, omit the quotation 
characters. 

• If layer groups, nested layer groups, or subtypes are not present, omit them and their separator. (The 
layer is required. The subtype is required if the layer has subtype fields defined.) 

• If there are layer groups, but the final layer name within the group is unique, that is, never duplicated in 
any other layer group, it is optional to omit the layer groups and nested layer groups. If the layer groups 
are not specified, it will always return the first layer name that matches in the search, no matter how 
deeply it is nested in layer groups. If the layer name is unique among all the groups, it will find the layer 
you intended to set. 

Examples: 

• One layer group called Structures with a layer called Buildings and field subtype Shed. No spaces: 
StartEditingTarget Stuctures:Buildings|Shed 

• A simple layer called Trees with subtype Alive (or a unique layer with subtype inside any number of layer 
groups. The layer groups may be omitted when the layer name is unique). No spaces: 

StartEditingTarget Trees|Alive 

• Layer group and layer (or unique layer inside any number of layer groups) with spaces. No subtype: 
StartEditingTarget "Small Buildings:Hay Storage" 

• One layer group, two different sub layer groups, layer that is not unique within the layer groups, and 
subtype, with spaces. Listing all the components is important, since the Coniferous and Deciduous 
layers are used in more than one layer group each: 

StartEditingTarget "Vegetation:Trees over 10m:Coniferous|Spruce" 
StartEditingTarget "Vegetation:Trees under 10m:Coniferous|Spruce" 
StartEditingTarget "Vegetation:Trees over 10m:Deciduous|Oak" 
StartEditingTarget "Vegetation:Trees under 10m: Deciduous|Oak" 

If you need help making a Keypad key using the StartEditingTarget keyword, send the text string you have tried 
so far and a screen shot of the layer displayed in the Create Features pane to support@datem.com. 

 
 
 

mailto:support@datem.com
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8. DAT/EM Capture Settings > SI page has new settings: 

a. Snap ring color is the color of the snap ring circle in superimposition. (October 14, 2024) 

b. Fill polygons in SI – When unchecked, superimposition (SI) will only draw an outline (using the fill color) 
when there is a fill defined in ArcGIS Pro. When checked on, it will draw both the outline and the fill for 
solid and many hatch and simple fill patterns. It will not be able to draw more complex fill patterns. Hint: 
DAT/EM suggests keeping this setting off, since fill can obscure the view of the images inside the 
polygon. (January 2024) 

c. Ignore Layer’s definition query. If off and the layer has a definition query, it will be applied to 
superimposition the same way it is applied in ArcGIS Pro’s view. If on, the contents of the entire layer will 
be displayed in superimposition. (March 1, 2024) 

d. Unknown layer color will be used as a “final fallback” color when all other methods to determine a 
superimposition color do not work. (October 14, 2024) 

 
New SI tab settings 

9. The DAT/EM Stream, Square, and Trace modes are now mutually exclusive. If you have one set and then set 
another, the initial one will turn off. (February 23, 2024)  

10. Cycle Select is implemented for Capture for ArcGIS Pro. It was previously available in Capture for 32-bit ArcMap. 
Cycle Select works for object and snap selections, whether DAT/EM snap is set on or off. The idea is to pick and 
hold the Summit cursor’s position still, then pick again any number of times without moving the cursor. It will 
“cycle” through the possible selections or snaps at the location (within the snap ring size, even if snap is off). If 
you pick too many times and skip the one you want, pick again until it “cycles around” and is offered again. When 
the correct selection or snap is offered, move the Summit cursor to accept it. 

Examples of Cycle Select: 

Cycle Select Example 1: DAT/EM Snap is on and you need to snap, but at the location where you want to 
snap, there are two objects at the same (x,y) and different (z) values. You want to snap to the lower one. 
Position the cursor near the objects. Both objects are inside the snap ring. Maybe you even see the 3D snap 
line going to the wrong, higher object, but do not worry! Pick and hold the Summit cursor’s position still. If the 
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wrong object is selected, continue to hold the cursor still and pick again. It will now select the lower object. 
When it has selected the one you like, simply move Summit’s cursor to accept the snap. 

Cycle Select Example 2: You start the DAT/EM Split Polygon tool. You position the cursor as near as 
possible to the polygon edge where you want to start the split line; however, there are three polygons there 
that share edges or are very close to each other. You may not be able to see whether the 3D snap line is 
going to the correct polygon, but do not worry! Pick and hold the Summit cursor’s position still. If the wrong 
polygon is highlighted for selection, continue to hold the cursor still and pick again, and maybe again, until it 
highlights the correct polygon, then move the Summit cursor to accept. Draw the split line and finish. 

Cycle Select Example 3: You start the ArcMap Selection Tool. You position the Summit cursor near the 
object you wish to select. There are multiple objects inside the snap ring, and you only want one of them. 
Optionally, if it is even possible, you can move the cursor so the snap ring excludes objects you do not want 
to select (this will reduce the number of picks you might need to make). Then pick and hold the cursor still. 
Continue to pick without moving the cursor position until the correct object is highlighted. Move the cursor to 
accept the selection. 

11. Snapping subjects have changed as follows: 

a. DAT/EM “Multi Snap” or “Cycle Select”: All edit and create commands now support cycle snap selection 
as described in the item above. If the cursor approaches multiple snap targets within the snap radius, and 
a pick snaps to the wrong location, hold the (x,y) still and pick again one or more times. It will cycle 
through the snap targets one by one. When the correct snap is given, move the cursor to accept the 
snap. (August 27, 2024) 

b. DAT/EM snapping now prioritizes or weights the snap types that are on (highlighted). The weighting is 
important when there is more than one potential snap type within the snap ring. Snaps are weighted in 
the following order, from higher weight to lower: Intersection, Vertex, Near. 

 
c. There is an additional keyword for toggling the Vertex, Nearest, and Intersection snap types (highlighted 

on the ribbon menu in the image above). The pre-existing keyword snaptypes* (with an “s” at the end) 
still works and is best for toggling multiple snap types at one time. The new keyword is snaptype (without 
the “s” on the end) and is best for specifically turning on or off one snap type at a time. The full syntax is: 

snaptype <nearest/vertex/intersection> <on/off> 

All the possible combinations: 

snaptype nearest on 

snaptype vertex on 

snaptype intersection on 

snaptype nearest off 

snaptype vertex off 

snaptype intersection off 

* See the “Capture for ArcGIS Pro User Guide” for information on the pre-existing snaptypes keyword. 
   

d. Snapping for selection could happen even with Snap Mode off. This is fixed. (October 28, 2024) 
 

e. The snap database generation process has efficiency improvements. For the user, this means less wait 
time. (November 9, 2024) 
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12. DAT/EM Streaming mode is now smoother and allows for Undo to remove multiple vertices. There is a new 
setting: DAT/EM Capture Settings > Streaming tab > Number of vertices to step back on an Undo, which 
allows the user to choose how many vertices to remove with one Undo during Streaming. If the current line has 
fewer than Number…, then Undo goes back one vertex at a time. (July 9, 2024) 

 
New choice for number of vertices to undo at one time during Streaming mode drawing 

Following an Undo event during Streaming, the user has a choice of what to do next: 

o After Undo, press the pick button right away to continue streaming from the current location, 

o Or move to a new location before pressing the pick button to continue streaming, 

o Or Undo again to remove more vertices, then choose again what to do next. 

For now, the streaming line is drawn in superimposition only – not in the ArcGIS Pro view – until it is finished (this 
may change in the future). 

 

13. ClearSelection is a new keyword to use on the DAT/EM Keypad or on Button Manager UserCad buttons. It calls 
the ArcGIS Pro “Clear Selection” tool. (February 26, 2024) 

14. DAT/EM Copy Parallel is a new tool to create one or more polylines or polygons parallel to selected polylines or 
polygons. There are several differences between ArcGIS Pro’s built-in Copy Parallel tool and DAT/EM Copy 
Parallel. The key differences: (January 26 and July 11, 2024) 

o The DAT/EM tool will create parallel objects using matched line or polygon geometry, but can also create 
polygons based on poylines or polylines based on polygons. (Esri’s tool only offsets with the same 
geometry type.) 

o The DAT/EM tool can create either a single offset or multiple 3D offsets at one time. (Esri’s tool only 
creates one offset at a time.) 
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New DAT/EM Copy Parallel creates single or multiple offsets and can mix line and polygon geometry types 

The keywords to use on the DAT/EM Keypad Controller and Button Manager User CAD Buttons are:  
 

Keyword Description 

DATEM_copyparallel  Launch the command dialog 

Apply 
(This is not a new keyword. It selects the Apply button in 
any DAT/EM Capture dialog.) 

Create multiple offset lines (the 
same as the Apply button in the 
dialog) 

To set horizontal and vertical offsets and the layer name: 

AddOffset <horizontal offset>,<vertical offset>, <layer> 

Or to set the horizontal and vertical offsets only: 

AddOffset <horizontal offset>,<vertical offset> 

Or to set the horizontal offset only (probably not useful!): 

AddOffset <horizontal offset> 

There is no way to set the vertical offset only using a 
keyword. 

Note: Polygons in ArcGIS Pro are clockwise. A positive 
horizontal offset value will offset to the inside of a polygon, 
and a negative value will draw to the outside. 

Add horizontal offset value, 
horizontal and vertical offset values, 
and optional layer to the Copy 
Parallel Settings list. 
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To use: 

 Choose a setting for multiple or single (measured) offsets: 

Multiple Offsets: Check on Create multiple parallel lines. The list control is enabled. Use the 
green + button to build a list of offsets by either keying in the horizontal and vertical offsets or 
measuring them with Summit. Select a polygon or polyline to offset. Press the Apply button (or 
submit the Apply keyword from the Keypad or a UserCad Button Manager button). The Summit 
input device’s Cancel/Reset/Finish (“Cancel”) button may be used to toggle between selecting 
line- or polygon-geometry objects and measuring the offset from the most recently selected 
object. When measuring, the currently highlighted offsets in the list are updated on a pick. A 
Button Manager UserCAD button may be set to call the Apply button in Create multiple parallel 
lines mode. 

Single Offsets: When Create multiple parallel lines is not checked, the list control is disabled 
and Summit’s Cancel button alternates between selecting existing features and measuring offset 
distances. In this mode the new parallel object is created immediately following a pick when 
measuring. 

 Follow the prompts. Prompts indicating the current mode (selecting or measuring) will always appear at 
the bottom of the dialog and usually in Summit’s CAD Command area (if Summit > Tools > Options > 
Main Text tab > Commands area > Show is on). 

 

15. DAT/EM Reshape Feature has the following changes: 

a. Reshape Feature for polygons now uses a 2D shortest path algorithm to decide which side of the 
polygon to keep after an edit. Previously when it used a 3D path, if there were some vertices at Z=0 in 
and otherwise high ground elevation object, the length of the 3D segments could cause the command to 
retain the wrong side of the polygon (May 23, 2024)  

b. Reshape Feature for polylines (line geometry) now allows the end (second) snap to be optional. The 
previous functionality still works, which is to use both beginning and end snaps to replace a mid-section of 
the line. Now to replace an end section, first snap to the original line, draw the new end section, and use 
the Cancel/Reset/Finish button to finish the sketch by replacing the end section. (Note that Reshape 
Feature always requires beginning and end snaps for polygons.) (October 18, 2024)  
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Steps to use DATEM Reshape Feature to replace the end section of a polyline 

16. DAT/EM Split Polygon is a new tool that splits a polygon and retains the elevations of the vertices digitized into 
the cut line. By contrast, the ArcGIS Pro Split Polygon tool flattens the elevations of the vertices in the cut line.  

As an example of the difference between the DAT/EM and ArcGIS Pro versions of the tool, let us say you draw a 
polygon around the base of a hill. Then you split the polygon by drawing a cut line of 50 vertices up one side, over 
the top, and down the other side of the hill. The ArcGIS Pro version of Split Polygon will interpolate the elevations 
of the 50 vertices to fit between the elevations picked on the original base polygon, so that the new polygon edges 
are under the hill. The DAT/EM version of Split Polygon will retain the individual vertex elevations so that the new 
polygon edges go up, over, and down the other side of the hill. 

The keyword to use on the DAT/EM Keypad Controller and Button Manager User CAD Buttons is:  

datem_SplitPolygon 

To use, select the DAT/EM version of Split Polygon from the DAT/EM Capture ribbon menu: 

 
Set your choice of DAT/EM Snap Mode (2D, 3D, OFF) and snap types (nearest, vertex) and change these at any 
time. You have a choice to snap the split line to the beginning and/or ending of the original polygon; each snap 
choice has a different result, see graphic description below. While drawing the split line, adjust the elevation to 
match the ground for each point. While digitizing, you may choose other snap types, turn snap off, or change 
snap modes. For the final point on the original polygon, set either 2D or 3D snap and the snap modes, and snap 
to the final tie-in point. Notes: 
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Original polygon 

 

  
With 2D or 3D snap on, the first and 
last picks keep the original polygon’s 
(x,y). Z is taken from the original 
polygon with a 2D snap, and from the 
stereoplotter elevation with a 3D snap. 

 

 
With snap off, the first and/or last picks 
may retain the full (x,y,z) of the 
stereoplotter cursor at the picks. This can 
change the visible “shape”! (Some snap 
overrides may occur if a selection 
distance is exceeded, so this may happen 
on only one side or neither side.) 

o DAT/EM’s Split Polygon tool uses DAT/EM Snap Mode and snap types to snap to the first and last points 
along the original polygon. If snap is off, it may activate a snap override to be sure a selection is made. 

Note: Esri’s version of the Split tool requires the cursor to cross the original polygon at the start and end; it is best 
to have snapping off for Esri’s version of the tool, because snapping can persistently snap to the polygon, which 
prevents crossing the polygon.  

17. DAT/EM Extend Line is a new tool that extends an existing “Source” line to another “Target” feature using 
Summit’s 3D digitizer for selections. (September 19, 2024) 

 
New DAT/EM Extend Line tool settings 
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Extend Line uses DAT/EM Cycle Select (see Cycle Select above) when multiple features are within the snap 
ring. The end segment closest to the initial Source selection is the beginning segment of the extension. The target 
point uses the current snap setting to control the elevation. When Snap Mode is 3D, the elevation of the Target 
feature is used. A 2D Snap Mode uses the current Summit Z value. 

Extend Line has four options: 

 Extend to selected point – always connects the Source line to the point selected by the user. The 
elevation depends on the DAT/EM Snap Mode setting. The Target feature may be a point, polyline, or 
polygon. 

 Extend Source along segment – extends along the Source line’s selected end segment to the 
intersection with the target line. It uses the selected point to select the object. The DAT/EM Snap Mode 
controls the Z value. The Target feature may be a point, polyline, or polygon. 

 Extend Source to intersection between end segments – extends both the Source and Target end 
segments out to their intersection and adds that point to the end of the Source line. The Target feature 
must be a polyline. The elevation is extrapolated from the pitch of the Source end segment when the 
DAT/EM Snap Mode is 3D. It is Summit’s Z when DAT/EM Snap Mode is 2D. 

 Extend the Target also – When Extend Source to intersection between end segments is on, it 
additionally extends the selected Target line to the intersection point. 

 

18. DAT/EM Cut Polygon is a new tool that cuts a hole in an existing polygon. To use: 

 Start DAT/EM Cut Polygon. 

 Select the polygon to cut. 

 Draw the hole that will be cut.  

Prompts will appear in Summit. A dialog offers settings: 

 

• If Copy Elevation is checked on, it uses the elevation value from the polygon being cut as the 
elevation of the hole. If it is not checked, then Summit’s current elevation is used. 

• If Fill Hole is checked on, a polygon matching the hole is created on the polygon layer you set in 
the combo box. 

• If Copy Fields is checked on, then fields with the same name and type are copied from the 
selected polygon into the polygon filling the hole. 
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19. There are many instances where DAT/EM prompts ArcGIS Pro for a color to use in superimposition, but it gives a 
blank or invalid response. This could result in the wrong superimposition (SI) color or the layer not being visible in 
superimposition. Now it sets a superimposition color for more cases as follows: (date range ending January 31, 2024) 

 The fill color if solid (or most patterns). 

 The gradient FROM color for all gradients. 

 The outline color if the other two are not set. 

 If all else fails, then it uses the color set in DAT/EM Capture Settings > SI tab > Unknown layer color. If 
you do not want it to use this color, temporarily set the layer’s color to a supported color style, followed by 
SI Update.  

 
Complex fill colors, including “Gradient” fill, shown in red in Summit’s superimposition 

20. The xyzout keyword was not working to launch the ASCII Export tool from the DAT/EM Keypad or Button 
Manager UserCad buttons. This is fixed. (March 18, 2024) 

21. Zoom Summit to Pick was moving Summit to (x,y,0) if the pick snapped to a 2D object having a null (or no) 
elevation. Now it will retain the current elevation from before the pick, if the pick returns a null Z. (February 28, 2024) 

22. Zoom to Selected Objects was not working. This is fixed. (March 1, 2024) 

23. Multipoint layers were not superimposing correctly for elevation. This is fixed. (October 2, 2024) 

24. Snapping, snapping-like selections in DAT/EM tools, and selections with snapping off have been improved. (ending 
November 6, 2024) 

25. Trace has functionality improvements. (November 7, 2024)  

26. A superimposition update (SI Update) will no longer be triggered by opening the ArcGIS Pro Attributes table. The 
side effect of this change may be fewer automatic SI Updates in other situations, so the user may need to 
manually select SI Update more often. (November 8, 2024) 

27. Performance is improved for 2D layers. (November 2024) 
 
 



DAT/EM Systems International Version 8.3 Release Notes 
 

Page 42 of 55 
 

DAT/EM Capture for 32-bit ArcGIS ArcMap 
Changes apply to 32-bit ArcGIS 10.0 (service pack 4), 10.1 (service pack 1), and 10.2.x through 10.9.x. Capture for ArcGIS ArcMap 
is still supported, but is no longer undergoing new development. 

This version may be compatible with ArcGIS 9.1, 9.2, 9.3 (service pack 1), 9.3.1(service pack 2). BE ADVISED: Testing no longer 
occurs for DAT/EM Capture with ArcGIS 9.x. It still installs for it and no code has been removed, so you may use 9.x provided it 
continues to work for you. Any issues will not be corrected. ArcGIS 9.x support may be dropped completely in a future release. Please 
continue to make plans to upgrade any remaining ArcGIS 9.x version to ArcGIS ArcMap 10.x or ArcGIS Pro. 

DAT/EM Capture for 32-bit ArcGIS ArcMap has the following changes: 
Capture for ArcGIS (ArcMap) Items 

DAT/EM Capture for 32-bit ArcGIS ArcMap aside from the Airfield3D options has no changes. 

 
Airfield3D (ArcMap) Items 

Airfield3D has the following change:  

This is not a change in Airfield3D, rather it is advice on how to use a new change in the DAT/EM Keypad for 
Airfield3D. This was available previously only by activating a dialog in Summit, but now it can be done from the 
DAT/EM Keypad. (January 31, 2024) 

The are two new DAT/EM Keypad keywords listed above in the DAT/EM Keypad area. They are: 

zindex delta <value> – Sets and applies Summit > Orientation > Z Index > Delta value without 
launching the dialog. 

zindex clear – clears the Z Index Delta value. 
 

Notes and disclaimers for general use appear above in the DAT/EM Keypad area. The Keywords were added for 
specific use in Airfield3D. They allow you to digitize certain obstacles above the ground elevation according to the 
following list supplied to one of our customers by the NGS: 
 

 Obstacle type INTERSTATE gets 17 feet added.  
 Obstacle type PRIMARY ROAD gets 15 feet added.  
 Obstacle type SECONDARY ROAD gets 10 feet added.  
 Obstacle type RAILROAD gets 23 feet added. 

For these obstacle types, you could add zindex delta <value> keys next to the four obstacle type keys on the 
Keypad. You would press the key before the matching obstacle type key. The strings may not be combined onto 
one key, because one has Summit/LandScape output, and the other has Capture output.  
 
Digitize these four types of obstacle points with the matching Z Index Delta applied and the cursor “on the ground” 
visually, but actively recording the indicated offset elevation for the digitized point. When the Z Index Delta is 
active, you will see red Z Index text in the lower right corner of Summit, for example: 

 
Example of red text in the lower right corner of Summit 

showing a Z Index delta is active for digitizing an INTERSTATE obstacle point at Z+17 feet 
 
Add another key with Summit/LandScape output type and zindex clear to use before digitizing any other obstacle 
type. There must not be any red Z Index text showing in the lower right corner of Summit for any other obstacle 
type besides INTERSTATE, PRIMARY ROAD, SECONDARY ROAD, and RAILROAD. 
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DAT/EM Capture and MapEditor for AutoCAD 
Changes apply to DAT/EM Capture and MapEditor for the following versions of AutoCAD: 

• 64-bit AutoCAD 2009-2025 versions with the latest service packs. Exception: 64-bit AutoCAD 2008 is not supported  

• 32-bit AutoCAD 2004-2008 versions with the latest service packs, provided you can get them to install on your 64-bit 
operating system (OS). DAT/EM no longer tests on 32-bit OS, so these must be running on 64-bit OS. DAT/EM is not 
responsible for helping to install a 32-bit version of AutoCAD on a 64-bit OS and cannot guarantee that this will succeed. 

When referring to a year/version number in the lists above, it includes AutoCAD, Civil3D, and Map3D. It does not include 
AutoCAD LT, which is a 2D product, and therefore will never work with a 3D cursor. 

Reminders: Install all available AutoCAD service packs and updates before installing DAT/EM software. Run each version of 
AutoCAD to make sure its license is active. 

DAT/EM software will install for multiple AutoCAD products of different year numbers on the same computer; however, it will only 
install for one of any multiple same-year versions (up to version 2018, when multiple same-year versions installed in different 
Program Files folders). For example, it will install for AutoCAD 2015, 2016, 2017 Civil3D, and Map3D 2018, because they are all 
different year versions; however, it will not install for both AutoCAD 2017 and AutoCAD Civil3D 2017 at the same time, because 
they are both the same year. In the case of multiple same-year versions, only one of them will receive the DAT/EM files at 
installation. To activate DAT/EM Capture in all of them, the AutoCAD \datem folder and the DAT/EM wintab driver file may be 
copied from the one that received the files to the other same-year versions. Contact DAT/EM Support for instructions. 

DAT/EM Capture and MapEditor for AutoCAD have the following changes: 

1. Version 8.3 is the first version to install for and work with for AutoCAD 2025. This includes the base AutoCAD 
version, Map3D, and Civil3D 2025 versions. (April 24, 2024)  

2. Capture running in AutoCAD 2004 was not saving all the values, such as map scale and units, from the SETUP 
dialog to the registry. This is fixed. (January 8, 2024) 

 

DAT/EM Capture and MapEditor for 64-bit MicroStation 
Changes apply to DAT/EM Capture and MapEditor for 64-bit, fully 3D (not 2.5D) Bentley MicroStation and several additional 
MicroStation-based products as listed below. The products must have been released before the date of the DAT/EM software build 
shown in the DAT/EM Setup file name or in DAT/EM Administration Tool > Release Information > Release Date. DAT/EM software 
may install for MicroStation releases that are newer or older than the following list, and they may work, but they will not be guaranteed 
to work. Approved versions include: 

• MicroStation CONNECT Update 17 

• MicroStation 2023 

• MicroStation 2024 

• OpenRoads Designer (commonly referred to as “ORD”), including final “Update” number, 2023, and 2024 versions 

• OpenCities Map Advanced, including final “Update” number, 2023 and 2024 versions 

• OpenCities Map Ultimate, including final “Update” number, 2023 and 2024 versions 

• OpenBridge Designer, including final “Update” number, 2023 and 2024 versions 
 

If you would like DAT/EM to investigate a product or newer version that is not listed above, please contact 
support@datem.com. 
 
Note: If there are multiple MicroStation and MicroStation-based products installed, DAT/EM software may install and 
load for all of them. DAT/EM Administration Tool > Release Information > CAD Enabler will enable or disable for all of them 
at one time. If you would like to restrict loading DAT/EM applications to specific MicroStation products, contact 
support@datem.com for instructions. 

 

mailto:support@datem.com
mailto:support@datem.com
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DAT/EM Capture and MapEditor for approved 64-bit MicroStation versions have the following changes: 

1. VERY IMPORTANT for MICROSTATION USERS! This subject is listed first, because it affects some of our most 
popular commands: ANNOTATE, AUTOARC, AUTOARC2D, BREAK, BREAK ELEMENT, DATDRAW, PSQR, 
PSQR SELECT, SPOTMODIFY, TOUCH, and TOUCH ENDS. To reduce the need for dialogs, these are now 
launched immediately using the most recent settings. To change settings, existing settings key-ins (per individual 
setting) can be used or dialogs can be raised using new <command> SETTINGS key-ins. 

Either the command by itself or the <command> SETTINGS dialog’s OK button starts the drawing/selection 
prompts for the command.  

For example: PSQR now has both PSQR and PSQR SETTINGS. If you start PSQR alone, it will launch 
immediately into drawing mode using the most recent settings. If you want to view the current settings, 
use PSQR SETTINGS followed by OK to run the command. To change settings silently (no dialog), use 
existing PSQR <settings key-ins>. 

You may not need to change existing DAT/EM Keypad keys, especially if they already call settings key-ins for the 
command. You may want to add the various <command> SETTINGS commands to the Keypad. All settings in 
these <command> SETTINGS dialogs have equivalent key-ins, which can be placed on the DAT/EM Keypad or 
Summit’s UserCad Button Manager buttons. 

One concern with some of the drawing commands not showing a dialog was that their “close on finish” setting 
might be set incorrectly; however, even when the dialog was displayed, users forgot to look at the setting! To help 
with this, there are new commands LOPEN and LOPENLAST, to be added to the existing LCLOSE and 
LCLOSELAST commands. These will either open or close a selected or most recent element. Optionally add 
these to your Keypad. See the next item below. 

2. LOPEN and LOPENLAST are new interactive commands. They are the opposite of the existing LCLOSE and 
LCLOSELAST commands. (October 16, 2024) 

     

• LOPEN – opens a selected shape or complex shape. It removes the final closing segment. The result will 
be an open line string or open complex string. 

• LOPENLAST – Like LOPEN, except that it works automatically on the most recently added element in the 
design file, provided that is a shape or complex shape. Hint: It is useful to open a newly drawn 
AUTOARC, AUTOARC2D, or DATDRAW result when that command’s close setting was on by mistake. 

3. When a Cancel button on Summit’s 3D input device canceled a tentative point, the tentative point mark and text 
would clear completely from superimposition, but the elevation text would stay in the display in the MicroStation 
view. The text will now clear on Cancel. (May 8, 2024) 

4. When DATEM SETTINGS > Move stereoplotter to tentative is on, and Summit > Tools > Options > Project > 
Auto load next… is off (unchecked), a tentative snap move will no longer force Summit to open a different model 
if the snap coordinate is outside the model where it originated. (June 11, 2024) 
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5. 3DOFFSET has the following changes: 

a. 3DOFFSET LAST is a new option in the 3DOFFSET commands. It runs 3DOFFSET using the most 
recent settings, but without raising the 3DOFFSET dialog. (October 4, 2024) 

b. 3DOFFSET has added support for templates in multiple offsets from .rcfg files (made by the ROAD 
command, see below) that contain template settings. 

 
3DOFFSET can now use ROAD’s .rcfg files that contain Template settings 

 

c. 3DOffset will now offset closed line strings that look like shapes as if they are shapes. It will no longer 
leave gaps or self-intersection crossings where the original element closed. Even if the older results were 
technically correct, the new results look better. (September 2024) 

   
Version 8.2 and older results (left) and 8.3 results (right) 
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6. ANNOTATE has the following changes: 

a. ANNOTATE will now run the command immediately using the most recent settings, and without showing 
a command dialog. 

b. ANNOTATE SETTINGS is a new command to show the settings dialog for ANNOTATE. The OK button 
closes the dialog and runs the command. 

The total list of ANNOTATE key-ins is now: 
ANNOTATE  
ANNOTATE ACTIVETXT 
ANNOTATE CELLNAME <case sensitive cell name> 
ANNOTATE CELLS  
ANNOTATE DEFAULTTXTLEVEL  
ANNOTATE KAPPA 
ANNOTATE NOKAPPA 

ANNOTATE SETTINGS  
ANNOTATE SHAREDCELLS  
ANNOTATE TEXTHEIGHT <height> 
ANNOTATE TXTLEVEL <level name> 
ANNOTATE TEXT <string> 
ANNOTATE XOFFSET <x offset distance> 
ANNOTATE YOFFSET <y offset distance> 

 

7. AUTOARC and AUTOARC2D have the following changes: 

a. AUTOARC and AUTOARC2D will now immediately run the drawing phase of the command using the 
most recent settings, and without showing a command dialog. 

b. AUTOARC SETTINGS and AUTOARC2D SETTINGS are new commands to show the settings dialog for 
these commands. The OK button in each dialog closes the dialog and runs the command. 

c. AUTOARC and AUTOARC2D’s in-progress element drawing is now snappable, allowing tentative snaps 
to itself before drawing is finished. (May 23, 2024)  

The total list of AUTOARC and AUTOARC2D key-ins is now: 
AUTOARC 
AUTOARC CLOSE <ON/OFF/TOGGLE> 
AUTOARC DRAWBREAK <ON/OFF/TOGGLE> 
AUTOARC SETTINGS 
AUTOARC SNAPPED <ADDVERT/BREAK/NOCHANGE> 
AUTOARC STROKE<ON/OFF/TOGGLE> 
AUTOARC TOLERANCE <value> 
CAUTOARC 

AUTOARC2D 
AUTOARC2D CLOSE <ON/OFF/TOGGLE> 
AUTOARC2D DRAWBREAK <ON/OFF/TOGGLE> 
AUTOARC2D SETTINGS 
AUTOARC2D SNAPPED <ADDVERT/BREAK/NOCHANGE>   
AUTOARC2D STROKE<ON/OFF/TOGGLE> 
AUTOARC2D TOLERANCE <value>  
CAUTOARC 

 

8. BREAK has the following changes: (October 17, 2024) 

a. BREAK will now immediately run the prompt and selection phase of the command using the most recent 
settings, and without showing a command dialog. 

b. BREAK SETTINGS is a new command to show the settings dialog for BREAK. The OK button closes the 
dialog and runs the command. 

The total list of BREAK key-ins is now: 
BREAK 
BREAK NEAREST 
BREAK SETTINGS 
BREAK SHOWVERT OFF 

BREAK SHOWVERT ON 
BREAK SHOWVERT TOGGLE 
BREAK VERTEX 
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9. BREAK ELEMENT has the following changes: (October 17, 2024) 

a. BREAK ELEMENT immediately runs the prompt and selection phase of the command using the most 
recent settings and without showing a dialog. 

b. BREAK ELEMENT SETTINGS is a new command to show the settings dialog for BREAK ELEMENT. The 
OK button closes the dialog and runs the command. 

c. BREAK ELEMENT had key-ins to make settings silently (or from the Keypad), but they were poorly 
named so that they seemed to belong to the BREAK command, since the word “ELEMENT” was not 
present. The previous commands may seem redundant, but they have been retained for backwards 
compatibility. New key-in commands have been added. The total list of new and primary key-ins is now: 
(December 20, 2023) 

 
BREAK ELEMENT ALLLEVELS 
BREAK ELEMENT ALLLEVELS OFF 
BREAK ELEMENT ALLLEVELS TOGGLE 
BREAK ELEMENT BYELEMENT 
BREAK ELEMENT BYFENCE 
BREAK ELEMENT BYLINE 

BREAK ELEMENT DELETEOFF 
BREAK ELEMENT DELETEON 
BREAK ELEMENT DELETETOGGLE 
BREAK ELEMENT DEPTHTOGGLE 
BREAK ELEMENT FULLDEPTH 
BREAK ELEMENT 

BREAK ELEMENT LEVELSTOGGLE 
BREAK ELEMENT SETTINGS 
BREAK ELEMENT VIEWDEPTH 
BREAK ELEMENT VIEWLEVELS 
 

10. CHANGEATTRIBUTES has the following changes: (December 18, 2023) 

a. CHANGEATTRIBUTES now processes text elements. 

b. In the semi-interactive version, unsaved dialog settings are now retained after going to and from the 
Classes and Selection Sets dialogs. 

11. CHANGEATTRIBUTES INTERIOR and PATTERN INTERIOR have the following enhancements and corrections 
for the situations listed: 

a. If MicroStation's Optimized Fence Clipping is found to be on when these commands run, they temporarily 
turn it off and later restore it. Optimized Fence Clipping changes how fence clipping works in a way that is 
incompatible with DAT/EM’s commands. 

b. DATEM’s software was modified to more accurately process zero-length POINT-type elements. 

c. Overlapping boundaries are now processed correctly. 

d. Superimposition is now temporarily disabled for faster command execution. 

e. Mixing complex and simple boundaries resulted in edit elements being skipped. 

f. PATTERN INTERIOR is more robust and skips inappropriate elements such as patterns and points. 

g. Exterior performance (all commands that use exterior clipping) was enhanced by setting geographic filters 
on the elements’ boundary searches. 

12. CHECKATTRIBUTES has the following changes: (September 13, 2024) 

a. The Check by Symbology > Add and Edit buttons now work in both 32- and 64-bit versions. 

b. CHECKATTRIBUTES now includes a new by set Template check, which is a fast way to find elements 
with missing or incorrect template associations. It includes individual element templates as well as None 
(no template association found) and the * template wildcard. The * wildcard can be any template, but 
must include a valid element template association. 

With this new check, CHECKATTRIBUTES tags and allows users to easily navigate to elements that fail 
to meet specified criteria, for example, elements that do not fit within a selection set or have attributes 
outside of specified attributes. The new option scans a selection set, checking elements (within the set) 
for their element template links. If an element template does not match the CHECKATTRIBUTES 
specification, it will be recorded. 
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In the example below, all elements will be checked to make sure they have an associated template: 

 
…and where the “everything” set is defined as: 
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In the example to the right, all elements are 
checked. If an element has an element 
template, the “None” filter fails and the 
element will be listed: 

 

 

 

 

In the example to the left, it checks the 
buildings selection set to make sure all the 
elements have a link to the “nuGroop\building” 
template. If the link does not exist or an 
element is linked to a different template, it will 
be listed. 

 

13. CROSSCHECK previously missed some intersections that were very close to an end point on the second 
element. This is now fixed. (March 13, 2024, Sept 13, 2024) 

14. DATDRAW commands now have DATDRAW <sub-command> SETTINGS key-ins, but the dialogs do not have 
an OK button like other, similar commands have. This is because of the DATDRAW Trace option needs to remain 
visible in the dialog. If you would like to close the DATDRAW dialog at any time, use the “x” in the upper right 
corner. 

The following are the new key-ins that raise the respective DATDRAW <sub-command> settings dialogs: 
DATDRAW AUTOARC SETTINGS 
DATDRAW 2DAUTOARC SETTINGS 

DATDRAW STREAM SETTINGS 
DATDRAW PSQR SETTINGS 
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15. ELINE has the following changes: 

a. ELINE’s in-progress section drawing is now snappable, allowing snaps to itself before the edit is finished. 
(May 23 and July 5, 2024) 

b. ELINE has enhanced error handling and has added fixes that were initially missed in the 64-bit migration. 
(July 5, 2024) 

16. EZEDIT REVERSE (whole element mode) was not working on complex elements. This is fixed. (April 9, 2024) 

17. JOINIT has the following changes: (August 15, 2024) 

a. JOINIT now preserves template associations. Template associations, if any, will be considered part of the 
element symbology. This means both elements being joined must either have no template set or both 
must have the same template set. Elements with nonmatching template associations will not be joined. 

b. JOINIT could make a complex shape with one line string in it. It will now simplify the element to a line 
string if possible. 

18. The MVUSER <X, Y, Z> key-in now parses and ignores extra white spaces found within the command string. 
Previously, the command would not move and would raise the dialog instead if, for example, there were two 
spaces between MVUSER and the X coordinate. (March 20, 2024) 

19. When SI SETTINGS’ Show snap ring is on, it now correctly synchronizes the “3D” label near the superimposed 
snap ring when the snap mode is toggled between 3D and 2D using DATEM SETTINGS’ Tentative to xy only or 
TENTATIVE <ON/OFF>. (April 3, 2024)  

20. PLACE CURVE SPACE (MicroStation’s command) now has basic dynamic superimposition (SI) support. 
Previously, it was missing some of the in-progress SI graphics and the SI rubber band. Note that SI does not 
support curved rubber banding. Curves will appear as line strings while being drawn. The entire object will refresh 
as simulated curves when finished (the SI SETTINGS > Stroke Tolerance for Elements setting affects the 
stroking. A setting of 10 should work well in most cases.) (May 16, 2024) 

21. PSQR and PSQR SELECT have the following changes: (October 17, 2024) 

a. PSQR and PSQR SELECT will now immediately run the prompt and drawing phase of the building 
squaring command using the most recent settings, and without showing a command dialog. 

b. PSQR SETTINGS and PSQR SELECT SETTINGS are new commands to show the settings dialogs. The 
OK button closes the dialog and runs the drawing phase of the command. 

c. The total list of key-ins for these commands is now: 
 

PSQR 
PSQR CLOSE LSTRING 
PSQR CLOSE NOCLOSE 
PSQR CLOSE SHAPE 
PSQR CLOSE TOGGLE 
 

PSQR MODE CORNERS 
PSQR MODE EDGES 
PSQR MODE TOGGLE 
PSQR PITCHED OFF 
PSQR PITCHED ON 

PSQR PITCHED TOGGLE 
PSQR SELECT 
PSQR SELECT SETTINGS 
PSQR SETTINGS 
PSQR ZTOL 
 

22. ROAD and ROAD SETTINGS have the following changes: 

a. ROAD’s in-progress element drawing is now snappable, allowing snaps to itself before drawing is 
finished. (July 29, 2024) 

b. ROAD SETTINGS now has complete support for element templates in all configuration settings. This is 
backwards compatible with .rcfg file configurations created in earlier versions; if an .rcfg file does not have 
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template entries, the templates will be processed as if the template is set to “None.” (July 29, 2024, additional 
updates August 16, 2024) 

 
ROAD’s new template settings 

[Load] and [Save] Buttons read and create proprietary .rcfg formatted text files; these are also now 
compatible with similar template enhancements in the 3DOFFSET command (see 3DOFFSET above). 
Element Attributes’ standard settings now include a line for Element Templates. 

 
Part of a parameter file for ROAD with Template lines present, even when set to “None” 

Note: The .rcfg files that contain template settings are not backwards compatible to incompatible 
environments, which include earlier DAT/EM versions (compiled before 29 July 2024) and any version 
Capture/MapEditor for 32-bit MicroStation. If a new .rcfg must be used in these incompatible 
environments, the user will need to edit the .rcfg file using a text editor to remove the lines starting with 
the word “Template.” DAT/EM will not be responsible for problems caused by text editing mistakes or by 
using new .rcfg files in incompatible environments. 

c. ROAD SETTINGS’ New and Edit dialogs are now wider to better show long level names. (October 8, 2024) 

d. There were some cases where the offsets would not be placed by ROAD. This is fixed. (October 28, 2024) 

 



DAT/EM Systems International Version 8.3 Release Notes 
 

Page 52 of 55 
 

23. SPOTMODIFY previously raised the settings dialog while activating the editing command, but the dialog could not 
dock and could not close when the next command was started. It now offers key-ins to start specific edits without 
requiring the dialog, and offers a settings command to show the dialog when needed: (October 17, 2024) 

• SPOTMODIFY (the word by itself) will now immediately run the command to edit point or cell locations 
using the most recent settings. Does not raise the settings dialog. 

• SPOTMODIFY SETTINGS - raises the settings dialog for SPOTMODIFY. The OK button closes the 
dialog and runs the command using the current settings. 

• SPOTMODIFY XYZ - runs the command with Modify set to XYZ in the background. Edits the selected 
point or cell in (x,y,z). Does not raise the settings dialog. 

• SPOTMODIFY XY runs the command with Modify set to XY in the background. Edits the selected point 
or cell in (x,y) only. Does not raise the settings dialog. 

• SPOTMODIFY Z - runs the command with Modify set to Z in the background. Edits the selected point or 
cell in (z) only. Does not raise the settings dialog. 

24. STROKE ELEMENT (MESTROKEELEMENT) will no longer leave duplicate vertices at the location where a line 
or line string segment adjoins an arc beginning or end point. (July 9, 2024) 

25. TOUCH, TOUCH ENDS, and TOUCH BATCH have the following changes: 

a. The interactive tool has enhancements for which end of the element to extend based on where you pick 
the element. (February 13, 2024)  

b. Previously, certain Touch pairs were missed when Match Z to second element was not selected. 

c. An error was corrected where the Match Z to second element adjustment might delete complex 
elements when the last element in the chain was an arc. 

d. Error checks were added to skip zero length (Point) elements. 

e. TOUCH ENDS could create an extended loop in the "to" element instead of clipping the element. This is 
fixed in 64-bit versions only. (November 15, 2024) 

f. TOUCH and TOUCH ENDS will now immediately run the command using the most recent settings, and 
without showing a command dialog. 

g. TOUCH SETTINGS and TOUCH ENDS SETTINGS are new commands to show the settings dialogs for 
TOUCH/TOUCH ENDS. The OK button closes the dialog and runs the command. 

h. The total list of key-ins is now: 
 

TOUCH 
TOUCH 2D 
TOUCH 3D 
TOUCH 3D TOGGLE 
TOUCH BREAK 
TOUCH NOCHANGE 
TOUCH SETTINGS 
TOUCH VERTEX 
TOUCH ZTOL <value> 
 

TOUCH ENDS 
TOUCH ENDS 2D 
TOUCH ENDS 3D 
TOUCH ENDS 3D TOGGLE 
TOUCH ENDS SETTINGS 
TOUCH ENDS ZTOL <value> 

26. TWOSHOT <ANGLE/SCALE> will now succeed in many more cases. Previously, it would give “Error -903” if the 
cell it was placing was in a cell library that was not attached to the active MicroStation environment. This error 
would be given even when MicroStation could find the cell to set with AC=<cell name>. MicroStation would find 
the cell and give the cell name to TWOSHOT, but TWOSHOT was not searching as many locations for cells as 
AC=<cell name>, and might not find the cell for itself. Sometimes only the error -903 would appear in the 
MicroStation Message Center, and no cell would be placed; other times, TWOSHOT would both place the cell 
and give the error; however, in this case the dynamic graphics would be missing while picking the cell size and/or 
angle. (March 14, 2024) 
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Note: If MicroStation’s AC=<cell name> command fails to find or set the cell, then TWOSHOT will not be able to 
place it. If you have trouble with AC=<cell name> not finding the cell, here are some things to check or try: 

• If you only have one cell library, attach it to the environment using RC=<cell library name>. This can be 
set on your Keypad for convenience. 

• If you have multiple cell libraries, make sure they can be found by the MS_CELLLIST environment 
variable. 

• Attach one cell library from a group of libraries. It does not even need to be the cell library that contains 
the cell. For example, if there are multiple cell libraries referenced by MS_CELLLIST, use RC=<cell 
library name> for any one of the files. Then use AC=<cell name> for cells from any of the libraries. This 
seems to help MicroStation find the cell, so it can then give the cell name to TWOSHOT. 

• And, of course, check the spelling of the cell name and make sure it exists in an accessible cell library. 
Both AC=<cell name> and TWOSHOT will fail if the cell does not exist. 

 

27. VISIT could create a duplicate list of entries, for example, 20 entries instead of 10. This is fixed. (March 14, 2024) 

28. VISIT, XYZIN, and XYZOUT’s browse dialogs are fixed to show the correct list of file names based on the 
selected file extension. (October 4, 2024) 

29. ZLABEL has the following changes: 

a. ZLABEL GUIDERDRAW’s list of sets now updates as expected after making a new set with the Sets 
button. (December 14, 2023) 

b. ZLABEL INTERVAL placed the correct text string, but placed it at Z=0. Now it places the text at the 
elevation of the labeled string. (January 16, 2024) 

c. ZLABEL PICK has the following changes: 

• ZLABEL PICK has reduced the number of required picks by one pick. (December 13, 2023) 

• When the two-pick angle setting was selected, the Rotate 180 button was rotating the placed text 
or cell element around the second angle pick point instead of around the element origin. This is 
fixed. (December 12, 2023) 

 

DAT/EM Capture and MapEditor for 32-bit MicroStation 
Changes apply to Capture and MapEditor for 32-bit MicroStation versions.  

DAT/EM has stopped new development for Capture and MapEditor for 32-bit MicroStation versions. Changes here include bug 
fixes and some modifications for the purpose of compatibility with new developments in the products for 64-bit MicroStation. 
 
* 32-bit MicroStation users be advised! DAT/EM still supports installation for several older 32-bit MicroStation versions (listed below). 
DAT/EM software will continue to install for 32-bit MicroStation versions as long as Bentley continues to provide developer licensing for 
them. When Bentley stops licensing them, DAT/EM will no longer be able to test in the 32-bit environment. At that time, DAT/EM will 
remove 32-bit MicroStation support in development versions and in the subsequent DAT/EM release. This schedule is up to Bentley. 
Bentley encourages their users to upgrade to 64-bit MicroStation. 

DAT/EM software installs for the following 32-bit MicroStation versions. 

• MicroStation V8i SelectSeries 10 and V8i SelectSeries 10-based products. SelectSeries 10 is the only version that both 
Bentley and DAT/EM support for Windows 10. The product names are V8i, Bentley Map, Map Enterprise, PowerView, Map 
PowerView, Power GeoPak, and PowerCivil. 

• MicroStation V8, V8 2004 Edition (version should 08.05.00.34 or higher), XM (version 08.09.04.88 or higher), 
MicroStation V8i and V8i-based products in SelectSeries numbers 3 and 4 (SelectSeries 1 and 2 not recommended). 
None of these versions are supported by Bentley under Windows 10 or 11. DAT/EM will install for them if they are present and 
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licensed on the computer. The product names are V8i, Bentley Map, Map Enterprise, PowerView, Map PowerView, Power 
GeoPak, and PowerCivil, except Power GeoPak Select Series 3 is not supported.  

If you upgrade to a higher SelectSeries number, you must reinstall DAT/EM software after installing the SelectSeries upgrade.  

DAT/EM will install for all supported 32- and 64-bit versions of MicroStation that are present on the computer and licensed at 
the time of the DAT/EM installation. 
 

DAT/EM Capture and MapEditor for 32-bit MicroStation versions have the following changes: 

1. CROSSCHECK in all 32- and 64-bit versions has a fix for some missed intersections. The problem could happen 
when the distance between the intersection and the second-set endpoint was proportionally small compared to 
the element being compared in the first set. (March 13, 2024) 

2. TOUCH, TOUCH ENDS, and TOUCH BATCH have the following changes: 

a. Previously, certain Touch pairs were missed when Match Z to second element was not selected. 

b. Error checks were added to skip zero-length (Point) elements. 

c. Previously, the first interactive TOUCH run might fail due to an initialization problem. This has been 
corrected. 

d. Previously, the Break option might fail on the first run. This is fixed. 

3. ZLABEL INTERVAL placed the correct text string, but placed it at Z=0. Now it places the text at the elevation of 
the labeled string. (January 16, 2024) 

 

DAT/EM Capture for Blue Marble Global Mapper 
Changes apply to Capture for Global Mapper. DAT/EM Capture for Global Mapper is supported for the following Global 
Mapper versions: 

• 24.x and 25.x, released before the time of the DAT/EM version 8.3 release date. The release may be compatible with version 
26.x; testing was not finished at the time of the DAT/EM release. Please contact DAT/EM Support for further information.  

To start using DAT/EM Capture for Global Mapper, contact DAT/EM or your DAT/EM reseller for a quote for a Stacked 
Capture for Global Mapper. This product is added on to the primary Capture for AutoCAD, MicroStation, or ArcGIS. 

Advice for enabling and disabling the DAT/EM Capture extension for Blue Marble Global Mapper: 

DAT/EM Software installs the Global Mapper Extension, but leaves it unregistered in Global Mapper by default. 
To use the extension, close Global Mapper, select Windows Start > Datem Software group > right click on 
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DAT/EM Administration Tool > More > Run as Administrator. Set CAD/GIS Package=Global Mapper, 
Action=Capture, Apply. Or, to disable at any time, set it to Action=Disable, Apply. 

 
To register/enable or unregister/disable, use the DAT/EM Administration Tool’s CAD Enabler 

Alternatively, toggle the extension from the Global Mapper > Help menu > License Manager. Note that it is 
correct to be called “DAT/EM Capture for Global Mapper V24+” for some later versions. 

1. The v.8.3 release may be compatible with version 26.x; testing was not finished at the time of the DAT/EM release. Please 
contact DAT/EM Support for further information. 

-End- 
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