
 
DAT/EM Systems International 
8240 Sandlewood Place, Suite 101 
Anchorage, Alaska USA 99507 
Phone (907) 522-3681 
Support Department Email: support@datem.com 
Web: www.datem.com  

Version 7.0 Release Notes
April 8, 2014

 
Page 1 of 36 

 
 

 

 

The following changes have been made to DAT/EM products between Release 6.8 and Release 7.0 (release 6.8 was the 
last version in the 6.x series). 
 
As always, DAT/EM welcomes comments and suggestions from you, our clients, so please don’t hesitate to contact our 
support department at support@datem.com, or by calling in or faxing us with your requests. 
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Operating Systems and Microsoft Updates 
Release 7.0 is supported on Windows XP Professional (see note below), Windows 7 Ultimate or Professional, Windows 8 
and 8.1 operating systems. 

Install all critical Microsoft Windows Updates before DAT/EM software installation.  

Microsoft Office 2007 users must install all available Microsoft Office updates before installing DAT/EM version 7.0. 
 

1. Version 7.0 is the first version to be approved for Windows 8. Notes: 
 

 In Windows 8, tooltips that display over the stereo view do not stop stereo as they did in Windows 7. 
 

 If you are a Windows 8 user and you miss the Windows 7 Start menu, we recommend the third-party 
Classic Shell™ application: http://www.classicshell.net/   

 
 

Microsoft Windows XP End of Lifecycle on April 8, 2014 
DAT/EM will stop support for Windows XP on the same date that Microsoft stops support for it. According to 
http://support.microsoft.com/ph/1173, “The support for Windows XP with Service Pack 3 ends April 8, 2014.” 

Version 7.0 worked with Windows XP on the date the DAT/EM release installation file was created; however, DAT/EM 
may not be able to solve Windows XP issues during the time that version 7.0 is used past April 8, 2014. Since Windows 
XP will not be receiving any security updates past April 8, 2014, DAT/EM does not recommend using Windows XP. 

Please plan to upgrade any remaining XP workstations to Windows 7 or Windows 8. 
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Hardware Locks/Dongles 
Please install Microsoft Updates and Service Packs for your operating system before applying lock reset programs. 
Network licensing should have the same Sentinel driver version on both the server and the local computers running the 
software. 
 

CAD Versions 
Release 7.0 has interfaces to the following CAD versions. These are both 32- and 64-bit versions unless otherwise noted: 

 AutoCAD: Autodesk 2004, 2005, 2006, 2007, 32-bit 2008, 2009, 2010, 2011, 2012, 2013, and 2014 products. Note that 64-bit 
AutoCAD 2008 is not supported. Install all available service packs. DAT/EM software will install for multiple AutoCAD products 
of different year numbers on the same computer; however, it will not install for multiple same-year versions together. For 
example, it will not install for both 2012 and Map3D 2012. Note that files may be copied manually to activate more same-year 
versions (contact DAT/EM Support for instructions).  
BE ADVISED: Versions 6.6 and higher no longer support AutoCAD 2000-2002 versions. If you use these old versions, please 
upgrade to AutoCAD 2004 or higher. AutoCAD version 2007 or higher is needed in order to use the AutoCAD MAPEDITOR. 
 

 ArcGIS: ArcMap 9.1, 9.2, 9.3 (service pack 1), 9.3.1(service pack 2), 10.0 (service pack 4), 10.1 (service pack 1) and 10.2 
(plus any available service pack as they are released). 
BE ADVISED: DAT/EM has tentative plans to drop support for ArcGIS 9.x versions at the second DAT/EM software release in 
2014. This would be approximately in October 2014. Please prepare to upgrade ArcGIS to a 10.x release. Contact DAT/EM if 
you have concerns about upgrading. 

 
 

 MicroStation: DAT/EM software installs for the following versions: MicroStation V8; V8 2004 Edition; XM; V8i Select Series 1 
(1 not recommended), 2, and 3; Bentley Map and Map Enterprise Select Series 1 (1 not recommended), 2, and 3. 
Note for Select Series number upgrades: If you upgrade to MicroStation or Bentley Map to a higher Select Series number, 
you must reinstall any DAT/EM software after installing the Select Series upgrade. 
Note for Power GeoPak Select Series 3: DAT/EM Software installs for Power GeoPak SS3, but it does not run well. Power 
GeoPak has timing problems loading other vendor’s applications. For example, when DAT/EM applications are loaded, the 
“Common.ma” file will not load. When DAT/EM applications load automatically, the “GeoPak” menu disappears from the menu 
bar. Therefore DAT/EM version 7.0 should not be installed for Power GeoPak. 

 
 

Video Drivers 
Please note our video driver installation/update recommendations: 

 DO NOT install the driver on media packaged with a video card. It will be too old. 

 1st: Get the latest driver for your video card and operating system from www.nVidia.com. 

 2nd: If the driver on www.nvidia.com does not work, contact support@datem.com for advice. We may ask you to 
download an older driver from either www.nvidia.com or www.datem.com, depending on your hardware. 

 If you need to change (update or back out) a video driver, please follow the instructions at www.datem.com 
Support > Downloads > Manuals > Installation Instructions>“StereoLCDInstallationInstructions.pdf”. This 
shows how to replace drivers and verify that the new drivers have been installed properly. It is very important to 
check on the “Custom” and “Clean” installation choices. 

 On existing workstations, check your video driver periodically. The easiest schedule is to check it before installing 
each DAT/EM software update. If you use a single-panel LCD display and the video driver is older than the one 
currently offered at www.nvidia.com, please update it using the “Custom” and “Clean” installation options. 

Further notes: 

 When checking your installed video driver version, remember that the actual version consists of the last five digits 
with the decimal point moved two spaces to the right. For example, 6.14.12.7642 is really version 276.42. In the 
past, nVidia sometimes omitted a zero (0) from the version; for example, version 6.14.13.732 was really 307.32. 

 To check the installed video driver version on Windows 7, right click anywhere on a blank area of the desktop. 
Select Screen Resolution > Advanced Settings > Adapter tab > Properties > Driver tab > Driver Version. 
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 To check the installed video driver version on Windows XP, right click anywhere on a blank area of the desktop. 
Select Properties > Settings tab > Advanced > Adapter tab > Properties > Driver tab > Driver Version. 

 For video settings, see www.datem.com Support > Downloads > Manuals > Installation Instructions. Most 
users will want either “PlanarInstallationInstructions.pdf” for Planar dual-LCD monitors or 
“StereoLCDInstallationInstructions.pdf” for single LCD stereo monitors. 

 

Software Installation, File Locations, and Installed Utilities 
The following has changed for DAT/EM software installation or the location where DAT/EM applications store data: 

 
 

1. The 64-bit versions of the applications are now primary on 
64-bit computers. For example, the desktop icons will 
activate the 64-bit versions. 
 
The 32-bit applications are still installed as the only version 
on 32-bit computers. 
 
The 32-bit applications are also installed on 64-bit computers 
as secondary or legacy applications. They can be started 
from Windows Start>All Programs>DAT/EM Software>32-
bit>(application name); however, DAT/EM recommends the 
64-bit applications whenever there is a choice. 

2. Blue Marble's Geographic Calculator ArcGIS plugin conflicts with DAT/EM's CaptureArcInfo.2010.dll. When 
DAT/EM software is installed, "Registration Failed" is reported near the end of installation. Run "C:\Program Files 
(x86)\Blue Marble Geo\Geographic Calculator\UnRegisterEsriPlugin.bat" before installing DAT/EM software. 
Contact DAT/EM for more information if you have Geographic Calculator and would like to use it in ArcGIS. 

3. There is a new DAT/EM-PCI Runtime ProPack installation file, new licensing procedures, and a 
new way to launch Summit. Download ProPack_for_Release_7_0_blt_mm_dd_2014.exe and 
the installation instructions document from www.datem.com . Please read the instructions 
document carefully before installing and running the ProPack software. 

4. There is a new “DAT/EM Release Information” Datem Info_64.exe file for the 64-bit version and a 
change has been made to the 32-bit Datem Info.exe. To manually set the hardware lock server’s IP address, run 
either one of the applications and select the “Set license server…” button in the lower left. It will make the setting 
for both the 32- and 64-bit versions at the same time. Note: Setting the IP address manually is usually only 
necessary when the hardware lock server is not on the same subnet as the DAT/EM workstation. 

64-bit applications 
(recommended) 

32-bit applications 
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5. Start > All Programs > Datem Software > Utilities > CAD Enabler is a new method to enable and disable any 
combination of licensed DAT/EM Captures and MapEditors. By comparison, in version 6.8, the “Capture Enable” 
and “Capture Disable” functions would enable/disable all Captures and MapEditors at one time. 

 Disabling a product is usually done to prevent taking a license from a network lock when AutoCAD, 
MicroStation, or ArcMap starts and Capture or MapEditor is not needed during the application’s session. 
This leaves the license free for another workstation to use. 

 The dialog does not check the hardware lock. It offers all products, but be aware that enabling a product 
will only work if the product is licensed. 

 The dialog does not check the current status of the applications. Be aware that the fully enabled settings 
that you see at first are defaults and do not indicate whether products are currently enabled or disabled. 

 For AutoCAD, the install routine initially generates two .rx files in <AutoCAD installation folder>\datem: 
mapEd.rx and capture.rx. When Map Editor is selected, mapEd.rx is copied to the acad.rx file name. 
When Capture is selected, capture.rx is copied to the acad.rx file name. If Disable is selected, acad.rx 
is removed. 

 For MicroStation, the install routine initially generates two .cfg files: <MicroStation installation 
folder>\<MicroStation type>\config\appl\DatemCapture.cfg and mapEd.cfg. When Map Editor is 
selected to enable, mapEd.cfg is unhidden and DatemCapture.cfg is hidden. When Capture & Map 
Editor is selected to enable, Datem.Capture.cfg is unhidden and mapEd.cfg is hidden. (To check the 
current status, right click on the file in an Explorer window; select “Properties”; view “Attributes”.) 

 For ArcMap, when Capture is selected to enable, C:\Program Files (x86)\CaptureArcInfo.2010.dll is 
registered in ArcGIS. When set to Disable, the .dll is unregistered. 

 

Choose which Captures and MapEditors to enable or disable. 

The default values do not indicate the currently enabled or licensed status of the products. 
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6. Share Settings (found in Windows Start > All Programs > Datem Software > Utilities > Share Settings) has the 
following fixes and changes. These allow you to standardize either all DAT/EM settings or portions of DAT/EM 
settings for one or more workstations. It does this by clearing or replacing registry entries. 

 The  “All Settings” option has been fixed. It was ineffective in version 6.8, because it created a binary file 
that was not applied correctly. Now the settings are written to an ASCII file; the file can be quite large, but 
is more useful as ASCII than as binary. 

 The Share Settings tool supports two new environment variables. 

 

Without environment variables set, “Environment variable not set” appears in light gray 

1) Environment variable: DATEM_DEFAULT_SETTINGS_FILE 

 This environment variable identifies a single .reg file for default settings other than the 
DAT/EM defaults. If a setting is not represented in this file and isn’t already set in the 
registry, then it will be set to a DAT/EM default setting. 

 If you select Reset All, then the “DAT/EM Systems International” registry tree will be 
deleted and the .reg file will be loaded. The full name of the DAT/EM registry tree key is: 

HKEY_CURRENT_USER\Software\DAT/EM Systems International 

 The first time you run Summit or Landscape and the “DAT/EM Systems International” 
tree is empty, this .reg file will be loaded. 

 If the environment variable is not defined or this .reg file cannot be found, it is ignored. 

 If this .reg file cannot be found, it will be marked in red. 

 

With environment variables set, but .reg file not found 
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2) Environment variable: DATEM_COMMON_FOLDER 

 This environment variable overrides the Common Settings value. If it is set, then the 
dialog will display the contents of the environment variable rather than a value stored in 
the registry. 

 The default for this setting is blank. 

 If this environment variable exists and the indicated folder is not found, it will be marked 
in red. 

 If this setting exists either in the registry or the environment variables, all .reg files 
contained in the folder are loaded. (See note below about using Windows Regedit to 
create .reg files that can be read by Share Settings.) 

 

 

With both environment variables set and folders and .reg file found 

 Windows Regedit can be used to generate a .reg file for ShareSettings. This can either be the entire 
“DAT/EM Systems International” registry tree or one or more individual branches, such as “Stereo Plotter” 
and/or “Landscape”. 

DAT/EM’s Share Settings application does not support Unicode; it uses the old ANSI standard. If you 
want to use Windows Regedit to create a Share Settings-compatible .reg file, you must export under the 
old Win9X/NT4 registrations files (*.reg) format (see graphic below). To run Regedit, key in “Regedit” in 
the Windows Start field or run regedit.exe. Navigate to HKEY_CURRENT_USER\Software\DAT/EM 
Systems International or the branch that you wish to export, such as 
HKEY_CURRENT_USER\Software\DAT/EM Systems International\Stereo Plotter. Right click on the 
branch you wish to export, set the Selected branch radio button, and select Export from the right click 
menu. Set Save as type to Win9x/NT registration files (*.reg) as shown below. 
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Export .reg files in the “Win9x/NT4 Registration Files (*.reg)” format 

7. (NOTE) This change was implemented in version 6.8, but if 6.8 was not installed, please take note. In version 6.7 
and earlier, DAT/EM applications often stored settings and files in the \Program Files\Datem Software or 
\Program Files (x86)\Datem Software folder. Now files that are common to all users or common to all DAT/EM 
applications will be stored in \ProgramData\Datem Systems OR equivalent Windows XP location. Here is a list 
of items than have been moved: 

 Geocalc data files and folder, which includes the elevation database 

 Cursor files 

 Keypad files 

 .reg files 

If your DAT/EM Keypad Controller files used any .bmp graphics from the former location, they may appear as a 
red “X” the first time you open the Keypad overlay. Use Keypad’s Tools>Image Directory to change the paths. 

Files placed in this location will be accessible by all users, so permission will no longer be an issue. Therefore, 
users will not need to have administrator privileges to save or change this data.  

Data can be stored per user. The stereoplotter.mac and Landscape.mac files that store shortcuts will be stored 
in \Users\<username>\AppData\Local\Datem Systems\<application name> (also has hidden attributes). 
Previously, custom shortcuts applied for all users. Now, they will be stored separately for each user. 
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DAT/EM Keypad 
The following changes were in the DAT/EM Keypad version 6.8, but were unintentionally omitted from the 6.8 notes: 

1. There are new keywords to use with a “Capture” output key. 

PlotterZoom:<value> 

PlotterZoom _MapScale:<value> 

Colon : characters are required. These keys zoom the Summit view as if you keyed in new values in the status 
bar on the lower right edge of the Summit window. Examples: 

PlotterZoom:2.5 

       

PlotterZoom _MapScale:500 

      

Summit Evolution 
The following changes have been made to Summit Evolution and the applications that are provided with it. 

1. Educational licenses purchased for version 7.0 and higher will be limited to 25 images in a project. 

2. Now you can rotate the 3D vector split window using the system mouse. Position the mouse pointer over the 3D 
vector split window. Hold down the system mouse wheel button and move the mouse to rotate the window. (Hold 
down, do not spin the wheel.) 

3. Localized histogram adjustments will no longer affect the embedded bird’s-eye view. 

4. Tools>Move to Ground no longer incorrectly allows model switching when Allow Model Switch is off and the 
cursor moves to a point near the edge of the model. 

5. This applies to all project types that have an "Add" or "Add images..." button that launches a Windows 7 "Open" 
dialog. The "Open" dialog can be made to search for all images in a folder tree. To do this, leave the "File name" 
field blank (do not click on an individual file unless you want an individual file). In the Windows "Open" dialog's 
search field, key in *.tif. It will automatically search the folder tree for all .tif files. When it has found them, select 
the "Open" button. Note1: This will not work in Windows XP, where only one file will be found. 
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6. The 64-bit version of Summit was fixed to prevent a crash upon selecting the Modify button on the 
Tools>Options>File Locations tab. 

7. Summit's Export Model Bounds "Full block..." with "Selected" files is fixed to export the selected files only instead 
of all files. 

8. The Summit Project Window’s "Rearrange Models" tool has new sorting method choices to help sort for either 
alpha or numeric characters in the image names. 

9. Summit can now be run on some touch screen tablets running Windows 8 and anaglyph stereo. This is in 
preparation for a future tablet-only Summit Mobile product, which is anticipated to have more in-the-field-
appropriate tools such as GPS integration. At this time, you are welcome to install version 7.0 on a compatible 
touchscreen tablet such as the Surface Pro and move your existing hardware lock to the tablet. Notes and hints: 

a. Stereo: At the time of version 7.0 release, tablet computers do not have stereo displays. 

b. Anaglyph stereo reminder: Set anaglyph stereo in Summit>Tools>Options>Main View>Anaglyph Mode. 

c. Digitizing (or not): The Capture interfaces are not available on a tablet, because there are no versions of 
AutoCAD, MicroStation, or ArcGIS that are compatible at this time. Summit does not interface to ArcGIS 
for Mobile at this time. Summit Lite on a touchscreen tablet could be used for project viewing only; there 
are no digitizing tools built in to Summit Lite. Summit Professional and Feature Collection could perform 
digitizing using Summit’s built-in DAT/EM Drawing Objects. 

d. Hardware: Check with DAT/EM Support for advice on compatible tablets. The Surface Pro has been 
tested and works. If you try a touchscreen tablet that DAT/EM has not tested yet, we would be glad to 
have your feedback on how it works. For example, we suspect the Getac tablet will work, but have not 
had the opportunity to try it, and we would like to know the results if you try it. 

e. Touchscreen Controls: Make touchscreen settings in Summit>Tools>Options  >Input 

Devices>Touchscreen options  by choosing the 2 fingers to zoom, 3 fingers for Z movement or 2 
fingers for Z movement, 3 fingers for zoom. 

   

Summit’s new touchscreen settings 
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10. Summit>Options>Main View>Anaglyph mode now supports Red/Cyan, Red/Blue, Red/Green, 
Green/Magenta, Yellow/Blue display modes. Set the option that matches the color of the stereo viewing glasses. 
These settings were added for touchscreen stereo support. 

 

New Anaglyph color combinations 

11. DAT/EM Drawing Tools can now select using a shape (polygon) in addition to the existing box (rectangle) 
selection method. Activate Select by Shape from the Drawing Tools toolbar. Click on each selection polygon 
vertex. Double click to end and activate the selection. 

 

      

Select DAT/EM Drawing Objects by drawing a polygon shape around them 
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12. Realtime Contour Visualization has a new setting to toggle the display of points. (This applies to 
Drawing>Realtime Contour Visualization, not to Terrain>Terrain Visualization.) 

 

 

Realtime Contour Visualization’s new point display toggle 

 

13. Terrain Visualization has the following changes: 

a. Terrain Visualization has an added automatic contour distance. 

b. Terrain Visualization has a new Maximum Zoom setting beyond which the contours will not generate. 
The message, “Max zoom exceeded” appears in the lower right of the dialog when zoomed out beyond 
the Maximum Zoom setting. 

 

Terrain Visualization’s new Maximum Zoom setting and “Max zoom exceeded” message 

c. Terrain Visualization has a fix for a problem where contours did not display.  
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14. There are two additional Custom CAD toolbars. Turn on the toolbars from Tools>Customize Toolbars>Custom 
CAD, Custom CAD 2 and Custom CAD 3. Set up and edit the buttons using the editor located on the original 
Custom CAD toolbar.  

  

Two additional Custom CAD toolbars can be edited by the editor located on the original toolbar 

15. There is a new Tools>Options>Input Devices>System Mouse>  >Use 2nd system mouse (Trackball) as Z 
control setting. When checked on, the 2nd system mouse scrolls Z when it moves on the table or a trackball 
spins. When it is off, it scrolls XY. It should be checked on for a Trackball, and the user’s choice for a second 
system mouse. 

 When Use 2nd.. is on, the right mouse button (button 7 in the Button Manager) can be set to any 
function. The right mouse button on the first mouse is used to stop and start Summit’s cursor. 

 When Use 2nd… is off (for a non-trackball second mouse), both buttons 2 on the first mouse and 
7 on the second mouse will be used to stop and start Summit’s cursor control; in this case, 
buttons 2 and 7 should both be set to “None” in the Button Manager.  

 

New Trackball system mouse option 
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16. The Blue Marble Geographics dialogs that make the coordinate translation settings now offer "Download Missing 
Files" in the right click menu for selections displayed in red text. The red text indicates that the selection is missing 
from the current database on disk. If the computer is connected to the internet, right click directly on the red text 
and select "Download Missing Files." The software will report whether the download was successful. The file is 
placed automatically in the proper location and it can be selected for use as soon as the download is complete.  

 

Right click on red text items to download missing Blue Marble database files. 

Note: If “Download Missing Files” is not offered, it is because the file is proprietary and therefore not available for 
download from the Blue Marble Geographics website. For example, some systems in Canada are only available 
from the Canadian Government. 

 

Proprietary files do not offer “Download Missing Files” in the right click menu 

17. Summit has major improvements in OpenGL graphics rendering. 

a. 3D stippling. The right and left stipple patterns will match and look proper in stereo. This was not 
possible with legacy OpenGL. 

b. Lines of any width. Legacy OpenGL only supports up to the driver supported limit (usually under 10 
pixels). 

c. Line Mitering.  No Miter:   With Miter:  

d. Speed. Stippling can be drawn fast with a single or few draw calls. The previous stipple [only available in 
some 7.0 betas with Capture for ArcGIS, not v.6.8] had to draw each line independently, which was slow. 

e. Uses modern OpenGL methods. 

f. The GPU shaders (source code that runs directly on GPU, not the CPU) require OpenGL 4.0. If this is 
not found, the drawing will revert to older methods. The new shaders can be disabled in this dialog. They 
are only enabled if SI performance boost is on. This was done so it can be turned off if desired or for 
testing. 

g. Faster Text rendering. 
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18. Aerial projects have the following changes: 

a. The following has been fixed: The epipolar corrections could be wrong for older aerial Summit projects 
that had rotations applied to the images in the Project Edit dialog. The epipolar correction angles would 
not be applied correctly to the view. This had no effect on the ground coordinates, which were always 
correct. It made the stereo view look bad and it would only line up well near the cursor. 

This epipolar display problem only affected projects that did not use the "Automatically rotate to north" 
setting. Note that the “Automatically rotate to north” setting has made rotating images in the project 
settings and rotating cameras obsolete in recent versions. 

b. The following has been fixed: There was a merge projects problem with aerial projects that had control 
overrides. A control override happens when there is a point listed in the control file as full "HV" 
(horizontal-vertical, or xyz), but the user changes the point to "H" or "XY" (horizontal only) or "Z" or "V" 
(vertical only) in the Absolute Orientation dialog. When the project was merged with another project, the 
setting from the control files was used instead of the override. The points would revert to a full "XYZ" or 
"HV" (horizontal-vertical) point. Now the merge projects process will use the final setting used in Absolute 
Orientation. 

c. Starting in version 6.8, the aerial project file stores the last-used camera parameters; if the “external” 
camera files can’t be found on disk, the “internal” cameras are used. Now in version 7.0, if the external 
camera files are lost, the internal cameras may be exported a replacement files. Select 
Summit>Files>Export>Write Internal Camera Files. If the original camera file had a name in the 
“Name” field in the Summit Camera Editor dialog, it will be used as the camera file name. 
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d. Summit's camera file has a new option for 12-parameter distortion. This uses the same 12-parameter 
“Coefficients” (8 K values, 4 P values) method that can be found in some Trimble Inpho Applications 
Master cameras. 

Inpho will soon incorporate this new camera distortion method into their Summit project export function. If 
you are using a version of Inpho that exports the older Summit .smtprj format, the camera distortion 
values must be manually copied and pasted from the Inpho camera into the Summit camera after Summit 
v.7.0 updates the exported .smtprj project to .smtxml format. 

  

Inpho camera “Coefficients” distortion method (left) and the new DAT/EM “Twelve Parameter” camera distortion 
method (right). At this time, you must copy and paste the values from the Inpho camera into the Summit camera. 
A future release of Inpho software (after March 2014) may have this export built in. 

e. This item is a beta provided for anyone who would like to try it: The RO Tie Points dialog for aerial 
projects offers a new bundle adjustment. First measure relative tie points between models and strips. Add 
ground control points in the Tie Points dialog and measure them. Select the Bundle Adj button. It is 
possible to use the Use Exteriors from file option to input existing exteriors, for example, EO values that 
are from GPS/IMU or other estimated EO values. If Use Exteriors from file is used, this allows it to skip 
the first step of the adjustment and proceed directly to the bundle adjustment. Ground control points are 
still needed, but having the initial EO values may allow you to get a good solution with fewer ground 
control points. 

 

Bundle Adjustment button in the Tie Points dialog 
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Make settings and press the Solve button. The settings affect the report 
only and do not affect the results of the bundle adjustment. 

 Number of Rays writes the number of images (rays) of a tie or 
control point into the report. 

 Residual limit to show (micrometers) is another reporting 
output. 5 is the default. 0 shows all residual for all points. This 
number could be used to find points will high residuals, since 
only those above this limit will display. 

 

After Solve, the message area shows results. 

 

 

A report appears. DAT/EM advises you to read through the report to look 
for any error messages that may be there. Use the Save As or Print 
buttons as desired. 
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19. ADS40/80/100 projects: have the following changes: 

a. ADS40/80 Project Edit dialog no longer shows all the settings for the coordinate conversion; there is a 
button to activate the coordinate conversion dialog. In the end, the settings are the same, while the 
display method is different. 

b. In version 6.8, “Automatically load next model when outside stereo area” did not work in ADS40/80 
projects that had a coordinate transformation applied. This has been fixed. 

c. Some customers have received imagery from the new ADS100 sensor. This imagery sets up with the 
existing Summit ADS40/80 project type. The only difference is that the Summit>File>New project type 
has been renamed “ADS40/80/100 Using Leica Kit”. You will need to be very careful with file sizes. 
Remember that the TIF standard limit is 4GB and the JPG compression standard supports only up to 3 
bands. Consider setting Image Creator to “New TIF & PYR” to keep the zoom pyramids separate from the 
1X image. Also consider “Jpeg 2000” (JP2) and “BigTIFF” output formats. BigTIFF will perform the faster 
than JP2. If you have any questions about which image format is the best for you, please contact 
support@datem.com.  

 

20. Satellite RPC and ALOS-1 projects have the following changes and additions: 

a. There are improvements to Import > Socet Set from SUP Only for satellite RPC projects. The Socet Set 
RPC adjustments are imported and applied correctly now. Previously, only the original RPC was 
imported, without applying Socet Set’s adjustments that they calculated after any control point readings. 

b. The RPC project’s Add Multiple button will now find JP2 files in the current folder and its subfolders. 
Previously, Add Multiple only found TIF and SMTI files. 

 

2. DAT/EM-PCI ProPack Projects require a new DAT/EM-PCI Runtime ProPack installation file, new 
licensing procedures, and a new way to launch Summit from a batch file. Download 
ProPack_for_Release_7_0_blt_mm_dd_2014.exe and the instructions from www.datem.com . 
Please read the instructions document carefully before installing and running the ProPack 
software. 
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21. VisionMap A3 and Frame projects: 

a. All A3 projects have an improved model generation method, which is found in Project window>Models 
tab>Generate Models. It better matches the images that are good model pairs and prevents matches of 
highly overlapping images from other flight strips. This model generator will only work if the A3 project has 
a projected system checked on for coordinate translation. 

b. VisionMap Frame Model is a new, additional VisionMap A3 project type. To start a project, select 
Summit>New>VisionMap Frame Model. Add the images to the project. The orientation data are in the 
<image_name>.model.xml files and are used automatically if they are found in the same folder as the 
images.  

  

Note: (Windows 7 and 8 only) In the VisionMap Frame Model Project Edit dialog, there is one Add 
images button to add all the images. Add Multiple is not needed, because you can now use Add 
images to search for “.tif” in the A3 Frame project’s root folder. All .tif files in the folder tree will be found. 
Select them all to add them at one time. 
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The default coordinate system is Geocentric and this will work, but DAT/EM suggests transforming to a 
projected system. 

 

Project window>Models tab>Generate Models will only work if you select a projected system first; use 
either Match Overlap or By image order. 

 

 

22. Imported Projects: 

a. The Z/I import tool was modified to calculate a principal point offset from the "photo_coord_sys_origin" 
entry in the Z/I "camera" file. A customer sent an example project that prompted this change. In the 
customer's file, the Z/I principal point was set to (0,0), but the field "photo_coord_sys_origin" contained 
the offset that was required in the Summit camera file's Principal Point setting. 

b. The Z/I import tool was modified to set the Summit project's "Atmospheric Correction" setting on if the Z/I 
""atmospheric_flag" is on in the Z/I "project" file. Previously, this settings did not match and had to be 
checked on manually. 

c. DiAP projects would not import in the 64-bit Summit version and the images might not display correctly or 
could crash on opening in either 32- or 64-bit Summit versions. A legacy allocation error in third-party 
code was fixed to correct this. 

NOTICE! It has recently come to DAT/EM’s attention that newer versions of Socet Set aerial projects may not be 
importing into Summit correctly. Due to a combination of late discovery and lack of enough comparison projects, 
the problem has not been fixed in version 7.0. If you can help us by sending comparison projects saved in both 
older and newer Socet Set versions, we could fix the problem more quickly. We are also interested in new-version 
Socet Set aerial projects that do import correctly for comparison. Please contact support@datem.com for more 
information on how you can help. 
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23. Superimposition has the following changes: 

a. A Summit superimposition crashing problem was fixed. The problem could be mistakenly attributed to 
Capture for ArcGIS. In version 6.8, Summit would crash in the following cases: A) ArcMap Undo (from the 
ArcMap toolbar) was issued during a sketch and followed by more digitizing, and B) ArcMap's classic task 
was in Modify, two objects were modified, then the task changed back to Create and digitizing was 
attempted. 

b. Superimposition only supports true type and open type fonts (ttf and otf). In previous versions, if an 
unsupported font type was encountered, superimposition would not show the text at all. Now the 
unsupported font will be replaced by either Tahoma or Arial so that it displays the text in superimposition. 

c. Superimposition has some improvements and uses modern OpenGL GPU shaders. Note that ‘Shaders’ 
are GPU source code that runs directly on the GPU, not the CPU. These enable DAT/EM to do more with 
superimposition, such as line patterning in Capture for ArcGIS and vertex marking in superimposition. 

The GPU shaders require OpenGL 4.0. If the video card model is too old to use the shaders, it will revert 
to older methods. They are only enabled if “SI performance boost” is on for compatible video cards. To 
manually toggle the use of the shaders, toggle the Summit>Tools>SI Performance Monitor>GPU Shaders 
checkbox. 

 

 

The following are some examples of the advantages of the new shaders: 

 3D stippling (Capture for ArcGIS). The right and left stipple patterns will match in three dimensions 
and look proper in stereo. 

 Lines of any width. Legacy OpenGL only supports up to the driver-supported limit (usually under 10 
pixels). 

 Line Mitering. No Miter:   With Miter:   

 Speed. Stippling and large quantities of text can be drawn fast with a single or few draw calls. The 
previous stipple had to draw each line independently (slow). 
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d. There is a new OpenGL GPU shader for marking vertices and showing vertex direction in 
superimposition. Select Summit>SI>Mark Vertices to check on the option. Select Summit>SI>Mark 
Options to set the color and size of the markers: 

   

 

“Mark Vertices” is on a pull-down menu, which means it can optionally be assigned to a function key. 
Select Tools>Shortcuts>”SI:Mark Vertices”>Create Shortcut and press the desired keyboard key(s). 
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24. Generate LIDAR Image (GenLidarImageUI[_64].exe) has a crash error that is fixed. 

25. Stereo Mate Generator has the following changes: 

a. There is a new 64-bit stereo mate generator called GenerateStereomateBatch_64.exe. 

b. The 32-bit version had its file name changed to GenerateStereomateBatch.exe. 

c. Both the 32- and 64-bit versions of Summit now launch the proper application from their 
Imagery>Generate Stereo Mates menu item. Previously, there was a mistake in the menu link. 

26. Contour Creator has the following changes: 

a. Contours could be wrong where two breaklines intersected or ended near each other. This is fixed. 

b. A crash situation occurred when Contour Creator encountered invalid breakline input. It no longer 
crashes, but the user will need to fix the input to obtain proper contours. 

27. Image Viewer has the following changes: 

a. There is a new 64-bit Image Viewer. 

b. DAT/EM Image Viewer no longer crashes on "Open Vector Files, Select Layers." 

28. Image Creator has the following changes: 

a. JP2: Version 6.8 changed jpeg2000 libraries. The new library did not read the older single-tile .jp2 with 
accompanying .j2i files; it would run out of memory trying to load the huge single tile. Now version 7.0 will 
pre-screen the .jp2 file; if it finds that the tile size is less than or equal to 2048, the newer, faster library is 
used. If the tile size is larger than 2048, the older library is used to read the .jp2. Note that Image Creator 
always outputs a "Summit optimized" .jp2 format to be read by the faster library. 

b. TIF: Support has been added for ORIENTATION "right top", "lower left", and "lower right" .tif files created 
by Vexcel UltraMap software. 

29. Project Viewer / Ortho+Mosaic has the following changes: 

a. Summit no longer automatically takes an Ortho+Mosaic license when it runs with a network lock. The 
license is only taken if Ortho+Mosaic is running. 

b. A boundary imported from a vector file now draws "on top" immediately. 

c. A "Default transparent color" was added to display transparency temporarily as a color (does not affect 
the transparency setting in the image file).  

d. "Continuous zoom" has replaced the user's selection for the overview image resolution.  

 Ability to view orthophotos or other projects with full zooming capability. A small overview 
image is no longer used and this was removed from options. 

 The “Show Images” dialog, toolbar and menu items are removed. Toolbars will have to be 
reset to actually get rid of the item; otherwise, it will be greyed out forever. 

 Images are now always ‘on’ by default. If required, you can still right click on the view to 
toggle the image display. 

 The images should load much faster. Full background multithreading is used. The image 
boundaries will load first, and the progress of overview loading will appear at the bottom. 

 Images will still unload upon processing orthophotos or mosaics. 

 It should use much less memory. Textures and image sizes are selected according to zoom 
level. Previously, a set size was used, which was bad if many images were in the project. For 
example, when zoomed way out it might choose 64x64 pixel tiles and load this size from all 
the images.  When zoomed way in it may choose 1024x1024 size tiles and only load from a 
single image. 

e. A crashing error was fixed for using a DWG file as vector input. 
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f. The “Clip Seam” tool was not working at the Mosaic Generation stage. This is fixed. 

g. Mosaic seam generation could create what DAT/EM calls “pink blob” seams in areas of multiple overlap 
or tiny slivers of overlap. Here is an example:  

 

To prevent this, the seam generation dialogs now include a hint: 

 

The options are: 

 Don’t Know – Default. This works just like previous versions. 

 Highly multiplely overlapped – for areas where many images overlap. This will fix the “pink 
blob” problem where many small seams are made in high overlap areas. Please note that this 
does not guarantee that all seams will be in overlapped areas. They could be in an area of a 
single image. Highly overlapped images will not have seams in a single image. If the overlap 
is not high enough to avoid this, try one of the other settings. Example of high overlap: 

 

 Low overlap – This algorithm weeds out areas with only a single image of data. This breaks 
down when there are tiny slivers of overlap or very small areas. This is a good setting for low 
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overlap projects; however, if “pink blob” seams are generated, try another setting. Example of 
low overlap: 

 

 

h. In previous versions, the overviews were loaded differently. Now the user does not need to set the 
resolution of the overviews; it is done automatically depending on the zoom level. As you zoom in, the 
resolution becomes higher. 

 

Landscape 
The following changes were made to LANDSCAPE: 

1. There is a new common interactive point edit dialog. Some of the existing tools, such as Face Shift, Breakline, 
and Single Point, have been moved to this dialog. 

2. Brush Z edit is a new interactive point edit tool. The surrounding point elevations are used to create a TIN that is 
used to smooth the points inside the Brush Size circle. It does this on the fly while you move the cursor around. It 
can be slow if you have a lot of points loaded in the view; avoid this by either loading fewer points or enabling 
“Only load points inside view”. 

 

DAT/EM Capture for ArcGIS 
Version 7.0 is compatible with ArcGIS 9.1, 9.2, 9.3.1, 10.0, 10.1, and 10.2 (each with the latest service packs installed) 
 
BE ADVISED: DAT/EM has tentative plans to drop support for ArcGIS 9.x versions at the second DAT/EM software release in 2014 
(v.7.0 is the first release of 2014). Please prepare to upgrade ArcGIS to a 10.x release. Contact DAT/EM if you have concerns about 
upgrading. 
 

Note: Blue Marble's Geographic Calculator ArcGIS plugin directly conflicts with DAT/EM's CaptureArcInfo.2010.dll. 
When DAT/EM software is installed, "Registration Failed" is reported near the end of installation. Run "C:\Program Files 
(x86)\Blue Marble Geo\Geographic Calculator\UnRegisterEsriPlugin.bat" before installing DAT/EM software. Contact 
DAT/EM for more information if you have Geographic Calculator and would like to use it in ArcGIS. 

The following changes were made to DAT/EM Capture for ArcGIS: 

1. The following is fixed: If you picked one point only with the "Add Vertex" tool, did not pick the vertex destination 
point, and changed DAT/EM tools, Add Vertex would delete the end part of the polyline. Now it cancels without 
doing anything if the second point is not received. 
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2. Superimposition display capability has been added for feature data object (FDO) graphics layers, which are 
collections of properties for annotation layers. Previously, if an FDO layer was encountered, ArcMap could crash. 

3. Summit’s superimposition could have problems if it encountered an empty color setting in a data layer. This refers 
to empty, not <Null>, since the software could already handle a <Null> setting correctly. The empty setting was 
seen in a customer’s data layer, and it is unknown whether it was a valid setting or a corrupt file. Either way, the 
DAT/EM software will handle the empty color now. 

4. Close Polyline no longer allows the "Modify" task to revert to "Create". 

5. The Export Snap States could write a blank file if an existing snap state wasn't selected. 

6. The following items apply to Topology layers in ArcMap’s TOC: 

a. Adding a Topology layer to the map corrupted Summit's superimposition. This has been fixed. 

b. Topology layers are shown in both the ArcMap TOC and in the Summit SI Layer Manager; however, 
topology layers are ignored whether on or off in the SI Layer Manager. The SI Layer Manager will no 
longer have problems when topology layers are added to ArcMap.  

7. This is really a Summit Superimposition fix, but it is worth mentioning in the ArcGIS list. A Summit superimposition 
crashing problem was fixed. The problem could be mistakenly attributed to Capture for ArcGIS. The symptoms 
were that Summit would crash in the following cases: A) ArcMap Undo (from the ArcMap toolbar) was issued 
during a sketch and followed by more digitizing, and B) ArcMap's classic task was in Modify, two objects were 
modified, then the task changed back to Create and digitizing was attempted. 

8. The offset tools were not copying the attributes of the feature being offset. This is fixed. 

9. The ArcMap-side DAT/EM Capture Options dialog’s superimposition tab has the following changes: 

a. All existing settings have changed from checkboxes to a list control. This allows us to add any number of 
new settings. 

b. Limit Text is new. When set to “Yes”, it limits the number of text items that will be sent to Summit to 
2500. Note that Summit itself will only draw the first 700 within its view. The 2500 limit on the ArcMap side 
ensures that annotation or labels that number greater than 2500 will now load much faster. 

c. Text Size is new. It controls the size of ArcMap labels in Summit’s superimposition. 

    

Limit Text and Text Size are new. 

All others changed from checkboxes to list controls. 
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10. Summit's superimposition will display a certain type of dashed line from ArcGIS as follows: 

 Either click directly on the symbol under the layer name in the ArcMap Table of Contents (TOC)>Select 
Edit Symbol or right click on the layer name in the TOC>select Properties>Symbology tab>click 
directly on the Symbol graphic: 

  

 

Select the Symbol icon on the left in the Symbol area: 
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Set Type=Simple Line Symbol and Style to the selected pattern. 

 

As long as the video card supports OpenGL 4.0 or higher and Summit>Tools>Performance 
Monitor>GPU Shaders is on, the pattern will appear in Summit’s superimposition: 

 

   

11. With previous versions of DAT/EM software, ArcMap could crash if changed to Layout view while DAT/EM's DLL 
was registered. Now the crash is prevented; all DAT/EM tools are deactivated when Layout view is on. 

12. Support for Layer Groups was added. Previously, having layer groups could cause Summit and/or ArcMap to 
crash. 

13. Communication could be lost between Summit and ArcMap, with or without also losing the kappa rotation angle 
applied to the ArcMap data view. The user could also cause this situation by changing the view rotation value in 
the Data Frame Tools toolbar. There are more refreshes in place now. The user can force a refresh by clicking on 
Layout View and back to Data view, which forces communication with Summit to refresh. 

14. Create Offset Line and Create Offset Curve now properly copy the attributions of the feature being offset. 

15. The "Clip one line to another object" and "Extend one line to another object" tools now clear any current selection 
before the first prompt. This prevents the first pick (in response to the first prompt) from clearing a selection rather 
than making a selection. 

16. Cursor designs that had opacity settings would appear black in the ArcMap data view. This happened when the 
cursor was set using the ArcMap-side DAT/EM Capture Options> (DAT/EM Cursor) tab. 

17. Summit’s SI could crash in cases such as when the ArcGIS data layer’s color (outline and/or fill color) was <Null> 
and for layers using representations. For some <Null> color setting combinations, SI would not crash, but would 
show a default color of white. Now <Null> colors are simply not displayed in superimposition. For polygons, this 
applies only if both the outline and the fill color are <Null>; if either the outline or fill color has a color setting while 
the other is <Null>, the non-null color setting is used. Representations are now displayed and flushed correctly 
from SI, although they should still be considered read only; you should not attempt to use DAT/EM drawing tools 
to modify objects with representations. 
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18. SI Drape has the following changes: 

a. ArcMap labels would not display in Summit Superimposition for objects that do not have an elevation or 
for objects that were draped using the SI Drape tool. Now labels will be draped and/or display at the right 
elevation in 2D SI. 

b. The SI Drape toolbar icon will appear highlighted while SI Drape is active. 

c. In version 6.8, if a file was checked on in SI Drape at the time ArcMap closed, the file would reload the 
next time ArcMap started. This reload would happen before picking a map file to open. If the file was 
large, there could be a long delay. There is a new Load on start checkbox. 

 Load on start = off: The checked files will not load automatically when ArcMap starts. 
Recommended for users who change projects often. Prevents time-consuming loading of DEM 
files that belong to a previous project. If off, the user must launch the SI Drape dialog and select 
“Apply” in order to load checked files. 

 Load on start = on: The files will load automatically when ArcMap starts. Recommended for 
users who work on the same project for more than one day. 

 

19. Shift Features can now rotate and scale the shifted feature when shifting using the stereoplotter. 

For example, this is useful when there are multiple buildings that have the same footprint. In that case, draw the 
first building using the DAT/EM squre tool. Then start Shift Features and turn on Make copy then shift, Use 
Summit to shift, Both, Rotate (if at different base angles), and Scale (if at different sizes, but the same aspect 
ratio). With 3D snap on, select two corner points along a side of the first existing building. Select two corner points  
along the corresponding side of the next building to create. Continue selecting two points along the corresponding 
sides of subsequent buildings to create. In the graphic below, notice that the yellow first-point vertex marker is 
always on the same corresponding corner of each building. 

    

New Rotate and Scale settings are useful to make similar buildings as rotated/scaled copies 
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20. Previously, when ArcMap had multiple data frames (also known as multiple “maps” in ArcObjects), vectors from 
all data frames would be superimposed in Summit. Now the active data frame will be the only source of 
superimposition vectors. 

21. Certain geodatabase feature classes could display “flat” in Summit’s superimposition at the elevation of the 
Summit cursor at the time the layer was last refreshed automatically or with a user-directed SI Update. This has 
been fixed. 

22. (User’s choice!) There is a newly installed cursor design called “DATEMCursorForArcMap.cursor” for Summit and 
Capture for ArcGIS. It looks like the DAT/EM cursor found on the DAT/EM Capture Tools toolbar, . This may 
optionally be set in the ArcMap-side DAT/EM Options>  tab. The purpose is to make the cursor design in 
ArcMap look like the DAT/EM cursor on the toolbar whenever the DAT/EM cursor is on. 

   

New cursor file makes the ArcMap cursor match the DAT/EM cursor toolbar icon 

 

23. Airfield3D has the following changes. More complete instructions are in a supplementary document, 
Airfield3D7.0ReleaseNotesSupplement.pdf. 

a. Editing is made easier due to Airfield3D overriding ArcMap's tendency to reset the task to "Create" after 
each modification. Now it stays set to "Modify" so that the next edit can be done. 

b. The ellipsoid height is now added to the "heads up" display at the lower center of the Summit main view 
when Airfield3D is active. 

c. Airfield3D has new Part 77 custom surfaces, an option to measure natural object types, and an ellipsoid 
height setting for obstruction surfaces. 

d. Airfield3D's report writer had Quadrant 1 and 4 swapped in the reports for the VGHS.csv and VGCS.csv. 
This is fixed. 

e. The beginning of the arcs in the VGHS and VGCS were starting at the end of the runway rather than the 
end of the primary surface as described in 18B on page 37. That caused a 200’ shift in their locations. 
This is fixed. After installing the fixed software, use the "Recalculate" button in the lower left of the 
Airfield3D dialog to automatically fix fields for objects that were digitized previously. 

f. Added a group code to points measured inside obstruction areas. The updater for the group code will give 
an warning if there are duplicate code number, but will skip the warning for <Null> or 0 (zero) values. 

 



DAT/EM Systems International Version 7.0 Release Notes 
 

 30

DAT/EM Capture and MapEditor for AutoCAD 
Changes apply to: 

32-bit AutoCAD 2004-2014 versions with the latest service packs. 

64-bit AutoCAD 2009-2014 versions with the latest service packs. Note that 64-bit AutoCAD 2008 is not supported. 

BE ADVISED: DAT/EM Capture no longer supports AutoCAD 2000-2002 versions. If you use these old AutoCAD versions, please 
upgrade to AutoCAD 2004 or higher before installing DAT/EM version 7.0. 

DAT/EM software will install for multiple AutoCAD products of different year numbers on the same computer; however, it will not 
install for multiple same-year versions together. For example, it will install for AutoCAD 2011 and AutoCAD Map3D 2012 together, 
but it will not install for both AutoCAD 2012 and AutoCAD Map3D 2012. Please note that files may be copied manually to activate 
more same-year versions (contact DAT/EM Support for instructions). 

Autodesk Infrastructure Design Suite installs three same-year AutoCAD versions (AutoCAD, Map3D, and Civil3D). You must run 
each version and register/”accept” each one before installing DAT/EM software whether or not you intend to run every version with 
DAT/EM Capture active. DAT/EM software will install completely for only one of them. After that, the user can manually copy the 
AutoCAD \datem folder and the wintab driver file into the other two versions of AutoCAD. Contact DAT/EM Support for instructions. 

Reminder: Install all available AutoCAD service packs and updates before installing DAT/EM software. 

Reminder: After every new AutoCAD installation, you must run AutoCAD at least one time to activate its license before installing 
DAT/EM software. This applies to every version of AutoCAD on the computer whether or not you intend to use every version with 
DAT/EM Capture. 

The following changes were made to DAT/EM Capture and MapEditor for AutoCAD: 

1. DATPAN has been fixed to properly set and read its registry values. 

2. Snap mode buttons in DAT/EM’s menus for AutoCAD have been fixed. 

3. Menus have an additional set of Osnap settings. The old set has "Osnap <mode>" only. The new set starts 
Capt3D followed by the Osnap setting. These have been placed in the ribbon menus and pull-down menus where 
needed. 

4. AutoCAD MapEditor TOUCH command has the following changes: 

a. TOUCH now properly adds a vertex to the "to" polyline if the "from" polyline has only 2 vertices. 

b. Previously, when MapEditor TOUCH added a vertex, it was always the Z of the "to" object, no matter how 
the elevation setting was configured. This has been fixed 

 

DAT/EM Capture and MapEditor for MicroStation 
Changes apply to Capture for MicroStation. DAT/EM software installs for the following MicroStation versions on 32-bit and 64-
bit operating systems: 

 MicroStation V8 and V8 2004 Edition: Version should be 08.05.00.34 or higher. 

 MicroStation XM: Version should be 08.09.04.88 or higher. 

 MicroStation V8i, V8i-based Bentley Map and Map Enterprise Select Series 1 (1 not recommended), 2, and 3, 
MicroStation PowerView Select Series 3 

If you upgrade from Select Series 1 to 2 or 3, you must reinstall DAT/EM software after installing the Series upgrade.  

DAT/EM will install for all versions of MicroStation that are present on the computer at the time of the DAT/EM installation. 

 
Note about Power GeoPak Select Series 3: DAT/EM Software installs for Power GeoPak SS3, but it does not run well. 
Power GeoPak has timing problems loading other vendor’s applications. For example, when DAT/EM applications are loaded, 
the “Common.ma” file will not load. When DAT/EM applications load automatically, the “GeoPak” menu disappears from the 
menu bar. Therefore DAT/EM version 7.0 should not be installed for Power GeoPak. 
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The following changes were made to DAT/EM Capture and MapEditor for MicroStation: 

1. MicroStation PowerView Select Series 3 is now supported. The installation routine will place the DAT/EM Capture 
files in the PowerView location. 

2. Fixed a MapEditor picker "pick by element" problem where it would lose picks. 

3. Fixed a problem with the MapEditor Selection Set Editor's "All points and cells" set. It was sometimes including 
lines and line strings that had length instead of only zero-length points. 

4. Tab pages have been removed and changed to single dialogs in DTMDistributor and ZLABEL SETTINGS. This 
solves problems with entering values in the fields on tab pages, such as the distance and angle fields in 
DTMDistributor. 

5. The MicroStation-side SI SETTINGS "All Levels" checkbox was being ignored in several previous versions. This 
setting is now active. If "All Levels" is on, all levels are displayed in Summit's superimposition, even if they are 
unchecked for display in MicroStation. If "All Levels" is off, levels that are unchecked for display in MicroStation 
will not be sent to superimposition. 

6. Transient elements were being assigned to the active level, which was causing problems for other applications 
that process the active level. Transients are now assigned a temporary “DatemTransients” level that is 
meaningless to other applications. An example of a transient element is VISIT's circle marker. 

7. Superimposition of more than 5000 levels, including levels from the main file and any reference files, was 
corrupting the level table in summit’s Superimposition. The limit is now 10000 levels. 

8. A fix was made to several commands that failed to operate correctly on complex shapes. LABELIT, TOUCH 
BATCH, TOUCH, BREAK, BREAK ELEMENT, and CROSSCHECK might have corrupted complex shapes during 
break operations. 

9. 2D Snapping: In recent versions of Capture for MicroStation, the DATEM SETTINGS (TENTATIVE ON) Tenative 
to XY only=ON (2D snap) setting was being ignored when digitizing a first vertex as a snap point. This is fixed 
and applies to all digitizing operations. 

As an example, a customer wanted to draw the top of a retaining wall and then draw the bottom of the wall using 
2D (xy only) snaps to each vertex in the top of the wall, allowing Summit to set the elevation for the entire bottom 
of the wall. The first vertex would incorrectly snap to the top of the wall, while the remaining vertices snapped 
correctly in 2D only. Now all vertices will snap correctly in 2D. 

10. AUTOARC and AUTOARC2D have the following enhancements. 

a. AUTOARC and AUTOARC2D both have a new checkbox to optionally stroke arcs into multiple straight 
segments at the end of digitizing. Arcs will be retained during digitizing for better "undo" capability. Arcs 
will be stroked and the element reduced to a simple line string element at the end. 

Note: To simplify UNDO processing, the optional stroke operation is applied after the new element is 
written to the design. 

 

New option to stroke arcs into multiple segments 

b. AUTOARC now shows arcs as transients in Summit's superimposition. 
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c. AUTOARC has new options to operate on snapped-to elements: 1) by adding a vertex at the snap point, 
or 2) by breaking the element at the snap point, or 3) by making no change to elements at snap points. 

 

New operations to be done to an element that Autoarc snaps to during drawing 

d. AUTOARC snap operations apply now to Tentative snaps as well as ACCUSNAPs. 

e. The points that are digitized during arc construction are again displayed. This helps with visualization 
during construction and during undo operations. 

f. Performance is improved. Arcs are no longer drawn in Summit’s superimposition until the final point is 
entered. The rubber banding for arcs is again a single line between the second and third points; however, 
arcs are displayed after construction, which is an improvement over previous versions, which only 
displayed the three arc pick points. 

g. Keyins have been added: 

 AUTOARC STROKE ON – strokes complex elements that contain arcs into line strings.     

 AUTOARC STROKE OFF – places complex elements (for elements that contain arcs). 

 AUTOARC STROKE TOGGLE – toggles the stroke on/off setting. 

 AUTOARC TOLERANCE <tolerance> – sets the stroke tolerance. 

 AUTOARC SNAPPED NOCHANGE – clears the “snapped” setting. 

 AUTOARC SNAPPED BREAK – breaks snapped-to elements at their intersection(s) with 
AUTOARC elements. 

 AUTOARC SNAPPED ADDVERT – adds vertices to snapped-to elements at their intersection(s) 
with AUTOARC elements. 

 AUTOARC2D STROKE ON – strokes complex elements that contain arcs into line strings. 

 AUTOARC2D STROKE OFF – places complex elements (for elements that contain arcs). 

 AUTOARC2D STROKE TOGGLE – toggles the stroke on/off setting. 

 AUTOARC2D TOLERANCE <tolerance> – sets the stroke tolerance. 

 AUTOARC2D SNAPPED NOCHANGE – clears the “snapped” setting. 

  AUTOARC2D SNAPPED BREAK – breaks snapped-to elements at their intersection(s) with 
AUTOARC2D elements. 

  AUTOARC2D SNAPPED ADDVERT – adds vertices to snapped-to elements at their 
intersection(s) with AUTOARC2D elements. 

11. BMARK has the following changes: 

a. BMARK has improved error handling if a legacy rules file contains format mistakes or lists a level that 
does not exist in the design file. 

b. Fixed an initialization problem with the hatching option input from legacy rules files. 

c. In previous versions with MicroStation V8i Select Series 3, the BMARK dialog might lock up, in particular 
when being accessed from a MapEditor parameter file. This is fixed. 
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12. DTMDISTRIBUTOR previously had settings on tab-style settings pages. We thought tabs would be useful, but 
they turned out to have functionality problems. We removed the tabs and moved all settings to the main dialog. 

 >>>  

Old and new settings presentation in DTMDISTRIBUTOR 

13. ELINE has the following fixes: 

a. The ELINE nearestz option could produce a complex chain that contained one line string. 

b. ELINE connection choices (upon resets at the end) now appear correctly in Summit's superimposition. 

c. ELINE now shows arcs as transients in Summit's superimposition. 

14. EZEDIT no longer sets elements adjacent to the edited arc to the active attributes. 

15. The legacy LABELIT command has been removed. Its replacement, ZLABEL, is now activated from the menu. 

16. GRIDIT previously placed the components of graphic cells on the active level. Point cells will continue to be 
placed on the active level. Graphic cells will now use symbology defined in the cell definition. 

17. MECHANGETAG is a new family of commands. See MEChangeTag7.0RelNotesSupplement.pdf for a detailed 
description of these changes. 

a. MECHANGETAG – Interactive change tag value command. This brings up a dialog. 
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The following keyins are used to set MECHANGETAG parameters as seen in the dialog. These keyins can be 
used in the GENERIC KEYIN entries in MapEditor parameter files: 

b. MECHANGETAG TAG1 – Changes the criteria to “1st Tag”. (MECHANGETAG TAG1 will be removed 
from the dialog in the next version. Please use MECHANGETAG TAGNAME instead.) 

c. MECHANGETAG TAG2  – Changes the criteria to “2nd Tag”. (MECHANGETAG TAG2 will be removed 
from the dialog in the next version. Please use MECHANGETAG TAGNAME instead.) 

d. MECHANGETAG SET <selection set name> – Changes the selection set scanned for tags matching the 
tag criteria 

e. MECHANGETAG TAGNAME <tag set> <tag name> – Changes the criteria to “By Tag Name” with a 
specific “Tag Name” and sets the associated “Tag Set”. 

f. MECHANGETAG TAGVALUE <current tag value> – Changes the criteria to “By Tag Value” and sets the 
associated “Current Tag Value”. 

g. MECHANGETAG NEWVALUE <new tag value> – Sets the new value that MECHANGETAG will write to 
specified tags. 

h. MECHANGETAG TAGGO – Run MECHANGETAG using the most recent settings. 

18. MEREPLACEOBJECT has the following fixes and changes: 

a. It has added error checking to prevent an array overrun when replacing a line string. 

b. It was using the text origin (lower leftmost text extent) as the origin of the new element when replacing 
text with other element types. It has been modified to use the text element’s snap point (justification point) 
as the origin of the new element. This applies text justification settings to the replacement element 
position. 

19. MEXPORT and XYZOUT now treat zero-length line strings in addition to zero-length lines as points. Previously, 
only zero length lines were viewed as points. 

20. MVUSER with "Userpick" was moving Summit to MicroStation’s active elevation, which could be zero. Now it 
moves Summit in xy only. 

21. PLACE SHAPE (MicroStation command) now has a rubber band in Summit's superimposition. 

22. PLOTTERZOOM_MAPSCALE <value> is a new command to set Summit's "Map Scale" value to <value>. 

 

23. PLOTTERZOOM <value> is an enhancement to the existing PLOTTERZOOM command. Note that plain 
PLOTTERZOOM makes the Summit zoom value match to the current MicroStation view zoom. PLOTTERZOOM 
<value> makes the Summit main view zoom to <value>. For example, PLOTTERZOOM 5 will zoom Summit 5:1. 
This enables you to use a keyin to set zooms that are not on the zoom toolbar presets. 

24. REPLACE CELL has an expanded cell name display to better show long cell names. 

25. ROAD now shows arcs as transients in Summit's superimposition. 

26. SCALLOP was putting the complex header on the wrong level. 

27. SHEETCUTTER has the following changes: 

a. If the Fence VOID mode was set to OUTSIDE before running SHEETCUTTER, the first design file that 
was created would be wrong. Subsequent design files would be correct. The first design file has been 
corrected. 

b. Fixed a serious timing problem that might result in elements in the first tile from being included in the 
output file. It now sets the proper fence mode sooner. 

c. Fixed a range check error for extracting the text file name for boundaries that have a large rotation angle. 
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28. VISIT has the following fixes and changes: 

a. VISIT now has an expand/collapse button to show/hide some of the dialog components. The dialog can 
be made smaller when not using the advanced options or when it is not necessary to show the full point 
list display. 

 

New VISIT expand/collapse buttons to control the dialog size 

b. VISIT and ZCHECK could crash when drawing its transient circle. This is fixed in both commands 

29. VOLUME (MEVOLUME) has changes: 

a. There is a fix for a problem generating automatic pile names for geographically close piles when using 
"Define Base" options. This affected the "Pre-defined label" level name, which might be set the level of a 
nearby pile. 

b. MEVOLUME has a new "Densify" setting. This performs vertex densification on the input data, and should 
improve the results for breaklines that contain long segments. If the user sets the densify option, the 
algorithm will interpolate points using the "Delta" parameter as the maximum distance in master units 
between points. The smaller the delta, the longer it will take to run the calculation but the calculation will 
be more refined. 

30. XYZIN had a problem with cell scaling where scaling in the Z direction was set to 1.0. If the cell scale was set to 
anything other than 1.0, the scale would be off in the Z direction. This is fixed. 

31. ZCHECK and VISIT could crash when drawing its transient circle. This is fixed in both commands. 
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32. ZLABEL has the following changes: 

a. ZLABEL GUIDERDRAW was fixed so that it no longer crashes after its "Undo Last" button is followed by 
an attempt to digitize more guiders. 

b. ZLABEL SETTINGS previously had settings on tab-style settings pages. We thought tabs would be 
useful, but they turned out to have functionality problems. We removed the tabs and moved the settings 
to individual settings dialogs. Both dialogs will appear when you start ZLABEL SETTINGS or they can be 
launched individually from buttons on the other ZLABEL dialogs. 

 

Old ZLABEL tab-style settings 

 

New individual ZLABEL settings dialogs 

 

DAT/EM Capture for Blue Marble Global Mapper - Beta 
A beta version of Capture for Blue Marble Global Mapper is included. If this is of interest to you, please download the beta 
instructions document from www.datem.com. Please send feedback to support@datem.com. We value our customers’ input 
for the future functionality of this product. 




