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The following changes have been made to DAT/EM products between Release 7.0 and Release 7.1. Please review these 
revisions made to the software and update your software to implement changes. 
 
As always, DAT/EM welcomes comments and suggestions from you, our clients, so please don’t hesitate to contact our 
support department at support@datem.com or call us with your requests. 
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Operating Systems and Microsoft Updates 
Release 7.1 is supported on the following operating systems: 

 Windows 7 Ultimate and Professional 

 Windows 8 and 8.1 Professional and Enterprise 

Install all critical Microsoft Windows Updates before DAT/EM software installation.  

Microsoft Office 2007 users must install all available Microsoft Office updates before installing DAT/EM version 7.0. 
 

1. Release 7.1 is the first version that is not supported on the Windows XP operating system. DAT/EM stopped 
support for Windows XP on the same date that Microsoft stopped support for it, which was on April 8, 2014. No 
further testing occurs in Windows XP. 

 
 

Hint: If you are a Windows 8.x user and you miss the Windows 7 Start menu, you may be interested in the third-party 
“Classic Shell” application. We’ve used it on our computers and tablets and really like it. Classic Shell™: 
http://www.classicshell.net/   
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Hardware Locks/Dongles 
Please install Microsoft Updates and Service Packs for your operating system before applying lock reset programs. 
Network licensing should have the same Sentinel driver version on both the server and the local computers running the 
software. 
 

1. DAT/EM has changed its hardware lock configuration. If you have a hardware lock that was “written” by DAT/EM 
13 August 2014 or earlier, you must apply a WriteLock.exe to update the lock. 
 
The newly written lock is not backwards compatible. If for any reason you want to return to v.7.0 or earlier, use the 
v.7.0 WriteLocks that are supplied with your v.7.1 update file set. 
 

Q: I have been using DAT/EM version 6.8 or 7.0. Do I need to apply a WriteLock? 
A: Yes! You need both a new WriteLock and a 7.1 installation keycode. 
 
Q: I have a network lock. Do I need to apply a WriteLock before I install version 7.1? 
A: Yes! You need both a new WriteLock and a set of 7.1 installation keycodes. 
 
Q: I have a softlock demo. Do I need to apply a WriteLock? 
A: No. The WriteLock does not apply to softlocks. You may upgrade to version 7.1 using a 7.1 installation 
keycode only. 
 
Q: I have a version 7.1 beta. Do I need to apply a WriteLock? 
A: It depends on the date of the beta. Check Windows Start>All Programs>Datem Software>Release 
Information>Release Date (month/day/year format). If it was created after 13 August 2014, you probably 
already applied a WriteLock and you do not need to do it again. If you have an earlier beta, you need to 
run the WriteLock. 

  
2. DAT/EM version 7.1 installation updates the Safenet Sentinel hardware lock driver to version 7.6.7. Please reboot 

when asked. 
 
If you have a network lock on a network server, install Sentinel v.7.6.7 on the server at the same time you install 
the DAT/EM v.7.1 update on your DAT/EM workstations. The Sentinel driver must match. There are three choices 
for installing the driver on the network server: 

 Run the DAT/EM “Datem_Setup_7_1_blt_mm_dd_yyyy.exe” file one time on the network server. The first 
time it runs, it will install the Sentinel driver. Reboot when asked. 

 Or, download and install version 7.6.7 from the Sentinel website: http://www.safenet-
inc.com/support_and_downloads/Download_Drivers/Sentinel_Drivers/ (note that the driver posted there 
could be updated beyond 7.6.7 at any time. If you want to use a newer driver, you must install it on all 
your DAT/EM workstations and on your network lock server.) 

 Or, download and install version 7.6.7 from the DAT/EM website: 
http://www.datemsystems.com/down/drivers/Sentinel%20Protection%20Installer%207.6.7.exe  
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CAD Versions 
Release 7.1 has interfaces to the following CAD versions. These are both 32- and 64-bit versions unless otherwise noted: 

 AutoCAD: Autodesk 2004, 2005, 2006, 2007, 32-bit 2008, 2009, 2010, 2011, 2012, 2013, 2014, and 2015 products. Note that 
64-bit AutoCAD 2008 is not supported. Install all available service packs. 
 
DAT/EM software will install for multiple AutoCAD products of different year numbers on the same computer; however, it will 
not install for multiple same-year versions together. For example, it will not install for both 2012 and Map3D 2012. Note that 
files may be copied manually to activate more same-year versions (contact DAT/EM Support for instructions).  
 
BE ADVISED: Versions 6.6 and higher no longer support AutoCAD 2000-2002 versions. If you use these old versions, please 
upgrade to AutoCAD 2004 or higher. AutoCAD version 2007 or higher is needed in order to use the new AutoCAD MAPEDITOR. 
 

 ArcGIS: ArcMap 9.1, 9.2, 9.3 (service pack 1), 9.3.1(service pack 2), 10.0 (service pack 4), 10.1 (service pack 1), 10.2, 10.2.1, 
and 10.3 (plus any available service pack as they are released). 
 
BE ADVISED: In response to user requests, DAT/EM has decided to support ArcGIS 9.x at least until mid 2015. At that time, 
we will again review plans to drop support for ArcGIS 9.x. Please continue to make plans to upgrade ArcGIS to a 10.x release. 
Contact DAT/EM if you have concerns about upgrading. 
 

 MicroStation: DAT/EM software installs for the following versions: MicroStation V8; V8 2004 Edition; XM; V8i Select Series 1 
(1 not recommended), 2, and 3; Bentley Map and Map Enterprise Select Series 1 (1 not recommended), 2, and 3. 
 
Note for Select Series number upgrades: If you upgrade to MicroStation or Bentley Map to a higher Select Series number, 
you must reinstall any DAT/EM software after installing the Select Series upgrade. 
 
Note for Power GeoPak Select Series 3: DAT/EM Software installs for Power GeoPak SS3, but its application loading 
process has a conflict with Power GeoPak, which has timing problems loading other vendor’s applications. When DAT/EM 
applications load automatically, the “GeoPak” menu disappears from the menu bar and error messages may appear. Through 
a customer, DAT/EM learned that Bentley Systems had provided a workaround, which is a macro to delay loading a file; the 
customer can now run Power GeoPak successfully. Contact DAT/EM if you would like to try this method to activate DAT/EM 
Capture with Bentley Power GeoPak. 
 

 Global Mapper: 32- and 64-bit Global Mapper 15.2 dated June 25, 2014 or later and Global Mapper 16.x. DAT/EM 
recommends a version 16.0.6 built 12 December 2014 or later. If both 15.2 and 16 are installed at the same time, the 
extension for 15.2 will be used in both. 

 

Video Drivers 
Please note our video driver installation/update recommendations: 

 DO NOT install the driver on media packaged with a video card. It will be too old. 

 1st: Get the latest driver for your video card and operating system from www.nVidia.com. 

 2nd: If the driver on www.nvidia.com does not work, contact support@datem.com for advice. We may ask you to 
download an older driver from either www.nvidia.com or www.datem.com, depending on your hardware. 

 If you need to change (update or back out) a video driver, please follow the instructions at www.datem.com 
Support > Downloads > Manuals > Installation Instructions>“StereoLCDInstallationInstructions.pdf”. This 
shows how to replace drivers and verify that the new drivers have been installed properly. It is very important to 
check on the “Custom” and “Clean” installation choices. 

 On existing workstations, check your video driver periodically. The easiest schedule is to check it before installing 
each DAT/EM software update. If you use a single-panel LCD display and the video driver is older than the one 
currently offered at www.nvidia.com, please update it using the “Custom” and “Clean” installation options. 

Further notes: 

 When checking your installed video driver version, remember that the actual version consists of the last five digits 
with the decimal point moved two spaces to the right. For example, 6.14.12.7642 is really version 276.42. In the 
past, nVidia sometimes omitted a zero (0) from the version; for example, version 6.14.13.732 was really 307.32. 

 To check the installed video driver version on Windows 7, right click anywhere on a blank area of the desktop. 
Select Screen Resolution > Advanced Settings > Adapter tab > Properties > Driver tab > Driver Version. 
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 For video settings, see www.datem.com Support > Downloads > Manuals > Installation Instructions. Most 
users will want either “PlanarInstallationInstructions.pdf” for Planar dual-LCD monitors or 
“StereoLCDInstallationInstructions.pdf” for single LCD stereo monitors. 

Software Installation, File Locations, and Installed Utilities 
The following has changed for DAT/EM software installation or the location where DAT/EM applications store data: 

Note: Blue Marble's Geographic Calculator ArcGIS plugin directly conflicts with DAT/EM's CaptureArcInfo.2010.dll. 
When DAT/EM software is installed, "Registration Failed" is reported near the end of installation. Run "C:\Program 
Files (x86)\Blue Marble Geo\Geographic Calculator\UnRegisterEsriPlugin.bat" before installing DAT/EM software. 
Contact DAT/EM for more information if you have Geographic Calculator and would like to use it in ArcGIS. 

1. This change was implemented in version 6.8, but if 6.8 was not installed, please take note. There is a new 
DAT/EM-PCI Runtime ProPack installation to install after installing version 6.8, 7.0, or 7.1. It allows you to use 
Geomatica 2010-to-2013 projects. Download the file at www.datem.com and install it. It will launch the PCI 
License Utility, which contains a fingerprint and a link to a web request form. Copy the fingerprint and use the link 
to send the fingerprint to PCI. 

 

PCI will send a license file. Rename the file to “lservrc.txt” and copy it to the 32-bit location: 

 \Program Files (x86)\Datem Software\ProPack\exe 

Run the following file in the 32-bit locations.  

 \Program Files (x86)\Datem Software\ProPack\exe\LaunchLicenseUtil.bat 

Select the “Import” button, and browse for the “lservrc.txt” file in that same folder. Information will appear in the 
license file list below the “Import” button. Close. 

 

Select “Import” and browse for lservrc.txt 
 
PIX images should now open in Summit when Summit is launched from Windows Start > All Programs > Datem 
Software > PCI ProPack > Summit 64 with Propack (64-bit) or Summit 32 with Propack (32 bit), which launch 
Summit from the LaunchSummitWithPropack.bat files in the corresponding 64- or 32- bit applications folders. If 
they continue to give license errors, please contact DAT/EM Support. 

DAT/EM Keypad 
The following changes were made to the DAT/EM Keypad for version 7.1: 

1. The Keypad Controller was performing “Next Overlay” and “Call Keys” in the wrong order. Now it changes the 
overlay first (if set) and calls the keys from the changed overlay. If the overlay is not changed, it calls the keys 
from the current overlay. 

2. The Keypad Controller couldn't call keys on another overlay that occupied the same spaces as the initiating 
overlay key. This is now possible. 

3. Additional error checking is in place to prevent a series of “Call Keys” keys from returning to previously activated 
keys in the same command sequence. This prevents an endlessly repeating series of Call Keys. 

 



DAT/EM Version 7.1 Release Notes 
 

 5

Elevation Database 
There is a new “SetupElevationModels blt 01 07 2015.exe” file that must be installed with version 7.1. This includes 
support for RANC08, the Canadian Geodetic Vertical Datum of 2013 (CGVD2013), and Japan GSIGEO 2011. Run this 
installation file after installing the DAT/EM software. 

Please note that there may be some systems that changed from a default of 3D units to 2D units. If the unit was not 
specified in an existing Summit Evolution project that has an active coordinate conversion/translation, and the elevation 
does not seem correct after opening in Summit Evolution version 7.1, please select Summit>Orientation>Coordinate 
Conversion>Output Coordinate System>Units and select a 3D unit, such as “Projected Point in Meters”. 

If a geoid is not defined in the area of the Summit cursor, the elevation will default to Ellipsoid Height. 

 

Summit Evolution 
The following changes have been made to Summit Evolution and the applications that are provided with it. 

1. SMTSLN is a new “Multiple Project Solution” file that can combine any type of Summit .smtxml projects together 
and display them in multiple viewports. 

For example, with a Multiple Project Solution file, you can combine an aerial project with one input coordinate 
system, an aerial project with a different input coordinate system, an A3 project, an orthophoto project, a satellite 
RPC project, and an ADS40 project into one .smtsln file and display them in six viewports. 

To create and use a Multiple Project Solution file: 
 Select File>Create Multiple project solution… 
 Use this dialog to select any smtxml projects. Hint: If you want these projects to move together (control 

each other’s cursor location), select projects that share a common geographic area and are set to the 
same output coordinate system. 
 

 
 

 Select Create File… to create the .smtsln. This is a “Summit solution” file, which contains links to 
projects and some viewport information. 

 Select Open Now to load the .smtsln. When this loads, it will load all the projects into 
Summit. Alternative methods to open: Select the .smtsln from File>Open or double click on an .smtsln 
file to start Summit (if not already running) and open the .smtsln file. 

 When a ‘Solution’ .smtsln file is opened, an extra tab is added to the project dock window: 
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This lists all the projects in the solution. This tab will not appear when a normal .smtxml file is loaded. 
 
The right click menu in the Projects tab offers to add another project to the multiple project solution file: 
 

 
 

 When an item is selected in this list, then that project becomes active and all tabs in this dock window will 
change to reflect the selection. 

 Items in red are projects that are not found. Click on the red project and find the project to correct it. 
 The active project is tied to the active viewport. If you are not using multiple viewports and you select 

a different project, the currently open model will close. This happens because clicking on a new project 
assigns it to the currently active viewport. 

 To open models from different projects at the same time, first activate multiple viewports 
(View>Viewports). Click on a viewport to activate it. Select the project on the project tab. Select the 
models tab and open a model. Now repeat the process to open a model from a different project in a 
different viewport. Again, click on a different viewport, select a different project, select the models tab, and 
open the model. NOTE: as you activate different viewports, the active project will automatically change. 

 
Pros (in favor of Multiple Project Solutions): 

 It is an alternative to merging projects. 
 Each project is distinct and can have its own coordinate system, scale, orientation, project type, 

etc. Merging projects cannot do this. 
 It is useful to view orthophoto projects at the same time as stereo projects and in the same Summit 

application window. 
 This is a good way to compare old and new projects from different imagery sources, for example, ADS40 

and aerial or RPC and orthophoto. 
 .Smtsln is not required, but useful when you need it. If you don’t need it, you can continue to use the 

single .smtxml project. 
 

Cons (not in favor of Multiple Project Solutions): 
 All the projects in the .smtsln are loaded. This could use too much memory if the user is not 

careful. Please do not add every .smtxml on your computer into a single .smtsln with the idea that you 
will be able to open anything and everything; this could easily run the system out of memory. 
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2. The system mouse input device settings have the following changes: 

a. In version 6.8, the system mouse-type cursor Button 2 in Button Manager could be used as both a 
start/stop cursor control and as a Cancel/Reset/Finish Sketch button. In version 7.0, it could only be used 
to start/stop cursor control. Now in v.7.1, it can again perform both functions. This is true only for the 
“Right double click” mouse option in Tools>Options>Input Device tab>System Mouse>Options. 

b. The “Pan with Middle button down, release on button up” setting was obsolete and has been removed. 

   

With these settings, system mouse button 2 can be used to start/stop cursor and to Cancel/Reset/Finish Sketch 

3. Summit now prevents Windows Sleep mode from activating while Summit is running. Sleep mode often stops and 
cannot recover the display of stereo if a stereo application is running when sleep mode activates. 

4. The Quick Options toolbar has a new toggle for the cursor ground rings. First use Tools > Customize Toolbars to 
check on the Quick Options toolbar. Then use Summit > Tools > Cursor to set the desired ground rings 
appearance. Toggle the ground rings from the Quick Options toolbar at any time. 

  

  

Toggle cursor ground rings from the Quick Options toolbar 

5. Tools>Shortcut Keys was missing some of the “Tools:Quick Options” selections. The list is complete now. 

6. The Custom CAD 2 and Custom CAD 3 toolbars were previously omitted from the Summit>CAD>Custom CAD 
Buttons menu, which meant they were missing from the Tools>Shortcuts>Shortcut Keys definition list options. 
Now all 28 Custom CAD options are available on the menu and may be set to function keys. 
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7. The “Aligns images” and “Snap toggle” tools from the Alignment toolbar have been added to the list of macros 
available to be set to a shortcut. They appear in Tools>Shortcuts>Shortcut Keys as Tools:Align and Tools:Snap. 

   

  

Align and Snap from the Alignment toolbar may now be set to a shortcut 

8. The Snap and Align tools (located on the Alignment toolbar) are fixed so that they work in anaglyph stereo mode. 

9. Lock Toolbars is a new option on the Tools pull-down menu. When locked, you will not be able to move, dock, 
or undock any of the Summit toolbars. This prevents accidental toolbar drag/drops. 

 

Check Lock Toolbars to prevent accidental toolbar drag/drops 

10. Tools>Function Keys has a new Report button. This makes a list of all set shortcuts and opens the list in 
Windows Notepad. 

 

New Report option in the Shortcut Keys dialog 
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11. Multiple viewports have the following changes; 

a. Multiple viewports with non-group models open have a new “Automatically load next model” toggle icon 
on the top right side of the viewport. Previously, we did not allow regular (non-group) models to change in 
non-active viewports. It is useful to set it on (blue) when the same model is open in multiple viewports, for 
example, when the standard RGB is in the focus viewport and the same model with a channel map 
applied to show the 4th band is open in a second viewport. In that case, it would be useful to make the 
models always change to the same model together. 

 

Multiple viewports with non-group models open have new automatically change model icons 

b. Multiple viewports have a new “Zoom with focus viewport” icon in the upper right.  

 

Multiple viewports new “Zoom with focus viewport” icon 

 

12. Summit>File>Print has enhanced printing abilities. Like the new OpenGL drawing routines, the new printing 
methods are only enabled for OpenGL 4.0 or newer. If it is not supported, the old dialog and print method is used. 
New abilities include: 

a. Print preview. 
b. Prints anaglyph, left, right or split screens (horizontal and vertical). 
c. Prints different areas, such as the whole model or boundaries from CAD. Found boundaries can be 

selected from a list. 
d. Can print full superimposition, including vertex markings (Summit>SI>Mark Vertices). 
e. Can virtually print to a TIFF 
f. Will print at higher resolution. 
g. Normal paper options are supported via the common Print Setup dialog. 

 
The stereo view’s currently set elevation is always used, even if CAD boundaries are selected. It does not use the 
elevation values from the CAD boundaries. 

 

 
Summit>File>Print Enhancements 
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13. In previous versions, if Summit>Tools>SI tab>Clip Scope was on when “side by side” was on in relative 
orientation (RO) or RO Tie Points, either the left or right image view would appear stretched. This has been fixed 
so that Clip Scope will not affect the side by side display. 

     

 

Previously, if Clip Scope was on with RO or Tie Points “Side by Side”, one image would appear stretched 
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14. Named Image Adjustments (NIAs) are new. NIAs are project based. Activate an NIA from the toolbar, from the 
below dialog, or from the Button Manager (Tools>Button Manager). When an NIA is active, it affects all images in 
the project and overrides the typical Image Adjustments. An import button is also included; select any other 
Summit project and you can import all the NIAs from that project. 

 

Named Image Adjustments toolbar 

 

Named Image Adjustments dialog 

You can also link a Channel Map configuration to a NIA. If you link an NIA with a Channel Map configuration, it 
overrides all other image adjustment settings. 

 

New setting to link a Channel Map to a Named Image Adjustment 
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The hierarchy for image adjustments is as follows: 

 Lowest priority: Typical Image Adjustments (Summit > Imagery > Image Adjustment) 

 Higher priority: Named Image Adjustments. These override typical image adjustments. 

 Highest priority: Channel Mapped Linked Images adjustments. These override everything else. 

If you change image adjustments and nothing seems to happen, check for Named and Channel Map Linked 
Named Image Adjustments. 

You can also set buttons in the Button Manager to perform NIA or Channel map cycles. To turn off  NIAs, use 
“<Not active>” (same string as in the toolbar combobox).  Example: 

 My NIA Name1;<Not active>|Another NIA Name2 

Similarly, channel maps are keyed in with number like 1|2|0 – zero or unrecognized values turn off channel 
mapping. 

 

“Channel Map” is a new Button Manager setting 

15. DAT/EM Drawing Objects has a new Segment Length option for drawing arcs. Set the option using Summit’s 
“Object Options” from the Drawing Tools toolbar. Select Segment Length and enter a distance in ground units. 
The points along a stroked arc will be approximately this distance apart (some variations occur where points are 
picked). 

16. The Summit > Tools > Measure Mean tool has a new Show checkbox. When on, it marks the point locations as 
temporary superimposition objects. 

 

New setting in Measure Mean 
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17. Summit>CAD>CAD Angle (angle override) will now retain the custom CAD angle for the entire project. 

 

 

18. In version 7.0, there was a problem with the Summit>Tools>Options>Project>"Automatically load next model 
when outside stereo region" function. This is fixed. The cursor will now stay at its current ground coordinate at the 
edge of the new model. The problem was as follows: 

 The cursor would move to the outside edge of a model on the outside edge of the entire project area. 

 The cursor would move either outside the stereo area or to within the Summit>Tools>Options> 
Project>"Edge" percentage of the edge of the model. There was no model to change to in that area. 

 The cursor would move back into a different model's stereo area. 

 At the edge of the new model's stereo area, the cursor would jump to the model center as the model 
opened. 

 

This problem is fixed: Cursor jump to center of model in Version 7.0 
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19. Summit had a limit to how far away it would move with the DAT/EM Capture “Move Summit by Pick” tools. If the 
model picked in the CAD/GIS view was too far away, it would not move at all. Now it will successfully move and 
open the far-away model. 

20. The north indicator arrow will now be on by default in the main view for new installations. 

21. A problem with the clicking areas in the Superimposition Layer Manager (Summit>SI>Layer Manager) has been 
fixed. If you picked below the Terrain Visualization list on the right side, it would activate the SI layers list for the 
left side. The only way to display the Terrain Visualization list was to pick directly on the text in that list. Now you 
can pick anywhere on the right side of the dialog to receive the Terrain Visualization list. 

22. Elevation model conversions that are outside the range of the valid conversion area will default to Ellipsoid Height 
elevation values. There were some cases where the conversion failed outside the range and instead of opening 
the model with Ellipsoid Height, it would not show the images in the view. This is fixed in DAT/EM software so that 
the images open and Ellipsoid Height is the default. 

23. When a project opens and the images are not found, it automatically searches for the images in the folder that 
contains the .smtxml and its subfolders. Previously, it did not search for images with the “.jp2” file extension. Now 
it will search for .jp2. 

 

24. Aerial projects have the following changes: 

a. Aerial projects can now define image scale, earth curvature correction, and refraction correction either by 
the previously available single image scale and project elevation method or by a new Use heights 
method, which defines individual model scales. The Use heights method is recommended for imagery 
sets that have a great amount of vertical relief, such as steep mountains with deep valleys or fjords. 

The Use heights method was developed at the request of a customer and Trimble/Inpho to match the 
same method available in Inpho version 5.7 and above. Equations were provided by Trimble and 
incorporated into Summit so that the Summit project coordinates will exactly match the Inpho project. 
Please note: 

 Inpho v.5.7 does not have the ability to export the Use heights values to a .smtxml file. 
Export the project from Inpho 5.7 into a .smtxml file. If you have Inpho 5.7, open the exported 
.smtxml file in Summit v.7.1. Cut and paste the values manually from Applications Master 5.7 
into Summit 7.1. 

 Trimble Inpho v.6.0 exports the Use heights values directly into a .smtxml that includes the 
Use heights values. 

The Use Heights method may be used whether or not the project originates in Inpho software. 
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Open an aerial project in Summit. Select Summit > Edit > Project and select the new Interior 
Corrections button. 

 

New “Interior Corrections” button for aerial projects 

The Individual Image Heights dialog appears. If the project was exported from an October 2014 or later 
version of Inpho Applications Master, the Flight and Terrain values may already be set. For earlier Inpho 
versions or for new Summit projects, the values will be set to “Default”. To automatically fill the Flight 
settings in with existing exterior orientation z values, select the Fill Flight Heights button. 

 

Fill Flight Heights button to set the EO z values 
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If they are not already set, click on the individual image Terrain column settings and set them to the 
terrain height of each image. Any image left with “Default” will use the settings from the initial dialog: 

   

 

Enter individual image terrain heights for each image.  

“Default” values are found on the previous Interior Corrections dialog. 

Now when the images are opened in models, they will have their own custom scale and corrections 
applied based on their flight and terrain height settings. 

Aerial Projects, Continued. 

b. Oblique imagery is now supported in the Aerial project type. Oblique options will apply for any imagery 
where omega and phi are greater than 15 degrees. For oblique imagery, it is necessary to adjust the 
movement method and the epipolar adjustment should be made relatively rather than as absolute angles. 
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Normally we show non-oblique aerial images by rotating each of them by their epipolar angles. If we do 
this for oblique imagery, the rotation into the screen can be quite large like this example: 

 

Demonstration of why oblique imagery shouldn’t be displayed like non-oblique imagery 

This results in a strange view and movement. For oblique imagery, we want to show the images relative 
to each other like this example:  

 

Proper display of oblique imagery 

This is a view of the images as if they were nadir. You will notice a very large change in scale (around 
25%). To show the images flat, we have to rotate the right image about the left image’s projection center.    
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When omega or phi of more than 15 degrees is detected, it will use the new oblique display and 
movement options. Summit > Orientation > Oblique Options activates a dialog for selecting xy and z 
movement and epipolar options. 

 

New movement and epipolar options for oblique imagery 

Aerial Projects, Continued. 

a. The Project Edit dialog can now change the extensions of selected images or all the images at one time. 
Select Modify EXT and select a new image extension (TIF, SMTI, or JP2).This is useful for cases where 
the project was made before processing the images with the Image Creator. This will substitute new file 
extensions without losing any orientation information that may already be applied to the old images. 

     

Original TIF images listed > “Change EXT(extension)” button > select SMTI (for example) 

 

Now all image names have the SMTI extension 
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Aerial Projects, Continued. 

b. Summit’s aerial Project Edit dialog has a new sort method to quickly remove images that are not found. 
This is useful when you only have part of a project. 

 Highlight the “Image Files” category. Image files that can’t be found are shown with a red “X”. 

 Click the “Files” column to sort. The sort options appear. Select “Ascending and remove not 
found.” 

      

Sort by “Ascending and remove not found” 

 The files have been sorted and the missing files removed. 

 

The missing files are removed 

 

c. (Note of interest for aerial projects) The Direct Linear Transform mentioned in the Close Range project 
type can calculate camera parameters for aerial images as well. Please see 25.b. below. 

d. File>Export Model Bounds for aerial projects will now use the project’s key-in elevation if Edit>Project has 
Average Elevation set to Key-In instead of Control File. 

e. The “Control point residuals” section of the Tie Points’ Bundle Adjustment report has been changed to 
“Control point average residual summary”. This shows the average residual of a control point on all 
photos where the control point is found. It is not likely to show all zeros in the reported digits. The 
previous method could often show all zeros due to the values being so small. 
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25. Close Range (Terresrial) projects have the following changes: 

a. The initial angles function is improved. 

 

b. A Direct Linear Transform (DLT) model has been added to Summit close range projects. This model 
allows Summit to orient photos without a known camera calibration. This is most useful for close range, 
but it could also be applied to aerial imagery if the aerial imagery is added to a Close Range project. 

Attributes of DLT: 
 This model is most similar to a satellite RPC. 
 It solves for camera parameters. 
 There are no model or photo coordinates, just pixel and ground. 
 It requires at least 6 control. If 7 or fewer control are used, then it uses an 11-parameter DLT. If 8 

or more points are measured, it uses a 16-parameter DLT. 1-11 are the standard parameters, 12-
14 are the optical distortion terms, and 15 -16 are de-centering distortions terms. Thus the more 
control there is, the better it can estimate the camera. 

 The DLT is currently only implemented under close range project type; however, you could add 
aerial images to a close range project if you wanted to perform the DLT for aerial imagery. A 
“Move like aerial” setting is provided. 

 
To perform the DLT in Summit: 

 If you don’t have a camera file, then DLT must be used. 
 Create a close range project. Summit>File>New>Close Range. 
 Add images and control files. Don’t add a camera file. Without a camera, Summit automatically 

assumes you will be using a DLT. 
 Use Tie Points or Control transfer to measure 6 or more ground points. If the project detects that 

there is no camera file, a different DLT-only tie points dialog will appear: 
 

 
 
 
 

 Note that Absolute Orientation (AO) and Relative Orientation (RO) will be inactive on the toolbar 
and menu. 

 You can use Summit>Help>Orientation Snapshot to see if DLT is actually being used and its 
calculated orientation parameters. 
 

Note: There may be some changes to the DLT process in future betas. 

26. ADS40/80/100 projects have the following changes: 

a. There are often problems with multiple same-named camera files from different sensors and/or different 
calibration dates existing in the folder tree. When Summit v.7.0 or lower would update the SUP file paths, 
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it would find the first file in the folder tree and use it. Note that the SUP format does not properly list the 
ADS sensor serial number and calibration date used for the image, so there is no failsafe way to match a 
SUP to its camera. However, sometimes the folder names can be used to help identify the correct camera 
file. The “Update SUP File Paths” function will now search in order as follows: 

 Find all the cameras in the folder tree. 
 If there is only one camera, use it. 
 If there are multiple cameras, try to match using folder names. 
 If the folder name match fails, do not change the SUP. Report the problem in the SUP report. 

The user would have three choices to fix the problem: 1) Remove the extra cameras from the 
search path, 2) Edit the path names, or 3) manually update the camera file path in the SUP 
using a text editor. 

b. (Related to the Ortho+Mosaic application) If the Summit project was from ADS40/80/100 imagery and had 
a channel map or image correction on, Ortho+Mosaic would crash when generating orthophotos using the 
“Use Channel Mapping…” and/or “Apply Image Adjustments…” setting. This is fixed. 

 

27. Satellite RPC and ALOS-1 projects have the following changes and additions: 

a. Multiple-model RPC projects would not automatically load the next model when the cursor left the 
previous model’s stereo area. This is fixed. It will also work as much as possible in a project that is in the 
native WGS84 (latitude-longitude) coordinates. Note: Summit>Tools>Options>Project>”Automatically 
load next model…” must be on in order for this to work. 

b. During RPC project setup, the “Add Multiple” button would not find images that had RPC files with a 
“_rpc.txt” file name extension. This file extension is now considered a valid RPC file name. 

c. A validation check was added so that an RPC file must always be found for any image that is dragged 
and dropped into an RPC project. 
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28. Imported Projects: 

a. The import tool has been upgraded to correctly import Socet Set projects for non-digital cameras. 

Note: Please be aware that DAT/EM has received several customers’ Socet Set projects that have a one-
pixel error in the x and y directions in the SUP interior matrices. With Socet Set’s SUP interior error, the 
imported Summit project (where the interior is done correctly) is at most ½ pixel off in either direction, and 
this decreases as you go to the center of the photo. Since an error in the interior affects all orientations, 
this will be seen as elevation differences in control points that are closer to the edges of the model. For 
more information, contact DAT/EM. 

b. File>Import>SimActive  GCP File (add to project) is a new format to read SimActive brand .GCP files and 
add the control point measurements and exterior values to the current project. It will also add image 
names if they are not already present in the current project. 

c. File>Import>Purview is new. It imports Purview brand projects. Please note that all examples received by 
DAT/EM had digital cameras, so the functionality for non-digital cameras is unknown. If you have 
questions or would like to share additional projects for development, please contact support@datem.com.  

d. The Z/I SSK import dialog’s single “Use Measured Control” checkbox has changed into two radio buttons. 
The overall functionality has not changed. The radio buttons help explain what happens when either 
setting – corresponding to the original checkbox on or off – is selected. 

 

New settings in the Z/I Import Dialog 

29. Superimposition has the following changes: 

a. Selected objects in AutoCAD did not show as selected in Summit’s superimposition. We improved this. 
They still will not display as selected when you first pick them and the AutoCAD command is still waiting 
for additional selections; however, when the command finishes its selection stage, the objects will change 
to selected in superimposition. This assumes that the Summit>Tools>Options>SI tab>”Selected Objects” 
settings are on. 

b. The AutoCAD ROTATE command will now create a superimposition rubber band between the base point 
and the rotation point. Note that we can’t do complex dynamics with AutoCAD, so the object will not 
appear to move to proposed locations along with the rubber band. 

c. Summit’s superimposition will show more native MicroStation commands in its command text area. There 
was also a performance improvement in the time it takes to process these commands. 

 

More MicroStation commands appear in Summit’s superimposition 
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30. Button Manager has the following changes: 

a. The TopoMouse tab now allows a shift button to be set. The Shift combobox lets you select any button as 
the Shift button. The button that becomes the shift and its own shifted button cannot be assign commands 
and become blank in the list. The shifted values are always the button number + 16. When a shift button 
is used, there will be 30 assignable buttons. If no shift button is set, then the list will have 16 buttons. 

In this example, button 13 is set as a shift. Button 13 and 29 (which is 13+16) disappear from the list: 

 

Example: Shift button=13, so button 13 and 29 disappear 

Notes on the Topomouse driver: When DAT/EM first received a Topomouse for development, it did not 
function on the computer. The latest SILabs driver installs automatically, but through testing on various 
Windows 7 and Windows 8 systems, we concluded that the latest SILabs driver does not work. With the 
bad driver, Summit may successfully connect to the device, but there will be no movement or button hits 
registered. 

After the latest SILabs driver installs automatically, it must be uninstalled. Use “Add Remove Programs” to 
uninstall any “Silicon Labs USBXpress Device” driver. Then install the older driver provided on the 
DAT/EM website in http://www.datemsystems.com/down/drivers/Leica_TopoMouse_USB_Driver.zip  
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b. ButtonConfig is a new DAT/EM Keypad Controller command to set a Button Manager button configuration 
from the Keypad. ButtonConfig is case insensitive. The configuration and device names are case 
sensitive. The command is insensitive to whitespace padding and spaces after ButtonConfig, that is: 

BUTTONCONFIGStealth Z      |           My Config Name 

will be parsed as:  

ButtonConfig Stealth Z|My Config Name              

It is sensitive to enclosed spaces, that is, StealthZ is not a valid device name. The device names must be 
keyed in exactly as they appear on the device’s tab in the Button Manager, for example, Softmouse3D 
or Stealth E/V or Space Series or Stealth Z. 

 

For example, to set the configuration in the graphic above called, “Config has spaces” on a Stealth V 
mouse, 

ButtonConfig Softmouse3D or Stealth E/V | Config has spaces 

 

 

31. Generate LIDAR Image (GenLidarImageUI[_64].exe) “Stereo Mate Generation” option has the following changes: 

a. Outliers are removed to get a better range. 

b. The Stereo mate is now expand horizontally. This required changes to Summit. Images created with the 
new version will not be backwards compatible with earlier Summit versions. If an older Summit version 
opens the files, it will get incorrect Z values and the images will separate strangely when moving. 

c. It now optimizes the point files before processing. With the old generator, a test file took 2 hours to 
generate. With the new version, the same file takes 30 min. The speed increase is due to using a better 
shift and optimizing the points files. 
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d. [Generated Stereo] projects (LIDAR Stereo Images and SAR Stereo):  

o The “Generate Stereo Mate” button now properly launches the Stereo Mate Generator instead of 
causing an error message. 

 

o Orientation > Z Index is now available for generated stereo projects. 

o The process of making the stereo mate had a sub-pixel calculation error that led to a Z elevation 
difference when viewing the resulting stereo mate model. This is fixed. 

 

32. Contour Creator’S Output tab>Generate button would give a message, “Unspecified error.” This was fixed. 
 

33. Point Translator and all other DAT/EM applications that read points files have added file formats: 

a. LAZ format, both read and write. 

b. LAS 1.4 formats. All LAS 1.4 formats can be read, but only the non-waveform formats are writeable. For 
example, Landscape can read, but can’t edit and write a waveform LAS 1.4 file. Use Point Translator to 
convert the waveform file to a non-waveform file before using it in Landscape. 

 

34. Image Creator can now place time stamps in the image header for the newly created image. 

 

 
Image Creator places time stamps in its output TIF-type files 
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35. Project Viewer / Ortho+Mosaic has the following changes: 

a. In v.7.0 only, Project Viewer/Ortho+Mosaic could crash on image reading if the following conditions were 
met: Summit was running with the aerial project open, the aerial project had an actively applied channel 
map, and Project Viewer/Ortho+Mosaic opened the same aerial project. This could more easily happen if 
Project Viewer/Ortho+Mosaic was launched from Summit and “Automatically load Summit projects” was 
on in Project Viewer/Ortho+Mosaic. This is fixed in v.7.1. 

b. In v.7.0 only, Ortho+Mosaic’s "Clip Images using Seam Lines" (for mosaic seams) did not work. This is 
fixed in 7.1. 

c. There is a new Export button on the “Individual Image Boundaries” dialog. This outputs the current 
orthophoto boundaries to a vector format. This button offers another way to launch the previously existing 
function found on Ortho+Mosaic’s File>Export menu. 

 

Export button in Individual Image Boundaries dialog 

d. If the Summit project was from ADS40/80/100 imagery and had a channel map or image correction on, it 
would crash when generating orthophotos using the “Use Channel Mapping…” and/or “Apply Image 
Adjustments…” setting. This is fixed. 

e. Ortho+Mosaic could crash on display of imagery. This is fixed. 

Landscape 
The following changes were made to LANDSCAPE: 

1. The right click menu in Landscape’s Image Manager winddow now offers to open the image in the DAT/EM Image 
Viewer. 

2. Landscape and all other DAT/EM applications that read points files have added file formats: 

a. LAZ format, both read and write. 

b. LAS 1.4 formats. All LAS 1.4 formats can be read, but only the non-waveform formats are writeable. For 
example, Landscape can read, but can’t edit and write a waveform LAS 1.4 file. Use Point Translator to 
convert the waveform file to a non-waveform file before using it in Landscape. 

3. Landscape’s Tools>Get 3D Device will now work whether or not Summit is running. 

4. Intensity can be adjusted. Select the Landscape>Tools>Options>Surface page and adjust the Intensity slider. 
The setting takes effect when “Apply Intensity” is on on the View toolbar: 

 

Apply intensity is on 
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Intensity set to -7 

 

Intensity set to +6 

5. A drawing offset point was added to Landscape. This improves zooming and moving abilities. 

6. LAZ file reading was fixed. This was actually an overall Point Manager fix that affected all DAT/EM applications 
that read point files. 

7. DEM file reading is fixed. It was reporting the wrong number of points, which in turn would lead to unreliable 
results. Like the LAX fix, this was an overall Point Manager fix that affected all DAT/EM applications that read 
point files. 
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8. There is a new interactive point editing dialog. The interactive editing tools that used to be on the toolbar have 
been moved to this dialog and two new tools have been added (see below). 

 

Interactive Point Editing tools have been moved to this dialog 

9. Delete is a new point editing tool. It is located in the new Interactive Point Edit dialog. It deletes the selected 
points. If “Automatically delete on Cancel” is on, then selected points are deleted when the Cancel button set in 
Button Manager is pressed. 

 

10. Change Class is a new point editing tool. It is located in the new Interactive Point Edit dialog. It changes the class 
of the selected points to the “New class” set in the dialog. If “Automatically change class on Cancel” is on, then 
selected points are changed when the Cancel button set in Button Manager is pressed. 
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11. An option is added to be able to not scale the cursor in perspective stereo mode. This makes the cursor easier to 
see when zoomed out. 

 

New Landscape “Scale cursor in perspective [stereo mode view]” toggle 

12. The Color Manager has been removed. Its functionality has been added to the Class Manager window. Select 
Landscape > Tools > Reset Toolbars to Default to activate the changes in the view. 

Pick on a color to change it.  Pick on a light bulb to toggle it.  Pick on an Id or Class Description to edit the string. 

 

The Color Manager’s functionality has been moved to the Class Manager window 
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DAT/EM Capture for ArcGIS 
Version 7.0 is compatible with ArcGIS 9.1, 9.2, 9.3.1, 10.0, 10.1, 10.2, 10.2.1, and 10.3 (each with the latest service packs 
installed) 
 
BE ADVISED: In response to user requests, DAT/EM has decided to support ArcGIS 9.x at least until the mid 2015, At that time, we will 
again review plans to drop support for ArcGIS 9.x. Please continue to make plans to upgrade ArcGIS to a 10.x release. Contact 
DAT/EM if you have concerns about upgrading. 

Note: Blue Marble's Geographic Calculator ArcGIS plugin directly conflicts with DAT/EM's CaptureArcInfo.2010.dll. 
When DAT/EM software is installed, "Registration Failed" is reported near the end of installation. Run "C:\Program Files 
(x86)\Blue Marble Geo\Geographic Calculator\UnRegisterEsriPlugin.bat" before installing DAT/EM software. Contact 
DAT/EM for more information if you have Geographic Calculator and would like to use it in ArcGIS. 

The following changes were made to DAT/EM Capture for ArcGIS: 

1. The Clip Line and Extend Line tools now detect when snapping is off and automatically turn it on. It gives a 
message when snapping is changed. Note that snapping is required for these commands. 

2. Starting the DAT/EM Capture Coordinates dialog will refresh the ArcMap view rotation to match Summit’s kappa 
angle. If you have any trouble with the ArcMap view angle not matching Summit, simply pick “DAT/EM Capture 
Coordinates” from the “DAT/EM Capture Tools” toolbar. 

 

DAT/EM Capture Coordinates will refresh the view angle in ArcMap to match Summit’s kappa 

   

3. “Quick Snap” is a new setting on the SI tab in the ArcMap-side DAT/EM Systems Options dialog. Quick Snap is 
designed to make it easier to move across the project when snap is enabled. 

 Quick Snap OFF: Check for snapping on each coordinate as it comes from Summit. 

 Quick Snap ON:  Generally check every 5th coordinate that comes from Summit. Always check the snap 
if a pick is performed, even if Quick Snap is turned on. 

        

New SI Quick Snap option 
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4. The DAT/EM Arc tool now has a choice of methods to place segments along a simulated arc using the “Draw Arc” 
tool. The new method is based on a Maximum arc segment length setting made in the ArcMap-side DAT/EM 
Options’ Arc page. The arc will be stroked by segments of approximately the setting length. The digitized points 
will be retained as well. The old method, which may still be done by setting Maximum arc segment length to 0 
(zero), divided the arc by projecting a circle and dividing the whole circle into a certain number of segments. 

 

Old method of arc simulation, when Maximum arc segment length = 0 

A certain number of segments were used per projected circle, no matter the circle’s radius. 

The arc would receive too few or too many segments in most cases. 

 

New method of arc simulation 

Based on a segment length and evenly dividing the arc. This gives a more even vertex density around curves. 

 

5. DAT/EM Capture Options has changed to a page-style dialog. The options categories are in a list to the left. 
Highlight a category to see the options for it. (See example below for the new Auto Height category.) 

6. “SetFieldValue” used from the DAT/EM Keypad had a problem that prevented 0 values from being set into null-
able fields. This is fixed. 

7. Summit had a limit to how far away it would move with the DAT/EM Capture “Drive Summit Evolution [by point 
picked on the ArcMap view]” tool. If the point picked in the CAD/GIS view was too far away from the currently 
open model, it would not move at all. Now it will successfully move and open the far-away model. 
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8. The Trace Single Object tool has some improvements to behavior at the end of the trace. Previously, it had 
trouble with the transition to the next tool once the trace was complete. Notes: 

 To toggle the direction of the trace around the traced object, pick the endpoint of the trace again. Pick the 
endpoint again before moving the cursor away. When it is tracing in the correct direction, then move the 
cursor to continue digitizing. (This has not changed.) 

 At the end of the trace, the tool that was active before the trace will resume. Exception: If the previous 
tool was Circle, it will default to Point-to-Point. 

 A rubber band has been added to the end of the trace to indicate that the sketch is still active. 

9. There is a new command to help set a new snapping tolerance and automatically update the snap ring radius in 
Summit’s superimposition. Previously, this took many steps to use the ArcMap snapping dialog, then DAT/EM 
Options to turn off and on the snap ring to refresh it. Now it can all be done from the DAT/EM Options dialog or a 
Keypad key / digitizer button string. 

 Keypad / Summit Button Manager Custom CAD string (not case sensitive):  

SetSnapTolerance <snap ring radius> 

Example: SetSnapTolerance 2.5 (sets the snap ring radius to 2.5m and refreshes the ring) 

            

Set the snap tolerance from the ArcMap-side DAT/EM Options > Snap page 

            

Set the snap tolerance from a Button Manager UserCAD button or DAT/EM Keypad key 

 The new DAT/EM method to set the snapping tolerance will force the ArcMap Snapping tolerance units to 
be “pixels”. If its units were set to “map units” (this is not ground distance!), you will see “pixels” in the 
dialog after using the new DAT/EM method. 
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10. Auto Height is a new option to populate a field with the difference between the object’s Z value (first vertex) and 
the elevation from a DTM/DEM file. 

 

 Browse for one or more DTM files (these can be any of the accepted point file formats, referred to 
generically as “DTM Files”, even if they are DEM files, LiDAR files, etc.). 

 “Load DTM on startup” should be used only if the same project is likely to be continued during the next 
ArcMap session; when on, the DTM file(s) will load as ArcMap starts, and there may be a noticeable 
delay in the startup time. 

 Use “+” to add a field name. Note that field names will not be read automatically from layers, or this list 
could become unmanageably large. Thus it is the user’s responsibility to exactly match the field name to 
be populated. 

 Check on the field name to be populated and check on “Enabled”. When the option is “Enabled”, it can 
populate the field as objects are digitized. 

 To refresh the values based on a new DTM file or to populate the field for existing objects, select the 
“Recalculate” button. Note that “Recalculate” will replace all values for all objects that have the checked 
field name. Any manual editing that you wish to do should be done after “Recalculate”! 

 

New “Auto Height” Option 
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11. Airfield3D has the following changes. 

 The map wasn’t being initialized if all the runways were non-vertically guided or the status dialog had 
never been opened previously. This could cause ArcMap to crash and to keep crashing on start until a 
reboot. This is fixed.   

 

DAT/EM Capture and MapEditor for AutoCAD 
Changes apply to: 

32-bit AutoCAD 2004-2015 versions with the latest service packs. 

64-bit AutoCAD 2009-2015 versions with the latest service packs. Exception: 64-bit AutoCAD 2008 is not supported. 

BE ADVISED: DAT/EM Capture no longer supports AutoCAD 2000-2002 versions. If you use these old AutoCAD versions, please 
upgrade to AutoCAD 2004 or higher before installing DAT/EM version 7.0. 

DAT/EM software will install for multiple AutoCAD products of different year numbers on the same computer; however, it will not 
install for multiple same-year versions together. For example, it will install for AutoCAD 2011 and AutoCAD Map3D 2012 together, 
but it will not install for both AutoCAD 2012 and AutoCAD Map3D 2012. Please note that files may be copied manually to activate 
more same-year versions (contact DAT/EM Support for instructions). 

Autodesk Infrastructure Design Suite installs three same-year AutoCAD versions (AutoCAD, Map3D, and Civil3D). You must run 
each version and register/”accept” each one before installing DAT/EM software whether or not you intend to run every version with 
DAT/EM Capture active. DAT/EM software will install completely for only one of them. After that, the user can manually copy the 
AutoCAD \datem folder and the wintab driver file into the other two versions of AutoCAD. Contact DAT/EM Support for instructions. 

Reminder: Install all available AutoCAD service packs and updates before installing DAT/EM software. 

Reminder: After every new AutoCAD installation, you must run AutoCAD at least one time to activate its license before installing 
DAT/EM software. This applies to every version of AutoCAD on the computer whether or not you intend to use every version with 
DAT/EM Capture. 

The following changes were made to DAT/EM Capture and MapEditor for AutoCAD: 

1. Version 7.1 is the first version to install for and run with AutoCAD 2015. 

2. If Summit Evolution’s project defined a model with an associated drawing (“Associate CAD Drawing” on the 
Models tab in Summit’s Project window), AutoCAD would not open the DWG file. This has been fixed for 
AutoCAD versions 2007 and higher.  

3. Selected objects in AutoCAD did not show as selected in Summit’s superimposition. We improved this. They still 
will not display as selected when you first pick them and the command is still waiting for additional selections; 
however, when the command finishes its selection stage, the objects will change to selected in superimposition. 
This assumes that the Summit>Tools>Options>SI tab>”Selected Objects” settings are on. 

4. Summit’s superimposition could show an excess rubber band line to an object that had been previously digitized. 
The rubber band would appear after drawing the object and then submitting an SI Update. This has been fixed. 

5. AutoCAD 2010 and higher will no longer crash if Capture is loaded and begins communicating with Summit when 
AutoCAD does not have a real drawing document open. Although the problem is prevented in 2010 and higher, it 
may only be noticeable in AutoCAD 2015. It is uncertain whether the conditions for the crash could be found in 
AutoCAD 2010-2014. DAT/EM internal testing noticed this crash in 7.1 beta versions when AutoCAD 2015 had a 
“New Tab” or home page view open. 

6. CULVERT has a new option to place either a LINE or a POLYLINE as the culvert centerline. 

  

7. MORPHEXPORTER now displays a message when it finishes. The messages reports how many objects were 
written to the file. This solves the problem of not knowing that the command had finished. 
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8. MVUSER and MVUSERPICK have the following changes: 

a. MVUSER’s Set Z option was being ignored. This is fixed. 

b. MVUSER and MVUSERPICK will check to see whether there is an active snap point before overriding the 
point’s elevation with the stereoplotter elevation. If there is a snap point, the stereoplotter will move to the 
snapped point’s full (x,y,z) coordinate. Non-snap picked points will continue to move to the picked xy and 
the stereoplotter z. This prevents accidental moves to z=0 in many cases. 

9. ROTATE will now create a rubber band between the base point and the rotation point in Summit’s 
superimposition. Note that we can’t do complex dynamics with AutoCAD, so the object will not appear to move to 
proposed locations along with the rubber band. 

10. SUMMIT ZOOM <value> and SUMMIT MAPSCALE <value> are two new commands to set the view zoom in the 
Summit Evolution stereoplotter. These commands essentially do the same thing, but allow you to express the 
setting in either a ratio form or by the map scale. Like any other key-in, these commands may be set on the 
DAT/EM Keypad. 

For example, SUMMIT ZOOM 7 would set a zoom value of exactly 7:1 in Summit. This is reported in the Summit 
Evolution status bar at the lower right of the Summit window: 

      

 

For example, SUMMIT MAPSCALE 500 would set the zoom expressed by map scale to 500. 

      

Note: Summit’s main view has maximum and minimum zoom limits. If you enter a value that is outside Summit’s 
zoom range, it will be set to the maximum or minimum zoom. 

11. MapEditor has the following changes: 

a. POLYLINE LENGTH is a new MapEditor command. 

This command finds polylines by length or by number of vertices and changes the polylines to a different 
layer. 

For example, it can find all polylines that have more than 5000 vertices for possible editing. This could 
help avoid complex line strings when converting the DWG to MicroStation DGN. 

As another example, it can find all polylines that are shorter than 0.1 meter or all polylines that are longer 
than 1000 meters. 

Note: This command does not find corrupt single-vertex polylines. Please use CLEANUP for that task. 
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New Polyline Length MapEditor command 

b. CLEANUP has a new “Convert non-coplanar 3D lightweight polylines to 3D polylines” option to convert 
lightweight polylines that have variable Z values to proper 3D polylines. When MicroStation exports to a 
DWG file, it often exports a certain percentage of objects that should have been 3D polylines into “illegal” 
lightweight polylines that have differing Z values. When this happens, AutoCAD reports that these 
polylines are non-coplanar or not parallel to the UCS, and it can’t fix or edit them. The new option 
converts any LWPOLYLINE that has varying Z values to a 3D polyline. It does not change lightweight 
polylines that are properly 2D.  

   

“…not parallel to the UCS” or “non-coplanar” message indicate there might be 
bad lightweight polylines in the drawing. These objects can’t be edited. 
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Note: Please use “Convert non-coplanar 3D lightweight…” while in a non-rotated UCS. 

Note: This option does not fix CIRCLEs that are not parallel to the UCS (not parallel to the xy plane). 
These are also exported to DWG by MicroStation. DAT/EM suggests drawing a new circle or a series of 
arcs or simulated arcs to replace the circle once it is in AutoCAD. If it is possible to plan ahead, do not 
draw circles using the ELLIPSE type in MicroStation. 

c. TOUCH was not always adding a vertex to the “to” polyline at all touched locations. Although AutoCAD’s 
functions would give us the vertex as the intersection point for clipping or extension, it would then 
incorrectly report that the point was not on the “to” segment. For cases where this happens, we now use 
our own libraries to place the vertex into the “to” segment. 

d. Previously, if the MapEditor dialog was open when a layer was made or changed or an object was 
modified, the MapEditor would pause while it synchronized with the AutoCAD layer states. The more 
layers there were in the drawing, the longer the pause. There is a significant performance enhancement 
that eliminates the pause. 

e. Fixed a potential crash that could happen as MapEditor loaded. 
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DAT/EM Capture and MapEditor for MicroStation 
Changes apply to Capture for MicroStation. DAT/EM software installs for the following MicroStation versions on 32-bit and 64-
bit operating systems: 

 MicroStation V8 and V8 2004 Edition: Version should be 08.05.00.34 or higher. 

 MicroStation XM: Version should be 08.09.04.88 or higher. 

 MicroStation V8i, V8i-based Bentley Map and Map Enterprise Select Series 1 (1 not recommended), 2, and 3; 
MicroStation PowerView Select Series 3; Power GeoPak* Select Series 3 

If you upgrade from Select Series 1 to 2 or 3, you must reinstall DAT/EM software after installing the Series upgrade.  

DAT/EM will install for all versions of MicroStation that are present on the computer at the time of the DAT/EM installation. 
 
*Note about Power GeoPak Select Series 3: DAT/EM Software installs for Power GeoPak SS3, but has initial loading 
conflicts that affect the GeoPak and DAT/EM menus. Bentley has offered a workaround for this issue. If you have the Bentley 
Power GeoPak product, please contact DAT/EM for further installation instructions. 

The following changes were made to DAT/EM Capture and MapEditor for MicroStation: 

1. MicroStation line styles and weights can now be shown in Summit’s superimposition. To toggle the setting, use 
the new MicroStation-side Show Line Styles in SI option in SI SETTINGS: 

 

MicroStation-side SI SETTINGS Show Line Styles in SI 

Set individual object overrides or by-level settings to the desired line weight and line styles: 

 

Line styles and weights in the MicroStation Level Manager 

 

The Summit-side SI options (Tools>Options>SI tab) Objects>Thickness and Points>Size settings will be 
multiplied times the MicroStation weight. If you would like the MicroStation weight to set the line thickness by 
itself, set Objects>Thickness=1.0x and Points>Size=1.0x. Otherwise set them to the desired weight factor to be 
multiplied times the MicroStation line weight. 
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Summit’s SI Objects Thickness and Points Size are multiplied times the MicroStation weight 

  

  

Examples of various line weight and line styles in superimposition (option turned off in lower right) 

Note: If the MicroStation-side settings do not have any effect, make sure Summit>Tools>Performance 
Monitor>GPU Shaders is on and the video card is compatible. If you have any questions about your video card, 
contact support@datem.com. 

 

2. The fields in the parameter file class have additional error checking. 

3. Summit’s superimposition will show more native MicroStation commands in its command text area. There was 
also a performance improvement in the time it takes to process these commands. 

 

More MicroStation commands appear in Summit’s superimposition 
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4. MicroStation was sending text snap points instead of justification points to Summit’s superimposition. Now the text 
representations should be much better in superimposition. Note that superimposition only uses one text size and 
applies it to both the text height and width. MicroStation could assign different sizes to height and width and some 
text fonts are asymmetric; in these cases, superimposition will not match the text exactly. 

5. In the Parameter File Editor, if you selected the “CPLine” command and selected “Add”, the line would be added 
to the parameter file as soon as the dialog appeared, which was before making new settings. Now it is added as 
the dialog closes, which is after making new settings. 

6. The Selection Set Editor has the following changes: 

a. The Export Selection Set function is fixed so that it no longer forces ".dgn" to the end of the filename that 
should have the ".sset" extension. 

b. The “Fence to Set” button no longer finds levels that are turned off for display. 

c. The “All Points and Cells” element selection group has been removed. In its place are two separate sets: 
“All Points (zero-length strings)” includes all zero-length type 3 lines and type 4 line strings by level and 
attributes; “All Cells” includes all cells by name. Both of these element selections must be added to the 
set separately in order to find both points and cells. This fixes a problem encountered with the former “All 
Points and Cells” where cell components were checked for the level and attributes. We determined that a 
combined set would never give the desired results, because points should be filtered by level and 
attributes, while cells should be filtered by cell name. 

7. AUTOARC has the following changes: 

a. Autoarc did not always break the snapped-to element with the “Break” option on. A units-of-resolution 
error was fixed. 

 

Autoarc’s Break option will work consistently now 

b. Autoarc with the “Stroke Arcs” setting on would not always remove the double vertex where two arcs 
adjoined. A larger tolerance is now used in the check for double vertex removal. 

8. CROSSCHECK has a performance improvement that cuts the time it takes in half for our test cases. 

9. DATDRAW will now close as a shape when the “Close on Reset” option is on. Previously, it closed as an end-
snapped line string. 

10. DTMEDIT has the following fixes: 

a. The “Within Shapes” option now sets the elevation of points found inside shapes. Previously, it could set 
the elevation of all points in the design file. 

b. Error checking was improved for element scans and element picks. 

c. It will now find zero-length lines as well as zero-length line strings. 

11. EZEDIT has improved error handling for vertex insert and move operations. 

12. FILTER with certain settings run from a parameter file may have failed to filter any points. It was ignoring the filter 
option setting. It would work if run interactively with the same settings. This is fixed. 
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13. FIND DUPLICATES (MEFINDDUPLICATES) has the following changes: 

a. Added error handling on the scans to prevent processing of deleted elements, etc. 

b. Process only parent elements (no sub elements on complex elements or nested cells) 

c. Added origin comparison on cells (previously any like-named cells that fell within cubic range of another 
would be flagged as a duplicate). 

d. For all coordinate comparisons, added a  Units of Resolution (UOR) tolerance allowance of 0.25 UORs to 
eliminate the effect of precision limitations. 

14. MECHANGETAG has the following changes: 

a. The “1st Tag” and “2nd Tag” options were removed. The “By Tag Name” and “By Tag Value” settings do 
everything that “1st Tag” and “2nd Tag” used to do, but they’re even better and less prone to mistakes. 

 
Old MECHANGETAG dialog with 1st and 2nd Tag and “By Tag Value” 

 

 
Updated MECHANGETAG dialog 

 
b. “Match characters within Tag Value” is similar to the older “By Tag Value”, but does not require an exact 

match of the entire Tag Value. The entire Tag Value is replaced, regardless of the selected criteria. 
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New “Match characters Within Tag Value” setting 

 
 

c. MECHANGETAG can now be used to either change the Tag Value or the Tag Name/Set. 
 

 
New option to either replace the tag value or the name of the tag 

 
d. The following keyins are used to set MECHANGETAG parameters and can be used in the GENERIC 

KEYIN entries in PAR files: 
 

 MECHANGETAG SET <selection set name> –   Changes the selection set scanned for tags 
matching the tag criteria. 

 
 MECHANGETAG TAGNAME <tag set>,<tag name> – Changes the criteria to search for tags 

with a specific Name (and sets the associated tag set and tag name). 
 

 MECHANGETAG TAGVALUE <current tag value> – Changes the criteria to search for tags with 
a specific value. 

 
 MECHANGETAG TAGSUB <current tag substring> – Searches tags for a substring within the tag 

value. 
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 MECHANGETAG NEWVALUE <new tag value> – Sets the new value that MECHANGETAG will 
write to specified tags. 

 
 MECHANGETAG NEWNAME <new tag set>,<new tag name> – Sets the new name that 

MECHANGETAG will write to specified tags. 
 

 MECHANGETAG TAGGO – Runs MECHANGETAG using the most recent settings. 
 

15. MVUSERPICK was fixed to keep Summit’s Z value for regular picks in the MicroStation view, but send the full 
(x,y,z) pick if it is a snap/tentative point. 

16. PSQR has a fix for a problem with its “S” squaring angle override. Now when the “S” override is used just before 
finishing the building, it only affects the closing angle of the current building. It does not affect subsequent 
buildings. Previously, it would act as a toggle that determined whether or not subsequent buildings would be 
squared at their closing segment. If used once, buildings would not square as they finished. If used a second time 
(buy only at the closing segment), they would resume squaring as they finished. Note that “S” used for an 
intermediate vertex was not a problem. 

17. RUNPAR has an additional subcommand to run the MapEditor purely from a key-in. RUNPAR alone still works to 
launch the dialog. The new command key-in is: 

RUNPAR <parameter file path and name, required> <log file path and name, optional> 

Example:    RUNPAR C:\MyParFolder\MyParFile3.par C:\MyMapEditorLogFiles\MyParFile3RunLog.log 

This command runs the parameter file on the current design file. If the log file is specified, it will also create a log 
file. The files extensions, such as .par or .log, are required as long as it matches the actual name of the existing 
parameter file or log file to create. 

 

18. SPOTINTERP has the following changes: 

a. It no longer restricts the entry of more than six characters into the Height, X Offset, and Y Offset fields in 
the SPOTINTERP SETTINGS dialog. 

b. If you used the select button in SPOTINTERP SETTINGS’ “DTMPOINT Attributes” dialog, any recent 
dialog entries in both DTMPOINT Attributes and SPOTINTERP SETTINGS would reset. This is fixed. 

c. In SPOTINTERP’s “DTMPOINT Attributes”, if you select a cell, the selection is changed from point to cell 
and the attribute is set to the cell name (rather than the symbology). 

d. The algorithm for finding the best elevation has been replaced. The previous algorithm could place the 
wrong elevation, might not place anything, and also could crash occasionally. It will now operate much 
more accurately and reliably. 

e. The radius setting was previously used as a diameter. Now it is a properly a radius. 

 

19. STROKE ELEMENT’s interactive version dialog “Sets” button would lock up MicroStation. This is fixed.  
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20. TOUCH BATCH has a new “Log potential edits to xyz file” option that allows you to find and view – but not edit 
automatically – “dangles”, which are line string endpoints that do not join to any other object. The user who 
requested this did not want to edit the dangles automatically, but rather, just wanted to look at them one by one. 

 

New “Log Potential Edits..” option 

21. TWOSHOT has the following additions and fixes: 

a. TWOSHOT TEXT <text to place>, TWOSHOT TEXTSCALE <text to place>, and TWOSHOT 
TEXTANGLE <text to place> are new commands to place text with two picks that define the insertion 
point and a rotation and/or scale point. It works similarly to the long-existing TWOSHOT cell commands. 
To use: 

Start one of the commands: 

TWOSHOT TEXT <text to place>: Requires two digitized points. The first is at the text insertion 
point and the second defines both the text scale and rotation angle. 

TWOSHOT TEXTSCALE <text to place>: Requires two digitized points. The first is at the text 
insertion point and the second defines the text scale. It uses the active angle. 

TWOSHOT TEXTANGLE <text to place>: Requires two digitized points. The first is at the text 
insertion point and the second defines the text angle. It uses the active text scale. 

If <text to place> is missing, the user is prompted the first time to enter the text in a dialog. Subsequent 
runs missing <text to place> will use the previously entered text until a new text string is entered. 

b. A bounding box may now displayed in Summit’s superimposition and MicroStation around the CELL or 
Text being placed by TWOSHOT. Previously, there was no Summit superimposition display until after 
elements were placed. TWOSHOT SIBBOX_OFF and TWOSHOT SIBBOX_ON are new key-ins to 
toggle the bounding box display. The bounding box is off by default. 

c. TWOSHOT commands have more error checks applied. A cleanup routine cancels TWOSHOT when a 
new command is run. Previously, TWOSHOT was only cancelled when certain (primitive) commands 
were run subsequently. 

d. The angle of the cell placed by TWOSHOT didn’t always match the selected angle. This is fixed.  
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22. VISIT has a new “Include Reference Elements” checkbox. When on, reference elements will be included in the 
visit list. 

 

New VISIT “Include Reference Elements” 

23. MEVOLUME has enhancements. 

a. The previous implementation of MEVOLUME did not support base element definitions that consisted of a 
series of asymmetric, unclosed “shelves”. It was previously assumed that piles were defined by enclosing 
base elements in the form of a polygon (shape). This did not work when the base elements consisted of a 
series of “shelves” that did not enclose the piles such as shown in the following test case: 

  

White lines are the unclosed base elements, together with breaklines (left) and alone (right) 
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Updated interactive interface (left) and batch interface (right) 

 

There is now the additional Pile Boundary Definitions option to define pile boundaries as either Closed 
Base Elements (as before) or as Closed Surface Elements (by symbology or level). To resolve 
ambiguity, the user is now required to define pile boundaries with a closed (either shape or string with 
snapped endpoints) element. 

 

New choices in Pile Boundary Definitions 

 

The example design shown above would be configured as Closed Surface Elements to define pile 
boundaries. 
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b. MEVOLUME has new Densify Options. The user is now able to (optionally) set a density factor for both 
surface and base definitions. Volume estimates are based on TINs created from surface and base 
elements that fall within a “Pile Boundary”. 

 

New Density options 

If density sampling is not enabled, the TIN size is based on actual sample size (that is, the number of 
original vertices on linear elements). If enabled, the Density Delta defines a smaller, more refined TIN 
size by interpolating between vertices. This will slow the volume calculation, but should provide improved 
accuracy.  

c. Both MEVOLUME’s base and surface elements are now clipped in (x,y) at pile boundaries to create 
samples on the boundary. Previously, it would only use those vertices that fell inside – not on – the 
boundary. 

24. ZLABEL’s text settings dialog was accidentally left as a modal dialog, whereas the cell settings were in a non-
modal dialog. In Window 7, some modal dialogs would be incorrectly displayed behind the application that started 
them. On some computers, MicroStation would seem to lock up when the ZLABEL text settings dialog was open. 
It was not really locked up; it was waiting for you to “OK” the dialog that you could not see. The dialog is now non-
modal. 
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DAT/EM Capture for Blue Marble Global Mapper 
Changes apply to Capture for Global Mapper 15.2 or 16.x. A Global Mapper version 15.2 or higher dated June 25, 2014 or later 
must be used. DAT/EM recommends version 16.0.6 or later (dated 12 December 2014 or later). If Global Mapper 15.2 and/or 
16.x is found installed on the computer when DAT/EM software installs, the complimentary DAT/EM Capture for Global 
Mapper extension will be installed automatically. There are no changes necessary for the DAT/EM hardware lock licensing. 

If both Global Mapper 15.2 and 16.x are found on the computer, the 15.x extension will be used for both. This is because they 
share a configuration file and the 16 extension is not backwards compatible with Global Mapper 15. For best results, uninstall 
15 and install the latest 16 before you install DAT/EM software. 

Please note the following: 

1. Capture for Blue Marble Global Mapper was considered a beta in DAT/EM version 7.0. It is considered a second 
generation beta in version 7.1. Individual changes will not be listed here. Please see the separate document 
called “DATEMCaptureForGlobalMapper-beta7.1-1.pdf” for instructions. 

2. The plugin is now compatible with versions 15.2 and 16.x of Global Mapper and for both the 32-bit and 64-bit 
versions. 

3. There are improvements to text scaling issues with Global Mapper and Summit Evolution’s superimposition. 

Note (as of 13 October 2014): DAT/EM’s development SDK license issued by Blue Marble has been approved. A non-
expiring SDK license is now built in to DAT/EM v.7.1 dated 13 November 2014 and later. Users must still ensure that their 
own Global Mapper software license is valid. 

 


